Κυριακή, 30 Δεκεμβρίου 2012

Ερωτήσεις πολλαπλής επιλογής

Ποια είναι η σωστή επιλογή;

1. ΟΧΙ ( ( Χ < > Υ) Ή (Χ > Ζ) ) =
    Α. ΟΧΙ ( Χ < > Υ) Ή ΟΧΙ (Χ > Ζ)
    Β. ΟΧΙ ( Χ = Υ) ΚΑΙ ΟΧΙ (Χ <=  Ζ)
    Γ. ( Χ = Υ) ΚΑΙ (Χ <= Ζ)
    Δ. ( Χ = Υ) Ή (Χ <= Ζ)

2. ΟΧΙ ( (Χ > 3) ΚΑΙ (Χ < 10) ) =
    Α. ΟΧΙ ( Χ > 3) ΚΑΙ ΟΧΙ (Χ < 10)
    Β. ( Χ <= 3) ΚΑΙ (Χ >= 10)
    Γ. (Χ <= 3) Ή (Χ >=10)
    Δ. ΟΧΙ ( Χ <= 3) Ή ΟΧΙ (Χ >= 10)

3.  (3*A+6) DIV 2 =
    A. 0
    B. 1
    Γ. Α+1
    Δ. Α+2

4.  (4*Α+10) MOD 2 =
     A. 1
     B. 0
     Γ. 2*Α+5
     Δ. τίποτα από τα παραπάνω

5.  Αν Χ = 5, Υ = 2 η εντολή
         Εμφάνισε  'Χ', Υ, 'Χ+Υ', Χ >= 5
     τυπώνει:
     Α.  Χ   2   Χ+Υ   Αληθής
     Β.  Χ   2   Χ+Υ   Ψευδής
     Γ.  5    2   Χ+Υ    Ψευδής
     Δ.  5    2    7        Αληθής

Απαντήσεις

1. Γ
2. Γ
3. Δ
4. Β
5. Α

Σάββατο, 29 Δεκεμβρίου 2012

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Όταν το βήμα _________ σε μια Για..από..μέχρι είναι 1
    παραλείπεται.
2. Μια __________ παράσταση αποτιμάται σε Αληθής
    ή Ψευδής.
3. Τα ________ κάνουν ένα πρόγραμμα πιο κατανοητό.
4. Τα ______ προβλήματα δεν είναι γνωστό ούτε αν
    λύνονται ούτε αν δεν λύνονται.
5. Τα ________ είναι μικρά σε μέγεθος και ανεξάρτητα
    μεταξύ τους.

Απαντήσεις

1. μεταβολής
2. λογική
3. σχόλια
4. ανοιχτά
5. υποπρογράμματα




Δευτέρα, 24 Δεκεμβρίου 2012

Προσδιορίστε το λάθος


















  
















Απαντήσεις

1. Υπάρχει λογικό λάθος στην αρχικοποίηση του Γ : πρέπει
    η αρχική τιμή της μεταβλητής να είναι 1 και όχι 0.
2. Υπάρχει συντακτικό λάθος : πρέπει να γράψουμε
     Διάβασε Χ αντί για το Διαβάστε Χ.
3. Υπάρχει συντακτικό λάθος : πρέπει να γράψουμε
     Τέλος_επανάληψης  αντί για το Τέλος_Για.
4.  Υπάρχει λογικό λάθος στη συνθήκη της  Μέχρις_ότου :
      το σωστό είναι Μέχρις_ότου Χ > 0.
5. Υπάρχει συντακτικό λάθος : πρέπει να γράψουμε
     μέχρι αντί για το μέχρι_και.





Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Ένας τελεστής δεν αντιστοιχεί κατ' ανάγκη σε πράξη.
2. Ένας πίνακας αποτελείται από 2 ή περισσότερες
    εγγραφές.
3. Όλες οι συναρτήσεις γράφονται σε ψευδογλώσσα.
4. Ένα πρόβλημα μπορεί να είναι επιλύσιμο ή άλυτο
    ή ανοιχτό.
5. Οι μεταβλητές είναι δομικά στοιχεία μιας γλώσσας
     προγραμματισμού.



Απαντήσεις

1. Σ
2. Λ
3. Λ
4. Σ
5. Σ



Συγγραφή συνάρτησης


Δευτέρα, 17 Δεκεμβρίου 2012

Πίνακας αλήθειας

Κατασκευάστε τον πίνακα αλήθειας της παράστασης
     ΟΧΙ Χ ΚΑΙ Υ Ή ΟΧΙ Ζ

Λύση

Ας συμβολίσουμε με Α - Αληθής, Ψ - Ψευδής και
έστω Σ = ΟΧΙ Χ  ΚΑΙ Υ

Χ        Υ       Ζ    ΟΧΙ Χ      Σ    ΟΧΙ Ζ    Σ Ή ΟΧΙ Ζ
Α        Α       Α       Ψ          Ψ        Ψ              Ψ
Α        Α       Ψ       Ψ          Ψ        Α              Α
Α        Ψ       Α       Ψ          Ψ        Ψ              Ψ
Α        Ψ       Ψ       Ψ          Ψ        Α              Α
Ψ        Α       Α       Α           Α        Ψ              Α
Ψ        Α       Ψ       Α           Α        Α              Α
Ψ        Ψ       Α       Α           Ψ        Ψ             Ψ
Ψ        Ψ       Ψ       Α           Ψ        Α             Α

Τετάρτη, 12 Δεκεμβρίου 2012

Κυκλώστε τα σωστά

Ποια από τα παρακάτω αποτελούν δομικά στοιχεία μιας
γλώσσας προγραμματισμού;
1. συνδετήρας
2. μεταβλητή
3. λογικό διάγραμμα
4. συμβολική σταθερά
5. υποπρόβλημα
6. τελεστής
7. δυαδικό σύστημα

Απαντήσεις

2, 4, 6

Κυριακή, 9 Δεκεμβρίου 2012

Μετατροπή


Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις  με σωστό τρόπο

1. Ο αλγόριθμος του πολλαπλασιασμού αλά ρωσικά
    περιλαμβάνει πολλαπλασιασμούς και ακέραιες
    διαιρέσεις με το 4.
2. Οι γλώσσες μηχανής δεν απαιτούν γνώσεις
    προγραμματισμού.
3. Όταν ο πίνακας Α[1000] είναι ταξινομημένος, το
    Α[1] είναι το μικρότερο στοιχείο του.
4. Μια συνάρτηση που ελέγχει την αρτιότητα ενός
    ακεραίου αριθμού πρέπει να είναι πραγματικού
    τύπου.
5. Η εντολή  Γράψε Τ_Ρ(Χ) έχει συντακτικό λάθος
    στην περίπτωση που η μεταβλητή Χ έχει αρνητική
    τιμή.



Απαντήσεις

1. Ο αλγόριθμος του πολλαπλασιασμού αλά ρωσικά
    περιλαμβάνει πολλαπλασιασμούς και ακέραιες
    διαιρέσεις με το 2.

2. Οι γλώσσες 4ης γενιάς δεν απαιτούν γνώσεις
    προγραμματισμού.
3. Όταν ο πίνακας Α[1000] είναι ταξινομημένος κατά
    αύξουσα σειρά, το  Α[1] είναι το μικρότερο στοιχείο
    του.

4. Μια συνάρτηση που ελέγχει την αρτιότητα ενός
    ακεραίου αριθμού πρέπει να είναι λογικού
    τύπου.

5. Η εντολή  Γράψε Τ_Ρ(Χ) έχει λογικό λάθος
    στην περίπτωση που η μεταβλητή Χ έχει αρνητική
    τιμή.


Σάββατο, 8 Δεκεμβρίου 2012

Ερωτήσεις πολλαπλής επιλογής

Κυκλώστε τη σωστή επιλογή

1. Οι πίνακες
     Α. κάνουν εξοικονόμηση μνήμης
     Β. είναι δυναμικές δομές δεδομένων
     Γ. χρησιμοποιούνται σπάνια
     Δ. παρέχουν τη δυνατότητα αποθήκευσης δοσμένου
         πλήθους δεδομένων (ίδιου τύπου)

2. Τα υποπρογράμματα
    Α. εξαρτώνται άμεσα από το κύριο πρόγραμμα που τα
         καλεί
    Β. καθιστούν την εκτέλεση του προγράμματος πιο
        γρήγορη
    Γ. έχουν ακριβώς μια είσοδο και μια έξοδο
    Δ. αποφεύγονται στον τμηματικό προγραμματισμό

3. Η Όσο..επανάλαβε
    Α. ολοκληρώνεται με τη δεσμευμένη λέξη Τέλος
    Β. είναι μια επαναληπτική δομή
    Γ. είναι ισχυρότερη από την Μέχρις_ότου
    Δ. δεν μπορεί να χρησιμοποιηθεί για έλεγχο
         εγκυρότητας εισερχόμενων δεδομένων

4. Η εντολή εκχώρησης
    Α. είναι ένας από τους τρόπους που έχουμε στη
         διάθεσή μας για να αλλάξουμε το περιεχόμενο
         μιας μεταβλητής
    Β.  διατηρεί και το αρχικό περιεχόμενο της
          εμπλεκόμενης μεταβλητής σε μια άλλη
          θέση της κύριας μνήμης
    Γ.  παρέχει τη δυνατότητα επισκόπησης του
         περιεχομένου μιας μεταβλητής
    Δ.  συμβολίζεται με το ==

5.  Ένα ημιδομημένο πρόβλημα
     Α. μπορεί να είναι άλυτο
     Β. μπορεί να είναι ανοιχτό
     Γ. δεν μπορεί να είναι επιλύσιμο
     Δ. είναι σίγουρα επιλύσιμο

Απαντήσεις

1. Δ
2. Γ
3. Β
4. Α
5. Δ

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω σχέσεις είναι σωστές και ποιες λάθος;
1.  (3 mod 7 >= 3 div 7 ) = Αληθής
2.  (4*Ν+8) mod 4 = 0
3.  ΟΧΙ (Χ mod 3 = 0) = (X mod 3 = 1)
4. (Χ < 5) Ή (Χ > 5) = (Χ < > 5)
5. (Χ = 1) Ή (Χ = 2) = (Χ = 1 ή 2)

Απαντήσεις

1. Σ
2. Σ
3. Λ
4. Σ
5. Λ




Πέμπτη, 6 Δεκεμβρίου 2012

Βρείτε τις λογικές τιμές

Δίνονται οι παρακάτω λογικές παραστάσεις
α)   Π1 =  Χ ΚΑΙ Ή Ζ)
β)   Π2 = ΟΧΙ Χ Ή ΟΧΙΚΑΙ Ζ)
γ)   Π3 = ΟΧΙ Ή Υ Ή Ζ)
δ)   Π4 = Χ Ή Υ ΚΑΙ Ζ
ε)   Π5 = Χ ΚΑΙ ΟΧΙ Υ ΚΑΙ ΟΧΙ Ζ
Προσδιορίστε τις τιμές των λογικών μεταβλητών Χ, Υ, Ζ
έτσι ώστε οι παραστάσεις να έχουν τις ακόλουθες τιμές:
    Π1 = Αληθής
    Π2 = Ψευδής
    Π3 = Αληθής
    Π4 = Αληθής
    Π5 = Αληθής
   
Περιορισμός : Δεν μπορείτε να χρησιμοποιήσετε πίνακα
αλήθειας.

Απάντηση

α) Πρέπει  Χ = Αληθής και Υ Ή Ζ = Αληθής. Συνεπώς
     έχουμε τρεις δυνατούς συνδυασμούς:
         Χ = Αληθής, Υ = Αληθής, Ζ = Αληθής
         Χ = Αληθής, Υ = Αληθής, Ζ = Ψευδής
         Χ = Αληθής, Υ = Ψευδής, Ζ = Αληθής

β) Πρέπει ΟΧΙ Χ = Ψευδής και ΟΧΙΚΑΙ Ζ) = Ψευδής.
     Αυτό σημαίνει ότι πρέπει:
            Χ = Αληθής και Υ ΚΑΙ Ζ = Αληθής
     Συνεπώς ο μοναδικός αποδεκτός συνδυασμός είναι:
           Χ = Αληθής, Υ = Αληθής, Ζ = Αληθής
   
γ) Πρέπει Χ Ή Υ Ή Ζ = Ψευδής. Συνεπώς ο μοναδικός
    αποδεκτός συνδυασμός είναι:
          Χ = Ψευδής, Υ = Ψευδής, Ζ = Ψευδής

δ)  Πρέπει   Χ = Αληθής και  Υ ΚΑΙ Ζ = Αληθής ή
                    Χ = Αληθής και  Υ ΚΑΙ Ζ = Ψευδής ή
                    Χ = Ψευδής και Υ ΚΑΙ Ζ = Αληθής
     Συνεπώς έχουμε τους συνδυασμούς τιμών:
                    Χ = Αληθής, Υ = Αληθής, Ζ = Αληθής
                    Χ = Αληθής, Υ = Αληθής, Ζ = Ψευδής
                    Χ = Αληθής, Υ = Ψευδής, Ζ = Ψευδής
                    Χ = Αληθής, Υ = Ψευδής, Ζ = Αληθής
                    Χ = Ψευδής, Υ = Αληθής, Ζ = Αληθής

ε) Πρέπει  Χ = Αληθής, ΟΧΙ Υ = Αληθής, ΟΧΙ Ζ = Αληθής
    Συνεπώς έχουμε:
         Χ = Αληθής, Υ = Ψευδής, Ζ = Ψευδής
         

Προσδιορισμός πλήθους επαναλήψεων

Θεωρήστε τις παρακάτω εμφωλευμένες δομές επανάληψης
   Για κ από Α μέχρι 12 μέ_βήμα Γ-1
       Για λ από 20 μέχρι Β με_βήμα -3
             Εμφάνισε 'ΤΕΣΤ'
       Τέλος_επανάληψης
   Τέλος_επανάληψης
Πόσες φορές τυπώνεται η λέξη ΤΕΣΤ σε καθεμιά από τις
παρακάτω περιπτώσεις;

1. Α = 12, Γ = 2, Β = 20
2. Α = 13, Γ = 20, Β = 5
3. Α = 15, Γ = 3, Β = 10
4. Α = 5, Γ = 1, Β = 2
5. Α = 3, Γ = 5, Β = 20
6. Α = 12, Γ = -3, Β = 30

Απάντηση
Πρέπει να βρούμε:
α) το πλήθος των επαναλήψεων της εξωτερικής Για
β) το πλήθος των επαναλήψεων της εσωτερικής Για
γ) να πολλαπλασιάσουμε τα δύο αποτελέσματα
Κατά συνέπεια:

1.   1 φορά (1 Χ 1 = 1)
2.   0 φορές (η εξωτερική Για δεν κάνει καμία επανάληψη)
3.   8 φορές    (2 Χ 4 = 8)
4.   άπειρες φορές (η εξωτερική Για είναι ατέρμων βρόχος)
5.   3 φορές (3 Χ 1 = 3)
6.   0 φορές ( 1 Χ 0 = 0)

Πέμπτη, 29 Νοεμβρίου 2012

Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για την εντολή Για..από..μέχρι;
1. Μπορεί να μετατραπεί σε μια Όσο..επανάλαβε που
    να επιφέρει το ίδιο αλγοριθμικό αποτέλεσμα.
2. Μπορεί να μετατραπεί σε μια Μέχρις_ότου που
    να επιφέρει το ίδιο αλγοριθμικό αποτέλεσμα.
3. Είναι ιδανική για έλεγχο εγκυρότητας εισερχόμενων
    δεδομένων.
4. Είναι ιδανική για μενού λειτουργιών.
5. Χρησιμοποιείται μόνο όταν γνωρίζουμε επακριβώς
    το πλήθος των επαναλήψεων.
6. Αυξάνει το μετρητή της σε κάθε επανάληψη.
7. Δεν πρέπει να έχει βήμα μεταβολής μηδέν, γιατί τότε
    μπορεί να παραβιαστεί η περατότητα.
8. Δεν μπορεί να χρησιμοποιηθεί σε επεξεργασία
    δεδομένων όπου η είσοδος τερματίζεται με
    ειδική τιμή (φρουρός).
9. Είναι η πιο ισχυρή επαναληπτική δομή.
10. Χρησιμοποιείται πολύ σπάνια.



Απαντήσεις

1, 2, 5, 7, 8

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1.  Μια αριθμητική παράσταση είναι πάντοτε ακεραίου ή
     πραγματικού τύπου.
2.  Το αποτέλεσμα της πράξης / είναι πάντοτε πραγματικού
     τύπου.
3. Πράξεις ίδιας προτεραιότητας εκτελούνται από τα δεξιά
    προς τα αριστερά.
4. Μια Όσο..επανάλαβε εμπεριέχει τουλάχιστον δύο
    εντολές.
5. Οι πίνακες αποκαλούνται και εγγραφές.


Απαντήσεις

1. Σ
2. Σ
3. Λ
4. Λ
5. Λ

Κυριακή, 18 Νοεμβρίου 2012

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1.  Οι ________ ενός αλγορίθμου είναι πεπερασμένες.
2.  Η εντολή ______ αλλάζει βίαια τη σειρά εκτέλεσης
     των εντολών ενός προγράμματος.
3.  Ο ________ προγραμματισμός υλοποιείται με τη
     γλώσσα προγραμματισμού PASCAL.
4.  Ο μικρότερος μονοδιάστατος πίνακας έχει ____
     στοιχεία.
5.  Η συνάρτηση Α_Τ επιστρέφει ένα αποτέλεσμα
     ______ ή _______ τύπου.
 


Απαντήσεις

1. εντολές
2. GOTO
3. δομημένος
4. δύο
5. ακέραιου, πραγματικού

Πέμπτη, 15 Νοεμβρίου 2012

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Αν Ν, Μ ακέραιες μεταβλητές, η εντολή  ΓΡΑΨΕ 'Ν+Μ'
    εμφανίζει το άθροισμα των περιεχομένων τους στην οθόνη.
2.  7+3*4 = 19
3.  Ο πίνακας αποτελείται από πεδία.
4.  Κάθε υποπρόγραμμα υλοποιείται με τη βοήθεια  μιας εντολής
     GOTO
5.  Αν η συνθήκη ελέγχου μιας Όσο..επανάλαβε είναι ευθύς
     εξαρχής Ψευδής, τότε δεν πραγματοποιείται καμία
     επανάληψη.


Απαντήσεις

1. Λ
2. Σ
3. Λ
4. Λ
5. Σ


Τρίτη, 13 Νοεμβρίου 2012

Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για το δείκτη ενός πίνακα;
1. Είναι σταθερά ή μεταβλητή ή παράσταση ακεραίου τύπου.
2. Ο τύπος του προσδιορίζει και τον τύπο δεδομένων του
    πίνακα.
3. Μπορεί να χρησιμοποιηθεί για τον προσδιορισμό μιας
    θέσης του πίνακα.
4. Συμβολίζεται πάντοτε με το όνομα Κ.
5. Μπορεί να είναι και λογικού τύπου.
6. Περικλείεται μέσα σε αγκύλες.


Απαντήσεις

1, 3, 6

Σάββατο, 10 Νοεμβρίου 2012

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω προτάσεις και επαναδιατυπώστε
τις με σωστό τρόπο.
1. Οι εντολές ενός αλγορίθμου ολοκληρώνεται μετά από
    κάποιο χρονικό διάστημα.
2. Η επικοινωνία των ανθρώπων μεταξύ τους γίνεται
    με τη βοήθεια των τεχνητών γλωσσών.
3. Ο μεταγλωττιστής είναι ένα πρόγραμμα σε γλώσσα
    μηχανής.
4. Οι τιμές ΑΛΗΘΗΣ και ΨΕΥΔΗΣ είναι συμβολικές
    σταθερές.
5. Ο προσδιορισμός της εποχής στην Ελλάδα είναι
     δομημένο πρόβλημα.


Απαντήσεις

1. Οι εντολές ενός αλγορίθμου ολοκληρώνεται μετά από
    πεπερασμένο χρονικό διάστημα.

2. Η επικοινωνία των ανθρώπων μεταξύ τους γίνεται
    με τη βοήθεια των φυσικών γλωσσών.

3. Ο μεταγλωττιστής είναι ένα μεταφραστικό πρόγραμμα.

4. Οι τιμές ΑΛΗΘΗΣ και ΨΕΥΔΗΣ είναι λογικές
    σταθερές.

5. Ο προσδιορισμός της εποχής στην Ελλάδα είναι
     ημιδομημένο πρόβλημα.



Τετάρτη, 7 Νοεμβρίου 2012

Συμπληρώστε τις σχέσεις

Ποια είναι τα αποτελέσματα των παρακάτω σχέσεων;
1.  Αν Ν, Μ περιττοί θετικοί ακέραιοι,
         (Ν - Μ) mod 2 = ......
2. Αν Ν περιττός θετικός ακέραιος και Μ άρτιος θετικός
    ακέραιος,
         (Ν+Μ) mod 2 = ......
3. Αν  ΚΑΠΠΑ = 'ΛΑΜΔΑ',
          (ΚΑΠΠΑ <= 'ΚΑΠΠΑ') = 
4. Αν  Ν θετικός ακέραιος,
          (5*Ν) div (10*N)  = ......
5. Αν  Ν θετικός ακέραιος,
          (5*Ν) ...... (100*N)  = 5*N
               

Απαντήσεις

1. 0
2. 1
3.  ΨΕΥΔΗΣ
4. 0
5. mod


Παρασκευή, 2 Νοεμβρίου 2012

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Ο ______ τύπος δεδομένων περιλαμβάνει τις τιμές ΑΛΗΘΗΣ
    και ΨΕΥΔΗΣ.
2. Τα αλφαριθμητικά δεδομένα αποκαλούνται και ________.
3. Η εγγραφή είναι μια _______ δομή δεδομένων.
4. Η γλώσσα προγραμματισμού ADA  προήλθε από την ______.
5. Ο πίνακας καταλαμβάνει ________ θέσεις στην κύρια μνήμη
    του υπολογιστή.


Απαντήσεις

1. λογικός
2. συμβολοσειρές
3. στατική
4. PASCAL
5. συνεχόμενες

Πέμπτη, 1 Νοεμβρίου 2012

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Κάθε πρόβλημα είναι αλληλένδετο με έναν υπολογιστή.
2. Αυτός που διατυπώνει ένα πρόβλημα αποκαλείται
    δημιουργός και αυτός που το επιλύει επιλυτής.
3. Μια δομή επανάληψης που τελειώνει μετά από
    συγκεκριμένο αριθμό επαναλήψεων αποκαλείται
    ατέρμων βρόχος.
4. Οι πίνακες είναι μια μορφή αρχείων.
5. Ένα υποπρόγραμμα διαθέτει το δικό του τμήμα
     δήλωσης συμβολικών σταθερών και μεταβλητών.

Απαντήσεις

1. Λ
2. Σ
3. Λ
4. Λ
5. Σ


Σάββατο, 27 Οκτωβρίου 2012

Συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία διαβάζει 120 δυάδες ακεραίων
αριθμών, υπολογίζει και εμφανίζει το γινόμενο, το άθροισμα
και τη διαφορά κάθε δυάδας.

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΔΥΑΔΕΣ
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Κ, Α, Β
     ΑΡΧΗ
           ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 120
              ΔΙΑΒΑΣΕ Α, Β
              ΓΡΑΨΕ 'ΑΘΡΟΙΣΜΑ =', Α+Β
              ΓΡΑΨΕ 'ΔΙΑΦΟΡΑ =', Α-Β
              ΓΡΑΨΕ 'ΓΙΝΟΜΕΝΟ = ', Α*Β
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ 

Παρασκευή, 26 Οκτωβρίου 2012

Έλεγχος αλγοριθμικών κριτηρίων

Ποιο ή ποια αλγοριθμικά κριτήρια παραβιάζονται στον
παρακάτω υποτιθέμενο αλγόριθμο;
    Αλγόριθμος Ασκ
    Διάβασε Χ
    Όσο (Χ+1) <= Α_Τ(Χ+1) επανάλαβε
         Αν Χ >= 0 τότε
              Ζ <-- 1/(Χ-100)
         αλλιώς
              Ζ <-- Χ^2
         Τέλος_αν
          Ζ <-- Ζ+Υ
    Τέλος_επανάληψης
    Τέλος Ασκ

Απαντήσεις

α) Είσοδος, γιατί το Υ δεν έχει πάρει καμία τιμή.
β) Έξοδος, γιατί ο αλγόριθμος δεν εμφανίζει κανένα
    αποτέλεσμα.
γ) Καθοριστικότητα, γιατί αν Χ = 100 η εντολή
    Ζ <-- 1/(Χ-100) δεν μπορεί να εκτελεστεί
δ) Περατότητα, αφού η συνθήκη της Όσο είναι
    πάντοτε αληθής και η επανάληψη δεν τερμα-
    τίζεται ποτέ.

Πέμπτη, 25 Οκτωβρίου 2012

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Για να λύσουμε ένα πρόβλημα πρέπει προηγουμένως
    να οριοθετήσουμε το χρόνο του.
2. Οι μοναδικοί τελεστές σύγκρισης που μπορούν να
    εφαρμοστούν σε αλφαριθμητικά δεδομένα είναι
    το = και το < >.
3. Οι βιβλιοθήκες περιέχουν προγράμματα που
     υλοποιούν συγκεκριμένες λειτουργίες.
4. Ο τμηματικός προγραμματισμός προέκυψε κυρίως
     μέσα από μια συντονισμένη προσπάθεια
     περιορισμού χρήσης της εντολής GOTO.
5. Οι γλώσσες υψηλού επιπέδου αποκαλούνται και
    συμβολικές γλώσσες.


Απαντήσεις


1. Για να λύσουμε ένα πρόβλημα πρέπει προηγουμένως
    να οριοθετήσουμε το χώρο του.
2. Οι μοναδικοί τελεστές σύγκρισης που μπορούν να
    εφαρμοστούν σε λογικά δεδομένα είναι
    το = και το < >.

3. Οι βιβλιοθήκες περιέχουν υποπρογράμματα που
     υλοποιούν συγκεκριμένες λειτουργίες.

4. Ο δομημένος προγραμματισμός προέκυψε κυρίως
     μέσα από μια συντονισμένη προσπάθεια
     περιορισμού χρήσης της εντολής GOTO.

5. Οι γλώσσες χαμηλού επιπέδου αποκαλούνται και
    συμβολικές γλώσσες.


Κυκλώστε τα σωστά

Ποιά από τα παρακάτω ισχύουν για τις λογικές
παραστάσεις;
1. Όταν ολοκληρωθεί ο υπολογισμός τους έχουν την
    τιμή Αληθής ή Ψευδής.
2. Χρησιμοποιούνται για τον έλεγχο δομών επιλογής
    ή επανάληψης.
3. Δεν περιλαμβάνουν αριθμητικές μεταβλητές.
4. Οι λογικές πράξεις που εμπεριέχουν εκτελούνται από
    τα αριστερά προς τα δεξιά.
5. Εμπεριέχουν μόνο λογικές πράξεις και όχι
    συγκρίσεις.
6. Αποκαλούνται και λογικές εκφράσεις ή συνθήκες.


Απαντήσεις

1, 2,  6

Τετάρτη, 24 Οκτωβρίου 2012

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η επικοινωνία του υπολογιστή με τον άνθρωπο γίνεται
    με τη βοήθεια των φυσικών γλώσσών,
2. Δύο εμφωλευμένες Αν..τότε μπορούν να αντικατασταθούν
    από μία κατάλληλα διατυπωμένη Αν..τότε που να
    επιφέρει το ίδιο αλγοριθμικό αποτέλεσμα.
3. Μια  σταθερά μπορεί να είναι ακέραια ή πραγματική ή
    αλφαριθμητική ή λογική.
4. Ο βρόχος επανάληψης που τερματίζεται μετά από
    κάποιο αριθμό επαναλήψεων αποκαλείται και
    ατέρμων.
5. Χ ΚΑΙ ΑΛΗΘΗΣ = Χ

Απαντήσεις

1. Λ
2. Σ
3. Σ
4. Λ
5. Σ

Πέμπτη, 18 Οκτωβρίου 2012

Κουμπαράς

Θέλετε να μαζέψετε 50000 ευρώ προκειμένου να αγοράσετε
ένα οικόπεδο. Από τα ετήσια εισοδήματα σας καταφέρνετε
να αποταμιεύετε ένα ποσοστό (%) τους. Γράψτε αλγόριθμο
ο οποίος:
α) διαβάζει τα εισοδήματα που είχατε κάθε χρόνο και το
    ποσοστό (%) επί των εισοδημάτων αυτών που καταφέρνατε
    να αποταμιεύετε (οι δύο παραπάνω τιμές εισόδου είναι
    διαφορετικές για κάθε χρόνο),
β) υπολογίζει και εμφανίζει πόσα χρόνια χρειάζονται για
    να πετύχετε το στόχο σας.

Λύση

     Αλγόριθμος Οικόπεδο
     Χρόνια <-- 0
     Αθρ <-- 0
     Όσο Αθρ < 50000 επανάλαβε
          Διάβασε Εισοδ, Ποσοστό
          Αθρ <-- Αθρ+Εισοδ*Ποσοστό/100
          Χρόνια <-- Χρόνια+1
     Τέλος_επανάληψης
     Εμφάνισε Χρόνια
     Τέλος Οικόπεδο

Τρίτη, 16 Οκτωβρίου 2012

Απάντηση σε ερώτηση

Γράψτε αλγόριθμο που:
α) διαβάζει τις τιμές πώλησης και τις μάρκες κάποιων
    tablet (η είσοδος δεδομένων ολοκληρώνεται μόλις
    δοθεί η απάντηση 'Ο'΄στην υποβαλλόμενη προς
    το χρήστη ερώτηση 'Υπάρχει άλλο tablet?')
β) υπολογίζει και εμφανίζει:
    * τη μάρκα της ακριβότερης συσκευής,
    * πόσα tablet στοίχιζαν περισσότερο από 300 ευρώ.

Λύση

     Αλγόριθμος tablet
     MAX <-- -9
     φ <-- 0
     Αρχή_επανάληψης
         Διάβασε Τιμή
         Διάβασε Μάρκα
         Αν Τιμή > ΜΑΧ τότε
              ΜΑΧ <-- Τιμή
              ΜαρκΜΑΧ <-- Μάρκα
         Τέλος_αν
         Αν Τιμή > 300 τότε
              φ <-- φ+1
         Τέλος_αν
         Εμφάνισε 'Υπάρχει άλλο tablet?'
         Διάβασε Απ
     Μέχρις_ότου Απ = 'Ο'
     Εμφάνισε ΜαρκΜΑΧ, φ
     Τέλος tablet
   

Δευτέρα, 15 Οκτωβρίου 2012

Φρουρός

Γράψτε αλγόριθμο που :
α) διαβάζει τους συντελεστές κάποιων πρωτοβάθμιων εξισώσεων
    ΑΧ = Β ( η είσοδος δεδομένων ολοκληρώνεται μόλις δοθεί
    ως τιμή εισόδου για το Α το 0),
β) επιλύει την κάθε εξίσωση ξεχωριστά και εμφανίζει τα αποτελέσματα
    στη μονάδα εξόδου.

Λύση

    Αλγόριθμος Εξισώσεις
    Αρχή_επανάληψης
        Διάβασε Α, Β
        Αν Α < > 0 τότε
            Χ <-- Β/Α
            Εμφάνισε Χ
        Τέλος_αν
    Μέχρις_ότου Α = 0
    Τέλος Εξισώσεις

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει τους αγαπημένους προορισμούς
διακοπών 130 αλλοδαπών τουριστών, υπολογίζει και εμφανίζει:
α) το ποσοστό (%) των τουριστών που επέλεξαν ως προορισμό
    τους την ΕΛΛΑΔΑ,
β) πόσοι δεν επέλεξαν ως προορισμό τους τη ΓΕΡΜΑΝΙΑ.

Λύση

      Αλγόριθμος Τουρ
      Ελλαδ <-- 0
      ΟχιΓερμ <-- 0
      Για κ από 1 μέχρι 130
           Διάβασε Προ
           Αν Προ = 'ΕΛΛΑΔΑ' τότε
               Ελλαδ <-- Ελλαδ+1
           Τέλος_αν
           Αν Προ < >  'ΓΕΡΜΑΝΙΑ' τότε
               ΟχιΓερμ <-- ΟχιΓερμ+1
           Τέλος_αν            
      Τέλος_επανάληψης
      ΠΟΣ <-- 100*Ελλαδ/130
      Εμφάνισε ΠΟΣ, ΟχιΓερμ
      Τέλος Τουρ

Τρίτη, 9 Οκτωβρίου 2012

Κυκλώστε τα σωστά

Ποιά από τα παρακάτω ισχύουν για την Αν..τότε..αλλιώς_αν;
  1. Είναι μια δομή πολλαπλής επιλογής.
  2. Αποκαλείται και εμφωλευμένος βρόχος.
  3. Χρησιμοποιείται όταν τα ενδεχόμενα είναι τουλάχιστον
      τρία.
  4. Χρησιμοποιείται όταν τα ενδεχόμενα είναι τουλάχιστον
      δύο.
  5. Παριστάνεται διαγραμματικά με ένα ρόμβο που έχει
      τουλάχιστον τρεις εξόδους για απάντηση.
  6. Τελειώνει με τη δεσμευμένη λέξη Τέλος_αν.
  7. Είναι μια δομή επανάληψης


Απαντήσεις

1, 3, 6

Πίνακας αντιστοίχησης

Δίνονται οι ακόλουθες έννοιες
    1. ελεύθερο κείμενο
    2. υπολογιστική διαδικασία
    3. αλγόριθμος
    4. γλώσσα μηχανής
    5. υποπρόγραμμα
και οι πιθανές ερμηνείες-ορισμοί
    α. τρόπος αναπαράστασης προγράμματος
    β. τρόπος αναπαράστασης αλγορίθμου
    γ. μηχανισμός παραγωγής πληροφοριών
    δ. επεξεργασία δεδομένων μέσω υπολογιστή
    ε. γλώσσα 4ης γενιάς
    στ. μια ακολουθία από 0 και 1
    ζ. ένα πρόγραμμα που εκτελεί υποδεέστερο έργο
    η. ένα τμήμα προγράμματος που εκτελεί ένα
        αυτόνομο έργο
    θ. ένας αλγόριθμος που δεν τελειώνει ποτέ
Γράψτε τον αριθμό (1-5) και δίπλα το γράμμα (α-θ)
στο οποίο αντιστοιχεί.

Απαντήσεις

1. β
2. θ
3. γ
4. στ
5. η

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η ___________ σταθερά είναι ένα όνομα που
    αντιπροσωπεύει μια σταθερή ποσότητα.
2. Κάθε  _________ ενός προγράμματος δεσμεύει
    συγκεκριμένο χώρο στην κύρια μνήμη του υπολογιστή.
3. Ο ___________ μεταφράζει ένα πρόγραμμα από
    γλώσσα χαμηλού επιπέδου σε γλώσσα μηχανής.
4. Η εντολή GOTO αλλάζει βίαια τη ________ εκτέλεσης
    των εντολών.
5. Η είσοδος είναι ένα από τα ________ κριτήρια.

Απαντήσεις

1. συμβολική
2. μεταβλητή
3. συμβολομεταφραστής
4. σειρά
5. αλγοριθμικά

Πέμπτη, 4 Οκτωβρίου 2012

Διατύπωση περιορισμών

Διατυπώστε τους παρακάτω περιορισμούς στη ΓΛΩΣΣΑ
1. Το Απ μπορεί να είναι 'Ν' ή 'ν'
2. Το ΡΕΣ δεν μπορεί να είναι ούτε 'ΑΡΧΗ' ούτε
    'ΤΕΛΟΣ'
3. Η πραγματική μεταβλητή Χ περιέχει ακέραιο και
    θετικό περιεχόμενο.
4. Το Χ δεν ανήκει στο διάστημα τιμών (0, 20)
5. Το Χ είναι τουλάχιστον 50 αλλά δεν υπερβαίνει
    το 100


Απαντήσεις

1. (Απ = 'Ν') Ή (Απ = 'ν')
2. (ΡΕΣ < > 'ΑΡΧΗ') ΚΑΙ (ΡΕΣ < > 'ΤΕΛΟΣ')
3. (Α_Μ(Χ) = Χ) ΚΑΙ (Χ > 0)
4. (Χ <= 0) Ή (Χ >= 20)
5. (Χ >= 50) ΚΑΙ (Χ <= 100)


Τετάρτη, 3 Οκτωβρίου 2012

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η πράξη div εφαρμόζεται μόνο πάνω σε ακέραια ορίσματα.
2. Η πράξη mod δίνει αποτέλεσμα πραγματικού τύπου.
3. Η λογική πράξη ΔΕΝ είναι γνωστή και ως άρνηση.
4. Η συνάρτηση Τ_Ρ υπολογίζει την τετραγωνική ρίζα
    του ορίσματός της.
5. Ο τελεστής * έχει μικρότερη ιεραρχία από τον 
    τελεστή /.



Απάντηση

1. Σ
2. Λ
3. Λ
4. Σ
5. Λ





Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Ο αλγόριθμος παριστάνεται σχηματικά με ένα
    ραβδόγραμμα.
2. Η συνθήκη που ελέγχει μια εντολή Όσο..επανάλαβε
    είναι μια παράσταση.
3. Η εντολή ΓΡΑΨΕ μπλοκάρει προσωρινά την
    εκτέλεση των εντολών ενός προγράμματος.
4. Η εντολή Για..από..μέχρι είναι ιδανική για έλεγχο
    εγκυρότητας των εισερχόμενων δεδομένων.
5. Ο πίνακας Α[2,3,5] είναι μονοδιάστατος.


Απαντήσεις

1. Ο αλγόριθμος παριστάνεται σχηματικά με ένα
    λογικό διάγραμμα.
2.  Η συνθήκη που ελέγχει μια εντολή Όσο..επανάλαβε 
     είναι μια λογική παράσταση.
3.   Η εντολή ΔΙΑΒΑΣΕ μπλοκάρει προσωρινά την
    εκτέλεση των εντολών ενός προγράμματος.
4. Η εντολή Μέχρις_ότου είναι ιδανική για έλεγχο
    εγκυρότητας των εισερχόμενων δεδομένων.
5. Ο πίνακας Α[2,3,5] είναι τρισδιάστατος.




Πέμπτη, 27 Σεπτεμβρίου 2012

Ερωτήσεις σωστού λάθους

Αν Ν θετικός ακέραιος, ποιες από τις παρακάτω σχέσεις είναι
σωστές και ποιες λάθος;
1. (4*Ν+8) mod 4 = 0
2. (4*Ν+8) div (4*N+9) = 0
3. (2^2 >= 2+3) = ΑΛΗΘΗΣ
4. ( 'ΚΑΛΗΜΕΡΑ' <=  'ΚΑΛΗΣΠΕΡΑ' ) = ΨΕΥΔΗΣ
5.  (Τ_Ρ(Α_Τ(Χ)) >= 0 ) = ΑΛΗΘΗΣ



Απαντήσεις

1. Σ
2. Σ
3. Λ
4. Λ
5. Σ

Τετάρτη, 26 Σεπτεμβρίου 2012

Πίνακας δεδομένων - ζητουμένων


Σ’ ένα χωριό κατοικούν 200 κάτοικοι. Αν τα 
παιδιά αποτελούν το 20% του πληθυσμού 
των ανδρών και οι γυναίκες είναι κατά 46 
περισσότερες από τους άνδρες, πόσοι 
άνδρες, γυναίκες και παιδιά κατοικούν 
στο χωριό αυτό;
1.     Κατασκευάστε πίνακα 
     δεδομένων - ζητούμενων.
2.     Μορφοποιήστε με μαθηματικό 
     τρόπο το πρόβλημα.

Λύση

1.

   Δεδομένα     * Το συνολικό πλήθος των 
                           κατοίκων είναι 200
                        * Τα παιδιά αποτελούν  
                           το 20% του πληθυ-
                           σμού των ανδρών
                        * Οι γυναίκες είναι κατά 
                           46 περισσότερες από 
                           τους άνδρες
  Ζητούμενα    * Πλήθος ανδρών
                        * Πλήθος γυναικών
                        * Πλήθος παιδιών

2. 
       Ας συμβολίσουμε με 
            Ανδ : το πλήθος των ανδρών
            Γυν : το πλήθος των γυναικών
            Παιδ: το πλήθος των παιδιών
       Ισχύουν οι σχέσεις:
            Ανδ+Γυν+Παιδ = 200
            Παιδ = Ανδ*20/100
            Γυν = Ανδ+46





Κυριακή, 23 Σεπτεμβρίου 2012

Απάντηση σε ερώτηση

Γράψτε αλγόριθμο ο οποίος:
α) διαβάζει δυάδες ακεραίων αριθμών (η είσοδος δεδομένων
    ολοκληρώνεται μόλις δοθεί η απάντηση 'ΟΧΙ' στην
     υποβαλλόμενη προς το χρήστη ερώτηση
      'Ολοκληρώθηκε η είσοδος;'),
β) υπολογίζει και εμφανίζει:
    * το άθροισμα κάθε δυάδας,
    * το ποσοστό (%) των δυάδων που τα μέλη τους διέφεραν
       περισσότερο από 20,
    * το πλήθος των δυάδων με ομόσημα μέλη.

Λύση

     Αλγόριθμος Δυάδες
     φ20 <-- 0
     πληθ <-- 0
     ομο <-- 0
     Αρχή_επανάληψης
           Διάβασε α, β
           αθρ <-- α+β
           πληθ <-- πληθ+1
           Εμφάνισε αθρ
           Αν α*β > 0 τότε
                ομο <-- ομο+1
           Τέλος_αν
           Αν Α_Τ(α-β) > 20 τότε
                φ20 <-- φ20+1
           Τέλος_αν
           Εμφάνισε 'Ολοκληρώθηκε η είσοδος;'
           Διάβασε Απ
     Μέχρις_ότου Απ = 'ΟΧΙ'
     ποσ <-- 100*φ20/Πληθ
     Εμφάνισε ομο, ποσ
     Τέλος Δυάδες

Σάββατο, 22 Σεπτεμβρίου 2012

Φρουρός

Γράψτε αλγόριθμο ο οποίος:
α) διαβάζει τριάδες ακεραίων αριθμών (η είσοδος δεδομένων
    ολοκληρώνεται μόλις κάποια από τις τιμές εισόδου είναι μη
    θετική),
β) υπολογίζει και εμφανίζει πόσες από τις παραπάνω τριάδες
    είναι Πυθαγόρειες.
Παρατήρηση : Πυθαγόρεια είναι μια τριάδα αριθμών που
έχει την ιδιότητα το τετράγωνο του ενός αριθμού να είναι
ίσο με το άθροισμα των τετραγώνων των δύο άλλων.

Λύση

    Αλγόριθμος Πυθαγορ
    πληθ <-- 0
    Αρχή_επανάληψης
         Διάβασε α, β, γ
         Αν (α > 0) ΚΑΙ (β > 0) ΚΑΙ (γ > 0) τότε
               Αν (α^2 = β^2+γ^2) Ή (β^2 = α^2+γ^2) Ή
                    (γ^2 = α^2+β^2) τότε
                      πληθ <-- πληθ+1
               Τέλος_αν
         Τέλος_αν
    Μέχρις_ότου (α <= 0) Ή (β <= 0) Ή (γ <= 0)
    Εμφάνισε πληθ
    Τέλος Πυθαγορ

Τρίτη, 18 Σεπτεμβρίου 2012

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Ο αλγόριθμος μπορεί να μην βγάζει κανένα αποτέλεσμα ως
     έξοδο.
2. Οι μεταβλητές ενός προγράμματος έχουν ένα μοναδικό
    τύπο δεδομένων που δηλώνεται στο τμήμα δήλωσης
    των μεταβλητών.
3. Οι εντολές εκχώρησης και ΔΙΑΒΑΣΕ μπορούν να
    αλλάξουν το περιεχόμενο μιας μεταβλητής.
4. Τα υποπρογράμματα δεν μπορούν να αλλάξουν το
    περιεχόμενο των πραγματικών παραμέτρων.
5. Οι συναρτήσεις είναι αναπόσπαστο στοιχείο ενός
    προγράμματος.
   

Απαντήσεις

1. Λ
2. Σ
3. Σ
4. Λ
5. Λ


Κυριακή, 16 Σεπτεμβρίου 2012

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που:
α) διαβάζει τους τίτλους και το πλήθος των σελίδων 130
    μυθιστορημάτων,
β) υπολογίζει και εμφανίζει:
    * πόσα βιβλία έχουν περισσότερες από 330 σελίδες,
    * τον τίτλο του βιβλίου με τις λιγότερες σελίδες.

Λύση

    Αλγόριθμος Μυθ
    φ330 <-- 0
    μικ <-- 99999
    Για κ από 1 μέχρι 130
         Διάβασε τιτλ
         Διάβασε σελ
         Αν σελ > 330 τότε
             φ330 <-- φ330+1
         Τέλος_αν
         Αν σελ < μικ τότε
             μικ <-- σελ
             τιτλμικ <-- τιτλ
         Τέλος_αν
    Τέλος_επανάληψης
    Εμφάνισε τιτλμικ, φ330
    Τέλος Μυθ

Πέμπτη, 13 Σεπτεμβρίου 2012

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει
τα έτη γέννησης των 500 μαθητών ενός γυμνασίου, υπολογίζει
και εμφανίζει:
α) το μέσο όρο ηλικίας τους,
β) τον αύξοντα αριθμό (1-500) του γηραιότερου μαθητή.

Λύση

      Αλγόριθμος Μαθητές
      σ <-- 0
      Μικ <-- 3001
      Για κ από 1 μέχρι 500
           Διάβασε Έτος
           Αν Έτος < Μικ τότε
                 Μικ <-- Έτος
                 ΑΑΓηρ <-- κ
           Τέλος_αν
           σ <-- σ+(2012-Έτος)
      Τέλος_επανάληψης
      μο <-- σ/500
      Εμφάνισε μο, ΑΑΓηρ
      Τέλος Μαθητές

Φρουρός

Γράψτε αλγόριθμο που διαβάζει την επωνυμία και το πλήθος των
ασφαλισμένων κάποιων ασφαλιστικών ταμείων (η είσοδος
δεδομένων ολοκληρώνεται μόλις δοθεί ως επωνυμία το κενό
διάστημα ή ως πλήθος ασφαλισμένων μια μη θετική τιμή),
υπολογίζει και εμφανίζει:
α) την επωνυμία του ασφαλιστικού ταμείου με τους
    περισσότερους ασφαλισμένους,
β) το ποσοστό (%) των ασφαλιστικών ταμείων που είχαν
    τουλάχιστον 20000 ασφαλισμένους.

Λύση

    Αλγόριθμος Ταμεία
    φ20 <-- 0
    πληθ <-- 0
    Μεγ <-- -100
    Αρχή_επανάληψης
            Διάβασε επ
            Διάβασε ασφ
            Αν (επ < > '  ') ΚΑΙ (ασφ > 0) τότε
                 πληθ <-- πληθ+1
                 Αν ασφ >= 20000 τότε
                      φ20 <-- φ20+1
                 Τέλος_αν
                 Αν ασφ > Μεγ τότε
                      Μεγ <-- ασφ
                      επΜεγ <-- επ
                 Τέλος_αν
            Τέλος_αν
    Μέχρις_ότου (επ = '  ') Ή (ασφ <= 0)
    Αν πληθ > 0 τότε
         ποσ20 <-- 100*φ20/πληθ
         Εμφάνισε ποσ20, επΜεγ
    αλλιώς
         Εμφάνισε 'Δε δόθηκαν δεδομένα'
    Τέλος_αν
    Τέλος Ταμεία

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Η επίλυση της εξίσωσης  αΧ=β είναι αδόμητο πρόβλημα.
2. Η συνάρτηση Τ_Ρ επιστρέφει αποτέλεσμα ακεραίου τύπου.
3. Η αποτελεσματικότητα είναι ένα αλγοριθμικό κριτήριο.
4. Μια δυναμική δομή δεδομένων αποθηκεύει τους κόμβους της
    σε μη συνεχόμενες θέσεις μνήμης.
5. Η λέξη ανθρώπων ανήκει στο τυπολογικό της ελληνικής
    γλώσσας.


Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Σ
5. Σ

Τετάρτη, 12 Σεπτεμβρίου 2012

Απάντηση σε ερώτηση+αναγωγή στη μονάδα

Γράψτε αλγόριθμο που :
α) διαβάζει τις τιμές πώλησης και το πλήθος των ετικετών
    κάποιων συσκευασιών (η είσοδος δεδομένων ολοκληρώνεται
    μόλις δοθεί η απάντηση 'ΟΧΙ' στην υποβαλλόμενη προς το
    χρήστη ερώτηση 'Υπάρχει άλλη συσκευασία;'),
β) υπολογίζει και εμφανίζει τον αύξοντα αριθμό της πιο
    συμφέρουσας για έναν πελάτη συσκευασίας.
Παρατήρηση: Καμιά συσκευασία δε στοίχιζε περισσότερα
από 5 ευρώ.

Λύση

    Αλγόριθμος Ασκ
    Μικ <-- 6
    Πληθ <-- 0
    Αρχή_επανάληψης
         Διάβασε Τιμ, Ετικ
         Πληθ <-- Πληθ+1
         ΤιμΕτικ <-- Τιμ/Ετικ
         Αν ΤιμΕτικ < Μικ τότε
              Μικ <-- ΤιμΕτικ
              ΑΑΜικ <-- Πληθ
         Τέλος_αν
         Εμφάνισε 'Υπάρχει άλλη συσκευασία;'
         Διάβασε Απ
    Μέχρις_ότου Απ = 'ΟΧΙ'
    Εμφάνισε ΑΑΜικ
    Τέλος Ασκ
    

Δευτέρα, 10 Σεπτεμβρίου 2012

Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει τις χωρητικότητες (σε λίτρα) 25
δεξαμενών και υπολογίζει:
α) τη μέση χωρητικότητα τους,
β) τον αύξοντα αριθμό (1-25) της δεξαμενής με τη μικρότερη
    χωρητικότητα,
γ) πόσες δεξαμενές είχαν χωρητικότητα που ξεπερνούσε
    τα 10000 λίτρα.
Παρατήρηση : Καμιά δεξαμενή δεν είχε χωρητικότητα
μεγαλύτερη από 20000 λίτρα.

Απάντηση

     Αλγόριθμος Δεξαμενές
     Μικ <-- 20001
     σ <-- 0
     φ <-- 0
     Για κ από 1 μέχρι 25
          Διάβασε χωρ
          σ <-- σ+χωρ
          Αν χωρ < Μικ τότε
               Μικ <-- χωρ
               ΑΑΜικ <-- κ
          Τέλος_αν
          Αν χωρ > 10000 τότε
               φ <-- φ+1
          Τέλος_αν
     Τέλος_επανάληψης
     μο <-- σ/25
     Αποτελέσματα // μο, ΑΑΜικ, φ //
     Τέλος Δεξαμενές

Σάββατο, 8 Σεπτεμβρίου 2012

Απάντηση σε ερώτηση

Γράψτε αλγόριθμο που:
α) διαβάζει το πλήθος  των μυθιστορημάτων που διάβασαν
     μέσα στο χρόνο κάποιοι μαθητές (η είσοδος δεδομένων
    ολοκληρώνεται μόλις δοθεί η απάντηση 'Ν' στην
    υποβαλλόμενη προς το χρήστη ερώτηση 'Υπάρχει άλλος
    μαθητής;'),
β) υπολογίζει και εμφανίζει:
    * το ποσοστό (%) των μαθητών που διάβασαν τουλάχιστον
       10 μυθιστορήματα,
    * τον αύξοντα αριθμό του μαθητή που διάβασε τα λιγότερα.
Παρατήρηση
Θεωρείστε ότι κανένας μαθητής δε διάβασε περισσότερα από
50 μυθιστορήματα.

Λύση

    Αλγόριθμος βιβλία
    πληθ <-- 0
    φ <-- 0
    μικ <-- 51
    Αρχή_επανάληψης
         Διάβασε αρβ
         πληθ <-- πληθ+1
         Αν αρβ >= 10 τότε
              φ <-- φ+1
         Τέλος_αν
         Αν αρβ < μικ τότε
              μικ <-- αρβ
              ααμικ <-- πληθ
         Τέλος_αν
         Εμφάνισε 'Υπάρχει άλλος μαθητής;'
         Διάβασε απ
    Μέχρις_ότου απ = 'Ν'
    ποσ10 <-- 100*φ/πληθ
    Εμφάνισε ποσ10, ααμικ
    Τέλος βιβλία

Φρουρός

Γράψτε αλγόριθμο που:
α) διαβάζει τις εβδομαδιαίες ώρες διδασκαλίας που παρακολουθούν
     κάποιοι μαθητές στα Αγγλικά (η είσοδος τερματίζεται μόλις
     δοθεί μια αρνητική τιμή εισόδου).
β) υπολογίζει το μέσο όρο εβδομαδιαίων ωρών διδασκαλίας
    των Αγγλικών ανά μαθητή.

Λύση

    Αλγόριθμος Αγγλ
    σ <-- 0
    πληθ <-- 0
    Αρχή_επανάληψης
        Διάβασε Ω
        Αν Ω >= 0 τότε
              σ <-- σ+Ω
              πληθ <-- πληθ+1
        Τέλος_αν
    Μέχρις_ότου Ω < 0
    Αν πληθ > 0 τότε
        μο <-- σ/πληθ
        Εμφάνισε μο
    αλλιώς 
        Εμφάνισε 'Δε δόθηκαν δεδομένα!'
    Τέλος_αν
    Τέλος Αγγλ

Τετάρτη, 5 Σεπτεμβρίου 2012

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και επαναδιατυπώστε
τις με σωστό τρόπο.
1. Ο αλγόριθμος ολοκληρώνεται μετά από περιορισμένο αριθμό
    βημάτων.
2. Το πρόβλημα του έτους 2000 είχε να κάνει με τον τρόπο
     αποθήκευσης της ώρας στους παλιότερους υπολογιστές.
3.  Οι εγγραφές είναι δομές δεδομένων δευτερεύουσας μνήμης.
4.  Μια από τις σκοπιές που εξετάζει η Πληροφορική τα δεδομένα
     είναι και αυτή των ψευδογλωσσών.
5.  Οι μεταβλητές έχουν σταθερό περιεχόμενο.



Απαντήσεις

1. Ο αλγόριθμος ολοκληρώνεται μετά από πεπερασμένο αριθμό
    βημάτων.

2. Το πρόβλημα του έτους 2000 είχε να κάνει με τον τρόπο
     αποθήκευσης της ημερομηνίας στους παλιότερους υπολογιστές.
3.  Οι εγγραφές είναι δομές δεδομένων κύριας μνήμης.

4.  Μια από τις σκοπιές που εξετάζει η Πληροφορική τα δεδομένα
     είναι και αυτή των γλωσσών προγραμματισμού.
5.  Οι μεταβλητές έχουν σταθερό τύπο δεδομένων.

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Η πράξη div μπορεί να εφαρμοστεί μόνο σε ορίσματα ακεραίου
    τύπου.
2. Ο τελεστής >= μπορεί να εφαρμοστεί και πάνω σε ορίσματα
    λογικού τύπου.
3. Ο πίνακας είναι μια συλλογή στοιχείων ακεραίου τύπου.
4. Μια συνάρτηση μπορεί να επιστρέψει ως αποτέλεσμά της έναν
    ολόκληρο πίνακα.
5. Ο ορισμός μιας διαδικασίας τελειώνει με τη δεσμευμένη
    λέξη ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ.

Απαντήσεις

1. Σ
2. Λ
3. Λ
4. Λ
5. Σ

Τετάρτη, 29 Αυγούστου 2012

Εμφωλευμένες δομές επιλογής

Σ' ένα fun park η χρέωση των πελατών (για όλες
τις δραστηριότητες του πάρκου) γίνεται ως εξής:
Σαββατοκύριακα
     Ενήλικες     25 ευρώ
     Παιδιά         17 ευρώ
Καθημερινές
     Ενήλικες     18 ευρώ
     Παιδιά         10 ευρώ
Γράψτε αλγόριθμο που:
α) διαβάζει το αν η ημέρα επίσκεψης ενός πελάτη
    είναι καθημερινή (Κ) ή Σαββατοκύριακο (Σ),
β) διαβάζει αν ο πελάτης αυτός είναι ενήλικος (Ε) ή
    παιδί (Π),
γ) υπολογίζει το ποσό που πρέπει να καταβάλλει για
   να εισέλθει στο πάρκο.

Λύση

    Αλγόριθμος Πάρκο
    Διάβασε Μέρα
    Διάβασε Πελάτης
    Αν Μέρα = 'Σ' τότε
         Αν Πελάτης = 'Ε' τότε
              Ποσό <-- 25
         αλλιώς
              Ποσό <-- 17
         Τέλος_αν
    αλλιώς
         Αν Πελάτης = 'Ε' τότε
              Ποσό <-- 18
         αλλιώς
              Ποσό <-- 10
         Τέλος_αν
    Τέλος_αν
    Αποτελέσματα // Ποσό //
    Τέλος Πάρκο

Κλιμακωτός υπολογισμός

Σ' ένα μαγαζί αθλητικών ειδών, η χρέωση των
φανελών προπόνησης της μάρκας ΑΑΑ γίνεται με
κλιμακωτό τρόπο ως εξής:
* οι πρώτες 5 τιμώνται προς 18 ευρώ,
* οι επόμενες 4 τιμώνται προς 16 ευρώ,
* από 10 και πάνω τιμώνται προς 12 ευρώ.
Γράψτε αλγόριθμο που δοθέντος του αριθμού
των φανελών που επιθυμεί να αγοράσει ένας
πελάτης, υπολογίζει το συνολικό ποσό που
πρέπει να καταβάλλει.

Λύση

    Αλγόριθμος ΑΑΑ
    Δεδομένα // Φαν //
    Αν Φαν <= 5 τότε
         Ποσό <-- Φαν*18
    αλλιώς_αν Φαν <= 9 τότε
         Ποσό <-- 5*18+(Φαν-5)*16
    αλλιώς
         Ποσό <-- 5*18+4*16+(Φαν-9)*12
    Τέλος_αν
    Αποτελέσματα // Ποσό //
    Τέλος ΑΑΑ

Αλγόριθμος ακολουθιακής δομής

Γράψτε αλγόριθμο που δοθέντος ενός αριθμού μηνών,
υπολογίζει σε πόσους αιώνες, έτη και μήνες αντιστοιχεί.

Λύση

   Αλγόριθμος Χρον
   Δεδομένα // ΣυνΜην //
   Αιωνες <-- ΣυνΜην div 1200
   Ετη <-- (ΣυνΜην mod 1200) div 12
   Μην <-- (ΣυνΜην mod 1200) mod 12
   Αποτελέσματα // Αιωνες, Ετη, Μην //
   Τέλος Χρον

Παρασκευή, 24 Αυγούστου 2012

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και επαναδιατυπώστε
τις με σωστό τρόπο.
1. Η δομή ακολουθίας είναι μια από τις τρεις αλγοριθμικές επιλογές.
2. Ένα πρόβλημα που δεν λύνεται αποκαλείται αδύνατο.
3. Η μετάφραση ενός προγράμματος σε τεχνητή γλώσσα μπορεί
    να γίνει μέσω μεταγλωττιστή ή διερμηνευτή.
4. Ο συγκριτικός τελεστής με τη μεγαλύτερη προτεραιότητα
    είναι ο ΟΧΙ.
5. Η επιλογή του μέσου μαζικής μεταφοράς είναι ένα αδόμητο
    πρόβλημα.





Απαντήσεις

1. Η δομή ακολουθίας είναι μια από τις τρεις αλγοριθμικές δομές.
2. Ένα πρόβλημα που δεν λύνεται αποκαλείται άλυτο.

3. Η μετάφραση ενός προγράμματος σε γλώσσα μηχανής μπορεί
    να γίνει μέσω μεταγλωττιστή ή διερμηνευτή.
4. Ο λογικός τελεστής με τη μεγαλύτερη προτεραιότητα
    είναι ο ΟΧΙ.

5. Η επιλογή του μέσου μαζικής μεταφοράς είναι ένα ημιδομημένο
    πρόβλημα.


Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1.Η αφαιρετικότητα είναι αλγοριθμικό κριτήριο.
2. Μια  δομή επανάληψης αποκαλείται και βρόχος.
3. Η δομή επιλογής μπορεί να χρησιμοποιηθεί για τη
    διενέργεια ελέγχων σε αλγορίθμους ή προγράμματα.
4. Ένας πίνακας μπορεί να είναι είτε μονοδιάστατος είτε
    δυσδιάστατος.
5. Τα υποπρογράμματα είναι αναπόσπαστα στοιχεία ενός
    προγράμματος.


Απαντήσεις

1. Λ
2. Σ
3. Σ
4. Λ
5. Λ

Σάββατο, 11 Αυγούστου 2012

Έλεγχος αλγοριθμικών κριτηρίων

Ποιο ή ποια αλγοριθμικά κριτήρια παραβιάζει το
παρακάτω σύνολο εντολών;
      Κ <-- 1
      Α <-- 0
      Όσο Κ <= 12 επανάλαβε
            Α <-- Α+1/(Κ-4)
            Αν Κ mod 12 = 0 τότε
                 Κ <-- Κ-10
            Τέλος_αν
            Κ <-- Κ+1
      Τέλος_επανάληψης
      Εμφάνισε Α

Λύση

    Παραβιάζονται:
    α) η καθοριστικότητα, γιατί όταν το Κ γίνει 4 η εντολή
        Α <-- Α+1/(Κ-4) δεν μπορεί να εκτελεστεί
    β) η περατότητα, γιατί το Κ δεν πρόκειται ποτέ να ξεπεράσει
        το 12 και η Όσο..επανάλαβε αποτελεί ατέρμων βρόχο (οι
        τιμές που παίρνει το Κ είναι 1, 2, ...., 12, 3, 4, ..., 12, 3, 4, ...., 12, κτλ)

Διόρθωση συντακτικών λαθών

Διορθώστε τον παρακάτω Αλγόριθμο και επαναδιατυπώστε τον
έτσι ώστε να μην έχει συντακτικά λάθη.
    Αλγόριθμος  Βρείτε τα λάθη
    Δεδομένο // Χ //
    Υ = Χ
    Όσο Υ > 0 επανέλαβε
         Διαβάστε Ζ
         Υ = Υ-Ζ
    ΤέλοςΌσο
    Αποτέλεσμα  Υ
    Τέλος_αλγορίθμου  Βρείτε τα λάθη

Απάντηση

    Αλγόριθμος  Βρείτε_τα_λάθη
    Δεδομένα // Χ //
    Υ <-- Χ
    Όσο Υ > 0 επανάλαβε
         Διάβασε Ζ
         Υ <-- Υ-Ζ
    Τέλος_επανάληψης
    Αποτελέσματα //Υ//
    Τέλος  Βρείτε_τα_λάθη

Επαναδιατύπωση λογικών συνθηκών

Επαναδιατυπώστε τις παρακάτω λογικές συνθήκες, χρησιμοποιώντας
μόνο συγκριτικούς τελεστές και το λογικό τελεστή Ή.
  1. ΟΧΙ (Χ = 'Α') Ή ΟΧΙ (Χ = 'Γ')
  2. ΟΧΙ ( (Χ >= 31) ΚΑΙ (Χ <= 111) )
  3. ΟΧΙ ( (Χ < > 1) ΚΑΙ (Χ < > 2) ΚΑΙ (Χ < > 3) )
  4. ΟΧΙ ( (Χ > 0) ΚΑΙ ΟΧΙ(Χ < > -3) )

Απαντήσεις

1. (Χ < > 'Α') Ή (Χ < > 'Γ')
2. ΟΧΙ ( (Χ >= 31) ΚΑΙ (Χ <= 111) ) =
    ΟΧΙ (Χ >= 31) Ή ΟΧΙ (Χ <= 111)  =
    (Χ < 31) Ή (Χ > 111)
3. ΟΧΙ ( (Χ < > 1) ΚΑΙ (Χ < > 2) ΚΑΙ (Χ < > 3) ) =
    ΟΧΙ (Χ < > 1) Ή ΟΧΙ (Χ < > 2) Ή ΟΧΙ (Χ < > 3)  =
    (Χ = 1) Ή (Χ = 2) Ή (Χ = 3)
4. ΟΧΙ ( (Χ > 0) ΚΑΙ ΟΧΙ(Χ < > -3) ) =
    ΟΧΙ ( (Χ > 0) ΚΑΙ (Χ = -3) ) =
    ΟΧΙ (Χ > 0) Ή ΟΧΙ (Χ = -3)  =
    (Χ < = 0) Ή (Χ < > -3)


Παρασκευή, 10 Αυγούστου 2012

Διατύπωση περιορισμών

Διατυπώστε τους παρακάτω περιορισμούς στη ΓΛΩΣΣΑ, χρησιμοποιώντας
κατάλληλες λογικές συνθήκες
1. Το Χ είναι μεγαλύτερο από το 200 και διαφορετικό τόσο από το 500
    όσο και από το 1000.
2. Το Υ είναι άρτιο ή πολλαπλάσιο του 3 αλλά όχι του 9.
3. Η πραγματική μεταβλητή  Z περιέχει ακέραιο και θετικό αριθμό.
4. Το Κ έχει τιμή 5 ή 10 ή 18
5. Το Μ δεν ανήκει στο διάστημα τιμών [-1, 999]

Απαντήσεις

1.  (Χ > 200) ΚΑΙ (Χ < > 500) ΚΑΙ (Χ < > 1000)
2.  (Υ mod 2 = 0) Ή ( (Υ mod 3 = 0) KAI (Y mod 9 < > 0) )
3. (Α_Μ(Ζ) = Ζ) ΚΑΙ (Ζ > 0)
4. (Κ = 5) Ή (Κ = 10) Ή (Κ = 18)
5.  (Μ < -1) Ή (Μ > 999)

Συγγραφή κατάλληλων εντολών εκχώρησης

Γράψτε τις εντολές εκχώρησης που υλοποιούν τις παρακάτω λειτουργίες:
1. Βάλε στο Β το γινόμενο του Α με το Γ, ελαττωμένο κατά 10.
2. Βάλε στο Γ το υπόλοιπο της διαίρεσης του τετραγώνου του Α
    με το 100.
3. Βάλε στο Α το πηλίκο της διαίρεσης του δεκαπλασίου του Β με
    το τριπλάσιο του Γ.
4. Βάλε στο Δ το μέσο όρο των Α, Β, πολλαπλασιασμένο με το Γ.
5. Βάλε στο Δ το αντίστροφο του γινομένου των Α, Β, Γ.



Απαντήσεις

1. Β <-- Α*Γ-10
2. Γ <-- Α^2 mod 100
3. Α <-- (10*Β) div (3*Γ)
4. Δ <-- (Α+Β)/2*Γ
5. Δ <-- 1/(Α*Β*Γ)



Έλεγχος ορθότητας εντολών εκχώρησης

Θεωρείστε το παρακάτω τμήμα δήλωσης μεταβλητών ενός
προγράμματος
         ΜΕΤΑΒΛΗΤΕΣ
                ΑΚΕΡΑΙΕΣ: Α, Β
                ΠΡΑΓΜΑΤΙΚΕΣ: Γ, Δ
                ΧΑΡΑΚΤΗΡΕΣ : Κ, Λ
                ΛΟΓΙΚΕΣ : Μ, Ξ
Ποιες από τις παρακάτω εντολές εκχώρησης είναι σωστές και ποιες
λάθος και γιατί;
     1. Α <-- Α+Β
     2. Β <-- Α*Γ
     3. Κ <-- Λ
     4. Λ <-- δοκιμή
     5. Μ <-- Κ = 'Λ'
     6. Ξ <-- 'ΨΕΥΔΗΣ'

Απαντήσεις

1. Σωστή, γιατί στο δεξιό μέλος υπάρχει μια ακέραια αριθμητική
    παράσταση.
2. Λάθος, γιατί δεν μπορούμε να εκχωρήσουμε σε μια ακέραια
    μεταβλητή το αποτέλεσμα μιας πραγματικής αριθμητικής
    παράστασης.
3. Σωστή, γιατί στο δεξιό μέλος υπάρχει μια αλφαριθμητική
    μεταβλητή.
4. Λάθος, γιατί στο δεξιό μέλος η λέξη δοκιμή δεν περικλείεται
    από αποστρόφους.
5. Σωστή, γιατί στο δεξιό μέλος υπάρχει μια σύγκριση (η οποία
    θα δώσει λογικό αποτέλεσμα).
6. Λάθος, γιατί το 'ΨΕΥΔΗΣ' είναι αλφαριθμητικό και έτσι
    υπάρχει ασυμφωνία τύπων.

Πίνακας αλήθειας

Θεωρήστε ότι Μ, Ν, Κ είναι λογικές μεταβλητές. Για ποιο ή ποιους συνδυασμούς
τιμών αυτών των μεταβλητών, η παράσταση ΟΧΙ (Μ Ή Ν) ΚΑΙ ΟΧΙ Κ έχει την
τιμή Αληθής.

Λύση

   Ας συμβολίσουμε με Α - Αληθής, Ψ - Ψευδής. Κατασκευάζουμε
   τον πίνακα αλήθειας της παράστασης:

Μ     Ν     Κ    Μ Ή Ν   ΟΧΙ(Μ Ή Ν)  ΟΧΙ Κ  ΟΧΙ (Μ Ή Ν) ΚΑΙ ΟΧΙ Κ
   Α   Α    Α       Α                Ψ         Ψ                Ψ
   Α   Α    Ψ      Α                Ψ         Α                Ψ
   Α   Ψ    Α      Α                Ψ         Ψ                Ψ
   Α   Ψ    Ψ      Α                Ψ         Α                Ψ
   Ψ   Α    Α      Α                Ψ         Ψ                Ψ
   Ψ   Α    Ψ      Α                Ψ         Α                Ψ
   Ψ   Ψ    Α      Ψ                Α         Ψ                Ψ
   Ψ   Ψ    Ψ      Ψ                Α         Α                Α

   Άρα ο μοναδικός συνδυασμός τιμών των Μ, Ν, Κ που δίνει στην παράσταση την
   τιμή Αληθής είναι:
               Μ = Ψευδής, Ν = Ψευδής, Κ = Ψευδής

Παρατήρηση
Το ερώτημα θα μπορούσε να απαντηθεί και χωρίς τη χρήση πίνακα αλήθειας ως εξής:
για να είναι όλη η παράσταση Αληθής θα πρέπει:
      ΟΧΙ Ή Ν) = Αληθής
      ΟΧΙ Κ = Αληθής
Συνεπώς πρέπει:
      Μ Ή Ν = Ψευδής
      Κ = Ψευδής
Άρα :
     Μ = Ψευδής, Ν = Ψευδής
     Κ = Ψευδής

Καθορισμός τελικής τιμής

Ποια είναι η τελική τιμή της μεταβλητής Μ μετά
την εκτέλεση των παρακάτω εντολών;
   Μ <-- 0
   Για  Κ από μέχρι 90
        Αν Κ <= 30 τότε
               Μ <-- Μ+2
        αλλιώς_αν Κ <= 60 τότε
               Μ <-- Μ+1
        αλλιώς
               Μ <-- Μ+5
        Τέλος_αν
   Τέλος_επανάληψης

Απάντηση

     Το Μ θα αυξηθεί 30 φορές κατά 2, 30 φορές κατά 1 και 30 φορές κατά 5.
     Αφού η αρχική τιμή του Μ είναι 0, η τελική τιμή του θα είναι:
           0+30*2+30*1+30*5 = 60+30+150 = 240

Παρασκευή, 3 Αυγούστου 2012

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η  Α_Τ είναι μια ____________ συνάρτηση της
    ΓΛΩΣΣΑΣ.
2. Μια __________ είναι ένα υποπρόγραμμα που μπορεί
    να υπολογίζει ένα ή περισσότερα αποτελέσματα.
3. Ο πίνακας Α[3, 5] είναι __________.
4. Η αναφορά στα στοιχεία ενός πίνακα γίνεται με τη
    βοήθεια ενός ή περισσοτέρων ______.
5. Η επίλυση μιας δευτεροβάθμιας εξίσωσης είναι
    ένα επιλύσιμο και  ________πρόβλημα
   

Απαντήσεις

1. ενσωματωμένη
2. διαδικασία
3. δυσδιάστατος
4. δεικτών
5. δομημένο

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η ψευδογλώσσα είναι ένας τρόπος αναπαράστασης
    αλγορίθμων που κινδυνεύει να παραβιάσει το
    κριτήριο της αποτελεσματικότητας.
2. Κάθε  διάγραμμα ροής περιλαμβάνει έναν ή
     περισσότερους ρόμβους.
3. Ένας πίνακας έχει μεταβλητό τύπο και σταθερό
    περιεχόμενο.
4. Κάθε Για..από..μέχρι μπορεί να μετατραπεί σε
    μια ισοδύναμη Όσο..επανάλαβε.
5. Η εντολή GOTO χρησιμοποιείται για την πραγματοποίηση
    ελέγχων στη ΓΛΩΣΣΑ.


Απαντήσεις

1. Λ
2. Λ
3. Λ
4. Σ
5. Λ

Κυριακή, 29 Ιουλίου 2012

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η δομή επανάληψης είναι μια ________ συνιστώσα.
2. Η δομή _______ είναι η απλούστερη αλγοριθμική δομή.
3. Η δομή ______ μας επιτρέπει να ελέγχουμε μια συνθήκη
    και ανάλογα να αποφασίζουμε για τη συνέχεια των ενεργειών
    μας.
4. Η εντολή α <-- β/γ παραβιάζει το κριτήριο της _________
    εφόσον προηγουμένως δεν έχει διασφαλιστεί ότι γ < > 0.
5. Η εντολή ________ επιτρέπει την εναλλαγή τιμών ανάμεσα
   σε δύο μεταβλητές.


Απαντήσεις

1. συνιστώσα
2. ακολουθίας
3. επιλογής
4. καθοριστικότητας
5. αντιμετάθεσε

Παρασκευή, 20 Ιουλίου 2012

Ερωτήσεις σωστού/λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η διατύπωση ενός προβλήματος πρέπει να γίνεται με σαφήνεια
    και ακρίβεια.
2. Ο αλγόριθμος πρέπει να ολοκληρώνει την επίλυση του
    προβλήματος μέσα σε πεπερασμένο χρόνο.
3. Τα στοιχεία ενός πίνακα καταλαμβάνουν μη συνεχόμενες
    θέσεις της κύριας μνήμης του υπολογιστή.
4. Τα υποπρογράμματα είναι βασικό και αναπόσπαστο
    στοιχείο του δομημένου προγραμματισμού.
5. Κάθε πρόγραμμα περιλαμβάνει τουλάχιστον μια
    δομή επιλογής

Απαντήσεις

1. Σ
2. Σ
3. Λ
4. Λ
5. Λ

Πέμπτη, 19 Ιουλίου 2012

Συγγραφή συνάρτησης

Θεωρήστε την ακόλουθη δομή επανάληψης:
     Για κ από Α μέχρι Β με_βήμα Γ
          Εμφάνισε 'φορές'
     Τέλος_επανάληψης
Γράψτε συνάρτηση η οποία δέχεται ως παραμέτρους
τις ακέραιες τιμές Α, Β, Γ και επιστρέφει το χαρακτήρα:
* Μ, αν πραγματοποιείται τουλάχιστον μια επανάληψη,
* Τ, αν ο βρόχος είναι ατέρμων,
* Κ, αν δεν πραγματοποιείται καμία επανάληψη

Λύση


     ΣΥΝΑΡΤΗΣΗ ΕΛ(Α, Β, Γ) : ΧΑΡΑΚΤΗΡΑΣ
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α, Β, Γ
     ΑΡΧΗ
           ΑΝ Γ = 0 ΤΟΤΕ
                 ΑΝ Α <= Β ΤΟΤΕ
                      ΕΛ <-- 'Τ'
                 ΑΛΛΙΩΣ
                      ΕΛ <-- 'Κ'
                 ΤΕΛΟΣ_ΑΝ
           ΑΛΛΙΩΣ_ΑΝ Γ > 0 ΤΟΤΕ
                  ΑΝ Α <= Β ΤΟΤΕ
                        ΕΛ <-- 'Μ'
                  ΑΛΛΙΩΣ
                        ΕΛ <-- 'Κ'
                  ΤΕΛΟΣ_ΑΝ
           ΑΛΛΙΩΣ   ! Γ < 0
                  ΑΝ Α >= Β ΤΟΤΕ
                        ΕΛ <-- 'Μ'
                  ΑΛΛΙΩΣ
                        ΕΛ <-- 'Κ'
                  ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παραμέτρους
τρεις ακέραιους Χ, Υ, Ζ και ελέγχει αν κάποιος
από αυτούς ισούται με το γινόμενο των δύο άλλων.

Λύση


    ΣΥΝΑΡΤΗΣΗ ΕΛΕΓΧΟΣ(Χ, Υ, Ζ) : ΛΟΓΙΚΗ
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ: Χ, Υ, Ζ
    ΑΡΧΗ
          ΑΝ  (Χ = Υ*Ζ) Ή (Υ = Χ*Ζ ) Ή (Ζ = Χ*Υ) ΤΟΤΕ
               ΕΛΕΓΧΟΣ <-- ΑΛΗΘΗΣ
          ΑΛΛΙΩΣ
               ΕΛΕΓΧΟΣ <-- ΨΕΥΔΗΣ
          ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Σάββατο, 14 Ιουλίου 2012

Συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παράμετρο ένα σύνολο bytes και
υπολογίζει σε πόσα GB, MB, ΚΒ και bytes αντιστοιχεί.
Υπενθυμίζεται ότι:
      ΚΒ = 1024 bytes
      MB = 1024 KB
      GB = 1024 MB

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΠΟΛ(TOTAL, GB, MB, KB, BYTES)
     METAΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: ΤΟΤΑL, GB, MB, KB, BYTES
     ΑΡΧΗ
            GB <-- TOTAL DIV 1024^3
            MB <-- (TOTAL MOD 1024^3) DIV 1024^2
            KB <-- ( (TOTAL MOD 1024^3) MOD 1024^2) DIV 1024
      BYTES <-- ( (TOTAL MOD 1024^3) MOD 1024^2) MOD 1024
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Παρασκευή, 13 Ιουλίου 2012

Συγγραφή συνάρτησης

Γράψτε συνάρτηση που υπολογίζει το πλήθος των
ακέραιων λύσεων της εξίσωσης ΑΧ+ΒΥ+ΓΖ+Δ = 0 στο
διάστημα [-1000, 1000]. Θεωρείστε ότι οι συντελεστές
Α, Β, Γ, Δ είναι ακεραίου τύπου.

Λύση

       ΣΥΝΑΡΤΗΣΗ Εξίσωση(Α, Β, Γ, Δ) : ΑΚΕΡΑΙΑ
       ΜΕΤΑΒΛΗΤΕΣ
              ΑΚΕΡΑΙΕΣ: Α, Β, Γ, Δ, ΠΛΗΘ, Χ, Υ, Ζ
       ΑΡΧΗ
              ΠΛΗΘ <-- 0
              ΓΙΑ Χ ΑΠΟ -1000 ΜΕΧΡΙ 1000
                    ΓΙΑ Υ ΑΠΟ -1000 ΜΕΧΡΙ 1000
                         ΓΙΑ Ζ ΑΠΟ -1000 ΜΕΧΡΙ 1000
                               ΑΝ Α*Χ+Β*Υ+Γ*Ζ+Δ = 0 ΤΟΤΕ
                                      ΠΛΗΘ <-- ΠΛΗΘ+1
                               ΤΕΛΟΣ_ΑΝ
                         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              Εξίσωση <-- ΠΛΗΘ
       ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Πίνακας αντιστοίχησης

Αντιστοιχήστε τις συναρτήσεις (1-5) με τον τύπο τους
(α-δ).
Συναρτήσεις
1. Υπολογισμός απόστασης δύο σημείων
2. Έλεγχος αν δύο αριθμητικές ποσότητες Χ, Υ είναι
    ίσες μεταξύ τους.
3. Εντοπισμός του πρώτου γράμματος σε μια λέξη.
4. Υπολογισμός του ποσοστού (%) των ανδρών σε
    ένα σύλλογο
5. Υπολογισμός του πλήθους των αριστούχων μαθητών
    σε ένα λύκειο.

Τύπος
α. ΑΚΕΡΑΙΑ
β. ΛΟΓΙΚΗ
γ. ΧΑΡΑΚΤΗΡΑΣ
δ. ΠΡΑΓΜΑΤΙΚΗ

Απαντήσεις
1. δ
2. β
3. γ
4. δ
5. α