Παρασκευή, 10 Αυγούστου 2012

Καθορισμός τελικής τιμής

Ποια είναι η τελική τιμή της μεταβλητής Μ μετά
την εκτέλεση των παρακάτω εντολών;
   Μ <-- 0
   Για  Κ από μέχρι 90
        Αν Κ <= 30 τότε
               Μ <-- Μ+2
        αλλιώς_αν Κ <= 60 τότε
               Μ <-- Μ+1
        αλλιώς
               Μ <-- Μ+5
        Τέλος_αν
   Τέλος_επανάληψης

Απάντηση

     Το Μ θα αυξηθεί 30 φορές κατά 2, 30 φορές κατά 1 και 30 φορές κατά 5.
     Αφού η αρχική τιμή του Μ είναι 0, η τελική τιμή του θα είναι:
           0+30*2+30*1+30*5 = 60+30+150 = 240

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου