Τετάρτη, 29 Αυγούστου 2012

Εμφωλευμένες δομές επιλογής

Σ' ένα fun park η χρέωση των πελατών (για όλες
τις δραστηριότητες του πάρκου) γίνεται ως εξής:
Σαββατοκύριακα
     Ενήλικες     25 ευρώ
     Παιδιά         17 ευρώ
Καθημερινές
     Ενήλικες     18 ευρώ
     Παιδιά         10 ευρώ
Γράψτε αλγόριθμο που:
α) διαβάζει το αν η ημέρα επίσκεψης ενός πελάτη
    είναι καθημερινή (Κ) ή Σαββατοκύριακο (Σ),
β) διαβάζει αν ο πελάτης αυτός είναι ενήλικος (Ε) ή
    παιδί (Π),
γ) υπολογίζει το ποσό που πρέπει να καταβάλλει για
   να εισέλθει στο πάρκο.

Λύση

    Αλγόριθμος Πάρκο
    Διάβασε Μέρα
    Διάβασε Πελάτης
    Αν Μέρα = 'Σ' τότε
         Αν Πελάτης = 'Ε' τότε
              Ποσό <-- 25
         αλλιώς
              Ποσό <-- 17
         Τέλος_αν
    αλλιώς
         Αν Πελάτης = 'Ε' τότε
              Ποσό <-- 18
         αλλιώς
              Ποσό <-- 10
         Τέλος_αν
    Τέλος_αν
    Αποτελέσματα // Ποσό //
    Τέλος Πάρκο

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου