Σάββατο, 27 Απριλίου 2013

Ερωτήσεις πολλαπλής επιλογής

1.  Η παρακάτω Για..από...μέχρι 
          Για κ από 4 μέχρι 2 με_βήμα 0
             Εμφάνισε 'τεστ'
          Τέλος_επανάληψης
     α. πραγματοποιεί τουλάχιστον μία επανάληψη
     β. είναι ατέρμων βρόχος
     γ. περιέχει συντακτικό λάθος αφού έχει βήμα
         μηδενικό
     δ. δεν πραγματοποιεί καμία επανάληψη

2.  Η παρακάτω Για..από...μέχρι 
          Για κ από μέχρι με_βήμα 0
             Εμφάνισε 'τεστ'
          Τέλος_επανάληψης
     α. πραγματοποιεί το πολύ 3 επαναλήψεις
     β. είναι ατέρμων βρόχος
     γ. παραβιάζει το κριτήριο της καθοριστικότητας
     δ. δεν πραγματοποιεί καμία επανάληψη

3.  Το πρόβλημα "Είναι τα α, β, γ μήκη πλευρών
     τριγώνου;" είναι:
     α. απόφασης
     β. υπολογιστικό
     γ. βελτιστοποίησης
     δ. ανοικτό
       
4. Η γλώσσα LISP είναι
    α. 4ης γενιάς
    β. κατάλληλη για επιστημονικές και μαθηματικές
       εφαρμογές
    γ. συναρτησιακή
    δ. ακατάλληλη για εφαρμογές τεχνητής νοημοσύνης

5. Μια συνάρτηση περιέχει
    α. τουλάχιστον μια εντολή ΔΙΑΒΑΣΕ
    β. τουλάχιστον μια εντολή ΓΡΑΨΕ
    γ. τουλάχιστον μια εντολή εκχώρησης
    δ. μια ομάδα εντολών ακολουθιακής δομής

Απαντήσεις

1. δ
2. β
3. α
4. γ
5. γ     

Ερωτήσεις σωστού-λάθους

Ποιές από τις παρακάτω προτάσεις είναι σωστές και
ποιές λάθος;
1. Μετά την εκτέλεση μιας εντολής εκχώρησης,
    το παλιό περιεχόμενο της μεταβλητής χάνεται.
2. Μετά την εκτέλεση των παρακάτω εντολών
        Διάβασε Χ, Υ
        Εμφάνισε 'α'
        Αν (Χ > Υ) ΚΑΙ (Χ <= Υ) τότε
             Εμφάνισε 'β'
        Τέλος_αν
    θα εμφανιστεί στη μονάδα εξόδου:
        α
        β
3. Αν οι τιμές εισόδου είναι ομόσημες, μετά την εκτέλεση
    των παρακάτω εντολών
        Διάβασε Χ, Υ
        Εμφάνισε  (Χ+Υ) mod 1
        Αν (Χ > Υ) 'Η (Χ <= Υ) τότε
             Εμφάνισε (2*A_T(Χ)+4*A_T(Υ)+3) mod 2
        Τέλος_αν
    θα εμφανιστεί στη μονάδα εξόδου:
        0
        1
4. Μια συνάρτηση δεν μπορεί να επεξεργαστεί τα
    στοιχεία ενός τρισδιάστατου πίνακα.
5. Ο συγκριτικός τελεστής >= έχει μικρότερη ιεραρχία
    από το συγκριτικό  τελεστή <=.

Απαντήσεις 

1. Σ 
2. Λ
3. Σ
4. Λ
5. Λ

      

Κυκλώστε τα σωστά

Ποιά από τα παρακάτω ισχύουν για τις γλώσσες
4ης γενιάς;
1. Απαιτούν εμπειρία στον προγραμματισμό.
2. Μπορούν να χρησιμοποιηθούν και από
    άτομα που δεν έχουν εμπειρία στον
    προγραμματισμό.
3. Ήταν προγενέστερες των γλωσσών υψηλού
    επιπέδου.
4. Σ' αυτές κατατάσσεται και η γλώσσα SQL.
5. Τα προγράμματα  που γράφονται σ' αυτές
     έχουν χαμηλή μεταφερσιμότητα.
6. Παρέχουν τη δυνατότητα υποβολής ερωτημάτων
    από το χρήστη προς το σύστημα.
7. Αποκαλούνται και συμβολικές γλώσσες.
8. Τα προγράμματα που γράφονται σ' αυτές
     εκτελούνται με τη βοήθεια διερμηνευτή.



Απαντήσεις

2, 4, 6

Τετάρτη, 24 Απριλίου 2013

Αντιστοίχηση

Δίνονται οι παρακάτω επεξεργασίες δεδομένων
   1. Ταξινόμηση μονοδιάστατου πίνακα
   2. Αναζήτηση τιμής σε μονοδιάστατο πίνακα
   3. Άθροισμα κάποιων τιμών  εισόδου (η είσοδος
       δεδομένων ολοκληρώνεται μόλις δοθεί η τιμή -999)
   4. Μενού λειτουργιών
   5. Γινόμενο κάποιων τιμών (η είσοδος δεδομένων
       ολοκληρώνεται μόλις δοθεί η απάντηση 'ΝΑΙ' στην
       υποβαλλόμενη προς το χρήστη ερώτηση
       'Ολοκληρώθηκε η είσοδος;')
   6. Αποταμίευση χρηματικών ποσών μέχρι την επίτευξη
       ενός στόχου.
   7. Άθροισμα 100 τιμών
   8. Διάθεση ενός χρηματικού ποσού για την αγορά
       προϊόντων από ένα σούπερ μάρκετ (οι τιμές τους
       δίνονται από το πληκτρολόγιο).
και οι δομές επανάληψης
    α. Για..από..μέχρι
    β. Όσο..επανάλαβε
    γ. Μέχρις_ότου
Γράψτε τον αριθμό της επεξεργασίας (1-8) και δίπλα το γράμμα
(α-γ) της επαναληπτικής δομής που είναι καταλληλότερη για την
πραγματοποίησή της.

Απαντήσεις

1. α
2. β
3. γ
4. γ
5. γ
6. β
7. α
8. β

Δευτέρα, 22 Απριλίου 2013

Καταγραφή και διόρθωση λαθών

Το παρακάτω σύνολο εντολών προσπαθεί λανθασμένα
να διαβάσει μια άρτια και αρνητική ακέραια τιμή και
στη συνέχεια να εμφανίσει την απόλυτη τιμή της.
Εντοπίστε όλα τα λάθη και χαρακτηρίστε τα (λογικά ή
συντακτικά).

      Αρχήεπανάληψης
           Διαβάστε Χ
      Μέχρις_ότουmod 2 = 1) KAI (X <= 0)
      Εμφάνισε Α_Μ(Χ)

Απάντηση

Αρχήεπανάληψης : συντακτικό λάθος (το σωστό
                                είναι Αρχή_επανάληψης)
Διαβάστε Χ : συντακτικό λάθος (το σωστό είναι
                     Διάβασε Χ)
mod 2 = 1) KAI (X <= 0) : λογικό λάθος (το σωστό
                είναι (Χ mod 2 = 0) KAI (X < 0) )
Εμφάνισε Α_Μ(Χ) : λογικό λάθος (το σωστό είναι
                Εμφάνισε Α_Τ(Χ) )

Προσδιορίστε τις τιμές των λογικών μεταβλητών

Ποιες τιμές πρέπει να έχουν οι μεταβλητές Χ, Υ, Ζ ώστε
οι παρακάτω λογικές παραστάσεις να έχουν την τιμή
ΑΛΗΘΗΣ
α)  ΟΧΙ ΚΑΙ Υ)  ΚΑΙ Ζ
β)  ΟΧΙ Χ Ή ΟΧΙ Υ ΚΑΙ ΟΧΙ Ζ
γ)  ΟΧΙ Ή Υ) ΚΑΙ Ζ
δ) ΟΧΙ Ή Ζ ΚΑΙ Υ)
Απαγορεύεται να χρησιμοποιήσετε πίνακα αλήθειας.

Απάντηση

α) Πρέπει Ζ = ΑΛΗΘΗΣ και ΟΧΙΚΑΙ Υ) = ΑΛΗΘΗΣ.
     Άρα Χ ΚΑΙ Υ = ΨΕΥΔΗΣ, που σημαίνει ότι αποδεκτοί
     συνδυασμοί είναι:
           Χ = ΑΛΗΘΗΣ, Υ = ΨΕΥΔΗΣ, Ζ = ΑΛΗΘΗΣ
           Χ = ΨΕΥΔΗΣ,  Υ = ΨΕΥΔΗΣ, Ζ = ΑΛΗΘΗΣ
           Χ = ΨΕΥΔΗΣ,  Υ = ΑΛΗΘΗΣ, Ζ = ΑΛΗΘΗΣ

β) 
    1η περίπτωση
    Αν ΟΧΙ Υ ΚΑΙ ΟΧΙ Ζ = ΑΛΗΘΗΣ, πρέπει
    ΟΧΙ Υ = ΑΛΗΘΗΣ και ΟΧΙ Ζ = ΑΛΗΘΗΣ,
    και επομένως Υ = ΨΕΥΔΗΣ και Ζ = ΨΕΥΔΗΣ
    Οι δυνατοί συνδυασμοί είναι δύο (το ΟΧΙ Χ δεν
    επηρεάζει την τελική τιμή της παράστασης):
           Χ = ΑΛΗΘΗΣ, Υ = ΨΕΥΔΗΣ, Ζ = ΨΕΥΔΗΣ
           Χ = ΨΕΥΔΗΣ, Υ = ΨΕΥΔΗΣ, Ζ = ΨΕΥΔΗΣ
   2η περίπτωση
   Αν ΟΧΙ Υ ΚΑΙ ΟΧΙ Ζ = ΨΕΥΔΗΣ, πρέπει
          ΟΧΙ Υ = ΨΕΥΔΗΣ, ΟΧΙ Ζ = ΨΕΥΔΗΣ ή
          ΟΧΙ Υ = ΨΕΥΔΗΣ, ΟΧΙ Ζ = ΑΛΗΘΗΣ ή
          ΟΧΙ Υ = ΑΛΗΘΗΣ, ΟΧΙ Ζ = ΨΕΥΔΗΣ
   και ΟΧΙ Χ = ΑΛΗΘΗΣ, άρα Χ = ΨΕΥΔΗΣ
   Κατά συνέπεια οι δυνατοί συνδυασμοί είναι:
          Χ = ΨΕΥΔΗΣ, Υ = ΑΛΗΘΗΣ, Ζ = ΑΛΗΘΗΣ
          Χ = ΨΕΥΔΗΣ, Υ = ΑΛΗΘΗΣ, Ζ = ΨΕΥΔΗΣ
          Χ = ΨΕΥΔΗΣ, Υ = ΨΕΥΔΗΣ, Ζ = ΑΛΗΘΗΣ       

γ) Πρέπει ΟΧΙΉ Υ) = ΑΛΗΘΗΣ και Ζ = ΑΛΗΘΗΣ.
    Άρα Χ Ή Υ = ΨΕΥΔΗΣ, πράγμα που σημαίνει ότι
    Χ = ΨΕΥΔΗΣ, Υ = ΨΕΥΔΗΣ. Μοναδικός αποδεκτός
    συνδυασμός τιμών :
        Χ = ΨΕΥΔΗΣ, Υ = ΨΕΥΔΗΣ, Ζ = ΑΛΗΘΗΣ

δ) Πρέπει ΟΧΙ (Χ Ή Ζ ΚΑΙ Υ) = ΑΛΗΘΗΣ, άρα
    Χ Ή Ζ ΚΑΙ Υ = ΨΕΥΔΗΣ
    Συνεπώς Χ = ΨΕΥΔΗΣ και Ζ ΚΑΙ Υ = ΨΕΥΔΗΣ.
    Αποδεκτοί συνδυασμοί:
          Χ = ΨΕΥΔΗΣ, Υ = ΨΕΥΔΗΣ, Ζ = ΨΕΥΔΗΣ
          Χ = ΨΕΥΔΗΣ, Υ = ΨΕΥΔΗΣ, Ζ = ΑΛΗΘΗΣ
          Χ = ΨΕΥΔΗΣ, Υ = ΑΛΗΘΗΣ, Ζ = ΨΕΥΔΗΣ

Σάββατο, 20 Απριλίου 2013

Έλεγχος ισοδυναμίας

Είναι τα παρακάτω σύνολα εντολών ισοδύναμα;
   
Τμήμα Α 
     
      Για κ από 1 μέχρι 4
           Εμφάνισε κ^2
      Τέλος_επανάληψης
      Εμφάνισε κ


Τμήμα Β 
     
      Για κ από μέχρι 3
           Εμφάνισε (κ+1)^2
      Τέλος_επανάληψης
      Εμφάνισε κ

Απάντηση

Τμήμα Α 
       Εμφανίζονται κατά σειρά οι τιμές :  1, 4, 9, 16 και η Για
       τερματίζεται με κ = 5. Έτσι η τελευταία Εμφάνισε 
       τυπώνει : 5

Τμήμα Β 
       Εμφανίζονται κατά σειρά οι τιμές :  1, 4, 9, 16 και η Για
       τερματίζεται με κ = 4. Αφού η τελευταία Εμφάνισε 
       τυπώνει 4, τα δύο τμήματα δεν είναι ισοδύναμα.

Ερωτήσεις πολλαπλής επιλογής

1. Σ' ένα πρόβλημα βελτιστοποίησης
    α. η λύση είναι το μέγιστο
    β. η λύση είναι το ελάχιστο
    γ. η λύση είναι εκείνη που ικανοποιεί κατά
        τον καλύτερο δυνατό τρόπο τα δεδομένα
        του προβλήματος
     δ. η λύση είναι εκείνη που ικανοποιεί κατά
        τον χειρότερο δυνατό τρόπο τα δεδομένα
        του προβλήματος

2.  Το λογικό διάγραμμα
     α. είναι ένας τρόπος διατύπωσης προβλημάτων
     β. είναι αναπόσπαστο στοιχείο του τμηματικού
         προγραμματισμού
     γ. είναι ένας τρόπος διατύπωσης προγραμμάτων
     δ. είναι μια μορφή αναπαράστασης αλγορίθμων

3. Ο πίνακας
    α. είναι μια δυναμική δομή δεδομένων
    β. απαιτεί δευτερεύουσα μνήμη
    γ. είναι μια συλλογή ακέραιων τιμών
    δ. έχει προκαθορισμένο πλήθος κλειδιών

4. Η εντολή ΔΙΑΒΑΣΕ
    α. δεν μπορεί να χρησιμοποιηθεί μέσα σε συνάρτηση
    β. δεν μπορεί να χρησιμοποιηθεί μέσα σε διαδικασία
    γ. μπλοκάρει μόνιμα την εκτέλεση του προγράμματος
    δ. είναι εντολή εξόδου

5. Η εντολή εκχώρησης
    α. είναι ο μοναδικός τρόπος αλλαγής περιεχομένου μιας
        μεταβλητής
    β. εξαφανίζει το παλιό περιεχόμενο μιας μεταβλητής
    γ. παριστάνεται με το σύμβολο ==
    δ. δεν χρησιμοποιείται συχνά

Απάντηση

1. γ
2. δ
3. δ
4. α
5. β

Έλεγχος αλγοριθμικών κριτηρίων

Ποιο ή ποια αλγοριθμικά κριτήρια παραβιάζει η παρακάτω
αλληλουχία εντολών;
       Διάβασε Χ
       Όσο Χ < 100 επανάλαβε
              Διάβασε Υ
              Υπολόγισε το μέσο όρο ΜΟ των Χ, Υ
               Εμφάνισε ΜΟ
               Διάβασε Χ
       Τέλος_επανάληψης
        Εμφάνισε 1/(Χ-200)

Απάντηση

α) Αποτελεσματικότητα, γιατί η εντολή
         Υπολόγισε το μέσο όρο ΜΟ των Χ, Υ
     δεν είναι απλή και άμεσα εκτελέσιμη
β) Καθοριστικότητα, γιατί αν ολοκληρωθεί η Όσο
    με Χ = 200, η Εμφάνισε 1/(Χ-200) δεν μπορεί
    να εκτελεστεί.

Πέμπτη, 11 Απριλίου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Μέσα στο σώμα εντολὠν μιας συνάρτησης δεν επιτρέπεται
    η χρήση των εντολών ______ και ______.
2. Όλες οι εντολές μιας διαδικασίας περικλείονται από τις
    δεσμευμένες λέξεις ______ και ______.
3. __________ ΑΝ είναι δύο ή περισσότερες εντολές
    ΑΝ..ΤΟΤΕ..ΑΛΛΙΩΣ που περιέχονται η μία μέσα
    στην άλλη.
4. Οποιαδήποτε εντολή ΟΣΟ..ΕΠΑΝΑΛΑΒΕ μπορεί
    να μετατραπεί σε μια _______με τα ίδια ακριβώς
    αλγοριθμικά αποτελέσματα.
5. Οι συμβολικές γλώσσες είναι στενά συνδεδεμένες
    με την _________του υπολογιστή.




Απαντήσεις

1. ΔΙΑΒΑΣΕ, ΓΡΑΨΕ
2. ΑΡΧΗ, ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
3. Εμφωλευμένα
4. ΜΕΧΡΙΣ_ΟΤΟΥ
5. αρχιτεκτονική


Ερωτήσεις σωστου-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Μια μεταβλητή έχει τοπική ισχύ.
2. Σε μια μεταβλητή ακεραίου τύπου μπορούμε να εκχωρήσουμε
    το αποτέλεσμα μιας αριθμητικής παράστασης πραγματικού
    τύπου.
3. Δεν μπορούμε να χρησιμοποιήσουμε τη λέξη  ΠΡΑΓΜΑΤΙΚΟΣ
    ως όνομα μιας μεταβλητής στη ΓΛΩΣΣΑ, γιατί είναι δεσμευμένη
   λέξη.
4. Ένα πρόγραμμα μπορεί να μην έχει καθόλου μεταβλητές.
5. Μια μεταβλητή του προγρἀμματος δεν μπορεί να έχει το ίδιο
    όνομα με μια συμβολική σταθερά ενός υποπρογράμματος.


Απαντήσεις

1. Σ
2. Λ
3. Λ
4. Σ
5. Λ





Τετάρτη, 3 Απριλίου 2013

Απλοποίηση

Ξαναγράψτε απλούστερα το παρακάτω σύνολο εντολών
με ένα μόνο Για..από..μέχρι.

  Για κ από 1 μέχρι 19 με_βήμα 13
       Για λ από 22 μέχρι 3 με_βήμα -5
             Για μ από 14 μέχρι 89 με_βήμα 21
                   Αν (μ > 50) ΚΑΙ (μ < 60) ΚΑΙ (λ > 18) τότε
                         Εμφάνισε (κ-λ)*μ
                   Τέλος_αν
             Τέλος_επανάληψης
       Τέλος_επανάληψης
  Τέλος_επανάληψης

Λύση

Για κ από 1 μέχρι 19 με_βήμα 13
    Εμφάνισε (κ-22)*56              
Τέλος_επανάληψης

Κυκλώστε τα σωστά

Ποιά από τα παρακάτω ισχύουν για έναν υπολογιστή;
1. Μπορεί να επιλύσει κάθε πρόβλημα.
2. Υπερτερεί σε ποιοτικό επίπεδο σε σχέση με τον
    ανθρώπινο εγκέφαλο.
3. Υπερτερεί σε ποσοτικό επίπεδο σε σχέση με τον
    ανθρώπινο εγκέφαλο.
4. Απαιτεί τη χρήση ιδιαίτερης γλώσσας προκειμένου
    ο άνθρωπος να επικοινωνήσει μαζί του.
5. Μπορεί να κάνεις πολλούς αλλά όχι σύνθετους
    υπολογισμούς.
6. "Καταλαβαίνει" μόνο τα ψηφία 0 και 1.
7.  Έχει απεριόριστη μνήμη προκειμένου να
     αποθηκεύει μεταβλητές.
8.  Μπορεί να κάνει επεξεργασίες δεδομένων.



Απαντήσεις

3,  4, 6,  8

Ερώτηση κρίσεως

Αναφέρετε  4 περιπτώσεις στις οποίες η χρήση
μονοδιάστατου πίνακα είναι απαραίτητη.

Απάντηση

1. Ταξινόμηση Ν τιμών.
2. Εύρεση μεγίστου Ν τιμών και τους αύξοντες αριθμούς
    (1-Ν) των τιμών που ισούνται με τον μέγιστο.
3. Εύρεση ελαχίστου Ν τιμών και τους αύξοντες αριθμούς
    (1-Ν) των τιμών που ισούνται με τον ελάχιστο.
4. Υπολογισμός συχνότητας εμφάνισης των τιμών
    Τ1, Τ2, ...., ΤΝ μέσα σ' ένα πλήθος δεδομένων.