Σάββατο, 27 Απριλίου 2013

Ερωτήσεις πολλαπλής επιλογής

1.  Η παρακάτω Για..από...μέχρι 
          Για κ από 4 μέχρι 2 με_βήμα 0
             Εμφάνισε 'τεστ'
          Τέλος_επανάληψης
     α. πραγματοποιεί τουλάχιστον μία επανάληψη
     β. είναι ατέρμων βρόχος
     γ. περιέχει συντακτικό λάθος αφού έχει βήμα
         μηδενικό
     δ. δεν πραγματοποιεί καμία επανάληψη

2.  Η παρακάτω Για..από...μέχρι 
          Για κ από μέχρι με_βήμα 0
             Εμφάνισε 'τεστ'
          Τέλος_επανάληψης
     α. πραγματοποιεί το πολύ 3 επαναλήψεις
     β. είναι ατέρμων βρόχος
     γ. παραβιάζει το κριτήριο της καθοριστικότητας
     δ. δεν πραγματοποιεί καμία επανάληψη

3.  Το πρόβλημα "Είναι τα α, β, γ μήκη πλευρών
     τριγώνου;" είναι:
     α. απόφασης
     β. υπολογιστικό
     γ. βελτιστοποίησης
     δ. ανοικτό
       
4. Η γλώσσα LISP είναι
    α. 4ης γενιάς
    β. κατάλληλη για επιστημονικές και μαθηματικές
       εφαρμογές
    γ. συναρτησιακή
    δ. ακατάλληλη για εφαρμογές τεχνητής νοημοσύνης

5. Μια συνάρτηση περιέχει
    α. τουλάχιστον μια εντολή ΔΙΑΒΑΣΕ
    β. τουλάχιστον μια εντολή ΓΡΑΨΕ
    γ. τουλάχιστον μια εντολή εκχώρησης
    δ. μια ομάδα εντολών ακολουθιακής δομής

Απαντήσεις

1. δ
2. β
3. α
4. γ
5. γ     

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου