Σάββατο, 20 Απριλίου 2013

Έλεγχος ισοδυναμίας

Είναι τα παρακάτω σύνολα εντολών ισοδύναμα;
   
Τμήμα Α 
     
      Για κ από 1 μέχρι 4
           Εμφάνισε κ^2
      Τέλος_επανάληψης
      Εμφάνισε κ


Τμήμα Β 
     
      Για κ από μέχρι 3
           Εμφάνισε (κ+1)^2
      Τέλος_επανάληψης
      Εμφάνισε κ

Απάντηση

Τμήμα Α 
       Εμφανίζονται κατά σειρά οι τιμές :  1, 4, 9, 16 και η Για
       τερματίζεται με κ = 5. Έτσι η τελευταία Εμφάνισε 
       τυπώνει : 5

Τμήμα Β 
       Εμφανίζονται κατά σειρά οι τιμές :  1, 4, 9, 16 και η Για
       τερματίζεται με κ = 4. Αφού η τελευταία Εμφάνισε 
       τυπώνει 4, τα δύο τμήματα δεν είναι ισοδύναμα.

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου