Τετάρτη, 3 Απριλίου 2013

Απλοποίηση

Ξαναγράψτε απλούστερα το παρακάτω σύνολο εντολών
με ένα μόνο Για..από..μέχρι.

  Για κ από 1 μέχρι 19 με_βήμα 13
       Για λ από 22 μέχρι 3 με_βήμα -5
             Για μ από 14 μέχρι 89 με_βήμα 21
                   Αν (μ > 50) ΚΑΙ (μ < 60) ΚΑΙ (λ > 18) τότε
                         Εμφάνισε (κ-λ)*μ
                   Τέλος_αν
             Τέλος_επανάληψης
       Τέλος_επανάληψης
  Τέλος_επανάληψης

Λύση

Για κ από 1 μέχρι 19 με_βήμα 13
    Εμφάνισε (κ-22)*56              
Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου