Σάββατο, 25 Φεβρουαρίου 2012

Έλεγχος γνώσεων για τη γλώσσα C++


Ποια από τα παρακάτω ισχύουν για τη γλώσσα C++;
1. Είναι γλώσσα ερωταπαντήσεων.
2. Είναι αντικειμενοστραφής γλώσσα.
3. Είναι μια γλώσσα γενικής χρήσης.
4. Χρησιμοποιήθηκε για τη δημιουργία του λειτουργικού συστήματος UNIX.
5. Είναι μια γλώσσα 5ης γενιάς.
6. Αποτέλεσε εξέλιξη της γλώσσας C.

Απαντήσεις

2, 6

Παρασκευή, 24 Φεβρουαρίου 2012

Έλεγχος γνώσεων για τη γλώσσα JAVA

Ποια από τα παρακάτω ισχύουν για τη γλώσσα JAVA;
1. Χρησιμοποιείται ιδιαίτερα για προγραμματισμό στο 
    διαδίκτυο (internet).
2. Είναι μια αντικειμενοστραφής γλώσσα.
3. Χρησιμοποιείται για την ανάπτυξη εφαρμογών που εκτελούνται 
    σε κατανεμημένα περιβάλλοντα.
4. Με αυτήν δημιουργήθηκαν πολλές εμπορικές εφαρμογές
    τα προηγούμενα 10 χρόνια.
5. Χαρακτηρίζεται από λιτότητα στην έκφραση.
6. Χρησιμοποιείται πολύ σπάνια τη σημερινή εποχή.

Απαντήσεις

1, 2, 3
  

Έλεγχος γνώσεων για τη γλώσσα BASIC

Ποια από τα παρακάτω ισχύουν για τη γλώσσα BASIC;
1. Αρχικά αναπτύχθηκε για την εκπαίδευση αρχαρίων στον 
    προγραμματισμό.
2. Προήλθε από την PL1.
3. Σχεδιάστηκε για να γράφονται σύντομα προγράμματα που 
    εκτελούνται με τη βοήθεια διερμηνευτή. 
4. Τα καταφέρνει καλά τόσο στην ανάπτυξη επιστημονικών
     όσο και εμπορικών εφαρμογών.
5. Είναι μια από τις πιο διαδεδομένες γλώσσες προγραμματισμού 
    σε γραφικό περιβάλλον για προσωπικούς υπολογιστές.
6. Υποστηρίζει τις αρχές του οπτικού προγραμματισμού.

Απαντήσεις

1, 3, 4

Έλεγχος γνώσεων για τη γλώσσα COBOL

Ποια από τα παρακάτω ισχύουν για τη γλώσσα COBOL;
1. Είναι κατάλληλη για την ανάπτυξη εμπορικών και 
    γενικότερα διαχειριστικών εφαρμογών.
2. Καθιερώθηκε ως πρότυπο και χρησιμοποιήθηκε από 
    πολλές επιχειρήσεις καθώς και από όλη τη δημόσια
    διοίκηση. 
3. Είχε ελάχιστη πρακτική εφαρμογή.
4. Παρέχει ισχυρότατες δυνατότητες διαχείρισης αρχείων 
    δεδομένων. 
5. Είναι μια γλώσσα πολύ υψηλού επιπέδου.
6. Ανήκει στην κατηγορία των γλωσσών χαμηλού
    επιπέδου.

Απαντήσεις

1, 2, 4
 

Έλεγχος γνώσεων για τη γλώσσα FORTRAN

Ποια από τα παρακάτω ισχύουν για τη γλώσσα FORTRAN;
1. Είναι μια γλώσσα 4ης γενιάς.
2. Είναι ιδανική για εμπορικές εφαρμογές.
3. Είναι κατάλληλη για την επίλυση μαθηματικών και 
    επιστημονικών προβλημάτων.
4. Υστερεί στη διαχείριση αρχείων δεδομένων και γενικότερα 
    αλφαριθμητικών πληροφοριών.
5. Είναι αντικειμενοστραφής.
6. Είναι μια γλώσσα γενικής χρήσης.

Απαντήσεις

3, 4

Τρίτη, 21 Φεβρουαρίου 2012

Έλεγχος γνώσεων για τη γλώσσα PASCAL

Ποια από τα παρακάτω ισχύουν για την PASCAL;

1. Είναι ένα σύγχρονο πακέτο διαχείρισης βάσεων δεδομένων.
2. Είναι μια από τις πιο  διαδεδομένες γλώσσες προγραμματι-
    σμού σε  γραφικό περιβάλλον για προσωπικούς υπολογιστές.
3. Βασικός τύπος δεδομένων της, από τον οποίο πήρε και το 
    όνομά της είναι η συνδεδεμένη λίστα.
4. Είναι κατάλληλη τόσο για την εκπαίδευση όσο και τη δημιουργία
    ισχυρών προγραμμάτων κάθε τύπου.
5. Είναι κατάλληλη για τη δημιουργία δομημένων προγραμμάτων.
6. Έχει μερικά κοινά χαρακτηριστικά με τη C.



Απαντήσεις

4, 5, 6

Έλεγχος γνώσεων για τη γλώσσα C

Ποια από τα παρακάτω ισχύουν για τη γλώσσα C;
1. Σχεδιάστηκε για να γράφονται σύντομα προγράμματα που 
    εκτελούνται με τη βοήθεια διερμηνευτή.
2. Χρησιμοποιείται ιδιαίτερα για προγραμματισμό στο
    διαδίκτυο (internet).
3. Είναι μια διαδικασιακή γλώσσα γενικής χρήσης. 
4. Χρησιμοποιείται για τη δημιουργία λειτουργικών συστημάτων 
    και άλλων πακέτων λογισμικού.
5. Έχει πολλές δυνατότητες γλώσσας χαμηλού επιπέδου.
6. Υποστηρίζει τις αρχές του οπτικού προγραμματισμού.


 
Απαντήσεις

3, 4, 5

Έλεγχος γνώσεων για τη γλώσσα DBASE

Ποια από τα παρακάτω ισχύουν για τη γλώσσα DBASE;
1. Αποτέλεσε άλλη μια αποτυχημένη προσπάθεια δημιουργίας 
   γλώσσας κατάλληλης για όλους τους τομείς προγραμματισμού.
2. Έχει εξαιρετικές δυνατότητες διαχείρισης αρχείων 
   (βάσεων) δεδομένων.
3. Μπορεί να χρησιμοποιηθεί άνετα και από άτομα  με ελάχιστες
   γνώσεις προγραμματισμού.
4. Ήταν η πρώτη γλώσσα προγραμματισμού.
5. Είναι μια γλώσσα πολύ υψηλού επιπέδου.
6. Είναι κατάλληλη για την εισαγωγή στον προγραμματισμό 
    μαθητών μικρής ηλικίας.


Απαντήσεις

2, 3

Έλεγχος γνώσεων για τη γλώσσα LISP

Ποια από τα παρακάτω ισχύουν για τη γλώσσα LISP;
1. Είναι μια γλώσσα που διαθέτει μια πλούσια συλλογή 
    τελεστών και τύπων δεδομένων.
2. Είναι εξέλιξη της γλώσσας C.
3. Κατατάσσεται στην κατηγορία των συναρτησιακών γλωσσών
4. Με αυτήν δημιουργήθηκαν πολλές εμπορικές εφαρμογές     σε προσωπικούς υπολογιστές.
5. Είναι ιδανική για τη δημιουργία παιχνιδιών.
6. Προορίζεται για την επεξεργασία συμβολικών δεδομένων.



Απαντήσεις

3, 5, 6

Δευτέρα, 20 Φεβρουαρίου 2012

Έλεγχος γνώσεων για τη γλώσσα PROLOG

Ποια από τα παρακάτω ισχύουν για τη γλώσσα PROLOG;
1. Είναι μια μη διαδικασιακή γλώσσα.
2. Χρησιμοποιείται για την ανάπτυξη εφαρμογών τεχνητής
    νοημοσύνης.
3. Ανήκει στην κατηγορία των συναρτησιακών γλωσσών.
4. Είναι κατάλληλη για προγραμματισμό στο διαδίκτυο.
5. Επιτρέπει τη δημιουργία ισχυρών δομημένων
    προγραμμάτων.
6. Είναι συμβολική γλώσσα.

Απαντήσεις

1, 2

Έλεγχος γνώσεων για τη γλώσσα ALGOL

Ποια από τα παρακάτω ισχύουν για τη γλώσσα ALGOL;
1. Είναι μια αντικειμενοστραφής γλώσσας.
2. Είναι ιδανική για την εισαγωγή αρχαρίων στον προγραμματισμό.
3. Χρησιμοποιείται για την ανάπτυξη λειτουργικών συστημάτων.
4. Ήταν μια αποτυχημένη ερευνητική προσπάθεια  δημιουργίας
    μιας γλώσσας προγραμματισμού που θα μπορούσε να
    χρησιμοποιηθεί για την ανάπτυξη εφαρμογών οποιουδήποτε
    τύπου.
5. Από αυτήν προήλθε η PASCAL.
6. Είναι γλώσσα 4ης γενιάς.

Απαντήσεις

4, 5

Σάββατο, 18 Φεβρουαρίου 2012

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Μια στατική δομή είναι και το αρχείο εγγραφών.
2. Μια μεταβλητή είναι ένα όνομα που αντιπροσωπεύει
    μια σταθερή τιμή.
3. Σ' ένα διάγραμμα ροής χρησιμοποιούνται μόνο πλάγια
    παραλληλόγραμμα, ορθογώνια παραλληλόγραμμα και
    βέλη.
4. Ο τελεστής DIV είναι αριθμητικός.
5. Δεν μπορούμε να εκχωρήσουμε σε μια μεταβλητή
    ακεραίου τύπου την τιμή -3.2.


Απαντήσεις


1. Λ
2. Λ
3. Λ
4. Σ
5. Σ

Επεξεργασία δοσμένου πλήθους τιμών

Γράψτε αλγόριθμο που διαβάζει τους αριθμούς φορολογικού
μητρώου (ΑΦΜ) και  το φόρο που κατέβαλλαν για τη χρονιά
που πέρασε 1200 επαγγελματίες, υπολογίζει και εμφανίζει:
α) το μέσο φόρο ανά επαγγελματία,
β) πόσοι επαγγελματίες πλήρωσαν περισσότερα από 300 ευρώ,
γ) το ΑΦΜ του επαγγελματία που πλήρωσε το λιγότερο φόρο
    (θεωρείστε ότι είναι μοναδικός).
Παρατήρηση : Κανένας επαγγελματίας δεν πλήρωσε φόρο
μεγαλύτερο από 1500 ευρώ.

Λύση

     Αλγόριθμος Ασκ
     σ <-- 0
     φ <-- 0
     Μικ <-- 1501
     Για κ από 1 μέχρι 1200
          Διάβασε ΑΦΜ, Φόρος
          σ <-- σ+Φόρος
          Αν Φόρος > 300 τότε
               φ <-- φ+1
          Τέλος_αν
          Αν Φόρος < Μικ τότε
                Μικ <-- Φόρος
                ΑΦΜ_ΜΙΚ <-- κ
          Τέλος_αν
     Τέλος_επανάληψης 
     ΜΟ <-- σ/1200
     Εμφάνισε ΜΟ, φ, ΑΦΜ_ΜΙΚ
     Τέλος Ασκ

Παρασκευή, 17 Φεβρουαρίου 2012

Συγγραφή συνάρτησης

Γράψτε συνάρτηση η οποία δέχεται ως παράμετρο τον
πραγματικό πίνακα Α[12, 4, 2] και ελέγχει αν το άθροισμα
των στοιχείων που βρίσκονται σε βάθος 1 είναι ίσο με
το άθροισμα των στοιχείων που βρίσκονται σε βάθος 2.

Λύση

    ΣΥΝΑΡΤΗΣΗ ΙΣΑ(Α) : ΛΟΓΙΚΗ
    ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Α[12, 4, 2], Κ, Λ, Σ1, Σ2
    ΑΡΧΗ
          Σ1 <-- 0
          Σ2 <-- 0
          ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 12
              ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 4
                    Σ1 <-- Σ1+Α[Κ, Λ, 1]
                    Σ2 <-- Σ2+Α[Κ, Λ, 2]
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΑΝ Σ1 = Σ2 ΤΟΤΕ
                ΙΣΑ <-- ΑΛΗΘΗΣ
           ΑΛΛΙΩΣ
                ΙΣΑ <-- ΨΕΥΔΗΣ

           ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Συγγραφή διαδικασίας

Γράψτε διαδικασία που γεμίζει τον ακέραιο  πίνακα Α[3, 4, 5]
με την τιμή -1.

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΓΕΜ(Α)
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α[3, 4, 5], Κ, Λ, Μ
     ΑΡΧΗ
            ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 3
                  ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 4
                      ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 5
                             Α[Κ, Λ, Μ] <-- -1
                      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δευτέρα, 13 Φεβρουαρίου 2012

Συμπληρώστε τα κενά

Συμπληρώστε τα κενά στις παρακάτω προτάσεις.
1. Η απλούστερη αλγοριθμική δομή είναι η __________.
2. Κάθε πρόγραμμα ξεκινάει με τη δεσμευμένη λέξη ______.
3. Ένα πρόβλημα που δεν γνωρίζουμε αν λύνεται ή δε
    λύνεται αποκαλείται _________.
4. Η γλώσσα μηχανής και οι _____________ γλώσσες δεν
    έχουν καθόλου μεταφερσιμότητα.
5. Πρέπει να υπάρχει συμφωνία τύπων ανάμεσα στις ______
    και στις πραγματικές παραμέτρους ενός υποπρογράμματος.

Απαντήσεις

1. ακολουθιακή
2. ΠΡΟΓΡΑΜΜΑ
3. ανοικτό
4. συμβολικές
5. τυπικές

Επεξεργασία τρισδιάστατου πίνακα

Γράψτε αλγόριθμο που γεμίζει τον ακέραιο πίνακα Α[2, 5, 4] με τις
τιμές 1, 2, 3, ..., 40.

Λύση

      Αλγόριθμος Ασκ
      χ <-- 1
      Για κ από 1 μέχρι 2
          Για λ από 1 μέχρι 5
               Για μ από 1 μέχρι 4
                     Α[κ, λ, μ] <--  χ
                     χ <-- χ+1
               Τέλος_επανάληψης
          Τέλος_επανάληψης
      Τέλος_επανάληψης
      Αποτελέσματα // Α //
      Τέλος Ασκ

Παρασκευή, 10 Φεβρουαρίου 2012

Μετατροπή

Ξαναγράψτε το παρακάτω σύνολο εντολών χρησιμοποιώντας
Για..από..μέχρι αντί για Μέχρις_ότου.
       κ <-- 8
      Α <-- 0
      Αρχή_επανάληψης
            Α <-- Α+κ
            κ <-- κ +2
      Μέχρις_ότου κ > Υ
      Εμφάνισε Α

Λύση
    
      Α <-- 8
     Για κ από 10 μέχρι Υ με_βήμα 2
            Α <-- Α+κ
            κ <-- κ +2
      Τέλος_επανάληψης
      Εμφάνισε Α

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος
1. Τα αλγοριθμικά κριτήρια είναι ιδιότητες που πρέπει να
    ικανοποιεί μια ομάδα εντολών προκειμένου να αποτελεί
   αλγόριθμο.
2. Κάθε αλγοριθμική δομή οργανώνει και εκτελεί τις εντολές
    που την αποτελούν με διαφορετικό τρόπο.
3. Οι μονοδιάστατοι πίνακες δεν απαιτούν μνήμη.
4. Οι δυσδιάστατοι πίνακες είναι σπάνιοι.
5. Μια συνάρτηση είναι πιο γρήγορη από μια διαδικασία
    που εκτελεί τον ίδιο υπολογισμό.

Απαντήσεις

1. Σ
2. Σ
3. Λ
4. Λ
5. Λ

Τετάρτη, 8 Φεβρουαρίου 2012

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο:
1. Το σύνολο εντολών μιας διαδικασίας δεν μπορεί
    να περιλαμβάνει τις εντολές ΔΙΑΒΑΣΕ και ΓΡΑΨΕ.
2. Οι εντολές εισόδου και εξόδου αποτυπώνονται σε
    ένα λογικό διάγραμμα με τετράγωνα.
3. Μια μεταβλητή που αναπαριστάνει το πλήθος των
    παιδιών μιας οικογένειας είναι λογικού τύπου.
4. Το ελεύθερο κείμενο είναι ένας από τους τρόπους
    διατύπωσης των προγραμμάτων.




Απαντήσεις

1. Το σύνολο εντολών μιας συνάρτησης δεν μπορεί
    να περιλαμβάνει τις εντολές ΔΙΑΒΑΣΕ και ΓΡΑΨΕ.
2. Οι εντολές εισόδου και εξόδου αποτυπώνονται σε
    ένα λογικό διάγραμμα με πλάγια παραλληλόγραμμα.
3. Μια μεταβλητή που αναπαριστάνει το πλήθος των
    παιδιών μιας οικογένειας είναι ακεραίου τύπου.
4. Το ελεύθερο κείμενο είναι ένας από τους τρόπους
    διατύπωσης των αλγορίθμων.

Κυριακή, 5 Φεβρουαρίου 2012

Μετατροπή Για σε Μέχρις_ότου

Ξαναγράψτε το παρακάτω σύνολο εντολών χρησιμοποιώντας
Μέχρις_ότου στη θέση της Για.
   
    Α <-- 0
    Για κ από Χ μέχρι Υ με_βήμα 2
          Α <-- Α-κ
    Τέλος_επανάληψης


Απάντηση

     Α <-- 0
     Αν Χ <= Υ τότε
          κ <-- Χ
         Αρχή_επανάληψης
               Α <-- Α-κ
               κ <-- κ+2
         Μέχρις_ότου κ > Υ
     Τέλος_αν
     Εμφάνισε Α

Μετατροπή συνάρτησης σε διαδικασία

Μετατρέψτε την παρακάτω συνάρτηση σε διαδικασία
    ΣΥΝΑΡΤΗΣΗ Φ(Α, Β, Γ) : ΑΚΕΡΑΙΑ
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ : Α, Β, Γ
    ΑΡΧΗ
           Α <-- Α+1
           Β <-- Β+2
           Φ <-- 2*Α+3*Β+4*Γ
    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Απάντηση

    ΔΙΑΔΙΚΑΣΙΑ Φ(Α, Β, Γ) : ΑΚΕΡΑΙΑ
    ΜΕΤΑΒΛΗΤΕΣ
          ΑΚΕΡΑΙΕΣ : ΒΑ, ΒΒ, Α, Β, Γ, Δ
    ΑΡΧΗ
           ΒΑ <-- Α
           ΒΒ <-- Β
           ΒΑ <-- ΒΑ+1
           ΒΒ <-- ΒΒ+2
           Φ <-- 2*ΒΑ+3*ΒΒ+4*Γ
    ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
      

Πέμπτη, 2 Φεβρουαρίου 2012

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η τιμή ΑΛΗΘΗΣ είναι μια αλφαριθμητική σταθερά.
2. Μια διαδικασία μπορεί να είναι ακεραίου ή λογικού ή
    πραγματικού ή αλφαριθμητικού τύπου.
3. Ο τύπος του δείκτη σε έναν μονοδιάστατο πίνακα
    είναι ακέραιος.
4. Το πρόβλημα "Επιβίωση πάνω στον ήλιο" είναι άλυτο.
5. Η γλώσσα LISP είναι ιδανική για την ανάπτυξη
    εφαρμογών τεχνητής νοημοσύνης.


Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Σ
5. Σ

Τετάρτη, 1 Φεβρουαρίου 2012

Πίνακας συχνοτήτων+τρισδιάστατος πίνακας

Δίνεται ακέραιος πίνακας Α[11, 10, 7]. Γράψτε αλγόριθμο
που υπολογίζει τη συχνότητα εμφάνισης των αριθμών
18, 19, 20, ...., 48.

Λύση

       Αλγόριθμος Ασκ
       Για κ από 1 μέχρι 31
            Συχν[κ] <-- 0
       Τέλος_επανάληψης
       Για κ από μέχρι 11
            Για λ από μέχρι 10
                 Για μ από μέχρι 7
                       Τιμή <-- Α[κ, λ, μ]
                       Αν (Τιμή >= 18) ΚΑΙ (Τιμή <= 48) τότε
                            Θέση <-- Τιμή-17
                            Συχν[Θέση] <-- Συχν[Θέση]+1
                       Τέλος_αν
                 Τέλος_επανάληψης
            Τέλος_επανάληψης
        Τέλος_επανάληψης
        Αποτελέσματα // Συχν //
       Τέλος Ασκ