Κυριακή, 5 Φεβρουαρίου 2012

Μετατροπή Για σε Μέχρις_ότου

Ξαναγράψτε το παρακάτω σύνολο εντολών χρησιμοποιώντας
Μέχρις_ότου στη θέση της Για.
   
    Α <-- 0
    Για κ από Χ μέχρι Υ με_βήμα 2
          Α <-- Α-κ
    Τέλος_επανάληψης


Απάντηση

     Α <-- 0
     Αν Χ <= Υ τότε
          κ <-- Χ
         Αρχή_επανάληψης
               Α <-- Α-κ
               κ <-- κ+2
         Μέχρις_ότου κ > Υ
     Τέλος_αν
     Εμφάνισε Α

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου