Τετάρτη, 1 Φεβρουαρίου 2012

Πίνακας συχνοτήτων+τρισδιάστατος πίνακας

Δίνεται ακέραιος πίνακας Α[11, 10, 7]. Γράψτε αλγόριθμο
που υπολογίζει τη συχνότητα εμφάνισης των αριθμών
18, 19, 20, ...., 48.

Λύση

       Αλγόριθμος Ασκ
       Για κ από 1 μέχρι 31
            Συχν[κ] <-- 0
       Τέλος_επανάληψης
       Για κ από μέχρι 11
            Για λ από μέχρι 10
                 Για μ από μέχρι 7
                       Τιμή <-- Α[κ, λ, μ]
                       Αν (Τιμή >= 18) ΚΑΙ (Τιμή <= 48) τότε
                            Θέση <-- Τιμή-17
                            Συχν[Θέση] <-- Συχν[Θέση]+1
                       Τέλος_αν
                 Τέλος_επανάληψης
            Τέλος_επανάληψης
        Τέλος_επανάληψης
        Αποτελέσματα // Συχν //
       Τέλος Ασκ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου