Σάββατο, 18 Φεβρουαρίου 2012

Επεξεργασία δοσμένου πλήθους τιμών

Γράψτε αλγόριθμο που διαβάζει τους αριθμούς φορολογικού
μητρώου (ΑΦΜ) και  το φόρο που κατέβαλλαν για τη χρονιά
που πέρασε 1200 επαγγελματίες, υπολογίζει και εμφανίζει:
α) το μέσο φόρο ανά επαγγελματία,
β) πόσοι επαγγελματίες πλήρωσαν περισσότερα από 300 ευρώ,
γ) το ΑΦΜ του επαγγελματία που πλήρωσε το λιγότερο φόρο
    (θεωρείστε ότι είναι μοναδικός).
Παρατήρηση : Κανένας επαγγελματίας δεν πλήρωσε φόρο
μεγαλύτερο από 1500 ευρώ.

Λύση

     Αλγόριθμος Ασκ
     σ <-- 0
     φ <-- 0
     Μικ <-- 1501
     Για κ από 1 μέχρι 1200
          Διάβασε ΑΦΜ, Φόρος
          σ <-- σ+Φόρος
          Αν Φόρος > 300 τότε
               φ <-- φ+1
          Τέλος_αν
          Αν Φόρος < Μικ τότε
                Μικ <-- Φόρος
                ΑΦΜ_ΜΙΚ <-- κ
          Τέλος_αν
     Τέλος_επανάληψης 
     ΜΟ <-- σ/1200
     Εμφάνισε ΜΟ, φ, ΑΦΜ_ΜΙΚ
     Τέλος Ασκ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου