Παρασκευή, 17 Φεβρουαρίου 2012

Συγγραφή διαδικασίας

Γράψτε διαδικασία που γεμίζει τον ακέραιο  πίνακα Α[3, 4, 5]
με την τιμή -1.

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΓΕΜ(Α)
     ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: Α[3, 4, 5], Κ, Λ, Μ
     ΑΡΧΗ
            ΓΙΑ Κ ΑΠΟ 1 ΜΕΧΡΙ 3
                  ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 4
                      ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 5
                             Α[Κ, Λ, Μ] <-- -1
                      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου