Κυριακή, 24 Ιουνίου 2012

Λογικό διάγραμμα


Κατασκευάστε το λογικό διάγραμμα του παρακάτω αλγορίθμου

Αλγόριθμος Ασκ
Διάβασε Χ, Υ
Αν Χ > Υ τότε
   Αν Χ mod 2 = 0 τότε
       Α <-- 21*Χ+Υ
   αλλιώς
       Α <-- 3*Χ^Υ
   Τέλος_αν
αλλιώς_αν Χ < Υ τότε
    Α <-- 0
    Κ <-- 3
    Αρχή_επανάληψης
       Α <-- Α+Κ
       Κ <--  Κ+2
    Μέχρις_ότου Κ > 120
αλλιώς
     Α <-- 100
Τέλος_αν
Εμφάνισε Α
Τέλος Ασκ

Λύση



Βήμα-βήμα εκτέλεση


Ποιο είναι το περιεχόμενο του πίνακα Α[6] μετά την εκτέλεση
των παρακάτω εντολών;

Χ <-- 20
Για Κ από 1 μέχρι 3
    Αν Χ >= 10 τότε
       Α[Κ] <-- Χ+1
       Α[Κ+3] <-- Χ-1
    αλλιώς
       Α[Κ+3] <-- Χ+7
       Α[Κ] <-- Χ-7
    Τέλος_αν
    Χ <-- Χ div 2
Τέλος_επανάληψης


Απάντηση



Χ = 20
Κ = 1
    Αφού Χ >= 10 = 20 >= 10 = Αληθής έχουμε
        Α[Κ] = Α[1] =  Χ+1 = 20+1 = 21
        Α[Κ+3] = Α[1+3] = Α[4] =  Χ-1 = 20-1 = 19
    Χ = Χ div 2 = 20 div 2 = 10
Κ = 2
     Αφού Χ >= 10 = 10 >= 10 = Αληθής έχουμε
         Α[Κ] = Α[2] =  Χ+1 = 10+1 = 11
         Α[Κ+3] = Α[2+3] = Α[5] =  Χ-1 = 10-1 = 9
     Χ = Χ div 2 = 10 div 2 = 5
Κ = 3
     Αφού Χ >= 10 = 5 >= 10 = Ψευδής έχουμε
          Α[Κ+3] = Α[3+3] = Α[6] = Χ+7 = 5+7 = 12
          Α[Κ] = Α[3] = Χ-7 = 5-7 = -2
     Χ = Χ div 2 = 5  di0v 2 = 2
Η Για τερματίζεται με Κ = 4.

Το περιεχόμενο του πίνακα Α είναι:

   21   11  -2  19   9   12



Κυκλώστε τα σωστά


Ποιες από τις παρακάτω αποτελούν τυπικές επεξεργασίες των πινάκων;
i.  Υπολογισμός γινομένου στοιχείων του πίνακα
ii. Υπολογισμός αθροισμάτων στοιχείων του πίνακα
iii. Ταξινόμηση των στοιχείων του πίνακα
iv. Μηδενισμός των περιεχομένων του πίνακα
v.  Εύρεση μεγίστου ή ελαχίστου στοιχείου του πίνακα
vi. Συγχώνευση δύο πινάκων
vii. Αναζήτηση ενός στοιχείου του πίνακα
viii. Διαχωρισμός του πίνακα

Απάντηση

ii, iii, v, vi, vii


Τετάρτη, 20 Ιουνίου 2012

Σχεδίαση λογικού διαγράμματος

Σχεδιάστε το λογικό διάγραμμα που αντιστοιχεί στο
παρακάτω σύνολο εντολών:


   Διάβασε Χ
   Διάβασε Υ
   Όσο Χ >= Υ επανάλαβε
       κ <-- 1
      Αρχή_επανάληψης
           Εμφάνισε κ*Χ+Υ
           Αν κ mod 2 = 0 τότε
               Εμφάνισε Χ^2-Υ
           Τέλος_αν
           κ <-- κ+1
      Μέχρις_ότου κ > Χ
      Χ <-- Χ-1
   Τέλος_επανάληψης
   Εμφάνισε κ, Χ


Λύση


Βήμα - βήμα εκτέλεση (πίνακας τιμών)


Δίνονται οι παρακάτω αριθμημένες εντολές ενός αλγορίθμου
1 Διάβασε Χ
2 Διάβασε Υ
3 Όσο Χ >= Υ επανάλαβε
4     κ <-- 1
5     Αρχή_επανάληψης
6         Εμφάνισε κ*Χ+Υ
7         Αν κ mod 2 = 0 τότε
8             Εμφάνισε Χ^2-Υ
9         Τέλος_αν
10       κ <-- κ+1
11    Μέχρις_ότου κ > Χ
12    Χ <-- Χ-1
13 Τέλος_επανάληψης
14 Εμφάνισε κ, Χ













Στη   στήλη   με   τίτλο   «Αριθμός   γραμμής»   καταγράφεται   
ο αριθμός γραμμής της εντολής που εκτελείται. Στις στήλες 
με τίτλο «Χ >= Υ», «κ > Χ» και «κ mod 2 = 0» 
καταγράφεται η λογική  τιμή Αληθής   ή   Ψευδής,   εφόσον   
η   εντολή   που   εκτελείται περιλαμβάνει την αντίστοιχη συνθήκη. 
Στη στήλη με τίτλο «Έξοδος» καταγράφεται η  τιμή  εξόδου, 
εφόσον η εντολή που εκτελείται είναι εντολή εξόδου. Στη   
συνέχεια   του   πίνακα υπάρχει   μια   στήλη   για   κάθε 
μεταβλητή του αλγόριθμου. Να  μεταφέρετε  τον  πίνακα  
στο   τετράδιο  σας  και  να  τον συμπληρώσετε     εκτελώντας     
τις     εντολές     του αλγορίθμου ως εξής: για κάθε εντολή 
που εκτελείται να γράψετε σε νέα γραμμή του πίνακα τον 
αριθμό της γραμμής της και το αποτέλεσμα της στην 
αντίστοιχη στήλη.
Σημείωση:    Ήδη όπως διαπιστώνετε έχουν συμπληρωθεί δύο
καταχωρήσεις (οι τιμές εισόδου για τις μεταβλητές Χ, Υ είναι 2
και 1 αντίστοιχα).



Λύση



Παρασκευή, 15 Ιουνίου 2012

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν στις παρακάτω
προτάσεις:

1. Τη μεγαλύτερη προτεραιότητα από όλους τους τελεστές την
    έχουν οι _________.
2. Οι συναρτήσεις υπολογίζουν ένα μόνο _______ και το
        επιστρέφουν μέσω μιας εντολής εκχώρησης στο _____ τους.
3. Η φυσσαλίδα είναι η πιο _______ αλλά και λιγότερο _______
        μέθοδος ταξινόμησης.

Απαντήσεις

1. αριθμητικοί
2. αποτέλεσμα, όνομά
3. απλή, αποτελεσματική

Πίνακας αντιστοίχησης


Κάνετε τις σωστές αντιστοιχίσεις από τη Στήλη Α στη Στήλη Β.
Στη Στήλη Β περισσεύουν 2 επιλογές.

       Στήλη Α               Στήλη Β
1. κωδικοποίηση        α. κατηγορία προβλημάτων
2. προσπέλαση           β. τρόπος αναπαράστασης αλγορίθμων
3. βελτιστοποίησης    γ. λειτουργία επί των δομών δεδομένων
4. ΚΑΛΕΣΕ               δ. εντολή κλήσης διαδικασιών
5. SQL                       ε. εντολή κλήσης συναρτήσεων
                                 στ. γλώσσα ερωταπαντήσεων
                                 ζ. γλώσσα επιστημονικής κατεύθυνσης

Απαντήσεις

1. β
2. γ
3. α
4. δ
5. στ

Πίνακας αλήθειας


Συμπληρώστε τον πίνακα αλήθειας που ακολουθεί

    Χ             Υ          Χ ΚΑΙ ΟΧΙ Υ    ΟΧΙ Χ ΚΑΙ Υ Χ Ή Υ
Αληθής Ψευδής
Αληθής Αληθής
Ψευδής   Ψευδής
Ψευδής   Αληθής

Απαντήσεις

 Χ            Υ         Χ ΚΑΙ ΟΧΙ Υ    ΟΧΙ Χ ΚΑΙ Υ Χ Ή Υ
Αληθής Ψευδής     Αληθής               Ψευδής            Αληθής
Αληθής Αληθής    Ψευδής               Ψευδής            Αληθής
Ψευδής   Ψευδής   Ψευδής               Ψευδής            Ψευδής
Ψευδής   Αληθής   Ψευδής               Αληθής            Αληθής

Μετατροπές


Δίνεται το παρακάτω σύνολο εντολών
    Διάβασε Χ
    Α <-- Χ
    Κ <-- 1
    Όσο Κ ≤ 100 επανάλαβε
        Αν Κ <= 30 τότε
             Κ <-- Κ+1
        αλλιώς
             Κ <-- Κ+2
        Τέλος_αν
        Α <-- Α+1/Κ
    Τέλος_επανάληψης
    Εμφάνισε Α
Ξαναγράψτε το με ισοδύναμο τρόπο, χρησιμοποιώντας Μέχρις_ότου αντί για Όσο..επανάλαβε και απλές Αν..τότε αντί για την Αν..τότε..αλλιώς


Απάντηση

    Διάβασε Χ
    Α <-- Χ
    Κ <-- 1
    Αρχή_επανάληψης
        Αν Κ <= 30 τότε
             Κ <-- Κ+1
        Τέλος_αν        
        Αν Κ > 30 τότε
             Κ <-- Κ+2
        Τέλος_αν
        Α <-- Α+1/Κ
    Μέχρις_ότου Κ > 100
    Εμφάνισε Α

Τρίτη, 5 Ιουνίου 2012

Σχολιασμός Θεμάτων Πανελλαδικών Εξετάσεων Δ' τάξης Εσπερινού Γενικού Λυκείου 2012

Οι απειροελάχιστες διαφορές ανάμεσα στις εκφωνήσεις των
θεμάτων αυτών και των αντίστοιχων του Ημερήσιου Γενικού
Λυκείου, αφήνουν την ίδια ακριβώς γεύση : απλό 1ο και 2ο  θέμα
(με μικρές απαιτήσεις από τη θεωρία), απαιτητικό 3ο Θέμα και
απόλυτα αναμενόμενο 4ο.
Ωστόσο το 4ο θέμα δεν είχε τα προβλήματα σαφήνειας στη διατύπωση
που είχε το αντίστοιχο 4ο Θέμα του Ημερήσιου Γενικού Λυκείου.

Λύσεις Θεμάτων Πανελλαδικών Εξετάσεων Δ' τάξης Εσπερινού Γενικού Λυκείου 2012


ΘΕΜΑ Α


Α1. 

1.ΛΑΘΟΣ
2. ΛΑΘΟΣ
3.ΛΑΘΟΣ
4. ΛΑΘΟΣ
5. ΣΩΣΤΟ

Α2, Α3, Α4, Α5 :  Βλέπε λύσεις Ημερήσιου Γενικού Λυκείου 2012

ΘΕΜΑ Β
Βλέπε λύσεις Ημερήσιου Γενικού Λυκείου 2012

ΘΕΜΑ Γ
Βλέπε λύσεις Ημερήσιου Γενικού Λυκείου 2012

ΘΕΜΑ Δ

    Αλγόριθμος  ΘΔ
    Για Λ από 1 μέχρι 10
        Διάβασε ΟΝΟΜΑ[Λ]
    Τέλος_επανάληψης
    Για Μ από 1 μέχρι 10
        Για Λ από 1 μέχρι 12
              Διάβασε Π[Μ, Λ]
              Διάβασε Κ[Μ, Λ]
       Τέλος_επανάληψης
    Τέλος_επανάληψης
    Για Μ από 1 μέχρι 10
       Σ1 <-- 0
       Σ2 <-- 0
       Για Λ από 1 μέχρι 12
             Σ1 <-- Σ1+Π[Μ, Λ]
             Σ2 <-- Σ2+Κ[Μ, Λ]
       Τέλος_επανάληψης
       ΕΤΗΣΙΑ_Π[Μ] <-- Σ1
       ΕΤΗΣΙΑ_Κ[Μ] <-- Σ2
   Τέλος_επανάληψης
   Για Μ από 1 μέχρι 10
      Αν ΕΤΗΣΙΑ_Π[Μ] > ΕΤΗΣΙΑ_Κ[Μ] τότε
         ΕΣΟΔΑ[Μ] <-- (ΕΤΗΣΙΑ_Π[Μ]-ΕΤΗΣΙΑ_Κ[Μ])*0.55
      αλλιώς
         ΕΣΟΔΑ[Μ] <-- 0
      Τέλος_αν
   Τέλος_επανάληψης
   Για Μ από 2 μέχρι 10
       Για Λ από 10 μέχρι Μ με_βήμα -1
           Αν ΕΣΟΔΑ[Λ-1] < ΕΣΟΔΑ[Λ] τότε
               Βοηθ <-- ΕΣΟΔΑ[Λ-1]
               ΕΣΟΔΑ[Λ-1] <-- ΕΣΟΔΑ[Λ]
               ΕΣΟΔΑ[Λ] <-- Βοηθ
           Τέλος_αν
       Τέλος_επανάληψης
   Τέλος_επανάληψης
   Για Μ από 1 μέχρι 10
       Εμφάνισε ΕΣΟΔΑ[Μ]
   Τέλος_επανάληψης
   Τέλος ΘΔ

Παρασκευή, 1 Ιουνίου 2012

Σχολιασμός Θεμάτων Πανελληνίων Εξετάσεων Γ' τάξης Ημερήσιου γενικού Λυκείου 2012

ΘΕΜΑ Α
Υπερβολικά βατή η θεωρία αφού μόλις 6 μονάδες ήταν
το ερώτημα Α5 που ήταν ερώτημα ανάπτυξης. Τα υπόλοιπα
υποερωτήματα ήταν επίσης πάρα πολύ απλά, χωρίς κάτι το
ιδιαίτερο.

ΘΕΜΑ Β
Αναμενόμενο, χωρίς κανένα ιδιαίτερο βαθμό δυσκολίας.

ΘΕΜΑ Γ
Μια καλή συνδυαστική άσκηση, αφού απαιτούσε συνδυασμό
μεθοδολογιών (πορτοφόλι+φρουρός). Ένας καλά προετοιμασμένος
μαθητής δεν θα αντιμετώπισε, λογικά,  κάποια ιδιαίτερη δυσκολία.

ΘΕΜΑ Δ
Το θέμα αυτό είχε πολύ προβληματική εκφώνηση. Η διευκρίνηση
στο ερώτημα Δ3 ήρθε εγκαίρως ευτυχώς, επιτρέποντας την
ορθή αντιμετώπισή του από τους διαβασμένους μαθητές. Κάτι
τέτοιο δεν ήρθε ωστόσο για το ερώτημα Δ5, πράγμα που κατά
τη γνώμη μου μπορεί να οδηγήσει σε δύο τελείως διαφορετικές
λύσεις. Το καλύτερο θα ήταν να γίνουν δεκτές και οι δύο
προσεγγίσεις, χωρίς καμιά βαθμολογική συνέπεια για τους
μαθητές που δεν ακολούθησαν την ενδεικτική λύση του
υπουργείου αλλά προτίμησαν τη πρώτη προσέγγιση (βλέπε σχετικό
άρθρο).

Εκφωνήσεις Θεμάτων Πανελλαδικών Εξετάσεων Γ' τάξης Ημερήσιου Γενικού Λυκείου 2012









































































































































































































































Λύσεις Πανελλήνιων Εξετάσεων Γ' τάξης
Ημερήσιου Γενικού Λυκείου 2012


ΘΕΜΑ Α


Α1.
    1. ΛΑΘΟΣ
    2. ΛΑΘΟΣ
    3. ΣΩΣΤΟ
    4. ΛΑΘΟΣ
    5. ΣΩΣΤΟ

Α2. 

Εντολή εκχώρησης     Τύπος μεταβλητής Χ        Περιεχόμενο
                                                                               μεταβλητής Χ    

Χ <-- 'ΑΛΗΘΗΣ'            ΧΑΡΑΚΤΗΡΕΣ               'ΑΛΗΘΗΣ'
Χ <-- 11.0-13.0              ΠΡΑΓΜΑΤΙΚΕΣ                  -2.0
Χ <-- 7 > 4                     ΛΟΓΙΚΕΣ                        ΑΛΗΘΗΣ
Χ <-- ΨΕΥΔΗΣ              ΛΟΓΙΚΕΣ                        ΨΕΥΔΗΣ
Χ <-- 4                            ΑΚΕΡΑΙΕΣ                            4                

Α3.
α.
      Α[3] <-- 3+Α[6]
      Α[9] <-- Α[7] - 2
      Α[8] <-- Α[3] - 5
      Α[4] <-- 5 + Α[9]
      Α[5] <-- (Α[3]+Α[7]) div 2

β.
       Για i από 1 μέχρι 5
            αντιμετάθεσε Α[i], A[11-i]
       Τέλος_επανάληψης


A4.
     
α.
     i <-- 99
     Όσο i >= 1 επανάλαβε
           x <-- i^2
           εμφάνισε x
           i <-- i-2
     Τέλος_επανάληψης



β. 
     i <-- 99
     Αρχή_επανάληψης
           x <-- i^2
           εμφάνισε x
           i <-- i-2
     Μέχρις_ότου i < 1

γ.
     Οι δύο κύριες λειτουργίες σε μια στοίβα δεδομένων είναι:
     * Ώθηση : εισαγωγή ενός νέου στοιχείο στην κορυφή της
       στοίβας. Θα πρέπει να ελέγχεται αν η στοίβα είναι γεμάτη
       πριν από κάθε ώθηση (ώθηση σε γεμάτη στοίβα προκαλεί
       υπερχείλιση)
     * Απώθηση : εξαγωγή ενός στοιχείου από την κορυφή της
       στοίβας. Θα πρέπει να ελέγχεται αν η στοίβα είναι άδεια
       πριν από κάθε απώθηση (απώθηση σε άδεια στοίβα προκαλεί
       υποχείλιση).

ΘΕΜΑ Β


Β1.
      Κ = 1
      Χ = -1
      i = 0
      Αφού Χ < 7 = -1 < 7 = ΑΛΗΘΗΣ, η Όσο εκτελείται
      τουλάχιστον μια φορά.
      1η επανάληψη
            i  = i+1 = 0+1 = 1
            K = K*X = 1*(-1) = -1
            H Εμφάνισε τυπώνει:
                  -1     -1
            Αφού i mod 2 = 1 mod 2 = 1 έχουμε:
                   X = X+2 = -1+2 = 1
            Επειδή Χ < 7 = 1 < 7 = Αληθής, η Όσο συνεχίζεται.
     2η επανάληψη
             i  = i+1 = 1+1 = 2
            K = K*X = -1*1 = -1
            H Εμφάνισε τυπώνει:
                  -1     1
            Αφού i mod 2 = 2 mod 2 = 0 έχουμε:
                   X = X+1 = 1+1 = 2
            Επειδή Χ < 7 = 2 < 7 = Αληθής, η Όσο συνεχίζεται.
      3η επανάληψη
             i  = i+1 = 2+1 = 3
            K = K*X = -1*2 = -2
            H Εμφάνισε τυπώνει:
                  -2     2
            Αφού i mod 2 = 3 mod 2 = 1 έχουμε:
                   X = X+2 = 2+2 = 4
            Επειδή Χ < 7 = 4 < 7 = Αληθής, η Όσο συνεχίζεται.
       4η επανάληψη
             i  = i+1 = 3+1 = 4
            K = K*X = -2*4 = -8
            H Εμφάνισε τυπώνει:
                  -8     4
            Αφού i mod 2 = 4 mod 2 = 0 έχουμε:
                   X = X+1 = 4+1 = 5
            Επειδή Χ < 7 = 5 < 7 = Αληθής, η Όσο συνεχίζεται.
       5η επανάληψη
             i  = i+1 = 4+1 = 5
            K = K*X = -8*5 = -40
            H Εμφάνισε τυπώνει:
                  -40     5
            Αφού i mod 2 = 5 mod 2 = 1 έχουμε:
                   X = X+2 = 5+2 = 7
            Επειδή Χ < 7 = 7 < 7 = Ψευδής, η Όσο τερματίζεται.

Β2.
          ν <-- 0
          s <-- 0
          Αρχή_επανάληψης
                Αν ν mod 2 = 1 τότε
                      x <-- -1
                αλλιώς
                     x <-- 1
                Τέλος_αν
                s <-- s+x/(2*ν+1)
                ν <-- ν+1
          Μέχρις_ότου ν = 99
          π <-- 4*s
          Εκτύπωσε π



ΘΕΜΑ Γ


             Αλγόριθμος ΘΓ
             Αρχή_επανάληψης
                   Διάβασε ΠΟΣΟ
             Μέχρις_ότου ΠΟΣΟ > 5000000
             Διαθ <-- ΠΟΣΟ
             Μικρά <-- 0
             Μεγάλα <-- 0
             ΕπιδΜικρών <-- 0
             ΕπιδΜεγάλων <-- 0
             ΣΤΑΜΑΤΑ <-- ΨΕΥΔΗΣ
             Όσο ΣΤΑΜΑΤΑ = ΨΕΥΔΗΣ επανάλαβε
                    Διάβασε ΟΝΟΜΑ
                    Αν ΟΝΟΜΑ < > 'ΤΕΛΟΣ' τότε
                           Διάβασε Προ
                           Αν (Προ >= 200000) ΚΑΙ (Προ <= 299999) τότε
                                Επιδ <-- Προ*60/100
                                Κατ <-- 1
                           αλλιώς
                                Επιδ <-- Προ*70/100
                                Κατ <-- 2
                           Τέλος_αν
                           Αν Διαθ >= Επιδ τότε
                               Διαθ <-- Διαθ-Επιδ
                               Εμφάνισε ΟΝΟΜΑ, Επιδ
                               Αν Κατ = 1 τότε
                                     Μικρά <-- Μικρά+1 
                                     ΕπιδΜικρών <-- ΕπιδΜικρών+Επιδ
                               αλλιώς
                                     Μεγάλα <-- Μεγάλα+1
                                     ΕπιδΜεγάλων <-- ΕπιδΜεγάλων+Επιδ
                               Τέλος_αν                                           
                           αλλιώς
                                Αν Κατ = 1 τότε
                                      ΣΤΑΜΑΤΑ <-- ΑΛΗΘΗΣ
                                Τέλος_αν
                           Τέλος_αν
                    αλλιώς
                           ΣΤΑΜΑΤΑ <-- ΑΛΗΘΗΣ
                    Τέλος_αν
             Τέλος_επανάληψης
             Σύνολο <-- Μικρά+Μεγάλα
             Αν Σύνολο > 0 τότε
                 Εμφάνισε Μικρά, ΕπιδΜικρών
                 Εμφάνισε Μεγάλα, ΕπιδΜεγάλων
                 Αν Διαθ > 0 τότε
                       Εμφάνισε Διαθ
                 Τέλος_αν
             αλλιώς
                  Εμφάνισε 'Δε δόθηκαν καθόλου δεδομένα!'
             Τέλος_αν
             Τέλος ΘΓ

Παρατηρήσεις
1. Η Όσο θα μπορούσε να δομηθεί και ως εξής :

  .....
  Όσο ΣΤΑΜΑΤΑ = ΨΕΥΔΗΣ επανάλαβε
       Διάβασε ΟΝΟΜΑ
       Αν ΟΝΟΜΑ < > 'ΤΕΛΟΣ' τότε
              ...
             Αν Διαθ >= Επιδ τότε
                  ....
             Τέλος_αν
             Αν Διαθ < 120000 τότε   ! 120000 = 200000*0.6
                    ΣΤΑΜΑΤΑ <-- Αληθής
             Τέλος_αν
       αλλιώς
            ΣΤΑΜΑΤΑ <-- ΑΛΗΘΗΣ
       Τέλος_αν
  Τέλος_επανάληψης
   ....

2. Θα μπορούσε να χρησιμοποιηθεί και Μέχρις_ότου:
    ....
    Αρχή_επανάληψης
         Διάβασε ΟΝΟΜΑ
         Αν ΟΝΟΜΑ < > 'ΤΕΛΟΣ' τότε
               .....
         Τέλος_αν
    Μέχρις_ότου (ΟΝΟΜΑ = 'ΤΕΛΟΣ') Ή (Διαθ < 120000)
    ....

ΘΕΜΑ Δ


    ΠΡΟΓΡΑΜΜΑ ΘΔ
    ΜΕΤΑΒΛΗΤΕΣ
          ΧΑΡΑΚΤΗΡΕΣ: ΟΝ[10, 2]
          ΑΚΕΡΑΙΕΣ: Μ, Λ, ΘΜΑΧ, ΑΑΜήνα
          ΠΡΑΓΜΑΤΙΚΕΣ: Π[10, 12], Κ[10, 12], Σ1, Σ2, ΜΑΧ,
                                ΕτΠαρ[10], ΕτΚατ[10], Έσοδα[10], ΜΙΝ
    ΑΡΧΗ
           ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 10
                ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 2
                       ΔΙΑΒΑΣΕ ΟΝ[Μ, Λ]
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 10
                ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 12
                       ΔΙΑΒΑΣΕ Π[Μ, Λ]
                       ΔΙΑΒΑΣΕ Κ[Μ, Λ]
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 10
                Σ1 <-- 0
                Σ2 <-- 0
                ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 12
                       Σ1 <-- Σ1+Π[Μ, Λ]
                       Σ2 <-- Σ2+Κ[Μ, Λ]
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                ΕτΠαρ[Μ] <-- Σ1
                ΕτΚατ[Μ] <-- Σ2
                Έσοδα[Μ] <-- (Σ1-Σ2)*0.55
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΜΑΧ <-- ΕτΠαρ[1]
           ΘΜΑΧ <-- 1
           ΓΙΑ Μ ΑΠΟ 2 ΜΕΧΡΙ 10
                ΑΝ ΕτΠαρ[Μ] > ΜΑΧ ΤΟΤΕ
                      ΜΑΧ <-- ΕτΠαρ[Μ]
                      ΘΜΑΧ <-- Μ
                ΤΕΛΟΣ_ΑΝ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΡΑΨΕ ΟΝ[ΘΜΑΧ, 2]
           ΚΑΛΕΣΕ  Λίστα_Εσόδων(Έσοδα)
           ΜΙΝ <-- Π[1, 1]
           ΑΑΜήνα <-- 1
           ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 10
                ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 12
                       ΑΝ Π[Μ, Λ] < ΜΙΝ ΤΟΤΕ
                              ΜΙΝ <-- Π[Μ, Λ]
                              ΑΑΜήνα <-- Λ
                       ΤΕΛΟΣ_ΑΝ
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           ΓΡΑΨΕ  ΑΑΜήνα
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

    ΔΙΑΔΙΚΑΣΙΑ Λίστα_Εσόδων(Έσοδα)
    ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Έσοδα[10], κ, λ, Βοηθ
    ΑΡΧΗ
         ΓΙΑ κ ΑΠΟ 2 ΜΕΧΡΙ 10
              ΓΙΑ λ ΑΠΟ 10 ΜΕΧΡΙ κ ΜΕ_ΒΗΜΑ -1
                     ΑΝ Έσοδα[λ-1] < Έσοδα[λ] ΤΟΤΕ
                          Βοηθ <-- Έσοδα[λ-1]
                          Έσοδα[λ-1] <-- Έσοδα[λ]
                          Έσοδα[λ] <-- Βοηθ
                     ΤΕΛΟΣ_ΑΝ
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 10
              ΓΡΑΨΕ Έσοδα[κ]
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Παρατήρηση
Στο ερώτημα Δ5, μπορεί να δοθεί μια τελείως διαφορετική
λύση, αν θεωρήσουμε ότι ζητείται ο αριθμός του μήνα
με τη μικρότερη συνολική παραγωγή ηλεκτρικής ενέργειας
από όλους τους πελάτες. Σε αυτή την περίπτωση, θα πρέπει
να γράψουμε τα ακόλουθα:
         ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 12
                Σ <-- 0
                ΓΙΑ Μ ΑΠΟ 1 ΜΕΧΡΙ 10
                      Σ <-- Σ+Π[Μ, Λ]                           
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                ΣΜΗΝ[Λ] <-- Σ
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         Μικ <-- ΣΜΗΝ[1]
         ΑΑΜήνα  <-- 1
         ΓΙΑ Μ ΑΠΟ 2 ΜΕΧΡΙ 10
                ΑΝ ΣΜΗΝ[Μ] < Μικ ΤΟΤΕ
                      Μικ <-- ΣΜΗΝ[Μ]
                      ΑΑμήνα <-- Μ
                ΤΕΛΟΣ_ΑΝ
         ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
         ΓΡΑΨΕ ΑΑΜήνα