Κυριακή, 24 Ιουνίου 2012

Βήμα-βήμα εκτέλεση


Ποιο είναι το περιεχόμενο του πίνακα Α[6] μετά την εκτέλεση
των παρακάτω εντολών;

Χ <-- 20
Για Κ από 1 μέχρι 3
    Αν Χ >= 10 τότε
       Α[Κ] <-- Χ+1
       Α[Κ+3] <-- Χ-1
    αλλιώς
       Α[Κ+3] <-- Χ+7
       Α[Κ] <-- Χ-7
    Τέλος_αν
    Χ <-- Χ div 2
Τέλος_επανάληψης


Απάντηση



Χ = 20
Κ = 1
    Αφού Χ >= 10 = 20 >= 10 = Αληθής έχουμε
        Α[Κ] = Α[1] =  Χ+1 = 20+1 = 21
        Α[Κ+3] = Α[1+3] = Α[4] =  Χ-1 = 20-1 = 19
    Χ = Χ div 2 = 20 div 2 = 10
Κ = 2
     Αφού Χ >= 10 = 10 >= 10 = Αληθής έχουμε
         Α[Κ] = Α[2] =  Χ+1 = 10+1 = 11
         Α[Κ+3] = Α[2+3] = Α[5] =  Χ-1 = 10-1 = 9
     Χ = Χ div 2 = 10 div 2 = 5
Κ = 3
     Αφού Χ >= 10 = 5 >= 10 = Ψευδής έχουμε
          Α[Κ+3] = Α[3+3] = Α[6] = Χ+7 = 5+7 = 12
          Α[Κ] = Α[3] = Χ-7 = 5-7 = -2
     Χ = Χ div 2 = 5  di0v 2 = 2
Η Για τερματίζεται με Κ = 4.

Το περιεχόμενο του πίνακα Α είναι:

   21   11  -2  19   9   12



Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου