Κυριακή, 24 Ιουνίου 2012

Λογικό διάγραμμα


Κατασκευάστε το λογικό διάγραμμα του παρακάτω αλγορίθμου

Αλγόριθμος Ασκ
Διάβασε Χ, Υ
Αν Χ > Υ τότε
   Αν Χ mod 2 = 0 τότε
       Α <-- 21*Χ+Υ
   αλλιώς
       Α <-- 3*Χ^Υ
   Τέλος_αν
αλλιώς_αν Χ < Υ τότε
    Α <-- 0
    Κ <-- 3
    Αρχή_επανάληψης
       Α <-- Α+Κ
       Κ <--  Κ+2
    Μέχρις_ότου Κ > 120
αλλιώς
     Α <-- 100
Τέλος_αν
Εμφάνισε Α
Τέλος Ασκ

Λύση



Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου