Τετάρτη, 20 Ιουνίου 2012

Σχεδίαση λογικού διαγράμματος

Σχεδιάστε το λογικό διάγραμμα που αντιστοιχεί στο
παρακάτω σύνολο εντολών:


   Διάβασε Χ
   Διάβασε Υ
   Όσο Χ >= Υ επανάλαβε
       κ <-- 1
      Αρχή_επανάληψης
           Εμφάνισε κ*Χ+Υ
           Αν κ mod 2 = 0 τότε
               Εμφάνισε Χ^2-Υ
           Τέλος_αν
           κ <-- κ+1
      Μέχρις_ότου κ > Χ
      Χ <-- Χ-1
   Τέλος_επανάληψης
   Εμφάνισε κ, Χ


Λύση


Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου