Παρασκευή, 29 Οκτωβρίου 2010

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν στις παρακάτω
προτάσεις
1. Η τιμή που υπολογίζει μια συνάρτηση επιστρέφεται
    μέσω μιας εντολής _______ στο όνομά της.
2. Όποτε καλείται ένα υποπρόγραμμα η διεύθυνση
    επιστροφής του ______ στη στοίβα χρόνου εκτέλεσης.
3. Οι _______ περιλαμβάνουν υποπρογράμματα και
    συνδέονται με το αντικείμενο πρόγραμμα μέσω του
    συνδέτη-φορτωτή.
4. Η LISP και η  PROLOG είναι γλώσσες τεχνητής _____.
5. Η ΔΙΑΒΑΣΕ επιτρέπει την εισαγωγή δεδομένων από
    το _______ του υπολογιστή.
6. Η ΓΡΑΨΕ εμφανίζει τα αποτελέσματα ενός προγράμμα-
    τος στην _____ του υπολογιστή.
 


Απάντηση

1. εκχώρησης
2. ωθείται
3. βιβλιοθήκες
4. νοημοσύνης
5. πληκτρολόγιο
6. οθόνη

Τετάρτη, 27 Οκτωβρίου 2010

Άσκηση : Κουμπαράς

Θέλετε να αγοράσετε ένα ποδήλατο αξίας 320 ευρώ. Οι γονείς σας
σας δίνουν κάθε εβδομάδα ένα χρηματικό ποσό για τα προσωπικά
σας έξοδα και εσείς καταφέρνετε να αποταμιεύετε το 30% του ποσού
αυτού. Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
α) διαβάζει το χρηματικό ποσό που σας δίνουν οι γονείς σας κάθε
     εβδομάδα,
β) υπολογίζει και εμφανίζει:
    * πόσες εβδομάδες απαιτούνται μέχρι να μαζέψετε το χρηματικό
       ποσό που απαιτείται για την αγορά του ποδηλάτου,
    * το περίσσευμα των χρημάτων σας μετά την αγορά.

Απάντηση

      ΠΡΟΓΡΑΜΜΑ ΠΟΔΗΛΑΤΟ
      ΣΤΑΘΕΡΕΣ
             ΑΞΙΑ = 320
      ΜΕΤΑΒΛΗΤΕΣ
             ΠΡΑΓΜΑΤΙΚΕΣ: Ποσό, Σύνολο, Περ
             ΑΚΕΡΑΙΕΣ: Εβδομ
      ΑΡΧΗ
              ΔΙΑΒΑΣΕ Ποσό
              Σύνολο <-- 0
              Εβδομ <-- 0
              ΟΣΟ Σύνολο < ΑΞΙΑ ΕΠΑΝΑΛΑΒΕ
                      Σύνολο <-- Σύνολο+Ποσό*30/100
                      Εβδομ <-- Εβδομ+1
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΓΡΑΨΕ Εβδομ
              Περ <-- Σύνολο-ΑΞΙΑ
              ΑΝ Περ > 0 ΤΟΤΕ
                     ΓΡΑΨΕ Περ
              ΑΛΛΙΩΣ
                     ΓΡΑΨΕ 'Δεν υπάρχει περίσσευμα'
              ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Τρίτη, 26 Οκτωβρίου 2010

Άσκηση : Πορτοφόλι

Θέλετε να διαθέσετε μέχρι 80 ευρώ για την αγορά
αναψυκτικών και ποτών. Γράψτε αλγόριθμο που:
α) διαβάζει το είδος (Α-Αναψυκτικό, Π - Ποτό) του
     επόμενου προς αγορά προϊόντος,
β) ελέγχει αν είναι δυνατή ή αγορά του ή όχι,
γ) αν η απάντηση στο ερώτημα β) είναι καταφατική οι
    αγορές συνεχίζονται, διαφορετικά εμφανίζεται το
    μήνυμα "Οι αγορές δεν μπορούν να συνεχιστούν",
δ) υπολογίζει και εμφανίζει:
    * πόσα αναψυκτικά αγοράστηκαν,
    * πόσα ποτά αγοράστηκαν,
    * το περίσσευμα των χρημάτων σας μετά την
       ολοκλήρωση των αγορών,
    * το συνολικό ποσό που διαθέσατε για αγορές.

Λύση

    Αλγόριθμος Πορτοφόλι
    Ανα <-- 0
    Ποτ <-- 0
    Ποσό <-- 80
    Αρχή_επανάληψης
          Διάβασε Είδος, Τιμή
          Αν Ποσό >= Τιμή  τότε
               Ποσό <-- Ποσό-Τιμή
               Αν Είδος = 'Α' τότε
                    Ανα <-- Ανα+1
               αλλιώς
                    Ποτ <-- Ποτ+1

               Τέλος_αν
          αλλιώς
               Εμφάνισε 'Οι αγορές δεν μπορούν να συνεχιστούν'
          Τέλος_αν
    Μέχρις_ότου Ποσό < Τιμή
    ΠοσΑγ <-- 80-Ποσό
    Εμφάνισε Ανα, Ποτ
    Αν Διαθ > 0 τότε
           Εμφάνισε Διαθ
    αλλιώς
           Εμφάνισε 'Δεν υπάρχει καθόλου περίσσευμα'
    Τέλος_αν
    Εμφάνισε  ΠοσΑγ
    Τέλος Πορτοφόλι

Δευτέρα, 25 Οκτωβρίου 2010

Δώστε την εκφώνηση της άσκησης

Δίνεται το παρακάτω πρόγραμμα σε ΓΛΩΣΣΑ
    ΠΡΟΓΡΑΜΜΑ ΑΣΚ
    ΜΕΤΑΒΛΗΤΕΣ
           ΑΚΕΡΑΙΕΣ: λ, Φ
           ΠΡΑΓΜΑΤΙΚΕΣ: Α[21], Χ, Υ, Ζ
    ΑΡΧΗ
           ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 21
                 ΔΙΑΒΑΣΕ Α[λ]
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           Χ <-- 0
           Φ <-- 0
           ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 21
                 ΑΝ Α[λ] > 0 ΤΟΤΕ
                      Φ <-- Φ+1
                 ΤΕΛΟΣ_ΑΝ
                 Χ <-- Χ+Α[λ]
           ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
           Υ <-- Χ/21
           Ζ <-- 100*Φ/21
           ΓΡΑΨΕ Υ, Ζ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Ποιά είναι η εκφώνηση του προβλήματος που καλείται να
επιλύσει;



Απάντηση



Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
α) διαβάζει 21 πραγματικές τιμές και τις καταχωρεί σε
      κατάλληλο μονοδιάστατο πίνακα,
β)  υπολογίζει και εμφανίζει:
      * το μέσο όρο των τιμών του πίνακα,
      * το ποσοστό (%) των στοιχείων του πίνακα που
         είναι θετικά.

Κυριακή, 24 Οκτωβρίου 2010

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η δομή ακολουθίας είναι μια από τις τρεις αλγοριθμικές
    ________.
2. Η ______ είναι το γεωμετρικό σχήμα με το οποίο ξεκινά
    και τελειώνει ένα διάγραμμα ροής.
3. Η μεταβλητή ενός προγράμματος καταλαμβάνει συγκεκριμένο
    χώρο στη _____ του υπολογιστή.
4. Όταν το βήμα μεταβολής σε μια εντολή Για..από..μέχρι είναι
    1, τότε ________.
5. Δύο ή περισσότερες δομές επανάληψης που περιέχονται η μία
    μέσα στην άλλη αποκαλούνται ________ δομές επανάληψης.
6. Για να εμφανίσουμε το 3ο στοιχείο του πίνακα Α[230] γράφουμε
    την εντολή ________.

Απάντηση

1. συνιστώσες
2. έλλειψη
3. μνήμη
4. παραλείπεται
5. εμφωλευμένες
6. Εμφάνισε Α[3]

'Ασκηση : Φρουρός+απάντηση σε ερώτηση (συνδυαστική)

Γράψτε αλγόριθμο που:
α) διαβάζει τα ονόματα κάποιων νομών της Ελλάδας ( η
    είσοδος δεδομένων ολοκληρώνεται μόλις δοθεί ως
    τιμή εισόδου το κενό διάστημα),
β) για καθένα από τους παραπάνω νομούς, διαβάζει
    τα ονόματα και τους πληθυσμούς πόλεων/χωριών
    του (η είσοδος δεδομένων ολοκληρώνεται μόλις
    δοθεί η απάντηση 'Ν' στην ερώτηση 'Ολοκληρώθηκε
    η είσοδος;'),
γ) υπολογίζει και εμφανίζει:
    * το όνομα της πόλης με το μεγαλύτερο πληθυσμό καθώς
       και το όνομα του νομού στον οποίο ανήκει,
    * πόσες πόλεις εξετάστηκαν από κάθε νομό,
    * το ποσοστό (%) των πόλεων/χωριών που είχαν
       περισσότερους από 10000 κατοίκους.
Παρατηρήσεις:
* Θεωρείστε ότι δόθηκαν δεδομένα για  τουλάχιστον ένα νομό
* Εξετάστηκε τουλάχιστον μια πόλη από κάθε νομό.

Λύση

      Αλγόριθμος Πόλεις
      Πληθ <-- 0
      Φ <-- 0
      ΜΑΧ <-- -1
      Αρχή_επανάληψης
           Διάβασε Νομ
           Αν Νομ < > '  ' τότε
                Πολ <-- 0
                Αρχή_επανάληψης
                     Διάβασε Πόλη
                     Διάβασε Πληθυσμός
                     Πολ <-- Πολ+1
                     Πληθ <-- Πληθ+1
                     Αν Πληθυσμός > ΜΑΧ τότε
                            ΜΑΧ <-- Πληθυσμός
                            ΝομΜΑΧ <-- Νομ
                            ΠολΜΑΧ <-- Πόλη
                     Τέλος_αν
                     Αν Πληθυσμός > 10000 τότε
                            Φ <-- Φ+1
                     Τέλος_αν
                     Εμφάνισε 'Ολοκληρώθηκε η είσοδος;'
                     Διάβασε Απ
                Μέχρις_ότου Απ = 'Ν'
                Εμφάνισε Πολ
           Τέλος_αν
      Μέχρις_ότου   Νομ = '  '
      ΠΟΣ <-- 100*Φ/Πληθ
      Εμφάνισε ΠολΜΑΧ, ΝομΜΑΧ
      Εμφάνισε ΠΟΣ
      Τέλος Πόλεις

Σάββατο, 23 Οκτωβρίου 2010

Άσκηση : Για+φρουρός (συνδυαστική)

Γράψτε αλγόριθμο που:
α)  διαβάζει τα ονοματεπώνυμα 22 τραγουδιστών και για καθένα
     από αυτούς τον τίτλο όλων των CD που έχουν τραγουδίσει
     (η είσοδος δεδομένων ολοκληρώνεται μόλις δοθεί ως
     τίτλος CD το κενό διάστημα),
β) υπολογίζει και εμφανίζει:
     * το πλήθος των CD κάθε τραγουδιστή,
     * το ονοματεπώνυμο του τραγουδιστή με το μεγαλύτερο
        πλήθος CD.
     * το συνολικό πλήθος όλων των CD.
Παρατήρηση: Θεωρείστε ότι κάθε τραγουδιστής έχει τραγου-
δίσει σε τουλάχιστον ένα CD.

Λύση

        Αλγόριθμος CD
        MAX <-- -1
        Πλήθος <-- 0
        Για λ από 1 μέχρι 22
             Διάβασε ΟΝ
             ΤρCD <-- 0
            Αρχή_επανάληψης
                   Διάβασε Τιτλ
                   Αν Τιτλ < > '  ' τότε
                         ΤρCD <-- ΤρCD+1
                          Πλήθος <-- Πλήθος+1
                   Τέλος_αν
            Μέχρις_ότου Τιτλ = '  '
            Εμφάνισε ΤρCD
            Αν ΤρCD > ΜΑΧ τότε
                 ΜΑΧ <-- ΤρCD
                 ONMAX <-- ON
            Τέλος_αν
        Τέλος_επανάληψης
        Εμφάνισε ONMAX, Πλήθος
        Τέλος CD

Πέμπτη, 21 Οκτωβρίου 2010

Άσκηση : Απάντηση σε ερώτηση

Γράψτε πρόγραμμα που διαβάζει τους τίτλους κάποιων ταινιών,
το ονοματεπώνυμο του σκηνοθέτη τους, το ονοματεπώνυμο
του πρωταγωνιστή τους και το σύνολο των εισιτηρίων που
πουλήθηκαν για αυτές στους ελληνικούς κινηματογράφους
(η είσοδος τερματίζεται μόλις δοθεί η απάντηση 'ΟΧΙ' στην
ερώτηση 'Υπάρχει άλλη ταινία;'), υπολογίζει και εμφανίζει:
α) τον τίτλο της δημοφιλέστερης ταινίας, το ονοματεπώνυμο
     του σκηνοθέτη της και το ονοματεπώνυμο του πρωταγωνιστή
     της,
β) το ποσοστό (%) των ταινιών που είχαν περισσότερα από
     100000 εισιτήρια,


Λύση


     ΠΡΟΓΡΑΜΜΑ ΤΑΙΝΙΕΣ
     ΜΕΤΑΒΛΗΤΕΣ
            ΧΑΡΑΚΤΗΡΕΣ: Τ, Σκ, Πρ, ΣκΜΑΧ, ΠρΜΑΧ,
                                        ΤΜΑΧ, Απ
            ΑΚΕΡΑΙΕΣ: ΕΙΣ, ΜΑΧ, Πληθ, Φ
            ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ
     ΑΡΧΗ
            Πληθ <-- 0
            Φ <-- 0
            ΜΑΧ <-- -1
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                   ΔΙΑΒΑΣΕ Τ, Σκ, Πρ
                   ΔΙΑΒΑΣΕ ΕΙΣ
                   Πληθ <-- Πληθ+1
                   ΑΝ ΕΙΣ > ΜΑΧ ΤΟΤΕ
                          ΜΑΧ <-- ΕΙΣ
                          ΤΜΑΧ <-- Τ
                          ΣκΜΑΧ <-- Σκ
                          ΠρΜΑΧ <-- Πρ
                   ΤΕΛΟΣ_ΑΝ
                   ΑΝ ΕΙΣ > 100000 ΤΟΤΕ
                          Φ <-- Φ+1
                   ΤΕΛΟΣ_ΑΝ
                   ΓΡΑΨΕ 'Υπάρχει άλλη ταινία;'
                   ΔΙΑΒΑΣΕ Απ
            ΜΕΧΡΙΣ_ΟΤΟΥ Απ = 'ΟΧΙ'
            ΠΟΣ <-- 100*Φ/Πληθ
            ΓΡΑΨΕ ΤΜΑΧ, ΣκΜΑΧ, ΠρΜΑΧ
            ΓΡΑΨΕ ΠΟΣ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Τετάρτη, 20 Οκτωβρίου 2010

΄Ασκηση : Αναγωγή στη μονάδα +Πορτοφόλι

Γράψτε αλγόριθμο που :
α) διαβάζει τις τιμές πώλησης και το βάρος(σε κιλά)
    25 διαφορετικών συσκευασιών απορρυπαντικού,
β) υπολογίζει και εμφανίζει:
     * τον αύξοντα αριθμό (1-25) και την τιμή πώλησης
        της πιο συμφέρουσας συσκευασίας,
     * πόσες από τις προηγούμενες συσκευασίες μπορείτε
        να προμηθευτείτε με 132 ευρώ.

Λύση

     Αλγόριθμος Απορ
     Διάβασε Τιμή
     Διάβασε Βάρος
     ΜΙΝ <--  Τιμή/Βάρος
     ΤιμΜΙΝ <-- Τιμή
     ΑΑΜΙΝ <-- 1
     Για λ από 2 μέχρι 25
           Διάβασε Τιμή
           Διάβασε Βάρος
           ΤιμΚΙΛΟΥ <-- Τιμή/Βάρος
           Αν ΤιμΚΙΛΟΥ < ΜΙΝ τότε
                ΜΙΝ <-- ΤιμΚΙΛΟΥ
                ΑΑΜΙΝ <-- λ
                ΤιμΜΙΝ <-- Τιμή
           Τέλος_αν
     Τέλος_επανάληψης
     Πληθ <-- 0
     Ποσό <-- 132
     Όσο Ποσό >= ΤιμΜΙΝ επανάλαβε
            Ποσό <-- Ποσό-ΤιμΜΙΝ
            Πληθ <-- Πληθ+1
     Τέλος_επανάληψης
     Εμφάνισε ΑΑΜΙΝ, ΤιμΜΙΝ
     Εμφάνισε Πληθ
     Τέλος Απορ

Τρίτη, 19 Οκτωβρίου 2010

Επεξεργασία δοσμένου πλήθους δεδομών

Γράψτε αλγόριθμο που διαβάζει τους νομούς καταγωγής
και την ηλικία 10000 ελλήνων φοιτητών  και υπολογίζει:
α) το ποσοστό (%) των φοιτητών που κατάγονται
     από το νομό ΗΡΑΚΛΕΙΟΥ,
β) το μέσο όρο ηλικίας των φοιτητών που κατάγονται
     από το νομό ΧΑΝΙΩΝ.

Λύση

       Αλγόριθμος Φοιτητές
       Ηρ <-- 0
       Χ <-- 0
       σ <-- 0
       Για λ από 1 μέχρι 10000
            Διάβασε Νομός, Ηλικία
            Αν Νομός = 'ΗΡΑΚΛΕΙΟΥ' τότε
                 Ηρ <-- Ηρ+1
            αλλιώς
                   Αν Νομός = 'ΧΑΝΙΩΝ' τότε               
                       Χ <-- Χ+1
                       σ <-- σ+Ηλικία
                   Τέλος_αν
            Τέλος_αν
       Τέλος_επανάληψης
       ΠΟΣ <-- 100*Ηρ/10000
       Εμφάνισε ΠΟΣ
       Αν Χ > 0 τότε
             ΜΟΧ <-- σ/Χ
             Εμφάνισε ΜΟΧ
       αλλιώς
             Εμφάνισε 'Δεν υπάρχουν φοιτητές από τα Χανιά'
       Τέλος_αν
       Τέλος Φοιτητές

Δευτέρα, 18 Οκτωβρίου 2010

Πόσες φορές εκτελείται η επανάληψη;

Δίνεται το παρακάτω σύνολο εντολών
    Για λ από Χ-1 μέχρι Υ+2 με_βήμα Ζ*2
         Εμφάνισε 'Ηράκλειο'
    Τέλος_επανάληψης
Πόσες φορές τυπώνεται η λέξη 'Ηράκλειο' όταν:
α) Χ = 20, Υ = 22, Ζ = 1
β) Χ = 120, Υ = 116, Ζ = 9
γ) Χ = 5.3, Υ = 6.2, Ζ = 0.4
δ) Χ = 19.2, Υ = 21.3, Ζ = 0
ε) Χ = 32, Υ = 19, Ζ = -7
στ) Χ = 12.3, Υ = 6.7, Ζ = 0.9

Απάντηση

    α) Αφού Χ-1 = 20-1 = 19, Υ+2 = 22+2 = 24 και
         Ζ*2 = 1*2 = 2, το 'Ηράκλειο' θα τυπωθεί
         3 φορές.
    β) Αφού Χ-1 = 120-1 = 119, Υ+2 = 116+2 = 118 και
        Ζ*2 = 9*2 = 18, το 'Ηράκλειο' δε θα τυπωθεί
        καμία φορά.
    γ) Αφού Χ-1 = 5.3-1 = 4.3, Υ+2 = 6.2+2 = 8.2 και
        Ζ*2 = 0.4*2 = 0.8, το 'Ηράκλειο' θα τυπωθεί
         5 φορές.
    δ) Αφού Χ-1 = 19.2-1 = 18.2, Υ+2 = 21.3+2 = 23.2 και
        Ζ*2 = 0*2 = 0, το 'Ηράκλειο' θα τυπωθεί
         άπειρες φορές.
    ε) Αφού Χ-1 = 32-1 = 31, Υ+2 = 19+2 = 21 και
        Ζ*2 = -7*2 = -14, το 'Ηράκλειο' θα τυπωθεί
         1 φορά.
  στ) Αφού Χ-1 = 12.3-1 = 11.3, Υ+2 = 6.7+2 = 8.7 και
        Ζ*2 = 0.9*2 = 1.8, το 'Ηράκλειο' δε θα τυπωθεί
        καμία φορά.

 

 

 
  

Ποιό η ποιά αλγοριθμικά κριτήρια παραβιάζονται

Δίνεται ο παρακάτω αλγόριθμος
    Αλγόριθμος Τεστ
    Διάβασε Μ
    σ <-- 0
    Όσο σ < Μ επανάλαβε
          Διάβασε α
          σ <-- σ+1/α
    Τέλος_επανάληψης
    Τέλος Τεστ

Λύση

     α)  Καθοριστικότητα, γιατί αν α = 0 η εντολή σ <-- σ+1/α
          δεν μπορεί να εκτελεστεί.
     β) Έξοδος, γιατί ο αλγόριθμος δεν εμφανίζει κανένα
         αποτέλεσμα

Σάββατο, 16 Οκτωβρίου 2010

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω προτάσεις και επαναδιατυπώστε τις
έτσι ώστε να είναι σωστές
1. Ο τελεστής ΟΧΙ είναι συγκριτικός.
2. Το τμήμα δήλωσης των μεταβλητών προηγείται του
    τμήματος δήλωσης των συμβολικών σταθερών.
3. Η γλώσσα PASCAL είναι κατάλληλη για την εκμάθηση
    προγραμματισμού σε παιδιά μικρής ηλικίας.
4. H VISUAL BASIC είναι ιδανική για την εφαρμογή
    του ορατού προγραμματισμού.
5. Ένας πίνακας Β[30] καταλαμβάνει 60 bytes στην
    κύρια μνήμη του υπολογιστή.


Απάντηση

1. Ο τελεστής ΟΧΙ είναι λογικός.
2. Το τμήμα δήλωσης των μεταβλητών έπεται του
    τμήματος δήλωσης των συμβολικών σταθερών.
3. Η γλώσσα LOGO είναι κατάλληλη για την εκμάθηση
    προγραμματισμού σε παιδιά μικρής ηλικίας.
4. H VISUAL BASIC είναι ιδανική για την εφαρμογή
    του οπτικού προγραμματισμού.
5. Ένας ακέραιος πίνακας Β[30] καταλαμβάνει 60 bytes στην
    κύρια μνήμη του υπολογιστή.

Παρασκευή, 15 Οκτωβρίου 2010

Άσκηση : βήμα-βήμα εκτέλεση (Μέχρις_ότου+Αν..τότε)

Τι θα εμφανίσει το παρακάτω σύνολο εντολών
     μ <-- 9
     λ <-- 13
     Αρχή_επανάληψης
          α <-- λ-μ
          Αν α > 0 τότε
              Εμφάνισε μ+1, λ-2
          Τέλος_αν
          μ <-- μ-3
          λ <-- λ-5
          Εμφάνισε μ, λ
     Μέχρις_ότου μ < 2

Λύση

      μ = 9
      λ = 13
      1η επανάληψη
           α = λ-μ = 13-9 = 4
           Αφού α > 0 = 4 > 0 = Αληθής
                επειδή μ+1 = 9+1 = 10, λ-2 = 13-2 = 11
                η Εμφάνισε τυπώνει:        10      11
           μ = μ-3 = 9-3 = 6
           λ = λ-5 = 13-5 = 8
           Η Εμφάνισε τυπώνει:     6     8
     2η επανάληψη
           α = λ-μ = 8-6 =2
           Αφού α > 0 = 2 > 0 = Αληθής
                επειδή μ+1 = 6+1 = 7, λ-2 = 8-2 = 6
                η Εμφάνισε τυπώνει:        7     6
           μ = μ-3 = 6-3 =3
           λ = λ-5 = 8-5 = 3
           Η Εμφάνισε τυπώνει:     3    3
      3η επανάληψη
           α = λ-μ = 3-3 = 0
           Αφού α > 0 = 0 > 0 = Ψευδής, η εντολή
           Εμφάνισε μ+1, λ-2 δεν εκτελείται.
           μ = μ-3 = 3-3 = 0
           λ = λ-5 = 3-5 =-2
           Η Εμφάνισε τυπώνει:     0   -2
      Αφού μ < 2 = 0 < 2 = Αληθής, η Μέχρις_ότου 
      ολοκληρώνεται.
 

 

     
    

Πέμπτη, 14 Οκτωβρίου 2010

Μετατροπές

Δίνεται το παρακάτω σύνολο εντολών
    Διάβασε Χ
    Όσο Χ <= 0 επανάλαβε
         Διάβασε Χ
    Τέλος_επανάληψης
    σ <-- 0
    Για λ από 1 μέχρι Χ
         Αν λ mod 4 = 0 τότε
              σ <-- σ+λ-1
         αλλιώς
              σ <-- σ-λ+2
         Τέλος_αν
    Τέλος_επανάληψης
Ξαναγράψτε το με ισοδύναμο τρόπο αντικαθιστώντας
α) την Όσο..επανάλαβε με Μέχρις_ότου
β) την Για..από..μέχρι με  Όσο..επανάλαβε
γ)  την Αν..τότε..αλλιώς με Αν..τότε 

Λύση

    Αρχή_επανάληψης
         Διάβασε Χ
    Τέλος_επανάληψης
    σ <-- 0
    λ <-- 1
   Όσο λ <= Χ επανάλαβε
         Αν λ mod 4 = 0 τότε
              σ <-- σ+λ-1
         Τέλος_αν
         Αν  λ mod 4 < >  0 τότε
              σ <-- σ-λ+2
         Τέλος_αν
         λ <-- λ+1
    Τέλος_επανάληψης

Ποιά είναι η τελική τιμή;

Ποιά είναι η τελική τιμή της μεταβλητής μ μετά την
εκτέλεση των παρακάτω εντολών
   μ <-- 0
   Για λ από 1 μέχρι 120
        μ <-- μ+3
        Για ν από 4 μέχρι 8
             μ <-- μ+1
        Τέλος_επανάληψης
   Τέλος_επανάληψης

Λύση

     Η εντολή μ <-- μ+3 εκτελείται 120 φορές ενώ η εντολή
     μ <-- μ+1 εκτελείται 120Χ5 = 600 φορές. Κατά συνέπεια:
        μ = 0+120*3+600*1 = 360+600 = 960

Τετάρτη, 13 Οκτωβρίου 2010

Άσκηση : επεξεργασία δοσμένου πλήθους δεδομένων (Για..από..μέχρι)

Σ' ένα γυμνάσιο λειτουργούν 16 τμήματα. Γράψτε αλγόριθμο που
διαβάζει το πλήθος των μαθητών κάθε τμήματος, υπολογίζει και
εμφανίζει:
α) το συνολικό πλήθος των μαθητών του γυμνασίου,
β) τον αύξοντα αριθμό (1-16) του τμήματος που είχε το μικρότερο
    πλήθος μαθητών,
γ) τον αύξοντα αριθμό (1-16) του τμήματος που είχε το μεγαλύτερο
    πλήθος μαθητών,
δ) πόσα τμήματα είχαν λιγότερους από 28 μαθητές.

Λύση

     Αλγόριθμος Γυμνάσιο
     Διάβασε Μαθ
     ΜΑΧ <-- Μαθ
     ΑΑΜΑΧ <-- 1
     ΜΙΝ <-- Μαθ
     ΑΑΜΙΝ <-- 1
     Πληθ <-- Μαθ
     Αν Μαθ < 28 τότε
          Πλ <-- 1
     αλλιώς
          Πλ <-- 0
     Τέλος_αν
     Για λ από 2 μέχρι 16
          Διάβασε Μαθ
          Αν  Μαθ > ΜΑΧ τότε
               ΜΑΧ <-- Μαθ
               ΑΑΜΑΧ <-- λ
          Τέλος_αν
          Αν  Μαθ < ΜΙΝ τότε
               ΜΙΝ <-- Μαθ
               ΑΑΜΙΝ <-- λ
          Τέλος_αν
          Αν  Μαθ < 28 τότε
               Πλ <-- Πλ+1
          Τέλος_αν
          Πληθ <-- Πληθ+Μαθ
     Τέλος_επανάληψης
     Εμφάνισε Πληθ, ΑΑΜΙΝ, ΑΑΜΑΧ, Πλ
     Τέλος Γυμνάσιο

Τρίτη, 12 Οκτωβρίου 2010

Υπολογισμός παραστάσεων

Αν  Α = 'Β', Β = 'Α', Γ = 4 και Δ = 8, υπολογίστε την τιμή των
παρακάτω παραστάσεων
1. (Α < Β) Ή (Γ+Δ >= 12)
2.  (2*Δ > Γ^2) ΚΑΙ (Α > 'Β')
3. (Δ mod Γ < 1) ΚΑΙ mod Δ > 0)
4.  (Α = '%') Ή (Β = 'Α') ΚΑΙ (Α <= 'Τ')

Λύση

1. (Α < Β) Ή (Γ+Δ >= 12)  = ('Β' < 'Α') Ή (4+8 >= 12)  =
    ('Β' < 'Α') Ή (12 >= 12)  = Ψευδής Ή Αληθής = Αληθής
2. (2*Δ > Γ^2) ΚΑΙ (Α > 'Β') = (2*8 > 4^2) ΚΑΙ ('Β' > 'Β') =
    (16 > 16) ΚΑΙ ('Β'> 'Β') = Ψευδής ΚΑΙ Ψευδής = Ψευδής
3. (Δ mod Γ < 1) ΚΑΙ (Γ mod Δ > 0) =
    (8 mod 4 < 1) ΚΑΙ (4 mod 8 > 0) =
    (0 < 1) ΚΑΙ (4 > 0) = Αληθής ΚΑΙ Αληθής = Αληθής
4. (Α = '%') Ή (Β = 'Α') ΚΑΙ (Α <= 'Τ') =
    ('Β' = '%') Ή ('Α' = 'Α') ΚΑΙ ('Β' <= 'Τ') =
    Ψευδής Ή Αληθής ΚΑΙ Αληθής =
    Ψευδής Ή Αληθής = Αληθής

Δευτέρα, 11 Οκτωβρίου 2010

Άσκηση : Απάντηση σε ερώτηση

Γράψτε αλγόριθμο που διαβάζει ονόματα χωρών και την έκτασή
τους σε τετραγωνικά χιλιόμετρα (η είσοδος δεδομένων ολοκληρώ-
νεται μόλις δοθεί η απάντηση 'ΟΧΙ' στην υποβαλλόμενη προς το
χρήστη ερώτηση 'Υπάρχει άλλη χώρα;') και υπολογίζει:
α) το πλήθος των χωρών που εξετάστηκαν,
β) το μέσο όρο έκτασης ανά χώρα,
γ) το όνομα της χώρας με τη μικρότερη έκταση.

Λύση

      Αλγόριθμος Χώρες
      Πληθ <-- 0
      σ <-- 0
      Μικ <-- 99999999999999999999999999999
      Αρχή_επανάληψης
           Διάβασε Χ
           Διάβασε Εκ
           σ <-- σ+Εκ
           Πληθ <-- Πληθ+1
           Αν Εκ < Μικ τότε
                Μικ <-- Εκ
                ΧωρΜ <-- Χ
           Τέλος_αν
           Εμφάνισε 'Υπάρχει άλλη χώρα;'
           Διάβασε Απ
      Μέχρις_ότου Απ = 'ΟΧΙ'
      ΜΟ <-- σ/Πληθ
      Εμφάνισε Πληθ, ΜΟ, ΧωρΜ
      Τέλος Χώρες

Άσκηση σε δυσδιάστατο πίνακα (μέσοι όροι και ελάχιστα ανά γραμμή)

Σε ένα κέντρο εκπαίδευσης νεοσυλλέκτων υπάρχουν 4
διμοιρίες που η καθεμιά της έχει δύναμη 65 ανδρών.
Γράψτε αλγόριθμο που :
α) δέχεται ως είσοδο την ηλικία των ανδρών και
    καταχωρεί τα δεδομένα αυτά στον πίνακα
    Η[4, 65],
β) υπολογίζει και εμφανίζει, για κάθε διμοιρία:
    * το μέσο όρο ηλικίας των ανδρών της,
    * τη μικρότερη ηλικία και τον αύξοντα αριθμό
       (1-65) του άνδρα που την έχει.

Λύση

      Αλγόριθμος Φαντάροι

      Για λ από 1 μέχρι 4
           Για μ από 1 μέχρι 65
                 Διάβασε Η[λ, μ]
           Τέλος_επανάληψης
      Τέλος_επανάληψης
      Για λ από 1 μέχρι 4
           Μικρ <-- Η[λ, 1]
           ΑΑ <-- 1
           σ <-- 0
           Για μ από 1 μέχρι 65
                 Αν Η[λ, μ] < Μικρ τότε
                       Μικρ <-- Η[λ, μ]
                       ΑΑ <-- μ
                 Τέλος_αν
                 σ <-- σ+Η[λ, μ]
           Τέλος_επανάληψης
           ΜΟ <-- σ/65
           Εμφάνισε ΜΟ, Μικρ, ΑΑ
      Τέλος_επανάληψης
      Τέλος Φαντάροι

Κυριακή, 10 Οκτωβρίου 2010

Άσκηση : Ποιό είναι το περιεχόμενο του πίνακα

Δίνονται οι παρακάτω εντολές
     β <-- 10
     Για λ από 1 μέχρι 5
          Για μ από 1 μέχρι 5
                 Χ[λ, μ] <-- β
                 β <-- -β
          Τέλος_επανάληψης
     Τέλος_επανάληψης
Ποιό είναι το περιεχόμενο του πίνακα Χ[5, 5] μετά
την εκτέλεση των παραπάνω εντολών;

Λύση

Ο πίνακας Χ γεμίζει (γραμμή-γραμμή)  με τις τιμές
10 και -10 εναλλάξ. Πράγματι αν β = 10, τότε η εντολή
β <-- -β αποδίδει στο β την τιμή -10. Αν τώρα β = -10,
η εντολή β <-- -β αποδίδει στο β την τιμή -(-10) = 10.
Κατά συνέπεια ο πίνακας Χ έχει το ακόλουθο περιεχόμενο:
        10       -10         10        -10       10
       -10        10        -10         10       -10
        10        -10        10         -10       10
       -10        10        -10         10       -10
        10        -10        10         -10       10
     

Άσκηση : Βήμα-βήμα εκτέλεση (Όσο+Αν..τότε..αλλιώς)

Αν η τιμή εισόδου είναι 60, τι θα εμφανίσει το παρακάτω
σύνολο εντολών;
      Διάβασε α
      Όσο α > 0 επανάλαβε
          Αν α > 40 τότε
                β <-- α mod 35
          αλλιώς
                β <-- α mod 21
          Τέλος_αν
          α <-- α-β
          Εμφάνισε α, β
      Τέλος_επανάληψης
Τι παρατηρείτε;

Λύση

      α = 60
      1η επανάληψη
             Αφού α > 40 = 60 > 40 = Αληθής έχουμε:
                   β = α mod 35 = 60 mod 35 = 25
             α = α-β = 60-25 = 35
             Η Εμφάνισε τυπώνει :
                    35      25
      2η επανάληψη
             Αφού α > 40 = 35 > 40 = Ψευδής έχουμε:
                   β = α mod 21 = 35 mod 21 = 14
             α = α-β = 35-14 = 21
             Η Εμφάνισε τυπώνει :
                    21      14
      3η επανάληψη
             Αφού α > 40 = 21 > 40 = Ψευδής έχουμε:
                   β = α mod 21 = 21 mod 21 = 0
             α = α-β = 21-0= 21
             Η Εμφάνισε τυπώνει :
                    21      0
      4η επανάληψη
             Αφού α > 40 = 21 > 40 = Ψευδής έχουμε:
                   β = α mod 21 = 21 mod 21 = 0
             α = α-β = 21-0= 21
             Η Εμφάνισε τυπώνει :
                    21      0
      κ.ο.κ.

Παρατηρούμε ότι από τη στιγμή που το β παίρνει την τιμή 0
το α θα διατηρήσει την τιμή 21 επ' άπειρον και κατά συνέπεια
η Όσο..επανάλαβε δεν πρόκειται ποτέ να τερματιστεί! Σε κάθε 
επανάληψη της λοιπόν (από την 3η και μετά) θα εμφανίζει 
τις τιμές:  21   0

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις
1. Στα προβλήματα απόφασης αναζητούμε τη λύση που
    ικανοποιεί κατά το βέλτιστο βαθμό τα δεδομένα του
    προβλήματος.
2. Ο αριθμός των αριστερών παρενθέσεων σε μια αριθμητική
    παράσταση πρέπει να είναι τουλάχιστον ίσος με τον αριθμό
    των δεξιών παρενθέσεων.
3. Μια μεταβλητή λογικού τύπου καταλαμβάνει 2 bytes στην
    κύρια μνήμη του υπολογιστή.
4. Προσπέλαση είναι μια λειτουργία επί των δομών δεδομένων
    η οποία προσπαθεί να εντοπίσει έναν ή περισσότερους
    κόμβους που ικανοποιούν κάποιο δοσμένο περιορισμό.
5. Η μέθοδος της φυσαλίδας περιλαμβάνει δύο εμφωλευμένα
    ΑΝ και μια εντολή ΓΙΑ..ΑΠΟ..ΜΕΧΡΙ.
6. Αν οι εντολές μια διαδικασία αλλάζουν την τιμή μιας
    τυπικής παραμέτρου, τότε μετά την ολοκλήρωση της
    κλήσης θα αλλάξει και η τιμή της αντίστοιχης πραγμα-
    τικής παραμέτρου.
7. Το σύνολο των εντολών μιας συνάρτησης περιλαμβάνει
    τουλάχιστον μια ΔΙΑΒΑΣΕ.

8. Σε ένα λογικό διάγραμμα ακολουθιακής δομής δεν 
    πρόκειται να συναντήσουμε ποτέ το γεωμετρικό 
    σχήμα της έλλειψης.


Λύση


1. Στα προβλήματα βελτιστοποίησης αναζητούμε τη λύση 
    που ικανοποιεί κατά το βέλτιστο βαθμό τα δεδομένα του
    προβλήματος.
2. Ο αριθμός των αριστερών παρενθέσεων σε μια αριθμητική
    παράσταση πρέπει να είναι ίσος ακριβώς με τον αριθμό
    των δεξιών παρενθέσεων.
3. Μια μεταβλητή λογικού τύπου καταλαμβάνει 1 byte στην
    κύρια μνήμη του υπολογιστή.
4. Αναζήτηση είναι μια λειτουργία επί των δομών δεδομένων
    η οποία προσπαθεί να εντοπίσει έναν ή περισσότερους 
    κόμβους που ικανοποιούν κάποιο δοσμένο περιορισμό.
5. Η μέθοδος της φυσαλίδας περιλαμβάνει δύο εμφωλευμένα
    ΓΙΑ..ΑΠΟ..ΜΕΧΡΙ και μια εντολή ΑΝ..ΤΟΤΕ.
6. Αν οι εντολές μια διαδικασία αλλάζουν την τιμή μιας
    τυπικής παραμέτρου, τότε μετά την ολοκλήρωση της
    κλήσης θα αλλάξει και η τιμή της αντίστοιχης πραγμα-
    τικής παραμέτρου, εφόσον η τελευταία είναι μεταβλητή.

7. Το σύνολο των εντολών μιας συνάρτησης περιλαμβάνει
    τουλάχιστον μια εντολή εκχώρησης.
8. Σε ένα λογικό διάγραμμα ακολουθιακής δομής δεν 
    πρόκειται να συναντήσουμε ποτέ το γεωμετρικό 
    σχήμα του ρόμβου.

Σάββατο, 9 Οκτωβρίου 2010

Άσκηση : Φρουρός

Γράψτε πρόγραμμα το οποίο διαβάζει τους τίτλους
των μαθημάτων που παρακολουθεί ένας μαθητής
της Γ' τάξης και το σύνολο των διδακτικών ωρών
του κάθε μαθήματος κατά τη διάρκεια της εβδομάδας
(η είσοδος δεδομένων ολοκληρώνεται μόλις δοθεί ως τίτλος
μαθήματος το κενό διάστημα), υπολογίζει και εμφανίζει:
α) το πλήθος των μαθημάτων που παρακολουθεί ο μαθητής,
β) τον τίτλο του μαθήματος που έχει το μεγαλύτερο σύνολο
    διδακτικών ωρών,
γ) το ποσοστό (%) των μαθημάτων που είναι μονόωρα.

Λύση

       ΠΡΟΓΡΑΜΜΑ ΜΑΘΗΤΗΣ
       ΜΕΤΑΒΛΗΤΕΣ
              ΑΚΕΡΑΙΕΣ: Πληθ, Μονο, Ωρες, Μεγ
              ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ
              ΧΑΡΑΚΤΗΡΕΣ: Τ, ΤΜεγ
       ΑΡΧΗ
              Πληθ <-- 0
              Μονο <-- 0
              Mεγ  <-- -1000
              ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                    ΔΙΑΒΑΣΕ Τ
                    ΑΝ Τ < > '  ' ΤΟΤΕ
                         ΔΙΑΒΑΣΕ Ωρες
                         Πληθ <-- Πληθ+1
                         ΑΝ Ωρες > Μεγ ΤΟΤΕ
                               Μεγ <-- Ωρες
                               ΤΜεγ <-- Τ
                         ΤΕΛΟΣ_ΑΝ
                         ΑΝ Ωρες = 1 ΤΟΤΕ
                               Μονο <-- Μονο+1
                         ΤΕΛΟΣ_ΑΝ
                    ΤΕΛΟΣ_ΑΝ
              ΜΕΧΡΙΣ_ΟΤΟΥ  Τ = '  '
              ΑΝ Πληθ > 0 ΤΟΤΕ
                    ΠΟΣ <-- 100*Μονο/Πληθ
                    ΓΡΑΨΕ Πληθ, ΤΜεγ, ΠΟΣ
              ΑΛΛΙΩΣ
                    ΓΡΑΨΕ 'Δε δόθηκαν δεδομένα!'
              ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Παρασκευή, 8 Οκτωβρίου 2010

Ποιά είναι η τελική τιμή της μεταβλητής

Μετά την εκτέλεση των παρακάτω εντολών, ποιά είναι η
τελική τιμή της μεταβλητής α.
     α <-- 0
     Για λ από 11 μέχρι 99 με_βήμα 9
          κ <-- 10
          Όσο κ > 0 επανάλαβε
               μ <-- 5
               Αρχή_επανάληψης
                    α <-- α+10
                    μ <-- μ+4
               Μέχρις_ότου μ > 13
               κ <-- κ-5
          Τέλος_επανάληψης
     Τέλος_επανάληψης

Απάντηση

Η Για..από..μέχρι εκτελείται 10 φορές, η Όσο..επανάλαβε
2 φορές και η Μέχρις_ότου 3 φορές. Κατά συνέπεια η
εντολή α <-- α+10 εκτελείται 10Χ2Χ3 = 60 φορές και έτσι
     α = 0+60*10 = 600.

Ερωτήσεις σωστού λάθους

Ποιές από τις παρακάτω προτάσεις είναι σωστές και ποιές
λάθος
1. Το πρόβλημα "Επιλύστε την εξίωση 3Χ-9 = 12" είναι
    επιλύσιμο.
2. Η μεταβλητή Α_12_3_Β δεν έχει αποδεκτό όνομα.
3. Η σταθερά 'Ανάπτυξη' είναι αλφαριθμητική.
4. Η απλούστερη λογική παράσταση είναι μια σύγκριση
    ανάμεσα σε αριθμητικά ή αλφαριθμητικά δεδομένα.
5. Η συνθήκη 123 mod 124 > 0 έχει την τιμή Αληθής.
6. Όταν μια εντολή προγράμματος συνεχίζεται και στην
    επόμενη γραμμή, η γραμμή αυτή ξεκινά με το %.
7. Η  εντολή   Χ <-- Τ_Ρ(Υ-5) παραβιάζει το κριτήριο
    της καθοριστικότητας όταν Υ < 5.
8. Η εντολή Δεδομένα // ... //  είναι μια από τις δύο
    εντολές εισόδου της ΓΛΩΣΣΑΣ.
9. Το παρακάτω σύνολο εντολών
       Αν Χ mod 2 = 3 τότε

            Υ <-- 11
       αλλιώς

            Υ <-- 111
       Τέλος_αν
    αποδίδει στο Υ την τιμή 111 (ανεξάρτητα από το
    περιεχόμενο της Χ)

10. Αν Α[4, 4] ακέραιος πίνακας που κάθε στοιχείο
      του ισούται με 10, το παρακάτω σύνολο εντολών
            Γ <-- 1
            Για λ από 1 μέχρι 4
                 Γ <-- Γ*Α[λ, 5-λ]
            Τέλος_επανάληψης
            Εμφάνισε Γ
     εμφανίζει στη μονάδα εξόδου την τιμή 10000.

 

Απάντηση

1. Σ
2. Λ
3. Σ
4. Σ
5. Σ
6. Λ
7. Σ
8. Λ
9. Σ
10.Σ

Πέμπτη, 7 Οκτωβρίου 2010

Συμπληρώστε τα κενά

Συμπληρώστε τα κενά που λείπουν
1. Οι σταθερές ενός αλγορίθμου μπορεί να είναι ______ ή
    αριθμητικές ή λογικές.
2. Η δομή ________ επιλογής δεν παρέχει τη δυνατότητα
    εναλλακτικής εκτέλεσης ανάμεσα σε δύο διαφορετικές
    ομάδες εντολών.
3. Η δομη επανάληψης
        Για κ από 12 μέχρι 122 με_βήμα 0
              Εμφάνισε 'τεστ'
        Τέλος_επανάληψης
    παραβιάζει το κριτήριο της ________.
4. Πράξεις ίδιας _________ εκτελούνται από τα αριστερά προς
    τα δεξιά.
5. Αν Α[5, 8] πίνακας λογικού τύπου, τότε τα κλειδιά του έχουν
   την τιμή _______ ή __________.
6. Δύο ________ Για..από..μέχρι δεν μπορούν να μοιράζονται
    τον ίδιο μετρητή.


Απάντηση

1. αλφαριθμητικές
2. απλής
3. περατότητας
4. προτεραιότητας
5. Αληθής, Ψευδής
6. εμφωλευμένες

Τετάρτη, 6 Οκτωβρίου 2010

Άσκηση : Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει τις μάρκες, τα μοντέλα και
τις ποσότητες ακτινοβολίας που εκπέμπουν 128 κινητά
τηλέφωνα και υπολογίζει:
α) τη μάρκα και το μοντέλο του κινητού που εκπέμπει
     τη μεγαλύτερη ακτινοβολία,
β) τη μέση ποσότητα εκπεμπόμενης ακτινοβολίας.

Λύση

     Αλγόριθμος ΚΙΝΗΤΑ
     ΜΑΧ <-- -999
     σ <-- 0
     Για λ από 1 μέχρι 128
          Διάβασε Μάρκα, Μοντέλο
          Διάβασε Ακτιν
          σ <-- σ+Ακτιν
          Αν Ακτιν > ΜΑΧ τότε
                ΜΑΧ <-- Ακτιν
                ΜαρκΜΑΧ <-- Μάρκα
                ΜοντΜΑΧ <-- Μοντέλο
          Τέλος_αν
     Τέλος_επανάληψης
     ΜΟ <-- σ/128
     Εμφάνισε  ΜαρκΜΑΧ, ΜοντΜΑΧ, ΜΟ
     Τέλος ΚΙΝΗΤΑ

Τρίτη, 5 Οκτωβρίου 2010

Εξεταστέα ύλη για τη σχολική περίοδο 2010-2011

Η εξεταστέα ύλη του μαθήματος "Ανάπτυξη εφαρμογών σε
προγραμματιστικό περιβάλλον" για τη σχολική περίοδο
2010-2011 είναι η ακόλουθη:

Κεφάλαιο 1
    Παράγραφοι:  1.1, 1.2, 1.3, 1.4, 1.5, 1.6
Κεφάλαιο 2
    Παράγραφοι: 2.1, 2.3, 2.4 (2.4.1, 2.4.2, 2.4.3, 2.4.4, 2.4.5)
    Παρατήρηση  
        Στην παράγραφο 2.4.3 αφαιρείται:
        Ι. η τελευταία πρόταση της σελ. 36 "Αν οι διαφορετικές
           επιλογές .. στο παράδειγμα που ακολουθεί"
       ΙΙ. το Παράδειγμα 5 (Επιλογή ορίων), σελ. 37
Κεφάλαιο 3
     Παράγραφοι : 3.1, 3.2, 3.3, 3.4, 3.5, 3.6, 3.7
Κεφάλαιο 6
     Παράγραφοι : 6.1, 6.2 (6.2.1, 6.2.2, 6.2.3, 6.2.4), 6.3,
                            6.4 (6.4.1, 6.4.2, 6.4.3), 6.7
Κεφάλαιο 7
     Παράγραφοι :7.1, 7.2, 7.3, 7.4, 7.5, 7.6, 7.7, 7.8, 7.9, 7.10
Κεφάλαιο 8
     Παράγραφοι : 8.1 (8.1.1), 8.2 (8.2.1, 8.2.2, 8.2.3)
Κεφάλαιο 9
     Παράγραφοι : 9.1, 9.2, 9.3, 9.4
Κεφάλαιο 10
     Παράγραφοι : 10.1, 10.2, 10.3, 10.4,
                            10.5 (10.5.1, 10.5.2, 10.5.3)

* Οι ενότητες 3.4 και 3.5 εξετάζονται μόνο ως θεωρία.
* Οι μαθητές θα μπορούν  να διατυπώνουν τις λύσεις των
   ασκήσεων των εξετάσεων είτε σε οποιαδήποτε μορφή
   παράστασης αλγορίθμου είτε σε "ΓΛΩΣΣΑ", όπως αυτή
   ορίζεται και χρησιμοποιείται στο διδακτικό εγχειρίδιο.

Είναι ισοδύναμα;

Δίνονται τα παρακάτω τμήματα εντολών

    Τμήμα Α

           ζ <-- 121
           Για λ από 4 μέχρι 28 με_βήμα 7
                  ζ <-- ζ-20
           Τέλος_επανάληψης
           Εμφάνισε ζ, λ
 

    Τμήμα  Β

           ζ <-- 21
           Για λ από 52 μέχρι 42 με_βήμα -10
                ζ <-- ζ+10
           Τέλος_επανάληψης
           Εμφάνισε ζ, λ
 
 
  Είναι τα τμήματα αυτά ισοδύναμα μεταξύ τους;

Λύση

     Τμήμα Α

           ζ = 121
           Η Για..από..μέχρι  εκτελείται 4 φορές και ολοκληρώνεται
           με λ = 32.
           Κατά συνέπεια η τιμή 20 αφαιρείται από το ζ 4 φορές και
           έτσι έχουμε τελικά:
                ζ = 121-4*20 = 121-80 = 41
          Η Εμφάνισε τυπώνει:
                 41     32

      Τμήμα Β

           ζ = 21
           Η Για..από..μέχρι  εκτελείται 2 φορές και ολοκληρώνεται
           με λ = 32.
           Κατά συνέπεια η τιμή 10 προστίθεται στο ζ 2 φορές και
           έτσι έχουμε τελικά:
                ζ = 21+2*10 = 21+20 = 41
            Η Εμφάνισε τυπώνει:               
                   41     32

    Συμπέρασμα : Αφού οι τελικές τιμές των μεταβλητών και
                           η έξοδος των αποτελεσμάτων συμπίπτουν,
                           τα τμήματα είναι ισοδύναμα μεταξύ τους.

Απλοποίηση

Απλοποιήστε το παρακάτω σύνολο εντολών
     Διάβασε α
     Αν (α > 0) Ή (α < 0) τότε
            β <-- ΑΛΗΘΗΣ ΚΑΙ (α < 100)
     αλλιώς
           β <-- (α = 0)
     Τέλος_αν
     Εμφάνισε β

Λύση

     Διάβασε α
     Αν α < > 0 τότε
            β <-- α < 100
     αλλιώς
           β <-- Αληθής
     Τέλος_αν
     Εμφάνισε β

Δευτέρα, 4 Οκτωβρίου 2010

Άσκηση : Κλιμακωτός και μη κλιμακωτός υπολογισμός

Σε ένα μαγαζί η τιμή πώλησης των Τ-SHIRT  αποτυπώνεται
στον πίνακα που ακολουθεί:
       Πλήθος τεμαχίων                    Τιμή ενός Τ-SHIRT
         Από 1 έως και 5                               11 ευρώ
         Από 6 έως και 9                                 9 ευρώ
         Από 10 και πάνω                              7,5 ευρώ
Γράψτε αλγόριθμο που διαβάζει το πλήθος των τεμαχίων
που θέλει να αγοράσει ένας πελάτης, υπολογίζει και
εμφανίζει το συνολικό κόστος της αγοράς του.

Λύση

Επειδή δεν διευκρινίζεται από την εκφώνηση αν η χρέωση
γίνεται με κλιμακωτό ή μη κλιμακωτό τρόπο, πρέπει να
διακρίνουμε δύο περιπτώσεις και να διατυπώσουμε μια λύση
για κάθε περίπτωση.

Μη κλιμακωτός υπολογισμός
  
     Αλγόριθμος Μπλουζάκια
     Διάβασε Πληθ
     Αν Πληθ <= 5 τότε
          Κόστος <-- Πληθ*11
     αλλιώς_αν Πληθ <= 9 τότε
          Κόστος <-- Πληθ*9
     αλλιώς
          Κόστος <-- Πληθ*7.5
     Τέλος_αν
     Εμφάνισε Κόστος
     Τέλος  Μπλουζάκια

Κλιμακωτός υπολογισμός
  
     Αλγόριθμος Μπλουζάκια
     Διάβασε Πληθ
     Αν Πληθ <= 5 τότε
          Κόστος <-- Πληθ*11
     αλλιώς_αν Πληθ <= 9 τότε
          Κόστος <-- 5*11+(Πληθ-5)*9
     αλλιώς
          Κόστος <-- 5*11+4*9+(Πληθ-9)*7.5
     Τέλος_αν
     Εμφάνισε Κόστος
     Τέλος  Μπλουζάκια


 

Κυριακή, 3 Οκτωβρίου 2010

Άσκηση : Βήμα-βήμα εκτέλεση εντολών (Αν..τότε..αλλιώς)

Τι θα εμφανίσει το παρακάτω τμήμα εντολών στην οθόνη;
     Χ <-- 12
     Υ <-- 3*Χ MOD 15+1
     ΑΝ Υ > 3 ΤΟΤΕ
         Ζ <-- (Υ-4)^2
     ΑΛΛΙΩΣ
         Ζ <-- 5*Υ+19
     ΤΕΛΟΣ_ΑΝ
     Μ <-- (Ζ DIV 2 = 1) KAI (Z > 1)
     ΓΡΑΨΕ Χ+Υ < > 14, '3*Χ+Υ^2', Μ, (10*Υ) DIV X

Λύση

     Χ = 12
     Υ = 3*Χ MOD 15+1 = 3*12 MOD 15+1 =
            36 MOD 15+1 = 6+1 = 7
     Αφού Υ > 3 = 7 > 3 = ΑΛΗΘΗΣ έχουμε:
          Ζ = (Υ-4)^2 = (7-4)^2 = 3^2 = 9
     M = (Ζ DIV 2 = 1) KAI (Z > 1) = (9 DIV 2 = 1) KAI (9 > 1) =
             (4 = 1) ΚΑΙ (9 > 1) = ΨΕΥΔΗΣ ΚΑΙ ΑΛΗΘΗΣ =
             ΨΕΥΔΗΣ
     Αφού (Χ+Υ < > 14) = (12+7 < > 14) = (19 < > 14) =
     ΑΛΗΘΗΣ και (10*Υ) DIV X = (10*7) DIV 12 =
     70 DIV 12 = 5, η ΓΡΑΨΕ εμφανίζει:
           ΑΛΗΘΗΣ   3*Χ+Υ^2   ΨΕΥΔΗΣ   5
   

Πίνακας αντιστοίχησης

Θεωρήστε δύο ακέραιες μεταβλητές Ν, Μ τέτοιες ώστε
το Μ να είναι πολλαπλάσιο του Ν και Ν < Μ.
Δίνονται ακόμη οι ακόλουθες αριθμητικές παραστάσεις
    1. Ν mod M
    2. N div M
    3. M mod N
    4. (2*Μ+7) mod 2
    5. (2*N+2) div 2
και οι παρακάτω ακέραιες τιμές:
    α. 1
    β. Ν
    γ. Μ
    δ. 0
    ε. 7
    στ. Ν+1
Γράψτε τον αριθμό της παράστασης (1-5) και δίπλα το
γράμμα (α-στ) του αποτελέσματός της.

Απάντηση

    1. β
    2. δ
    3. δ
    4. α
    5. στ

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση

1. Η δομή πολλαπλής επιλογής Αν..τότε..αλλιώς_αν
    α. χρησιμοποιείται σπάνια
    β. χρησιμοποιείται όταν υπάρχει ένα μόνο ενδεχόμενο
    γ. μπορεί να αντικατασταθεί από εμφωλευμένες
        Αν..τότε..αλλιώς που να επιφέρουν το ίδιο
        αλγοριθμικό αποτέλεσμα
    δ. μπορεί να αντικατασταθεί από μια ακολουθιακή
        δομή που να επιφέρει το ίδιο αλγοριθμικό
        αποτέλεσμα.

2. Η Αν..τότε είναι δομή
    α. απλής επιλογής
    β. σύνθετης επιλογής
    γ. πολλαπλής επιλογής
    δ. εμφωλευμένης επιλογής

3. Οι συμβολικές σταθερές
    α. είναι ονόματα που αντιπροσωπεύουν σταθερές
        ποσότητες
    β. είναι υποχρεωτικές σε κάθε πρόγραμμα
    γ. είναι υποχρεωτικές σε κάθε αλγόριθμο
    δ. είναι δύσχρηστες και δημιουργούν μεγάλα προ-
        βλήματα στον προγραμματισμό

4. Αν Α, Β λογικές μεταβλητές ισχύει η σχέση
    α. ΟΧΙ Ή Β) = ΟΧΙ Α Ή ΟΧΙ Β
    β. ΟΧΙ ΚΑΙ Β) = ΟΧΙ Α Ή ΟΧΙ Β
    γ. ΟΧΙ ΚΑΙ Β) = ΟΧΙ Α ΚΑΙ ΟΧΙ Β
    δ. ΟΧΙ Ή Β) = ΟΧΙ(ΟΧΙ Α ΚΑΙ ΟΧΙ Β)

5. Αν η αρχική και η τελική τιμή ενός προϊόντος που
    αγοράσατε με δόσεις ήταν Αρχ και Τελ αντίστοιχα
    (θεωρείστε ότι Αρχ < Τελ), για να υπολογίσετε το
    ποσοστό ΠΟΣ με το οποίο επιβαρυνθήκατε επί της
    αρχικής τιμής, πρέπει να κάνετε την ακόλουθη
    εντολή εκχώρησης
    α. ΠΟΣ <-- 100*(Τελ-Αρχ)/Τελ
    β. ΠΟΣ <-- 100*Αρχ/(Τελ-Αρχ)
    γ. ΠΟΣ <-- 100*Τελ/(Τελ-Αρχ)
    δ. ΠΟΣ <-- 100*(Τελ-Αρχ)/Αρχ

Απάντηση

    1. γ
    2. α
    3. α
    4. β
    5. δ

Σάββατο, 2 Οκτωβρίου 2010

Υπολογισμός αριθμητικών παραστάσεων

Αν Χ = 10, Υ = -7, Ζ = 1.2, να υπολογίσετε (βήμα-βήμα)
τις τιμές των ακόλουθων αριθμητικών παραστάσεων
1. (Χ+Υ)^2 div 2
2. Ζ+4*Χ mod 100
3. ( (4-Y) div 12)*X
4. Z-Y*X+X div (-Y)

Λύση

    1. (Χ+Υ)^2 div 2 = (10-7)^2 div 2 = 3^2 div 2 =
        9 div 2 = 4
    2. Ζ+4*Χ mod 100 = 1.2+4*10 mod 100 =
        1.2+40 mod 100 =1.2+40 = 41.2
    3. ( (4-Y) div 12)*X = ( (4+7) div 12)*10 =
        (11 div 12)*10 = 0*10 = 0
    4. Z-Y*X+X div (-Y) = 1.2-(-7)*10+10 div 7 =
        1.2+70+10 div 7 = 1.2+70+1 = 71.2+1 =
        72.2

Ερωτήσεις σωστού-λάθους (κεφάλαια 2, 7)

Ποιές από τις παρακάτω προτάσεις είναι σωστές και ποιές
λάθος;
1. Ένας αλγόριθμος μπορεί να έχει και βοηθητικές μεταβλητές.
2. Σ' έναν αλγόριθμο πρέπει υποχρεωτικά να δηλώνουμε τον
    τύπο της κάθε μεταβλητής.
3. Η πράξη 14.2 div 2 δίνει ως αποτέλεσμα την τιμή 7.1
4. Ο τελεστής / δίνει πάντοτε αποτέλεσμα πραγματικού
    τύπου.
5. Μια μεταβλητή ακεραίου τύπου καταλαμβάνει 2 bytes
    στην κύρια μνήμη του υπολογιστή.
6. Η λογική πράξη Α ΚΑΙ Β δίνει αποτέλεσμα Ψευδής μόνο
    όταν τόσο το Α όσο και το Β έχουν την τιμή Ψευδής.
7. Η λογική πράξη Α Ή Β δίνει αποτέλεσμα Αληθής μόνο
    όταν τόσο το Α όσο και το Β έχουν την τιμή Αληθής.
8. Η συνάρτηση της ΓΛΩΣΣΑΣ Ε υπολογίζει την εφαπτομένη
    μιας γωνίας.
9. Ο λογικός τύπος δεδομένων περιλαμβάνει τις τιμές ΑΛΗΘΗΣ
    και ΨΕΥΔΗΣ.
10. Η δομή επιλογής είναι μια ομάδα εντολών που εκτελούνται
      ακριβώς μια φορά, σύμφωνα με τη σειρά που τις έχουμε
      γράψει.
11. Οι εντολές που περιέχονται μέσα σε μια δομή απλής επιλογής
      εκτελούνται 0 ή 1 φορές.
12. Η ομάδα εντολών μιας Αν..τότε μπορεί να περιλαμβάνει μια
      εντολή Επίλεξε.
13. Ισχύει ότι ΑΛΗΘΗΣ <= ΨΕΥΔΗΣ = ΑΛΗΘΗΣ
14. Ισχύει ότι 'ΒΕΛΟΣ' > 'ΓΕΩΡΓΟΣ' = ΨΕΥΔΗΣ
15. Το περιεχόμενο μιας μεταβλητής μπορεί να αλλάξει με μια
       εντολή εκχώρησης ή μια εντολή ΓΡΑΨΕ.
16. Δε γνωρίζουμε ποιά είναι η τελευταία εντολή ενός αλγορίθμου
      ή ενός προγράμματος.
17. Η λέξη ΑΚΕΡΑΙΟΣ είναι δεσμευμένη λέξη της ΓΛΩΣΣΑΣ.


Απάντηση

1. Σ
2. Λ
3. Λ
4. Σ
5. Σ
6. Λ
7. Λ
8. Λ
9. Σ
10. Λ
11. Σ
12. Σ
13. Λ
14. Σ
15. Λ
16. Σ
17. Λ

Συμπλήρωση σταυρόλεξου (Υποπρογράμματα)














































Λύση

Συμπλήρωση σταυρόλεξου (Κεφάλαιο 6)







































































Λύση


Συμπλήρωση σταυρόλεξου (Πίνακες)







































































Λύση

Συμπλήρωση σταυρόλεξου (Κεφάλαια 2, 7, 8)














































Λύση

Παρασκευή, 1 Οκτωβρίου 2010

Συμπλήρωση σταυρόλεξου (Κεφάλαιο 1)




  Λύση




Καταγράψτε τα επιμέρους στοιχεία ενός προγράμματος

Δίνεται το παρακάτω πρόγραμμα
    ΠΡΟΓΡΑΜΜΑ ΑΣΚ
    ΣΤΑΘΕΡΕΣ
        Λ = 'ΓΥΜΝΑΣΙΟ'
        Μ = 23.2
    ΜΕΤΑΒΛΗΤΕΣ
        ΑΚΕΡΑΙΕΣ: Χ
        ΠΡΑΓΜΑΤΙΚΕΣ: Υ
    ΑΡΧΗ
         ΔΙΑΒΑΣΕ Χ
         ΑΝ Χ <= 0 ΤΟΤΕ
               Υ <-- Χ+Μ+1.99
         ΑΛΛΙΩΣ
               Υ <-- Μ-Χ+2.33

         ΤΕΛΟΣ_ΑΝ
         ΓΡΑΨΕ Υ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Καταγράψτε τις:
α) σταθερές
β) συμβολικές σταθερές
γ) μεταβλητές
δ) εντολές εισόδου
ε) εντολές εξόδου
στ) συγκριτικούς τελεστές
ζ) αριθμητικούς τελεστές
η) λογικούς τελεστές
ι) λογικές εκφράσεις (συνθήκες)

Απάντηση

α) 'ΓΥΜΝΑΣΙΟ', 23.2, 0, 1.99, 2.33
β)  Λ, Μ
γ)  Χ, Υ
δ) ΔΙΑΒΑΣΕ Χ
ε) ΓΡΑΨΕ Υ
στ) <=
ζ) +, +, -, +
η) δεν υπάρχουν
ι)  Χ <= 0

Άσκηση με GOTO

Ξαναγράψτε το παρακάτω σύνολο εντολών έτσι ώστε να
ικανοποιεί τις αρχές του δομημένου προγραμματισμού
      ΔΙΑΒΑΣΕ Λ
      ΑΝ Λ > 0 ΤΟΤΕ GOTO 10
      Λ <-- -Λ
10:  α <-- 1
       κ <-- 1
20:  ΑΝ κ > Λ ΤΟΤΕ GOTO 30
       α <-- α*(κ+1)
       κ <-- κ+1
       GOTO 20
30:  ΓΡΑΨΕ α


Λύση

      ΔΙΑΒΑΣΕ Λ
      ΑΝ Λ <= 0 ΤΟΤΕ
           Λ <-- -Λ
      ΤΕΛΟΣ_ΑΝ 
      α <-- 1
      κ <-- 1
      ΟΣΟ κ <= Λ ΕΠΑΝΑΛΑΒΕ
           α <-- α*(κ+1)
           κ <-- κ+1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ α