Πέμπτη, 14 Οκτωβρίου 2010

Μετατροπές

Δίνεται το παρακάτω σύνολο εντολών
    Διάβασε Χ
    Όσο Χ <= 0 επανάλαβε
         Διάβασε Χ
    Τέλος_επανάληψης
    σ <-- 0
    Για λ από 1 μέχρι Χ
         Αν λ mod 4 = 0 τότε
              σ <-- σ+λ-1
         αλλιώς
              σ <-- σ-λ+2
         Τέλος_αν
    Τέλος_επανάληψης
Ξαναγράψτε το με ισοδύναμο τρόπο αντικαθιστώντας
α) την Όσο..επανάλαβε με Μέχρις_ότου
β) την Για..από..μέχρι με  Όσο..επανάλαβε
γ)  την Αν..τότε..αλλιώς με Αν..τότε 

Λύση

    Αρχή_επανάληψης
         Διάβασε Χ
    Τέλος_επανάληψης
    σ <-- 0
    λ <-- 1
   Όσο λ <= Χ επανάλαβε
         Αν λ mod 4 = 0 τότε
              σ <-- σ+λ-1
         Τέλος_αν
         Αν  λ mod 4 < >  0 τότε
              σ <-- σ-λ+2
         Τέλος_αν
         λ <-- λ+1
    Τέλος_επανάληψης

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου