Τρίτη, 5 Οκτωβρίου 2010

Είναι ισοδύναμα;

Δίνονται τα παρακάτω τμήματα εντολών

    Τμήμα Α

           ζ <-- 121
           Για λ από 4 μέχρι 28 με_βήμα 7
                  ζ <-- ζ-20
           Τέλος_επανάληψης
           Εμφάνισε ζ, λ
 

    Τμήμα  Β

           ζ <-- 21
           Για λ από 52 μέχρι 42 με_βήμα -10
                ζ <-- ζ+10
           Τέλος_επανάληψης
           Εμφάνισε ζ, λ
 
 
  Είναι τα τμήματα αυτά ισοδύναμα μεταξύ τους;

Λύση

     Τμήμα Α

           ζ = 121
           Η Για..από..μέχρι  εκτελείται 4 φορές και ολοκληρώνεται
           με λ = 32.
           Κατά συνέπεια η τιμή 20 αφαιρείται από το ζ 4 φορές και
           έτσι έχουμε τελικά:
                ζ = 121-4*20 = 121-80 = 41
          Η Εμφάνισε τυπώνει:
                 41     32

      Τμήμα Β

           ζ = 21
           Η Για..από..μέχρι  εκτελείται 2 φορές και ολοκληρώνεται
           με λ = 32.
           Κατά συνέπεια η τιμή 10 προστίθεται στο ζ 2 φορές και
           έτσι έχουμε τελικά:
                ζ = 21+2*10 = 21+20 = 41
            Η Εμφάνισε τυπώνει:               
                   41     32

    Συμπέρασμα : Αφού οι τελικές τιμές των μεταβλητών και
                           η έξοδος των αποτελεσμάτων συμπίπτουν,
                           τα τμήματα είναι ισοδύναμα μεταξύ τους.

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου