Σάββατο, 9 Οκτωβρίου 2010

Άσκηση : Φρουρός

Γράψτε πρόγραμμα το οποίο διαβάζει τους τίτλους
των μαθημάτων που παρακολουθεί ένας μαθητής
της Γ' τάξης και το σύνολο των διδακτικών ωρών
του κάθε μαθήματος κατά τη διάρκεια της εβδομάδας
(η είσοδος δεδομένων ολοκληρώνεται μόλις δοθεί ως τίτλος
μαθήματος το κενό διάστημα), υπολογίζει και εμφανίζει:
α) το πλήθος των μαθημάτων που παρακολουθεί ο μαθητής,
β) τον τίτλο του μαθήματος που έχει το μεγαλύτερο σύνολο
    διδακτικών ωρών,
γ) το ποσοστό (%) των μαθημάτων που είναι μονόωρα.

Λύση

       ΠΡΟΓΡΑΜΜΑ ΜΑΘΗΤΗΣ
       ΜΕΤΑΒΛΗΤΕΣ
              ΑΚΕΡΑΙΕΣ: Πληθ, Μονο, Ωρες, Μεγ
              ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ
              ΧΑΡΑΚΤΗΡΕΣ: Τ, ΤΜεγ
       ΑΡΧΗ
              Πληθ <-- 0
              Μονο <-- 0
              Mεγ  <-- -1000
              ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                    ΔΙΑΒΑΣΕ Τ
                    ΑΝ Τ < > '  ' ΤΟΤΕ
                         ΔΙΑΒΑΣΕ Ωρες
                         Πληθ <-- Πληθ+1
                         ΑΝ Ωρες > Μεγ ΤΟΤΕ
                               Μεγ <-- Ωρες
                               ΤΜεγ <-- Τ
                         ΤΕΛΟΣ_ΑΝ
                         ΑΝ Ωρες = 1 ΤΟΤΕ
                               Μονο <-- Μονο+1
                         ΤΕΛΟΣ_ΑΝ
                    ΤΕΛΟΣ_ΑΝ
              ΜΕΧΡΙΣ_ΟΤΟΥ  Τ = '  '
              ΑΝ Πληθ > 0 ΤΟΤΕ
                    ΠΟΣ <-- 100*Μονο/Πληθ
                    ΓΡΑΨΕ Πληθ, ΤΜεγ, ΠΟΣ
              ΑΛΛΙΩΣ
                    ΓΡΑΨΕ 'Δε δόθηκαν δεδομένα!'
              ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου