Τετάρτη, 6 Οκτωβρίου 2010

Άσκηση : Επεξεργασία δοσμένου πλήθους δεδομένων

Γράψτε αλγόριθμο που διαβάζει τις μάρκες, τα μοντέλα και
τις ποσότητες ακτινοβολίας που εκπέμπουν 128 κινητά
τηλέφωνα και υπολογίζει:
α) τη μάρκα και το μοντέλο του κινητού που εκπέμπει
     τη μεγαλύτερη ακτινοβολία,
β) τη μέση ποσότητα εκπεμπόμενης ακτινοβολίας.

Λύση

     Αλγόριθμος ΚΙΝΗΤΑ
     ΜΑΧ <-- -999
     σ <-- 0
     Για λ από 1 μέχρι 128
          Διάβασε Μάρκα, Μοντέλο
          Διάβασε Ακτιν
          σ <-- σ+Ακτιν
          Αν Ακτιν > ΜΑΧ τότε
                ΜΑΧ <-- Ακτιν
                ΜαρκΜΑΧ <-- Μάρκα
                ΜοντΜΑΧ <-- Μοντέλο
          Τέλος_αν
     Τέλος_επανάληψης
     ΜΟ <-- σ/128
     Εμφάνισε  ΜαρκΜΑΧ, ΜοντΜΑΧ, ΜΟ
     Τέλος ΚΙΝΗΤΑ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου