Πέμπτη, 14 Οκτωβρίου 2010

Ποιά είναι η τελική τιμή;

Ποιά είναι η τελική τιμή της μεταβλητής μ μετά την
εκτέλεση των παρακάτω εντολών
   μ <-- 0
   Για λ από 1 μέχρι 120
        μ <-- μ+3
        Για ν από 4 μέχρι 8
             μ <-- μ+1
        Τέλος_επανάληψης
   Τέλος_επανάληψης

Λύση

     Η εντολή μ <-- μ+3 εκτελείται 120 φορές ενώ η εντολή
     μ <-- μ+1 εκτελείται 120Χ5 = 600 φορές. Κατά συνέπεια:
        μ = 0+120*3+600*1 = 360+600 = 960

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου