Πέμπτη, 21 Οκτωβρίου 2010

Άσκηση : Απάντηση σε ερώτηση

Γράψτε πρόγραμμα που διαβάζει τους τίτλους κάποιων ταινιών,
το ονοματεπώνυμο του σκηνοθέτη τους, το ονοματεπώνυμο
του πρωταγωνιστή τους και το σύνολο των εισιτηρίων που
πουλήθηκαν για αυτές στους ελληνικούς κινηματογράφους
(η είσοδος τερματίζεται μόλις δοθεί η απάντηση 'ΟΧΙ' στην
ερώτηση 'Υπάρχει άλλη ταινία;'), υπολογίζει και εμφανίζει:
α) τον τίτλο της δημοφιλέστερης ταινίας, το ονοματεπώνυμο
     του σκηνοθέτη της και το ονοματεπώνυμο του πρωταγωνιστή
     της,
β) το ποσοστό (%) των ταινιών που είχαν περισσότερα από
     100000 εισιτήρια,


Λύση


     ΠΡΟΓΡΑΜΜΑ ΤΑΙΝΙΕΣ
     ΜΕΤΑΒΛΗΤΕΣ
            ΧΑΡΑΚΤΗΡΕΣ: Τ, Σκ, Πρ, ΣκΜΑΧ, ΠρΜΑΧ,
                                        ΤΜΑΧ, Απ
            ΑΚΕΡΑΙΕΣ: ΕΙΣ, ΜΑΧ, Πληθ, Φ
            ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣ
     ΑΡΧΗ
            Πληθ <-- 0
            Φ <-- 0
            ΜΑΧ <-- -1
            ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                   ΔΙΑΒΑΣΕ Τ, Σκ, Πρ
                   ΔΙΑΒΑΣΕ ΕΙΣ
                   Πληθ <-- Πληθ+1
                   ΑΝ ΕΙΣ > ΜΑΧ ΤΟΤΕ
                          ΜΑΧ <-- ΕΙΣ
                          ΤΜΑΧ <-- Τ
                          ΣκΜΑΧ <-- Σκ
                          ΠρΜΑΧ <-- Πρ
                   ΤΕΛΟΣ_ΑΝ
                   ΑΝ ΕΙΣ > 100000 ΤΟΤΕ
                          Φ <-- Φ+1
                   ΤΕΛΟΣ_ΑΝ
                   ΓΡΑΨΕ 'Υπάρχει άλλη ταινία;'
                   ΔΙΑΒΑΣΕ Απ
            ΜΕΧΡΙΣ_ΟΤΟΥ Απ = 'ΟΧΙ'
            ΠΟΣ <-- 100*Φ/Πληθ
            ΓΡΑΨΕ ΤΜΑΧ, ΣκΜΑΧ, ΠρΜΑΧ
            ΓΡΑΨΕ ΠΟΣ
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου