Τετάρτη, 20 Οκτωβρίου 2010

΄Ασκηση : Αναγωγή στη μονάδα +Πορτοφόλι

Γράψτε αλγόριθμο που :
α) διαβάζει τις τιμές πώλησης και το βάρος(σε κιλά)
    25 διαφορετικών συσκευασιών απορρυπαντικού,
β) υπολογίζει και εμφανίζει:
     * τον αύξοντα αριθμό (1-25) και την τιμή πώλησης
        της πιο συμφέρουσας συσκευασίας,
     * πόσες από τις προηγούμενες συσκευασίες μπορείτε
        να προμηθευτείτε με 132 ευρώ.

Λύση

     Αλγόριθμος Απορ
     Διάβασε Τιμή
     Διάβασε Βάρος
     ΜΙΝ <--  Τιμή/Βάρος
     ΤιμΜΙΝ <-- Τιμή
     ΑΑΜΙΝ <-- 1
     Για λ από 2 μέχρι 25
           Διάβασε Τιμή
           Διάβασε Βάρος
           ΤιμΚΙΛΟΥ <-- Τιμή/Βάρος
           Αν ΤιμΚΙΛΟΥ < ΜΙΝ τότε
                ΜΙΝ <-- ΤιμΚΙΛΟΥ
                ΑΑΜΙΝ <-- λ
                ΤιμΜΙΝ <-- Τιμή
           Τέλος_αν
     Τέλος_επανάληψης
     Πληθ <-- 0
     Ποσό <-- 132
     Όσο Ποσό >= ΤιμΜΙΝ επανάλαβε
            Ποσό <-- Ποσό-ΤιμΜΙΝ
            Πληθ <-- Πληθ+1
     Τέλος_επανάληψης
     Εμφάνισε ΑΑΜΙΝ, ΤιμΜΙΝ
     Εμφάνισε Πληθ
     Τέλος Απορ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου