Παρασκευή, 8 Οκτωβρίου 2010

Ποιά είναι η τελική τιμή της μεταβλητής

Μετά την εκτέλεση των παρακάτω εντολών, ποιά είναι η
τελική τιμή της μεταβλητής α.
     α <-- 0
     Για λ από 11 μέχρι 99 με_βήμα 9
          κ <-- 10
          Όσο κ > 0 επανάλαβε
               μ <-- 5
               Αρχή_επανάληψης
                    α <-- α+10
                    μ <-- μ+4
               Μέχρις_ότου μ > 13
               κ <-- κ-5
          Τέλος_επανάληψης
     Τέλος_επανάληψης

Απάντηση

Η Για..από..μέχρι εκτελείται 10 φορές, η Όσο..επανάλαβε
2 φορές και η Μέχρις_ότου 3 φορές. Κατά συνέπεια η
εντολή α <-- α+10 εκτελείται 10Χ2Χ3 = 60 φορές και έτσι
     α = 0+60*10 = 600.

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου