Τρίτη, 19 Οκτωβρίου 2010

Επεξεργασία δοσμένου πλήθους δεδομών

Γράψτε αλγόριθμο που διαβάζει τους νομούς καταγωγής
και την ηλικία 10000 ελλήνων φοιτητών  και υπολογίζει:
α) το ποσοστό (%) των φοιτητών που κατάγονται
     από το νομό ΗΡΑΚΛΕΙΟΥ,
β) το μέσο όρο ηλικίας των φοιτητών που κατάγονται
     από το νομό ΧΑΝΙΩΝ.

Λύση

       Αλγόριθμος Φοιτητές
       Ηρ <-- 0
       Χ <-- 0
       σ <-- 0
       Για λ από 1 μέχρι 10000
            Διάβασε Νομός, Ηλικία
            Αν Νομός = 'ΗΡΑΚΛΕΙΟΥ' τότε
                 Ηρ <-- Ηρ+1
            αλλιώς
                   Αν Νομός = 'ΧΑΝΙΩΝ' τότε               
                       Χ <-- Χ+1
                       σ <-- σ+Ηλικία
                   Τέλος_αν
            Τέλος_αν
       Τέλος_επανάληψης
       ΠΟΣ <-- 100*Ηρ/10000
       Εμφάνισε ΠΟΣ
       Αν Χ > 0 τότε
             ΜΟΧ <-- σ/Χ
             Εμφάνισε ΜΟΧ
       αλλιώς
             Εμφάνισε 'Δεν υπάρχουν φοιτητές από τα Χανιά'
       Τέλος_αν
       Τέλος Φοιτητές

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου