Δευτέρα, 11 Οκτωβρίου 2010

Άσκηση σε δυσδιάστατο πίνακα (μέσοι όροι και ελάχιστα ανά γραμμή)

Σε ένα κέντρο εκπαίδευσης νεοσυλλέκτων υπάρχουν 4
διμοιρίες που η καθεμιά της έχει δύναμη 65 ανδρών.
Γράψτε αλγόριθμο που :
α) δέχεται ως είσοδο την ηλικία των ανδρών και
    καταχωρεί τα δεδομένα αυτά στον πίνακα
    Η[4, 65],
β) υπολογίζει και εμφανίζει, για κάθε διμοιρία:
    * το μέσο όρο ηλικίας των ανδρών της,
    * τη μικρότερη ηλικία και τον αύξοντα αριθμό
       (1-65) του άνδρα που την έχει.

Λύση

      Αλγόριθμος Φαντάροι

      Για λ από 1 μέχρι 4
           Για μ από 1 μέχρι 65
                 Διάβασε Η[λ, μ]
           Τέλος_επανάληψης
      Τέλος_επανάληψης
      Για λ από 1 μέχρι 4
           Μικρ <-- Η[λ, 1]
           ΑΑ <-- 1
           σ <-- 0
           Για μ από 1 μέχρι 65
                 Αν Η[λ, μ] < Μικρ τότε
                       Μικρ <-- Η[λ, μ]
                       ΑΑ <-- μ
                 Τέλος_αν
                 σ <-- σ+Η[λ, μ]
           Τέλος_επανάληψης
           ΜΟ <-- σ/65
           Εμφάνισε ΜΟ, Μικρ, ΑΑ
      Τέλος_επανάληψης
      Τέλος Φαντάροι

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου