Κυριακή, 10 Οκτωβρίου 2010

Άσκηση : Ποιό είναι το περιεχόμενο του πίνακα

Δίνονται οι παρακάτω εντολές
     β <-- 10
     Για λ από 1 μέχρι 5
          Για μ από 1 μέχρι 5
                 Χ[λ, μ] <-- β
                 β <-- -β
          Τέλος_επανάληψης
     Τέλος_επανάληψης
Ποιό είναι το περιεχόμενο του πίνακα Χ[5, 5] μετά
την εκτέλεση των παραπάνω εντολών;

Λύση

Ο πίνακας Χ γεμίζει (γραμμή-γραμμή)  με τις τιμές
10 και -10 εναλλάξ. Πράγματι αν β = 10, τότε η εντολή
β <-- -β αποδίδει στο β την τιμή -10. Αν τώρα β = -10,
η εντολή β <-- -β αποδίδει στο β την τιμή -(-10) = 10.
Κατά συνέπεια ο πίνακας Χ έχει το ακόλουθο περιεχόμενο:
        10       -10         10        -10       10
       -10        10        -10         10       -10
        10        -10        10         -10       10
       -10        10        -10         10       -10
        10        -10        10         -10       10
     

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου