Παρασκευή, 1 Οκτωβρίου 2010

Άσκηση με GOTO

Ξαναγράψτε το παρακάτω σύνολο εντολών έτσι ώστε να
ικανοποιεί τις αρχές του δομημένου προγραμματισμού
      ΔΙΑΒΑΣΕ Λ
      ΑΝ Λ > 0 ΤΟΤΕ GOTO 10
      Λ <-- -Λ
10:  α <-- 1
       κ <-- 1
20:  ΑΝ κ > Λ ΤΟΤΕ GOTO 30
       α <-- α*(κ+1)
       κ <-- κ+1
       GOTO 20
30:  ΓΡΑΨΕ α


Λύση

      ΔΙΑΒΑΣΕ Λ
      ΑΝ Λ <= 0 ΤΟΤΕ
           Λ <-- -Λ
      ΤΕΛΟΣ_ΑΝ 
      α <-- 1
      κ <-- 1
      ΟΣΟ κ <= Λ ΕΠΑΝΑΛΑΒΕ
           α <-- α*(κ+1)
           κ <-- κ+1
      ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΓΡΑΨΕ α

       

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου