Τετάρτη, 27 Οκτωβρίου 2010

Άσκηση : Κουμπαράς

Θέλετε να αγοράσετε ένα ποδήλατο αξίας 320 ευρώ. Οι γονείς σας
σας δίνουν κάθε εβδομάδα ένα χρηματικό ποσό για τα προσωπικά
σας έξοδα και εσείς καταφέρνετε να αποταμιεύετε το 30% του ποσού
αυτού. Γράψτε πρόγραμμα σε ΓΛΩΣΣΑ το οποίο:
α) διαβάζει το χρηματικό ποσό που σας δίνουν οι γονείς σας κάθε
     εβδομάδα,
β) υπολογίζει και εμφανίζει:
    * πόσες εβδομάδες απαιτούνται μέχρι να μαζέψετε το χρηματικό
       ποσό που απαιτείται για την αγορά του ποδηλάτου,
    * το περίσσευμα των χρημάτων σας μετά την αγορά.

Απάντηση

      ΠΡΟΓΡΑΜΜΑ ΠΟΔΗΛΑΤΟ
      ΣΤΑΘΕΡΕΣ
             ΑΞΙΑ = 320
      ΜΕΤΑΒΛΗΤΕΣ
             ΠΡΑΓΜΑΤΙΚΕΣ: Ποσό, Σύνολο, Περ
             ΑΚΕΡΑΙΕΣ: Εβδομ
      ΑΡΧΗ
              ΔΙΑΒΑΣΕ Ποσό
              Σύνολο <-- 0
              Εβδομ <-- 0
              ΟΣΟ Σύνολο < ΑΞΙΑ ΕΠΑΝΑΛΑΒΕ
                      Σύνολο <-- Σύνολο+Ποσό*30/100
                      Εβδομ <-- Εβδομ+1
              ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
              ΓΡΑΨΕ Εβδομ
              Περ <-- Σύνολο-ΑΞΙΑ
              ΑΝ Περ > 0 ΤΟΤΕ
                     ΓΡΑΨΕ Περ
              ΑΛΛΙΩΣ
                     ΓΡΑΨΕ 'Δεν υπάρχει περίσσευμα'
              ΤΕΛΟΣ_ΑΝ
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου