Παρασκευή, 1 Οκτωβρίου 2010

Καταγράψτε τα επιμέρους στοιχεία ενός προγράμματος

Δίνεται το παρακάτω πρόγραμμα
    ΠΡΟΓΡΑΜΜΑ ΑΣΚ
    ΣΤΑΘΕΡΕΣ
        Λ = 'ΓΥΜΝΑΣΙΟ'
        Μ = 23.2
    ΜΕΤΑΒΛΗΤΕΣ
        ΑΚΕΡΑΙΕΣ: Χ
        ΠΡΑΓΜΑΤΙΚΕΣ: Υ
    ΑΡΧΗ
         ΔΙΑΒΑΣΕ Χ
         ΑΝ Χ <= 0 ΤΟΤΕ
               Υ <-- Χ+Μ+1.99
         ΑΛΛΙΩΣ
               Υ <-- Μ-Χ+2.33

         ΤΕΛΟΣ_ΑΝ
         ΓΡΑΨΕ Υ
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Καταγράψτε τις:
α) σταθερές
β) συμβολικές σταθερές
γ) μεταβλητές
δ) εντολές εισόδου
ε) εντολές εξόδου
στ) συγκριτικούς τελεστές
ζ) αριθμητικούς τελεστές
η) λογικούς τελεστές
ι) λογικές εκφράσεις (συνθήκες)

Απάντηση

α) 'ΓΥΜΝΑΣΙΟ', 23.2, 0, 1.99, 2.33
β)  Λ, Μ
γ)  Χ, Υ
δ) ΔΙΑΒΑΣΕ Χ
ε) ΓΡΑΨΕ Υ
στ) <=
ζ) +, +, -, +
η) δεν υπάρχουν
ι)  Χ <= 0

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου