Δευτέρα, 4 Οκτωβρίου 2010

Άσκηση : Κλιμακωτός και μη κλιμακωτός υπολογισμός

Σε ένα μαγαζί η τιμή πώλησης των Τ-SHIRT  αποτυπώνεται
στον πίνακα που ακολουθεί:
       Πλήθος τεμαχίων                    Τιμή ενός Τ-SHIRT
         Από 1 έως και 5                               11 ευρώ
         Από 6 έως και 9                                 9 ευρώ
         Από 10 και πάνω                              7,5 ευρώ
Γράψτε αλγόριθμο που διαβάζει το πλήθος των τεμαχίων
που θέλει να αγοράσει ένας πελάτης, υπολογίζει και
εμφανίζει το συνολικό κόστος της αγοράς του.

Λύση

Επειδή δεν διευκρινίζεται από την εκφώνηση αν η χρέωση
γίνεται με κλιμακωτό ή μη κλιμακωτό τρόπο, πρέπει να
διακρίνουμε δύο περιπτώσεις και να διατυπώσουμε μια λύση
για κάθε περίπτωση.

Μη κλιμακωτός υπολογισμός
  
     Αλγόριθμος Μπλουζάκια
     Διάβασε Πληθ
     Αν Πληθ <= 5 τότε
          Κόστος <-- Πληθ*11
     αλλιώς_αν Πληθ <= 9 τότε
          Κόστος <-- Πληθ*9
     αλλιώς
          Κόστος <-- Πληθ*7.5
     Τέλος_αν
     Εμφάνισε Κόστος
     Τέλος  Μπλουζάκια

Κλιμακωτός υπολογισμός
  
     Αλγόριθμος Μπλουζάκια
     Διάβασε Πληθ
     Αν Πληθ <= 5 τότε
          Κόστος <-- Πληθ*11
     αλλιώς_αν Πληθ <= 9 τότε
          Κόστος <-- 5*11+(Πληθ-5)*9
     αλλιώς
          Κόστος <-- 5*11+4*9+(Πληθ-9)*7.5
     Τέλος_αν
     Εμφάνισε Κόστος
     Τέλος  Μπλουζάκια


 

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου