Τρίτη, 26 Οκτωβρίου 2010

Άσκηση : Πορτοφόλι

Θέλετε να διαθέσετε μέχρι 80 ευρώ για την αγορά
αναψυκτικών και ποτών. Γράψτε αλγόριθμο που:
α) διαβάζει το είδος (Α-Αναψυκτικό, Π - Ποτό) του
     επόμενου προς αγορά προϊόντος,
β) ελέγχει αν είναι δυνατή ή αγορά του ή όχι,
γ) αν η απάντηση στο ερώτημα β) είναι καταφατική οι
    αγορές συνεχίζονται, διαφορετικά εμφανίζεται το
    μήνυμα "Οι αγορές δεν μπορούν να συνεχιστούν",
δ) υπολογίζει και εμφανίζει:
    * πόσα αναψυκτικά αγοράστηκαν,
    * πόσα ποτά αγοράστηκαν,
    * το περίσσευμα των χρημάτων σας μετά την
       ολοκλήρωση των αγορών,
    * το συνολικό ποσό που διαθέσατε για αγορές.

Λύση

    Αλγόριθμος Πορτοφόλι
    Ανα <-- 0
    Ποτ <-- 0
    Ποσό <-- 80
    Αρχή_επανάληψης
          Διάβασε Είδος, Τιμή
          Αν Ποσό >= Τιμή  τότε
               Ποσό <-- Ποσό-Τιμή
               Αν Είδος = 'Α' τότε
                    Ανα <-- Ανα+1
               αλλιώς
                    Ποτ <-- Ποτ+1

               Τέλος_αν
          αλλιώς
               Εμφάνισε 'Οι αγορές δεν μπορούν να συνεχιστούν'
          Τέλος_αν
    Μέχρις_ότου Ποσό < Τιμή
    ΠοσΑγ <-- 80-Ποσό
    Εμφάνισε Ανα, Ποτ
    Αν Διαθ > 0 τότε
           Εμφάνισε Διαθ
    αλλιώς
           Εμφάνισε 'Δεν υπάρχει καθόλου περίσσευμα'
    Τέλος_αν
    Εμφάνισε  ΠοσΑγ
    Τέλος Πορτοφόλι

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου