Κυριακή, 24 Οκτωβρίου 2010

'Ασκηση : Φρουρός+απάντηση σε ερώτηση (συνδυαστική)

Γράψτε αλγόριθμο που:
α) διαβάζει τα ονόματα κάποιων νομών της Ελλάδας ( η
    είσοδος δεδομένων ολοκληρώνεται μόλις δοθεί ως
    τιμή εισόδου το κενό διάστημα),
β) για καθένα από τους παραπάνω νομούς, διαβάζει
    τα ονόματα και τους πληθυσμούς πόλεων/χωριών
    του (η είσοδος δεδομένων ολοκληρώνεται μόλις
    δοθεί η απάντηση 'Ν' στην ερώτηση 'Ολοκληρώθηκε
    η είσοδος;'),
γ) υπολογίζει και εμφανίζει:
    * το όνομα της πόλης με το μεγαλύτερο πληθυσμό καθώς
       και το όνομα του νομού στον οποίο ανήκει,
    * πόσες πόλεις εξετάστηκαν από κάθε νομό,
    * το ποσοστό (%) των πόλεων/χωριών που είχαν
       περισσότερους από 10000 κατοίκους.
Παρατηρήσεις:
* Θεωρείστε ότι δόθηκαν δεδομένα για  τουλάχιστον ένα νομό
* Εξετάστηκε τουλάχιστον μια πόλη από κάθε νομό.

Λύση

      Αλγόριθμος Πόλεις
      Πληθ <-- 0
      Φ <-- 0
      ΜΑΧ <-- -1
      Αρχή_επανάληψης
           Διάβασε Νομ
           Αν Νομ < > '  ' τότε
                Πολ <-- 0
                Αρχή_επανάληψης
                     Διάβασε Πόλη
                     Διάβασε Πληθυσμός
                     Πολ <-- Πολ+1
                     Πληθ <-- Πληθ+1
                     Αν Πληθυσμός > ΜΑΧ τότε
                            ΜΑΧ <-- Πληθυσμός
                            ΝομΜΑΧ <-- Νομ
                            ΠολΜΑΧ <-- Πόλη
                     Τέλος_αν
                     Αν Πληθυσμός > 10000 τότε
                            Φ <-- Φ+1
                     Τέλος_αν
                     Εμφάνισε 'Ολοκληρώθηκε η είσοδος;'
                     Διάβασε Απ
                Μέχρις_ότου Απ = 'Ν'
                Εμφάνισε Πολ
           Τέλος_αν
      Μέχρις_ότου   Νομ = '  '
      ΠΟΣ <-- 100*Φ/Πληθ
      Εμφάνισε ΠολΜΑΧ, ΝομΜΑΧ
      Εμφάνισε ΠΟΣ
      Τέλος Πόλεις

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου