Σάββατο, 20 Σεπτεμβρίου 2014

Διορθώστε τις λανθασμένες προτάσεις

Διορθώστε τις παρακάτω λανθασμένες προτάσεις
και επαναδιατυπώστε τις με σωστό τρόπο
1. Μια λογική παράσταση αποτιμάται με την τιμή
    'Ψευδής' ή 'Αληθής'.
2. Μια έλλειψη έχει μία ή περισσότερες εξόδους
    για απάντηση σ' ένα λογικό διάγραμμα.
3. Κάθε πρόγραμμα έχει τουλάχιστον μια μεταβλητή.
4. Ένας πίνακας καταλαμβάνει συνεχόμενες θέσεις
    της δευτερεύουσας μνήμης του υπολογιστή.
5. Ένα υποπρόγραμμα πρέπει να εξαρτάται άμεσα
    από το κύριο πρόγραμμα.



Απάντηση

1. Μια λογική παράσταση αποτιμάται με την τιμή  
    Ψευδής ή Αληθής.
2. Ένας ρόμβος  έχει μία ή περισσότερες εξόδους
    για απάντηση σ' ένα λογικό διάγραμμα.
3. Ένα πρόγραμμα μπορεί να  μην έχει καμία 
     μεταβλητή.
4. Ένας πίνακας καταλαμβάνει συνεχόμενες θέσεις
    της κύριας μνήμης του υπολογιστή.
5. Ένα υποπρόγραμμα πρέπει να είναι ανεξάρτητο
    από το κύριο πρόγραμμα.

Κυκλώστε τα σωστά

Ποιά από τα παρακάτω ισχύουν για τους αλγόριθμους;
1. Γράφονται σε μια γλώσσα προγραμματισμού
2. Γράφονται σε ψευδογλώσσα.
3. Πληρούν συγκεκριμένα κριτήρια.
4. Εκτελούνται απευθείας στον υπολογιστή.
5. Δεν έχουν καμιά σχέση με τα προγράμματα.

Απάντηση

2, 3

Κυριακή, 14 Σεπτεμβρίου 2014

Ερωτήσεις σωστού/λάθους

Ποιες από τις παρακάτω προτάσεις είναι
σωστές και ποιες λάθος;
1. Η κωδικοποίηση των αλγορίθμων είναι
    ένα αλγοριθμικό κριτήριο.
2. Η περατότητα είναι ένας από τους τρόπους
   αναπαράστασης των αλγορίθμων.
3. Τα διαγράμματα ροής ολοκληρώνονται με
    έναν κύκλο.
4. Αν Χ πραγματική μεταβλητή, Α_Μ(Χ) <= Χ.
5. Αν Χ ακέραια μεταβλητή και Α_Τ(Χ) < > Χ,
    το περιεχόμενο της μεταβλητής είναι αρνητικό.


Απαντήσεις

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ


Συμπληρώστε τα κενά

Συμπληρώστε τα κενά που λείπουν
1.  _____ Ή Χ = Χ
2.  _____ ΚΑΙ Χ = Χ
3. _____ ΚΑΙ Χ = Ψευδής
4. _____ Ή Χ = Αληθής

Απαντήσεις

1. Ψευδής
2. Αληθής
3. Ψευδής
4. Αληθής

Κυριακή, 7 Σεπτεμβρίου 2014

Ποιο είναι πιο γρήγορο;

Δίνονται τα παρακάτω ισοδύναμα τμήματα εντολών:

Τμήμα Α

     Αν  Χ < 100 τότε
         Εμφάνισε Χ
     αλλιώς_αν Χ < 200 τότε
         Εμφάνισε Χ+1
     αλλιώς_αν Χ < 300 τότε
         Εμφάνισε Χ+2
     αλλιώς
         Εμφάνισε Χ+3
     Τέλος_αν

Τμήμα Β

     Αν  Χ < 100 τότε
         Εμφάνισε Χ
     αλλιώς
          Αν Χ < 200 τότε
                Εμφάνισε Χ+1
          αλλιώς
               Αν Χ < 300 τότε
                   Εμφάνισε Χ+2
               αλλιώς
                   Εμφάνισε Χ+3
               Τέλος_αν
           Τέλος_αν
      Τέλος_αν

   Τμήμα Γ

     Αν  Χ < 100 τότε
         Εμφάνισε Χ
     Τέλος_αν
     Αν (Χ >= 100) ΚΑΙ (Χ < 200) τότε
          Εμφάνισε Χ+1
     Τέλος_αν
     Αν (Χ >= 200) ΚΑΙ (Χ < 300) τότε
           Εμφάνισε Χ+2
     Τέλος_αν
     Αν  Χ >= 300 τότε
            Εμφάνισε Χ+3
     Τέλος_αν

Ποιο είναι γρηγορότερο και γιατί;

Απάντηση

Το πιο αργό από τα τρία είναι το τμήμα Γ, αφού κατά
την εκτέλεσή του θα πραγματοποιηθούν και οι τέσσερις
έλεγχοι (κάθε Αν..τότε είναι ανεξάρτητη από τις άλλες).
Τα τμήματα Α και Β έχουν την ίδια ακριβώς ταχύτητα
εκτέλεσης η οποία και είναι η μεγαλύτερη δυνατή για
τη συγκεκριμένη υπολογιστική διαδικασία (μόλις
αποτιμηθεί μια συνθήκη ως Αληθής εκτελείται η
αντίστοιχη Εμφάνισε και η αλληλουχία εντολών
ολοκληρώνεται επί τόπου).





Πέμπτη, 4 Σεπτεμβρίου 2014

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
     Για κ από 10 μέχρι 28 με_βήμα 19
         Για λ από 5 μέχρι 12 με_βήμα 8
              Για μ από 12 μέχρι 36 με_βήμα 45
                   Για ν από 32 μέχρι 40 με_βήμα 8
                        Εμφάνισε κ+λ+μ-ν
                   Τέλος_επανάληψης
              Τέλος_επανάληψης
         Τέλος_επανάληψης
     Τέλος_επανάληψης

Απάντηση

Η πρώτη Για εκτελείται μόνο για κ = 10, η δεύτερη μόνο
για λ = 5, η τρίτη μόνο για μ = 12 και η τέταρτη για ν = 32
και ν = 40. Αφού 10+5+12-32 = -5 και 10+5+12-40 = -13,
στη μονάδα εξόδου θα εμφανιστούν οι τιμές:
      -5
      -13

Δώστε την εκφώνηση

Ποιά είναι η εκφώνηση του προβλήματος που επιλύει
ο παρακάτω αλγόριθμος;
    Αλγόριθμος Ασκ
    Δεδομένα // Ν //
    Για κ από 1 μέχρι Ν
        Αρχή_επανάληψης
             Διάβασε Χ
        Μέχρις_ότου Χ > 99
        Εμφάνισε Χ mod 10
    Τέλος_επανάληψης
    Τέλος Ασκ

Απάντηση

Γράψτε αλγόριθμο που διαβάζει Ν (θεωρήστε το
ως δεδομένο) ακέραιους αριθμούς μεγαλύτερους
του 99 και εμφανίζει το τελευταίο ψηφίο του καθενός.
Ο αλγόριθμος πρέπει να διασφαλίζει την εγκυρότητα
των εισερχόμενων δεδομένων.