Πέμπτη, 4 Σεπτεμβρίου 2014

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
     Για κ από 10 μέχρι 28 με_βήμα 19
         Για λ από 5 μέχρι 12 με_βήμα 8
              Για μ από 12 μέχρι 36 με_βήμα 45
                   Για ν από 32 μέχρι 40 με_βήμα 8
                        Εμφάνισε κ+λ+μ-ν
                   Τέλος_επανάληψης
              Τέλος_επανάληψης
         Τέλος_επανάληψης
     Τέλος_επανάληψης

Απάντηση

Η πρώτη Για εκτελείται μόνο για κ = 10, η δεύτερη μόνο
για λ = 5, η τρίτη μόνο για μ = 12 και η τέταρτη για ν = 32
και ν = 40. Αφού 10+5+12-32 = -5 και 10+5+12-40 = -13,
στη μονάδα εξόδου θα εμφανιστούν οι τιμές:
      -5
      -13

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου