Κυριακή, 30 Οκτωβρίου 2011

Δώστε την εκφώνηση του προβλήματος

Γράψτε την εκφώνηση του προβλήματος που επιλύει
ο παρακάτω αλγόριθμος
     Αλγόριθμος ΑΣΚ
     Γ <-- 1
     Πληθ <-- 0
     Αρχή_επανάληψης
         Διάβασε Χ
         Πληθ <-- Πληθ+1
         Γ <-- Γ*Χ
         Εμφάνισε 'Υπάρχουν άλλα δεδομένα;'
         Διάβασε Απ
     Μέχρις_ότου (Πληθ = 120) Ή (Απ = 'ΟΧΙ')
     Αποτελέσματα // Γ //
     Τέλος ΑΣΚ

Απάντηση

     Γράψτε αλγόριθμο που διαβάζει κάποιες αριθμητικές τιμές
     ( η είσοδος δεδομένων ολοκληρώνεται μόλις το πλήθος
     των τιμών εισόδου φθάσει το 120 ή όταν δοθεί η απάντηση
     'ΟΧΙ' στην υποβαλλόμενη προς το χρήστη ερώτηση
     'Υπάρχουν άλλα δεδομένα;') και υπολογίζει το γινόμενό
     τους.

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Η δομή επανάληψης είναι μια προγραμματιστική
    δομή.
2. Η δομή επιλογής περιλαμβάνει μια σειρά εντολών
    που εκτελούνται ακριβώς μια φορά με τη σειρά που
    έχουν γραφεί.
3. Το πρόβλημα υπολογισμού της απόστασης δύο
    σημείων του επιπέδου είναι αδόμητο.
4. Ένας δισδιάστατος πίνακας που έχει ίδιο αριθμό
    γραμμών και στηλών αποκαλείται τετράγωνος.
5. Για να είναι σωστή η εντολή
            Ζ <-- Χ < Υ
    θα πρέπει οι μεταβλητές Ζ, Χ, Υ να είναι λογικού τύπου.



Απαντήσεις

1. Η δομή επανάληψης είναι μια αλγοριθμική
    δομή.
2. Η δομή ακολουθίας περιλαμβάνει μια σειρά εντολών
    που εκτελούνται ακριβώς μια φορά με τη σειρά που
    έχουν γραφεί.

3. Το πρόβλημα υπολογισμού της απόστασης δύο
    σημείων του επιπέδου είναι δομημένο.

4. Ένας δισδιάστατος πίνακας που έχει ίδιο αριθμό
    γραμμών και στηλών αποκαλείται τετραγωνικός.

5. Για να είναι σωστή η εντολή
            Ζ <-- Χ < Υ
    θα πρέπει η μεταβλητή Ζ να είναι λογικού τύπου
    και οι μεταβλητές Χ, Υ αριθμητικού τύπου (ακέραιες
    ή πραγματικές).


Πέμπτη, 27 Οκτωβρίου 2011

Φρουρός+απάντηση σε ερώτηση

Γράψτε αλγόριθμο που διαβάζει δυάδες αριθμών, υπολογίζει
και εμφανίζει το γινόμενό τους. Η είσοδος των δεδομένων
ολοκληρώνεται μόλις μια τουλάχιστον από τις τιμές εισόδου
είναι αρνητική ή όταν δοθεί η απάντηση 'Ν' στην υποβαλλόμενη
προς το χρήστη ερώτηση 'Θέλεις να σταματήσεις;'

Λύση

     Αλγόριθμος ΑΣΚ
     Αρχή_επανάληψης
           Διάβασε α, β
           Αν (α >= 0) ΚΑΙ (β >= 0) τότε
                 γ <-- α*β
                 Εμφάνισε γ
           Τέλος_αν
            Εμφάνισε 'Θέλεις να σταματήσεις;'
            Διάβασε Απ
     Μέχρις_ότου (α < 0) Ή (β < 0) Ή (Απ = 'Ν')
     Τέλος ΑΣΚ

Επεξεργασία δοσμένου πλήθους τιμών

Γράψτε αλγόριθμο που διαβάζει 120 αριθμητικές τιμές,
υπολογίζει και εμφανίζει πόσες από αυτές είναι ακέραιες.

Λύση

     Αλγόριθμος ΑΣΚ
     Ακερ <-- 0
     Για κ από 1 μέχρι 120
          Διάβασε Χ
          Αν Α_Μ(Χ) = Χ τότε
               Ακερ <-- Ακερ+1
          Τέλος_αν
     Τέλος_επανάληψης
     Εμφάνισε Ακερ
     Τέλος ΑΣΚ

Τρίτη, 25 Οκτωβρίου 2011

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν στις παρακάτω προτάσεις
1. Η περατότητα είναι ένα αλγοριθμικό ________.
2. Τα δομημένα είναι μια υποκατηγορία των επιλύσιμων
     προβλημάτων με κριτήριο το βαθμό _______ των
     λύσεων.
3. Οι γλώσσες ____________ αναπτύχθηκαν προκειμένου
     να επικοινωνεί ο άνθρωπος με τη μηχανή.
4. Το ________ δήλωσης των μεταβλητών ενός προγράμματος
    ξεκινάει με τη δεσμευμένη λέξη ΜΕΤΑΒΛΗΤΕΣ.
5. Η εντολή ___________ και η εντολή ΔΙΑΒΑΣΕ είναι οι
    μοναδικοί τρόποι αλλαγής του περιεχομένου μιας μεταβλητής.

Απάντηση

1. κριτήριο
2. δόμησης
3. προγραμματισμού
4. τμήμα
5. εκχώρησης

Ερωτήσεις σωστού λάθους

Ποιές από τις παρακάτω προτάσεις είναι σωστές και ποιές
λάθος;
1. Τα συντακτικά λάθη εντοπίζονται κατά τη φάση της
    σύνδεσης του αντικείμενου προγράμματος με τις
    βιβλιοθήκες.
2. Ο συντάκτης είναι ένας ειδικευμένος κειμενογράφος,
    κατάλληλος για τη συγγραφή πηγαίων προγραμμάτων.
3. Μια μεταβλητή της ΓΛΩΣΣΑΣ αντιστοιχεί σε μια
    συγκεκριμένη θέση μνήμης του υπολογιστή.
4. Σ' ένα πρόγραμμα δεν μπορούμε να χρησιμοποιήσουμε
    τις δηλώσεις Δεδομένα και Αποτελέσματα.
5. Κάθε πρόγραμμα δίνει τα ίδια πάντα αποτελέσματα όποτε
    εκτελείται.



Απάντηση

1. Λ
2. Σ
3. Σ
4. Σ
5. Λ

Κυριακή, 23 Οκτωβρίου 2011

Άσκηση : Γέμισμα πίνακα

Με ποιές τιμές γεμίζει ο πίνακας Α[10] μετά την εκτέλεση
των παρακάτω εντολών;
        Χ <-- 28
        Για κ από 1 μέχρι 5
             Α[κ] <-- Χ mod 4
             A[11-κ] <-- A[κ]+1
             Χ <-- Χ-4
        Τέλος_επανάληψης


Λύση


       Το Χ παίρνει διαδοχικά τις τιμές 28, 24, 20, 16, 12, και 8.
       Καθεμιά από αυτές είναι πολλαπλάσιο του 4, πράγμα που
       σημαίνει ότι το  Χ mod 4 ισούται με 0.
       Κατά συνέπεια:
       * τα στοιχεία Α[1], Α[2], Α[3], Α[4] και  Α[5] θα πάρουν
          την τιμή 0,
       * τα στοιχεία Α[6], Α[7], Α[8], Α[9] και  Α[10] θα πάρουν
          την τιμή 1.
       Το περιεχόμενο του Α είναι λοιπόν:
              0   0   0   0   0  1   1   1   1   1
     

Άσκηση : συγγραφή διαδικασίας

Γράψτε διαδικασία η οποία δέχεται ως παράμετρο ένα θετικό
τετραψήφιο Ν και διαβάζει συνεχώς θετικούς τετραψήφιους
(να γίνεται έλεγχος εγκυρότητας των εισερχόμενων τιμών)
μέχρι να δοθεί μια τιμή εισόδου ίση με το Ν ή το συνολικό
πλήθος των τιμών εισόδου (εξαιρουμένων των μη θετικών
τετραψήφιων) να φτάσει το 5. Αυτό το συνολικό πλήθος των
τιμών εισόδου αποτελεί και τη μοναδική παράμετρο αποτελέσματος
της  διαδικασίας.


Λύση


       ΔΙΑΔΙΚΑΣΙΑ ΒΡΕΣ(Ν, ΠΛΗΘ)
       ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Ν, ΠΛΗΘ, Χ
       ΑΡΧΗ
             ΠΛΗΘ <-- 0
             ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                   ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
                       ΓΡΑΨΕ 'Δώσε θετικό τετραψήφιο:'
                       ΔΙΑΒΑΣΕ Χ
                   ΜΕΧΡΙΣ_ΟΤΟΥ (Χ >= 1000) ΚΑΙ (Χ <= 9999)
                   ΠΛΗΘ <-- ΠΛΗΘ+1
             ΜΕΧΡΙΣ_ΟΤΟΥ (Χ = Ν) Ή (ΠΛΗΘ = 5)
       ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Παρασκευή, 21 Οκτωβρίου 2011

Γέμισμα πίνακα

Ποιο είναι το περιεχόμενο του πίνακα Α[100] μετά την εκτέλεση
των παρακάτω εντολών (θεωρείστε ότι το Ν είναι
θετικός ακέραιος)
     Για κ από 1 μέχρι 100
          Αν κ mod 2 = 1 τότε
               Α[κ] <-- Ν mod (N+1)
          αλλιώς
               Α[κ] <-- Ν div (N+1)
          Τέλος_αν
     Τέλος_επανάληψης


Απάντηση


      Αφού το Ν είναι θετικός ακέραιος, ισχύουν οι σχέσεις:
            Ν mod (N+1) = Ν
            Ν div (N+1) = 0
      Κατά συνέπεια, ο πίνακας Α γεμίζει με τον ακόλουθο
      τρόπο:
           * τα περιττά στοιχεία του (Α[1], Α[3], ..., Α[99])
              παίρνουν την τιμή Ν
           * τα άρτια στοιχεία του (Α[2], Α[4], ..., Α[100])
              παίρνουν την τιμή 0.
      Το περιεχόμενο του Α λοιπόν είναι :
             Ν, 0, Ν, 0, ...., Ν, 0

Πέμπτη, 20 Οκτωβρίου 2011

Άσκηση : συγγραφή συνάρτησης

Σ' ένα πολιτιστικό σύλλογο αποφάσισαν να διαθέσουν το 15%
των ετήσιων εσόδων του (από τις εισφορές των μελών), στην
αγορά βιβλίων. Ωστόσο το ποσό αυτό δεν πρέπει να υπερβαίνει
τα 250 ευρώ. Αν η ετήσια εισφορά κάθε μέλους είναι 30 ευρώ,
γράψτε συνάρτηση η οποία δέχεται ως παράμετρο το πλήθος
των μελών του συλλόγου και υπολογίζει το ποσό που διατέ-
θηκε τελικά για την αγορά βιβλίων.

Λύση

      ΣΥΝΑΡΤΗΣΗ ΒΙΒΛΙΑ(ΠΛΗΘ) : ΠΡΑΓΜΑΤΙΚΗ
      ΣΤΑΘΕΡΕΣ
             ΣΥΝΔΡΟΜΗ = 30
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: ΠΛΗΘ, ΕΙΣΦ
            ΠΡΑΓΜΑΤΙΚΕΣ: ΠΟΣΟ
      ΑΡΧΗ
            ΕΙΣΦ <-- ΠΛΗΘ*ΣΥΝΔΡΟΜΗ
            ΠΟΣΟ <-- ΕΙΣΦ*15/100
            ΑΝ ΠΟΣΟ > 250 ΤΟΤΕ
                   ΠΟΣΟ <-- 250
            ΤΕΛΟΣ_ΑΝ
            ΒΙΒΛΙΑ <-- ΠΟΣΟ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Σάββατο, 15 Οκτωβρίου 2011

Συγγραφή διαδικασίας

Γράψτε διαδικασία που δέχεται ως παραμέτρους μια γωνία Χ
και υπολογίζει το ημίτονο, το συνημίτονο, την εφαπτομένη και
τη συνεφαπτομένη της γωνίας αυτής. Αν δεν είναι εφικτός ο
υπολογισμός της εφαπτομένης ή της συνεφαπτομένης, να
εκχωρείται στις αντίστοιχες παραμέτρους αποτελέσματος η
τιμή -9999.9

Λύση

     ΔΙΑΔΙΚΑΣΙΑ ΤΡΙΓ(Χ, ΗΜΧ, ΣΥΝΧ, ΕΦΧ, ΣΦΧ)
     ΜΕΤΑΒΛΗΤΕΣ
           ΠΡΑΓΜΑΤΙΚΕΣ: Χ, ΗΜΧ, ΣΥΝΧ, ΕΦΧ, ΣΦΧ
     ΑΡΧΗ
           ΗΜΧ <-- ΗΜ(Χ)
           ΣΥΝΧ <-- ΣΥΝ(Χ)
           ΑΝ ΣΥΝΧ < > 0 ΤΟΤΕ           
                 ΕΦΧ <-- ΕΦ(Χ)
           ΑΛΛΙΩΣ
                 ΕΦΧ <-- -9999.9
           ΤΕΛΟΣ_ΑΝ
           ΑΝ ΗΜΧ < > 0 ΤΟΤΕ           
                 ΣΦΧ <-- 1/ΕΦΧ
           ΑΛΛΙΩΣ
                 ΣΦΧ <-- -9999.9
           ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Συγγραφή συνάρτησης

Γράψτε συνάρτηση που δέχεται ως παραμέτρους:
* το συνολικό πλήθος των μαθητών μιας τάξης,
* το πλήθος των αγοριών
και υπολογίζει το ποσοστό (%) των αγοριών στην
τάξη αυτή (αν δεν είναι δυνατός ο υπολογισμός
η συνάρτηση επιστρέφει -1).

Λύση

       ΣΥΝΑΡΤΗΣΗ ΠΟΣ(Πληθ, Αγόρια) : ΠΡΑΓΜΑΤΙΚΗ
       ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: Πληθ, Αγόρια
       ΑΡΧΗ
             ΑΝ Πληθ > 0 ΤΟΤΕ
                   ΠΟΣ <-- 100*Αγόρια/Πληθ
             ΑΛΛΙΩΣ
                   ΠΟΣ <-- -1
             ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Τρίτη, 11 Οκτωβρίου 2011

Επίτευξη στόχου

Θέλετε να μαζέψετε 1000 ευρώ προκειμένου να πάτε
καλοκαιρινές διακοπές. Για το σκοπό αυτό αποταμιεύετε
κάποιο χρηματικό ποσό κάθε μέρα. Γράψτε αλγόριθμο ο
οποίος:
α) διαβάζει το ποσό που αποταμιεύετε καθημερινά,
β) υπολογίζει και εμφανίζει:
    * πόσες ημέρες χρειάστηκαν για να πετύχετε το
       στόχο σας,
    * το πιθανό περίσσευμα χρημάτων αν υπάρχει.

Λύση

      Αλγόριθμος Κουμπαράς
      Ημέρες <-- 0
      Σύνολο <-- 0
      Όσο Σύνολο < 1000 επανάλαβε
            Διάβασε Ποσό
            Σύνολο <-- Σύνολο+Ποσό
            Ημέρες <-- Ημέρες+1
      Τέλος_επανάληψης
      Εμφάνισε Ημέρες
      Αν Σύνολο > 1000 τότε
            Εμφάνισε Σύνολο-1000
      αλλιώς
            Εμφάνισε 'Δεν υπάρχει περίσσευμα'
      Τέλος_αν
      Τέλος Κουμπαράς

Κυριακή, 9 Οκτωβρίου 2011

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω προτάσεις και επαναδιατυπώστε τις
με σωστό τρόπο.
1. Αν Χ θετικός ακέραιος, τότε  το Χ mod 4 είναι μεγαλύτερο
    του 0 και όχι μεγαλύτερο από το 4.
2. Η λογική πράξη ΚΑΙ έχει τη μεγαλύτερη προτεραιότητα
    από κάθε άλλη λογική πράξη.
3. Η εντολή Υ <-- Τ_Ρ(Χ) μπορεί να παραβιάζει το
    κριτήριο της αποτελεσματικότητας αν Χ < 0.
4. Το γεωμετρικό σχήμα του ρόμβου απεικονίζει μια
    εντολή εκχώρησης σ' ένα λογικό διάγραμμα.
5. Η μοναδική εντολή εξόδου σ' ένα πρόγραμμα της
    ΓΛΩΣΣΑΣ είναι η ΕΜΦΑΝΙΣΕ.


Απάντηση


1. Αν Χ θετικός ακέραιος, τότε  το Χ mod 4 είναι τουλάχιστον
    0 και όχι μεγαλύτερο από το 3.
2. Η λογική πράξη ΟΧΙ έχει τη μεγαλύτερη προτεραιότητα
    από κάθε άλλη λογική πράξη.
3. Η εντολή Υ <-- Τ_Ρ(Χ) μπορεί να παραβιάζει το
    κριτήριο της καθοριστικότητας αν Χ < 0.
4. Το γεωμετρικό σχήμα του ορθογωνίου παραλληλογράμμου
    απεικονίζει μια εντολή εκχώρησης σ' ένα λογικό διάγραμμα.
5. Η μοναδική εντολή εξόδου σ' ένα πρόγραμμα της
    ΓΛΩΣΣΑΣ είναι η ΓΡΑΨΕ.

Σάββατο, 8 Οκτωβρίου 2011

Υπολογισμός πλήθους επαναλήψεων

Πόσες φορές εκτελείται η παρακάτω Για..από..μέχρι;
     Για κ από 1.2 μέχρι 7.3 με_βήμα 0.04
          Εμφάνισε 'τεστ'
     Τέλος_επανάληψης


Απάντηση


     Πολλαπλασιάζω όλες τις τιμές με τη μικρότερη
     δύναμη του 10 που τις καθιστά ακέραιες. Η
     παρακάτω Για..από..μέχρι είναι ισοδύναμη με
     την αρχική:
         Για κ από 120  μέχρι 730 με_βήμα 4
              Εμφάνισε 'τεστ'
        Τέλος_επανάληψης
    Κατά συνέπεια το πλήθος των επαναλήψεων είναι:
         (730-120) div 4 + 1 = 610 div 4 + 1 = 152+1 = 153

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση

1. Η ιεραρχική σχεδίαση
    Α. χρησιμοποιεί κατά κύριο λόγο την GOTO
    B. είναι μια τεχνική ανάλυσης προβλημάτων από
         "πάνω προς τα κάτω"
    Γ. είναι μια ξεπερασμένη μέθοδος προγραμματισμού
    Δ. χρησιμοποιείται σπάνια

2. Ένας  αλγόριθμος
    Α. είναι διατυπωμένος σε γλώσσα προγραμματισμού
    Β. είναι άμεσα εκτελέσιμος στον υπολογιστή
    Γ. μπορεί να διατυπωθεί με τέσσερις εναλλακτικούς
        τρόπους
    Δ. μπορεί να μην τελειώνει ποτέ

3. Η εντολή Όσο..επανάλαβε
    Α. μπορεί να χρησιμοποιηθεί μόνο όταν γνωρίζουμε το
         πλήθος των επαναλήψεων
    Β. είναι πιο ισχυρή από την Μέχρις_ότου
    Γ. χρησιμοποιείται σπάνια
    Δ. είναι μια μορφή βρόχου

4. Ένας πίνακας
    Α. μπορεί να περιέχει τόσο αλφαριθμητικά όσο και
         αριθμητικά δεδομένα
    Β. μπορεί να μην έχει κάποιο συγκεκριμένο τύπο δεδομένων
    Γ. καταλαμβάνει συνεχόμενες θέσεις μνήμης στον υπολογιστή
    Δ. είναι μια δυναμική δομή δεδομένων

5. Μια συνάρτηση
    Α. υπολογίζει και επιστρέφει ένα μόνο αποτέλεσμα
    Β. έχει μία ή περισσότερες παραμέτρους
    Γ. τελειώνει με τη δεσμευμένη λέξη ΤΕΛΟΣ
    Δ. μπορεί να κληθεί μόνο μέσα από το κύριο πρόγραμμα

Απαντήσεις

1. Β
2. Γ
3. Δ
4. Γ
5. Α

Τρίτη, 4 Οκτωβρίου 2011

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1.  2 div 9 = 0
2.  0 div  9 = απροσδιόριστο
3.  2 mod 9 = 2
4.  (2*κ+7) mod 2 = 1
5. (4*κ+8) div 2 > 2*κ+4 = ΑΛΗΘΗΣ

Απαντήσεις

1. Σ
2. Λ
3. Σ
4. Σ
5. Λ


Σάββατο, 1 Οκτωβρίου 2011

Θέματα Επαναληπτικών Πανελλαδικών Εξετάσεων Εσπερινού Γενικού Λυκείου 2011
























Λύσεις Επαναληπτικών Πανελλαδικών Εξετάσεων Εσπερινού Γενικού Λυκείου 2011


Επαναληπτικές Πανελλαδικές εξετάσεις Δ’ τάξης Εσπερινού Γενικού Λυκείου 2011

ΘΕΜΑ Α
Οι λύσεις όλων των ερωτημάτων είναι ίδιες με αυτές των επαναληπτικών του ημερήσιου, εκτός από το ερώτημα 5 του Α4 :
Α = 1   Μ = 8127  Β = 1

ΘΕΜΑ Β
Οι λύσεις όλων των ερωτημάτων είναι ίδιες με αυτές των επαναληπτικών του ημερήσιου.

ΘΕΜΑ Γ
Η λύση είναι ίδια με αυτή των επαναληπτικών του ημερήσιου.

ΘΕΜΑ Δ

Αλγόριθμος ΘΔ
Για κ απο 1 μεχρι 20
Διαβασε Ονομ[κ]
Τελος_επαναληψης
Για κ απο 1 μεχρι 20
Για λ απο 1 μεχρι 5
Διαβασε Κερδη[κ, λ]
Τελος_επαναληψης
Τελος_επαναληψης
Μεγ <-- -100
Για κ απο 1 μεχρι 20
Σ <-- 0
Για λ απο 1 μεχρι 5
Σ <-- Σ+Κερδη[κ, λ]
Τελος_επαναληψης
Αν Σ > Μεγ τότε
Μεγ <-- Σ
ΘΜεγ <-- κ
Τέλος_αν
Τελος_επαναληψης
Εμφάνισε Ονομ[ΘΜεγ]
Διάβασε Εταιρεία
Βρεθ <-- Ψευδής
Θέση <-- 0
κ <-- 1
Όσο (κ <= 20) ΚΑΙ (Βρεθ = Ψευδής) επανάλαβε
Αν Ονομ[κ] = Εταιρεία τότε
Βρεθ <-- Αληθής
Θέση <-- κ
αλλιώς
κ <-- κ+1
Τέλος_αν
Τέλος_επανάληψης
Αν Βρεθ = Αληθής τότε
Μικ <-- Κέρδη[Θέση, 1]
ΘΜικ <-- 1
Για λ από 2 μέχρι 5
Αν Κέρδη[Θέση, λ] < Μικ τότε
Μικ <-- Κέρδη[Θέση, λ]
ΘΜικ <-- λ
Τέλος_αν
Τέλος_επανάληψης
Έτος <-- 2000+ΘΜικ
Εμφάνισε Έτος
αλλιώς
Εμφάνισε ‘Δεν υπάρχει αυτό το όνομα εταιρείας’
Τέλος_αν
Τέλος ΘΔ