Παρασκευή, 21 Οκτωβρίου 2011

Γέμισμα πίνακα

Ποιο είναι το περιεχόμενο του πίνακα Α[100] μετά την εκτέλεση
των παρακάτω εντολών (θεωρείστε ότι το Ν είναι
θετικός ακέραιος)
     Για κ από 1 μέχρι 100
          Αν κ mod 2 = 1 τότε
               Α[κ] <-- Ν mod (N+1)
          αλλιώς
               Α[κ] <-- Ν div (N+1)
          Τέλος_αν
     Τέλος_επανάληψης


Απάντηση


      Αφού το Ν είναι θετικός ακέραιος, ισχύουν οι σχέσεις:
            Ν mod (N+1) = Ν
            Ν div (N+1) = 0
      Κατά συνέπεια, ο πίνακας Α γεμίζει με τον ακόλουθο
      τρόπο:
           * τα περιττά στοιχεία του (Α[1], Α[3], ..., Α[99])
              παίρνουν την τιμή Ν
           * τα άρτια στοιχεία του (Α[2], Α[4], ..., Α[100])
              παίρνουν την τιμή 0.
      Το περιεχόμενο του Α λοιπόν είναι :
             Ν, 0, Ν, 0, ...., Ν, 0

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου