Σάββατο, 28 Δεκεμβρίου 2013

Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για τον αλγόριθμο;
1. Εκτελείται στον υπολογιστή.
2. Είναι γραμμένος σε μια γλώσσα προγραμματισμού.
3. Μπορεί να γραφεί σε ψευδογλώσσα.
4. Είναι ένας μηχανισμός παραγωγής πληροφοριών.
5. Επιλύει μόνο μαθηματικά προβλήματα.
6. Έχει αυστηρά καθορισμένες εντολές.
7. Οι εντολές του μπορεί να επαναλαμβάνονται για πάντα.
8. Ικανοποιεί τα κριτήρια της αποτελεσματικότητας και της
    εξόδου.

Απαντήσεις

3, 4, 6, 8

Πέμπτη, 26 Δεκεμβρίου 2013

Εκφώνηση προβλήματος

Δώστε την εκφώνηση του προβλήματος που επιλύει
ο παρακάτω αλγόριθμος
     Αλγόριθμος Ασκ
     Αρχή_επανάληψης
           Διάβασε Χ
           Αν Χ > 0 τότε
                Αν Χ mod 2 = 0 τότε
                      Εμφάνισε 'Ο', Χ ' είναι άρτιος'
                αλλιώς
                      Εμφάνισε 'Ο', Χ, 'είναι περιττός'
                Τέλος_αν                
           Τέλος_αν
     Μέχρις_ότου Χ <= 0
     Τέλος Ασκ

Απάντηση

Γράψτε αλγόριθμο που :
α) διαβάζει μια ακολουθία ακεραίων αριθμών
    (η είσοδος ολοκληρώνεται μόλις δοθεί μια
     μη θετική τιμή),
β) ελέγχει καθένα από αυτούς ως προς την
    αρτιότητα τους και εμφανίζει κατάλληλα
    ενημερωτικά μηνύματα.


Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η συγχώνευση είναι μια λειτουργία επί των δομών
    δεδομένων που αποτελεί το αντίστροφο του _______.
2. Ο _________ πίνακας έχει τουλάχιστον δύο γραμμές και
    τουλάχιστον δύο στήλες.
3. Τα στοιχεία ενός πίνακα καταλαμβάνουν ________
    θέσεις στην κύρια μνήμη του υπολογιστή.
4. Ο ______ είναι προσδιορίζει τη θέση ενός στοιχείου
    στον πίνακα.
5. Ένας δυσδιάστατος πίνακας μπορεί να θεωρηθεί ως
    μονοδιάστατος που τα στοιχεία του είναι ________
    πίνακες.


Απαντήσεις

1. διαχωρισμού
2. δυσδιάστατος
3. συνεχόμενες
4. δείκτης
5. μονοδιάστατοι



Παρασκευή, 20 Δεκεμβρίου 2013

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Κάθε αλγόριθμος υλοποιεί μια επεξεργασία δεδομένων.
2. Η ταξινόμηση μπορεί να γίνει είτε κατά αύξουσα είτε κατά
    φθίνουσα σειρά.
3. Η εντολή Για..από..μέχρι έχει πάντοτε βήμα μεταβολής
    θετικό ή μηδέν.
4. Το κριτήριο της καθοριστικότητας  παραβιάζεται όταν
    η εντολή δεν είναι απλή και άμεσα εκτελέσιμη.
5. Ο τμηματικός προγραμματισμός είναι μια μεθοδολογία
    δημιουργίας αλγορίθμων.

Απαντήσεις

1. Σ
2. Σ
3. Λ
4. Λ
5. Λ


Κυριακή, 15 Δεκεμβρίου 2013

Λογικό διάγραμμα

Διατυπώστε τον αλγόριθμο σε ψευδογλώσσα που αντιστοιχεί
στο παρακάτω διάγραμμα

































Λύση

Αλγόριθμος Ασκ
Για Κ από 1 μέχρι 20
    Για Λ από μέχρι 20
        Για Μ από μέχρι 20
             Εμφάνισε  Α[Κ], Α[Λ], Α[Μ]
        Τέλος_επανάληψης
    Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Ασκ



Συγγραφή διαδικασίας


Παρασκευή, 13 Δεκεμβρίου 2013

Ερωτήσεις πολλαπλής επιλογής

Κυκλώστε τη σωστή επιλογή

1. Το μέγιστο στοιχείο στον ταξινομημένο πίνακα
    Α[90] είναι:
    α. το Α[1]
    β. το Α[90]
    γ. το Α[45]
    δ. το Α[1] ή το Α[90]

2. Ένας τετραγωνικός πίνακας
    α. έχει τρεις κύριες διαγωνίους
    β. έχει περισσότερες γραμμές από στήλες
    γ. είναι πάντοτε αριθμητικού τύπου (ακέραιου
        ή πραγματικού)
    δ. έχει τόσες γραμμές όσες και στήλες 

3. Ο δυσδιάστατος πίνακας Α[11, 10]
    α. έχει δύο τουλάχιστον μέγιστα στοιχεία
    β.  έχει ένα τουλάχιστον ελάχιστο στοιχείο
    γ.  έχει 110 στοιχεία ίδιου τύπου
    δ. έχει  21 στοιχεία ίδιου τύπου

4. Ο πίνακας Α[11, 2, 3] είναι:
    α. τετραδιάστατος
    β. δυσδιάστατος, με βάθος 3
    γ. τρισδιάστατος 
    δ. μονοδιάστατος

5. Ο πίνακας :
    α. αποθηκεύει τα στοιχεία του σε συνεχόμενες
        θέσεις της δευτερεύουσας μνήμης
    β. είναι μια δυναμική δομή δεδομένων
    γ. είναι μια μορφή αρχείου
    δ. περιορίζει τις δυνατότητες του προγράμματος

Απαντήσεις

1. δ
2. δ
3. γ
4. γ
5. δ


Επαναδιατύπωση

Θεωρείστε τον ακέραιο πίνακα Α[345].
Ξαναγράψτε απλούστερα το παρακάτω σύνολο εντολών
    Για κ από 1 μέχρι 100 με_βήμα 200
         Για λ από 200 μέχρι 50 με_βήμα -190
              Για μ από 30 μέχρι 60 με_βήμα 40
                     Εμφάνισε Α[κ]*Α[λ]+Α[μ]
              Τέλος_επανάληψης
         Τέλος_επανάληψης
    Τέλος_επανάληψης
   

Απάντηση
Η πρώτη Για εκτελείται μόνο για κ = 1
Η δεύτερη Για εκτελείται μόνο για λ = 200
Η τρίτη Για εκτελείται μόνο για μ = 30.
Άρα όλο το σύνολο των εντολών μπορεί να αντικατασταθεί
από την εντολή :
    Εμφάνισε Α[1]*Α[200]+Α[30]

Πέμπτη, 5 Δεκεμβρίου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν στις παρακάτω
προτάσεις.
1. Ο πίνακας Α[10, 20] έχει _______ στοιχεία.
2. Ο ακέραιος πίνακας Α[3, 4, 2] απαιτεί ____ bytes
    για την αποθήκευση του στην κύρια μνήμη RAM.
3. Αν ο πίνακας Α[200] είναι ταξινομημένος κατά
   φθίνουσα σειρά, το μεγαλύτερο στοιχείο είναι το
   ____.
4. Η συνάρτηση που ελέγχει αν μια αριθμητική τιμή
    είναι ακέραια είναι ________ τύπου.
5. Η  γλώσσα προγραμματισμού ______ είναι
    συναρτησιακή.

Απαντήσεις 

1. 200
2. 48
3. Α[1]
4. λογικού
5. LISP



Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Η δυαδική αναζήτηση είναι ο λιγότερο αποδοτικός
   τρόπος αναζήτησης τιμής σε πίνακα.
2. Όταν το βήμα μεταβολής είναι 1 σε μια
    Για..από..μέχρι παραλείπεται.
3. Η μέθοδος ταξινόμησης που επιλέγουμε εξαρτάται
    και από την αρχική διάταξη των στοιχείων του
    πίνακα.
4. Τα στοιχεία ενός πίνακα συχνοτήτων είναι
    μετρητές ιδιότητας.
5. Στους εμφωλευμένους βρόχους, ο βρόχος που
    βρίσκεται εξωτερικά ολοκληρώνεται πρώτος.

Απαντήσεις

1. Λ
2. Σ
3. Σ
4. Σ
5. Λ



Κυριακή, 17 Νοεμβρίου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η πρώτη γλώσσα προγραμματισμού υψηλού επιπέδου
    ήταν η _______.
2. Ο ακέραιος πίνακας Α[20] απαιτεί _____ bytes για την
    αποθήκευσή του στην κύρια μνήμη.
3. Μια μεταβλητή αρχικά έχει _________ τιμή.
4. Τα σχόλια δεν είναι ___________.
5. Ο δομημένος προγραμματισμός εμπεριέχει τόσο την
     ________ σχεδίαση όσο και τον ______ προγραμματισμό.



Απαντήσεις 

1. FORTRAN
2. 40
3. απροσδιόριστη
4. εκτελέσιμα
5. ιεραρχική, τμηματικό




Πέμπτη, 14 Νοεμβρίου 2013

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι
σωστές και ποιες λάθος;
1. Ένας αλγόριθμος μπορεί να περιλαμβάνει
    μία ή περισσότερες συμβολικές σταθερές.
2. Πίνακες+Αρχεία = Προγράμματα
3. Ένας δείκτης είναι μια μεταβλητή πραγματικού
    τύπου που χρησιμοποιείται για να προσδιορίσει
    τη θέση κάποιου στοιχείου μέσα σ' ένα πίνακα.
4. Τα προγράμματα σε BASIC εκτελούνται με τη
    βοήθεια διερμηνευτή.
5. Η FORTRAN υστερεί στη διαχείριση αλφαρι-
    θμητικών πληροφοριών.

Απάντηση

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ




Τετάρτη, 6 Νοεμβρίου 2013

Μετατροπή λογικού διαγράμματος σε ψευδοκώδικα

Γράψτε τον αλγόριθμο σε ψευδογλώσσα που αντιστοιχεί
στο παρακάτω λογικό διάγραμμα






































Λύση

Αλγόριθμος Ασκ
Για Κ από 1 μέχρι 30 με_βήμα 3
     Για Λ από 20 μέχρι 3 με_βήμα -1
          Για Μ από 4 μέχρι 37 με_βήμα 2
               Εμφάνισε Κ, Λ, Μ
          Τέλος_επανάληψης
     Τέλος_επανάληψης 
Τέλος_επανάληψης
Τέλος Ασκ


Σάββατο, 26 Οκτωβρίου 2013

Ποιες είναι οι διαφορές μεταγλωττιστή και διερμηνευτή;

1) Ο μεταγλωττιστής μεταφράζει όλες τις εντολές σε
    γλώσσα μηχανής και μετά τις εκτελεί. Ο διερμηνευτής
    μεταφράζει και εκτελεί επί τόπου μία εντολή κάθε
    φορά.
2) Ο διερμηνευτής παρέχει τη δυνατότητα πιο γρήγορου
    ελέγχου  και διόρθωσης των εντολών σε σχέση με το
    μεταγλωττιστή. Ο μεταγλωττιστής ωστόσο εξασφαλίζει
    ταχύτερη εκτέλεση του προγράμματος από το διερμηνευτή.
   

Συνηθισμένα σενάρια παραβίασης αλγοριθμικών κριτηρίων

Αναφέρετε τα πιο συνηθισμένα σενάρια παραβίασης
αλγοριθμικών κριτηρίων

Απάντηση

Είσοδος :  χρήση μιας μεταβλητής που δεν έχει πάρει
                 προηγουμένως τιμή.
Έξοδος :   ο αλγόριθμος δεν εμφανίζει κανένα αποτέλεσμα.
Περατότητα : κάποια επαναληπτική δομή δεν τερματίζεται
                      ποτέ (ατέρμων βρόχος).
Καθοριστικότητα :  σε κάποια εντολή πραγματοποιείται
                                 διαίρεση χωρίς να έχει διασφαλιστεί
                                 ότι ο παρονομαστής είναι διάφορος
                                 του μηδέν ή επιχειρείται ο υπολογισμός
                                 τετραγωνικής ρίζας χωρίς να έχει
                                 διασφαλιστεί ότι η υπόρριζος ποσότητα
                                 είναι μεγαλύτερη ή ίση του μηδενός.
Αποτελεσματικότητα: κάποια εντολή δίδεται με περιγραφικό
                                      τρόπο και μπορεί να αναλυθεί σε δύο
                                      ή περισσότερα απλούστερα βήματα.

Πίνακας αλήθειας

Κατασκευάστε τον πίνακα αλήθειας της παράστασης
     ΟΧΙ Χ ΚΑΙ Ρ  Ή ΟΧΙ Μ
όπου Χ, Ρ, Μ λογικές μεταβλητές

Απάντηση
Έστω ότι:
     Σ = ΟΧΙ Χ ΚΑΙ Ρ

 Χ    Ρ     Μ    ΟΧΙ Χ       ΟΧΙ Μ         Σ             Σ  Ή ΟΧΙ Μ
 Α    Α    Α         Ψ               Ψ         Ψ             Ψ
 Α    Α    Ψ         Ψ               Α         Ψ             Α
 Α    Ψ    Α         Ψ               Ψ         Ψ             Ψ
 Α    Ψ    Ψ         Ψ               Α         Ψ             Α
 Ψ    Α    Α         Α               Ψ         Α             Α
 Ψ    Α    Ψ         Α               Α         Α             Α
 Ψ    Ψ    Α         Α               Ψ         Ψ            Ψ
 Ψ    Ψ    Ψ         Α               Α         Ψ            Α

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Κάθε  πρόγραμμα τελειώνει με τη δεσμευμένη λέξη
    ΤΕΛΟΣ και το όνομα του προγράμματος.
2. Κάθε συνάρτηση υπολογίζει και επιστρέφει ένα μόνο
    αποτέλεσμα.
3. Μια διαδικασία δεν είναι απαραίτητο να ικανοποιεί
    τα αλγοριθμικά κριτήρια.
4. Μετά από την εκτέλεση μιας εντολής Διάβασε, ένα
    τουλάχιστον δεδομένο έχει εισαχθεί στον αλγόριθμο.
5. Οι εντολές Διάβασε και Γράψε εξουδετερώνουν η
   μία την άλλη.

Απαντήσεις

1. Λ
2. Σ
3. Λ
4. Σ
5. Λ


  

Δευτέρα, 21 Οκτωβρίου 2013

Καταγραφή πλήθους επαναλήψεων

Πόσες φορές εμφανίζουν τη λέξη 'ΤΕΣΤ' οι παρακάτω
εντολές;
     Διάβασε Υ
     Αρχή_επανάληψης
        Διάβασε Χ
        Για κ από Χ+1 μέχρι Υ
             Εμφάνισε 'ΤΕΣΤ'          
        Τέλος_επανάληψης
        Εμφάνισε 'ΤΕΣΤ'
     Μέχρις_ότου Α_Τ(Χ) >= 0
     Εμφάνισε 'ΤΕΣΤ'

Απάντηση

Η Μέχρις_ότου εκτελείται ακριβώς μια φορά
αφού η συνθήκη Α_Τ(Χ) >= 0 είναι Αληθής
ανεξάρτητα από την τιμή του Χ. Έτσι σίγουρα το
ΤΕΣΤ θα εμφανιστεί τουλάχιστον 2 φορές (μία
φορά θα το τυπώσει η Εμφάνισε που βρίσκεται
αμέσως μετά τη Για, και μια φορά η Εμφάνισε
που βρίσκεται έξω από τη Μέχρις_ότου).
Πάμε τώρα στη Για..από..μέχρι:
* Αν Χ+1 = Υ, δηλαδή Χ = Υ-1, θα εμφανιστεί το
   ΤΕΣΤ ακριβώς μια φορά
* Αν  Χ < Υ-1, το ΤΕΣΤ θα εμφανιστεί
     (Υ-(Χ+1)) div 1 + 1 = (Y-X-1)+1 = (Y-X) φορές
* Αν Χ > Υ-1, το ΤΕΣΤ δε θα εμφανιστεί καμία
   φορά.
Κατά συνέπεια, το συνολικό πλήθος εμφανίσεων
της λέξης ΤΕΣΤ είναι:
* 3, αν Χ = Υ-1
* Υ-Χ+2, αν Χ < Υ-1
* 2, αν Χ > Υ-1 

Κυριακή, 13 Οκτωβρίου 2013

Απλοποιήσεις

Ξαναγράψτε το παρακάτω σύνολο εντολών
χρησιμοποιώντας μία μόνο Για..από..μέχρι,
έτσι ώστε να εμφανίζει τα ίδια ακριβώς
αποτελέσματα στη μονάδα εξόδου.

     Για κ από 12 μέχρι 189 με_βήμα 11
          Για μ από 13 μέχρι 1000 με_βήμα 19
                 Αν μ = 19 τότε
                      Εμφάνισε κ+μ
                      Για λ από 120 μέχρι 10 με_βήμα -1
                            Αν λ = 100 τότε
                                 Εμφάνισε (κ-λ)*μ
                            Τέλος_αν
                      Τέλος_επανάληψης
                  Τέλος_αν
          Τέλος_επανάληψης
     Τέλος_επανάληψης

Λύση

     Για κ από 12 μέχρι 189 με_βήμα 11
          Εμφάνισε κ+19
          Εμφάνισε (κ-100)*19
     Τέλος_επανάληψης

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή επιλογή

1. Μια διαδικασία
    α. είναι ένα πρόγραμμα χωρίς συμβολικές σταθερές
    β. δεν μπορεί να υπολογίζει αποτελέσματα
    γ. δεν μπορεί να αντικατασταθεί από μια συνάρτηση
        που να επιτελεί την ίδια λειτουργία
    δ. έχει το δικό της τμήμα δήλωσης μεταβλητών και
       συμβολικών σταθερών

2. Οι αριθμητικοί τελεστές
    α. δεν έχουν καμιά απολύτως ιεραρχία
    β. έχουν μικρότερη προτεραιότητα από τους
        συγκριτικούς τελεστές
    γ. αποκαλούνται και πολλαπλασιαστές
    δ. έχουν μεγαλύτερη προτεραιότητα από τους
        λογικούς τελεστές

3. Οι εντολές ενός αλγορίθμου
     α. μπορεί και να μην τελειώνουν ποτέ
     β. εκτελούνται σε πεπερασμένο χρόνο
     γ. ικανοποιούν το κριτήριο της συνάφειας
     δ. μπορεί να είναι ασαφείς και απροσδιόριστες

4. Οι τεχνητές γλώσσες
    α. χρησιμοποιούνται για την επικοινωνία των ανθρώπων
        μεταξύ τους
    β. δεν έχουν συντακτικό
    γ. χρησιμοποιούνται για την επικοινωνία του ανθρώπου
        με τον υπολογιστή
    δ. είναι δυσνόητες και δύσχρηστες

5. Ο δομημένος προγραμματισμός
    α. στηρίζεται στις δομές της ακολουθίας, επιλογής και
        επανάληψης
    β. στηρίζεται στη χρήση της εντολής GOTO
    γ. οδηγεί σε μακροσκελή προγράμματα
    δ. είναι μια τεχνική σχεδίασης λογικών διαγραμμάτων
       

Απαντήσεις

1. δ
2. δ
3. β
4. γ
5. α




Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Κάθε πρόγραμμα τελειώνει με τη λέξη ΤΕΛΟΣ.
2. Η δομή επιλογής είναι η πιο απλή αλγοριθμική δομή.
3. Η εμβέλεια των ονομάτων σε μια συνάρτηση είναι
    καθολική.
4. Κάθε λογικό διάγραμμα αρχίζει και τελειώνει με
    ένα ρόμβο.
5. Αν Μ < Ν, τότε Μ div N = M




Απαντήσεις

1. Κάθε πρόγραμμα τελειώνει με τη λέξη
    ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
2. Η δομή ακολουθίας είναι η πιο απλή αλγοριθμική δομή.
3. Η εμβέλεια των ονομάτων σε μια συνάρτηση είναι
    τοπική.
4. Κάθε λογικό διάγραμμα αρχίζει και τελειώνει με
    μια έλλειψη.
5. Αν Μ < Ν, τότε Μ div N = 0



Πέμπτη, 10 Οκτωβρίου 2013

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές
και ποιες λάθος;
1. Μια δομή πολλαπλής επιλογής μπορεί να
    αντικατασταθεί από μια δομή απλής επιλογής
    που να επιφέρει το ίδιο αλγοριθμικό αποτέλεσμα.
2. Όταν το βήμα είναι 0, η περιεχόμενη ομάδα
    εντολών μιας Για..από..μέχρι εκτελείται άπειρες
    φορές.
3. Η καθοριστικότητα είναι ένας από τους τρόπους
    αναπαράστασης ενός αλγορίθμου.
4. Όταν η συνθήκη μιας Όσο..επανάλαβε είναι
    Αληθής, η περιεχόμενη ομάδα εντολών συνεχίζει
    να επαναλαμβάνεται.
5. Μια Μέχρις_ότου είναι ιδανική για έλεγχο
    ορθότητας εισερχόμενων δεδομένων και
    για την υλοποίηση προγραμμάτων που
    παρέχουν μενού λειτουργιών.

Απαντήσεις

1. Λ
2. Λ
3. Λ
4. Σ
5. Σ


Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
     Για κ από 12 μέχρι 29 με_βήμα 18
          Για λ από 10 μέχρι 7 με_βήμα -11
              Για μ από 20 μέχρι 80 με_βήμα 100
                    Εμφάνισε κ+λ+μ
              Τέλος_επανάληψης
          Τέλος_επανάληψης
     Τέλος_επανάληψης

Λύση

      * Η Για κ από ....γίνεται μία φορά (κ = 12)
      * Η Για λ από ... γίνεται μία φορά (λ = 10)
      * Η Για μ από ... γίνεται μία φορά (μ = 20)

      Έτσι η Εμφάνισε θα εκτελεστεί μία μόνο φορά και
      θα τυπώσει το αποτέλεσμα της παράστασης
      κ+λ+μ για κ = 12, λ = 10, μ = 20. Αφού
      κ+λ+μ = 12+10+20 = 42, η Εμφάνισε τυπώνει:
            42

Συμπληρώση κενών

Συμπληρώστε τα κενά που λείπουν ώστε το
παρακάτω σύνολο εντολών να εμφανίζει
όλους τους περιττούς ακεραίους από
το 1 έως και το 113

   Για κ από _____ μέχρι _____ με_βήμα ____
        Εμφάνισε  __*__ - 1
   Τέλος_επανάληψης

Απάντηση

     Για κ από 1 μέχρι 57 με_βήμα 1
        Εμφάνισε  2*κ - 1
     Τέλος_επανάληψης

Παρασκευή, 27 Σεπτεμβρίου 2013

Συνδιαστική

Δίνονται οι ακέραιες τιμές Α, Β με Α < Β. Γράψτε 
αλγόριθμο που εμφανίζει τις τετράδες
Χ,Υ,Ζ, Κ από το ακέραιο διάστημα τιμών
[1, 200] που έχουν άθροισμα μεγαλύτερο από  
την τιμή 2*Α+Β.

Λύση

Αλγόριθμος Συνδ
Για  Χ από 1 μέχρι 200
    Για  Υ από μέχρι 200
        Για  Ζ από μέχρι 200
            Για  Κ από μέχρι 200
                 Αν (Χ+Υ+Ζ+Κ) > 2*Α+Β τότε
                      Εμφάνισε Χ, Υ, Ζ, Κ
                 Τέλος_αν
            Τέλος_επανάληψης
        Τέλος_επανάληψης
    Τέλος_επανάληψης
Τέλος_επανάληψης
Τέλος Συνδ

Έλεγχος ιδιότητας ανά στήλη


Μέγιστο-ελάχιστο-κύρια διαγώνιος


Συγγραφή διαδικασίας


Συγγραφή συνάρτησης


Παρασκευή, 13 Σεπτεμβρίου 2013

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή επιλογή.
1. Ο αλγόριθμος
    α. είναι μια μορφή δεδομένων
    β. μπορεί να μην έχει έξοδο
    γ. υλοποιεί μια επεξεργασία δεδομένων
    δ. διατυπώνεται σε ΓΛΩΣΣΑ

2. Μια συνάρτηση
    α. μπορεί να κάνει οποιαδήποτε λειτουργία
    β. μπορεί να εκτυπώνει αποτελέσματα
    γ. να διαβάζει δεδομένα
    δ. υπολογίζει και επιστρέφει ένα μόνο
        αποτέλεσμα
 
3. Το λογικό διάγραμμα
    α. είναι ένας τρόπος αναπαράστασης αλγορίθμων
    β. είναι μια γλώσσα προγραμματισμού
    γ. δεν μπορεί να χρησιμοποιηθεί για την
        αναπαράσταση αλγορίθμων ακολουθιακής
       δομής
    δ. είναι άμεσα εκτελέσιμο στον υπολογιστή

4. Το πρόγραμμα
    α. εκτελείται στον υπολογιστή
    β. είναι γραμμένο σε ψευδογλώσσα
    γ. γράφεται στα Αγγλικά
    δ. είναι μια ακολουθία από 0 και 1

5. Μια δομή επιλογής
    α. επιτρέπει την επανάληψη μιας ομάδας
        εντολών
    β. επιτρέπει τη διενέργεια ενός ελέγχου πριν
        από την εκτέλεση κάποιων ενεργειών
    γ. ξεκινάει με τη δεσμευμένη λέξη
        Α_N
    δ. τελειώνει με τη δεσμευμένη λέξη
        ΑΛΛΙΩΣ

Απαντήσεις

1. γ
2. δ
3. α
4. α
5. β

Πέμπτη, 12 Σεπτεμβρίου 2013

Πίνακας αντιστοίχησης

Δίνονται οι  παρακάτω μεταβλητές
1. Επωνυμία δρόμου
2. Πλήθος επιβατών λεωφορείου
3. Ποσοστό ανδρών σε ένα σύλλογο
4. Αποτέλεσμα μιας εξεταστικής
    διαδικασίας (επιτυχής ή ανεπιτυχής)
5. Μάρκα μιας συσκευής
και οι τύποι:
α. ΑΚΕΡΑΙΕΣ
β. ΠΡΑΓΜΑΤΙΚΕΣ
γ. ΛΟΓΙΚΕΣ
δ. ΧΑΡΑΚΤΗΡΕΣ
Γράψτε τον αριθμό και δίπλα το κατάλληλο γράμμα
ώστε να προκύψει η σωστή αντιστοίχηση.

Απαντήσεις

1. δ
2. α
3. β
4. γ
5. δ

Τρίτη, 10 Σεπτεμβρίου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Τα ___________ δεδομένα γίνονται αντιληπτά από
    έναν εξωτερικό παρατηρητή με μια από τις πέντε
    ανθρώπινες αισθήσεις.
2. Το ___________ κείμενο είναι μια μορφή
    αναπαράστασης αλγορίθμων.
3. Το ΚΑΙ είναι ένας _________ τελεστής.
4. Η ________ των συγκριτικών τελεστών είναι
    μικρότερη αυτής των αριθμητικών.
5. Κάθε υποπρόγραμμα τελειώνει με τη
    δεσμευμένη λέξη _______ ή ________.


Απαντήσεις

1. δεδομένα
2. ελεύθερο
3. λογικός
4 ιεραρχία ή προτεραιότητα
5. ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ, ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


Διόρθωση λανθασμένων προτάσεων και επαναδιατύπωσή τους

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο.
1. Η δομή επιλογής επιτρέπει την επανάληψη μιας
    ομάδας εντολών.
2. Η πράξη div δίνει αποτέλεσμα πραγματικού τύπου.
3. Ένα πρόγραμμα πρέπει να έχει τουλάχιστον μια
    μεταβλητή.
4. Ο τμηματικός προγραμματισμός είναι μια
    τεχνική διάσπασης των προβλημάτων σε
    υποπροβλήματα.
5. Ο πίνακας εμπεριέχει μια ομάδα δεδομένων.



Απαντήσεις

1. Η δομή επανάληψης επιτρέπει την επανάληψη μιας
    ομάδας εντολών.
2. Η πράξη div δίνει αποτέλεσμα ακεραίου τύπου.
3. Ένα πρόγραμμα μπορεί να μην έχει καθόλου
    μεταβλητές.
4. Ο τμηματικός προγραμματισμός είναι μια
    τεχνική διάσπασης των προγραμμάτων σε
    υποπρογράμματα.
5. Ο πίνακας εμπεριέχει μια ομάδα δεδομένων ίδιου τύπου.

Παρασκευή, 6 Σεπτεμβρίου 2013

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές
και ποιες λάθος;
1. Η ταχύτητα είναι αλγοριθμικό κριτήριο.
2. Ο αλγόριθμος γράφεται στη γλώσσα προγραμματισμού
    PASCAL.
3. Το συνηθέστερο μέσο διατύπωσης των προβλημάτων
    είναι ο λόγος.
4. ΟΧΙ ΚΑΙ Υ) = ΟΧΙ Χ ΚΑΙ ΟΧΙ Υ
5. Ο πίνακας αλήθειας της λογικής παράστασης
          ΟΧΙ Ή Υ Ή Ζ)
    περιλαμβάνει 8 συνδυασμούς τιμών για τις
    μεταβλητές Χ, Υ, Ζ.


Απαντήσεις

1. Λ
2. Λ
3. Σ
4. Λ


Παρασκευή, 30 Αυγούστου 2013

Συγγραφή διαδικασίας


Συγγραφή συνάρτησης


Κυκλώστε τα σωστά

Ποιά από τα παρακάτω ισχύουν για τα υποπρογράμματα
1. Πρέπει να έχουν μεγάλο μέγεθος.
2. Πρέπει να έχουν μικρό μέγεθος.
3. Είναι ανεξάρτητα μεταξύ τους.
4. Μπορούν να καλούν και το κύριο πρόγραμμα.
5. Ενεργοποιούνται με μια ειδική εντολή.
6. Έχουν μια μόνο είσοδο και μια έξοδο.
7. Εκτελούν ένα αυτόνομο έργο.
8. Υπολογίζουν και επιστρέφουν τουλάχιστον
     ένα αποτέλεσμα.
9. Γράφονται πριν από το κύριο πρόγραμμα.
10. Μπορούν να πραγματοποιήσουν οποιαδήποτε
      λειτουργία.

Απαντήσεις

2, 3, 6, 7

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές
και ποιες λάθος;
1. Δεν γνωρίζουμε ποια είναι η πρώτη εντολή
    ενός προγράμματος.
2. Ένα πρόγραμμα με σχόλια εκτελείται πιο
    γρήγορα από το ίδιο πρόγραμμα χωρίς
    σχόλια.
3. Η λέξη ΠΡΑΓΜΑΤΙΚΟΣ είναι δεσμευμένη
    στη ΓΛΩΣΣΑ.
4. Αν ΠΠ συμβολική σταθερά, η εντολή
        ΓΡΑΨΕ ΠΠ
    δεν μπορεί να εκτελεστεί.
5. Αν Α[80] ακέραιος πίνακας που περιέχει
    τιμές από το 1 έως και το 80, η εντολή
        ΔΙΑΒΑΣΕ Α[Α[3]]
    μπορεί να προκαλέσει τη βίαιη διακοπή
    της εκτέλεσης του προγράμματος.

Απαντήσεις

1. Σ
2. Λ
3. Λ
4. Λ
5. Λ



Συγγραφή συνάρτησης


Τετάρτη, 21 Αυγούστου 2013

Μέγιστο - ελάχιστο



Μετρητές ιδιότητας - ποσοστά


Επαναδιατύπωση συνθηκών με περιορισμούς


Έλεγχος ορθότητας εντολών εκχώρησης


Εντολές εκχώρησης


Τετάρτη, 7 Αυγούστου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Η δομή ενός προβλήματος αποτυπώνεται κατά το
   στάδιο της _________.
2. Οι γλώσσες υψηλού επιπέδου ________ το κόστος
    παραγωγής των προγραμμάτων.
3. Η λέξη ΠΡΟΓΡΑΜΜΑ είναι _______ στη ΓΛΩΣΣΑ.
4. Ένας αλγόριθμος πρέπει να περιέχει τουλάχιστον μια
     εντολή ________.
5. Τα υποπρογράμματα πρέπει να είναι ___________
    μεταξύ τους.

Απαντήσεις

1. ανάλυσης
2. μείωσαν
3. δεσμευμένη
4. εξόδου
5. ανεξάρτητα


Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για την επεξεργασία των
δεδομένων
1. Περιλαμβάνει τουλάχιστον μια αριθμητική πράξη.
2. Μπορεί να περιλαμβάνει συγκρίσεις.
3. Εφαρμόζεται πάνω σε δεδομένα.
4. Μπορεί να γίνει από τον υπολογιστή ή τον ανθρώπινο
    εγκέφαλο.
5. Δέχεται ως είσοδο πληροφορίες.
6. Δίνει ως αποτέλεσμα άλλα δεδομένα.

Απαντήσεις

2, 3, 4

Κυριακή, 4 Αυγούστου 2013

Πίνακας αντιστοίχησης

Αντιστοιχήστε τα προβλήματα της ομάδας Α
με την κατηγορία στην οποία ανήκουν (ομάδα Β)
Ομάδα Α
1. Υπολογισμός όγκου κυλίνδρου.
2. Η κρίση στην ευρωζώνη.
3. Η προβολή ψηφιακού τηλεοπτικού προγράμματος
    από τηλεόραση παλιάς τεχνολογίας, χωρίς τη
    χρήση αποκωδικοποιητή.
4. Υπολογισμός συνολικού κόστους προμήθειας
     αγαθών από κατάστημα.
5. Κίνηση ενός βενζινοκίνητου οχήματος χωρίς
    βενζίνη

Ομάδα Β
α. Επιλύσιμα
β. Ανοικτά
γ. Άλυτα

Απαντήσεις

1. α
2. β
3. γ
4. α
5. γ



   

Σάββατο, 3 Αυγούστου 2013

Ερωτήσεις σωστού-λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και
ποιες λάθος;
1. Η ανάλυση είναι ένα από τα στάδια αντιμετώπισης
    ενός προβλήματος.
2. Η σαφήνεια στη διατύπωση είναι πρωταρχικός
    παράγοντας για την κατανόηση ενός προβλήματος.
3. Η καθοριστικότητα είναι ένας τρόπος αναπαράστασης
    αλγορίθμων.
4. Η δομή επιλογής είναι μια αλγοριθμική συνιστώσα.
5. Το αποτέλεσμα της πράξης mod είναι πάντοτε
    μικρότερο ή ίσο του 1.



Απαντήσεις

1. Σ
2. Σ
3. Λ
4. Σ
5. Λ


Παρασκευή, 2 Αυγούστου 2013

Διατύπωση περιορισμών

Διατυπώστε τους παρακάτω περιορισμούς στη ΓΛΩΣΣΑ
1. Χ = 10 ή 20 ή 30
2. Το Υ είναι διάφορο του 5 και του 100
3. Το Ζ είναι πολλαπλάσιο του 6 αλλά όχι του 8
4. Το Μ είναι περιττός και αρνητικός
5. Το Ν είναι θετικός ακέραιος στο διάστημα
    [19, 28].

Απαντήσεις

1. (Χ = 10) Ή (Χ = 20) Ή (Χ = 30)
2. (Υ < > 5) ΚΑΙ (Υ < > 100)
3. (Ζ mod 6 = 0) KAI (Z mod 8 < > 0)
4. (M mod 2 = 1) KAI (M < 0)
5. (A_M(N) = N) KAI (N  >= 19) KAI (N <= 28)

Τρίτη, 23 Ιουλίου 2013

Ερωτήσεις πολλαπλής επιλογής

Επιλέξτε τη σωστή απάντηση

1. Στη διαγραμματική αναπαράσταση της Μέχρις_ότου
    α. ο ρόμβος βρίσκεται στην κορυφή
    β. ο ρόμβος έχει τρεις εξόδους
    γ. υπάρχουν πολύ μεγάλες ομοιότητες με τη
        διαγραμματική αναπαράσταση της Για..από..μέχρι
    δ. σχηματίζεται ένας βρόχος (θηλιά)

2. Σε ένα  πρόβλημα
    α. τα δεδομένα είναι πάντοτε τα ίδια
    β. η λύση μπορεί να είναι και προφανής
    γ. υπάρχει πάντοτε κάποια λύση
    δ. δεν είναι απαραίτητο η λύση να προέλθει
        από ένα ηλεκτρονικό υπολογιστή

3. Μια συνάρτηση
    α. μπορεί να έχει (προαιρετικά) ένα τύπο
    β. μπορεί να επιτελεί ένα αυτόνομο έργο
    γ. εμφανίζει πάντοτε τα αποτελέσματά της
        στην οθόνη
    δ. ενεργοποιείται αμέσως μόλις ξεκινήσει
        το πρόγραμμα

4. Η γλώσσα C
    α. είναι αντικειμενοστραφής
    β. είναι ιδανική για προγραμματισμό στο
        διαδίκτυο
    γ. μπορεί να χρησιμοποιηθεί για τη δημιουργία
        λειτουργικών συστημάτων
    δ. είναι εξέλιξη της γλώσσας JAVA

5. Ο δείκτης σε ένα μονοδιάστατο πίνακα
    α. είναι μια σταθερά ή μεταβλητή ή παράσταση
        ακεραίου τύπου
    β. μπορεί να πάρει ως τιμή ένα θετικό
        αριθμό ή το μηδέν
    γ. καθορίζει τον τύπο δεδομένων του πίνακα
        αυτού
    δ. περικλείεται ανάμεσα σε άγκιστρα

   

Απαντήσεις

1. δ
2. δ
3. β
4. γ
5. α



Βρείτε το πλήθος των επαναλήψεων

Πόσες φορές θα εμφανιστεί η λέξη 'ΝΚ' μετά την εκτέλεση
των παρακάτω εντολών;
    Για κ από Α-10 μέχρι Β+3 με_βήμα Γ+7
         Εμφάνισε 'ΝΚ'
    Τέλος_επανάληψης

Λύση

 * Γ = -7 (βήμα μηδέν)
       Αν (Α - 10 <= Β+3)  = (Α <= Β+13), άπειρες φορές
       Αν Α > Β+13, καμία φορά

* Γ > -7  (βήμα θετικό)
       Αν Α < Β+13, τουλάχιστον μία φορά
       Αν Α = Β+13, ακριβώς μία φορά
       Αν Α > Β+13, καμία φορά

* Γ < -7 (βήμα αρνητικό)
      Αν Α < Β+13, καμία φορά
      Αν Α = Β+13, ακριβώς μία φορά
      Αν Α > Β+13, τουλάχιστον μία φορά

Πίνακας αλήθειας

Κατασκευάστε τον πίνακα αλήθειας της λογικής
παράστασης
     Π =  ΟΧΙ Ή Υ ΚΑΙ Ζ)

Λύση
Ας συμβολίσουμε με Α - Αληθής, Ψ - Ψευδής

         Χ       Υ      Ζ     Υ ΚΑΙ Ζ    Χ Ή Υ ΚΑΙ Ζ            Π
       ____________________________________________
          Α       Α     Α           Α                   Α               Ψ
          Α       Α     Ψ           Ψ                   Α               Ψ
          Α       Ψ     Α           Ψ                   Α               Ψ
          Α       Ψ     Ψ           Ψ                   Α               Ψ
          Ψ       Α     Α           Α                   Α               Ψ
          Ψ       Α     Ψ           Ψ                   Ψ               Α
          Ψ       Ψ     Α           Ψ                   Ψ               Α
          Ψ       Ψ     Ψ           Ψ                   Ψ               Α

Σάββατο, 20 Ιουλίου 2013

Πίνακας δεδομένων-ζητουμένων

Σε ένα χωριό, το 30% των κατοίκων είναι άνδρες, το 45% είναι
γυναίκες και το 25% είναι παιδιά. Αν το πλήθος των γυναικών
είναι κατά 540 μεγαλύτερο από αυτό των ανδρών και το
πλήθος των παιδιών είναι κατά 180 μικρότερο από αυτό των
ανδρών, να βρείτε το πλήθος των ανδρών, των γυναικών, των
παιδιών και το συνολικό πλήθος των κατοίκων του παραπάνω
χωριού.
Α) Κατασκευάστε πίνακα δεδομένων-ζητουμένων
Β) Μορφοποιήστε με μαθηματικό τρόπο το πρόβλημα.

Λύση

Α)
      Δεδομένα     * Το 30% των κατοίκων είναι άνδρες
                           * Το 45% των κατοίκων είναι γυναίκες
                           * Το 25% των κατοίκων είναι παιδιά
                           * Το πλήθος των γυναικών είναι κατά
                              540 μεγαλύτερο από αυτό των ανδρών
                           * Το πλήθος των παιδιών είναι κατά 180
                              μικρότερο από αυτό των ανδρών
   
      Ζητούμενα   * Το πλήθος των ανδρών
                           * Το πλήθος των γυναικών
                           * Το πλήθος των παιδιών
                           * Το συνολικό πλήθος όλων των κατοίκων

Β)  Ας συμβολίσουμε με
           Σύνολο : το συνολικό πλήθος των κατοίκων
           Παιδιά : το πλήθος των παιδιών
           Γυναίκες : το πλήθος των γυναικών  
           Άνδρες : το πλήθος των ανδρών
     Ισχύουν οι σχέσεις:
              Παιδιά = Άνδρες-180
              Γυναίκες = Άνδρες+540
              Άνδρες+Γυναίκες+Παιδιά = Σύνολο
              Άνδρες = Σύνολο*30/100
              Γυναίκες = Σύνολο*45/100
              Παιδιά = Σύνολο*25/100
       

Σαφήνεια διατύπωσης

Επιλύστε την εξίσωση 5Χ+12 = 0. Είναι το παραπάνω
πρόβλημα διατυπωμένο με σαφήνεια και ακρίβεια;

Απάντηση

'Οχι, γιατί λείπει το πεδίο ορισμού της εξίσωσης.
Για παράδειγμα στο Ν είναι αδύνατη ενώ στο R
έχει λύση -12/5.

Πέμπτη, 18 Ιουλίου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1. Το πρόγραμμα είναι ένας _________ διατυπωμένος
    σε μια γλώσσα προγραμματισμού.
2. Το πρόβλημα που δεν γνωρίζουμε ούτε αν λύνεται
    ούτε αν δε λύνεται χαρακτηρίζεται _______.
3. Μια γλώσσα ______ γενιάς δεν απαιτεί ιδιαίτερες
    γνώσεις προγραμματισμού.
4. Το υποπρόγραμμα επιτελεί ένα _______ έργο.
5. Τα στοιχεία των πινάκων είναι _______ τύπου.

Απαντήσεις

1. αλγόριθμος
2. ανοικτό
3. 4ης
4. αυτόνομο
5. ίδιου


Τρίτη, 9 Ιουλίου 2013

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Ένα από τα κριτήρια κατηγοριοποίησης των
    προβλημάτων είναι και το κόστος της επίλυσης
    που επιζητούν.
2. Μια μέθοδος αναζήτησης σε μη ταξινομημένο
    πίνακα είναι η σειριακή ή γραμμωτή μέθοδος.
3. Μια μεταβλητή της ΓΛΩΣΣΑΣ έχει ένα μοναδικό
    όνομα και μεταβλητό τύπο δεδομένων.
4. Η αρχή και το τέλος σε ένα λογικό διάγραμμα
    παριστάνεται με ένα πλάγιο παραλληλόγραμμο.
5. Η ιεραρχική σχεδίαση είναι μια τεχνική ανάλυσης
    προβλήματος σε υποπροβλήματα, από κάτω
    προς τα πάνω.



Απαντήσεις

1. Ένα από τα κριτήρια κατηγοριοποίησης των
    προβλημάτων είναι και το είδος της επίλυσης
    που επιζητούν.
2. Μια μέθοδος αναζήτησης σε μη ταξινομημένο
    πίνακα είναι η σειριακή ή γραμμική μέθοδος.
3. Μια μεταβλητή της ΓΛΩΣΣΑΣ έχει ένα μοναδικό
    όνομα και μοναδικό τύπο δεδομένων.
4. Η αρχή και το τέλος σε ένα λογικό διάγραμμα
    παριστάνεται με μια έλλειψη.
5. Η ιεραρχική σχεδίαση είναι μια τεχνική ανάλυσης
    προβλήματος σε υποπροβλήματα, από πάνω
    προς τα κάτω.


Πέμπτη, 4 Ιουλίου 2013

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες
λάθος;
1. Πολύ σημαντικός παράγοντας για την επίλυση ενός
    προβλήματος είναι η οριοθέτηση του χώρου του.
2. Ένα αδόμητο πρόβλημα δεν μπορεί να είναι
    επιλύσιμο.
3. Το πρόβλημα του έτους 2000 είχε να κάνει με τον
    τρόπο αποθήκευσης της ημερομηνίας στη μνήμη
    των παλαιών υπολογιστών.
4.  Ο υπολογιστής δρα επικουρικά στην ανθρώπινη
     δραστηριότητα.
5.  Η βασική πράξη που μπορεί να κάνει ο υπολογιστής
    και στην οποία στηρίζονται όλες οι άλλες πράξεις
    είναι ο πολλαπλασιασμός.

Απαντήσεις

1. Σ
2. Λ
3. Σ
4. Σ
5. Λ


Σάββατο, 29 Ιουνίου 2013

Συμπλήρωση κενών

Συμπληρώστε τα κενά που λείπουν
1.  (9 div 10) * 2013 = _____
2. (4*κ+7) mod 2 >= 1 = ____________ (το κ είναι ακέραιο)
3. 'ΑΕΡΑΣ' > 'ΑΕΡΑΤΟΣ' = _________
4. ΟΧΙ ( (Χ = 'α') Ή (Χ = 'β') Ή (Χ = 'γ') ) = ___________
5. ΟΧΙ ( (Χ > 3) ΚΑΙ (Χ < 11) ) = _________

Απαντήσεις

1. 0
2. Aληθής
3. Ψευδής
4. (Χ < > 'α') ΚΑΙ (Χ < > 'β') ΚΑΙ (Χ < > 'γ')
5. (Χ <= 3) Ή (Χ >= 11)


Κυκλώστε τα σωστά

Ποια από τα παρακάτω ισχύουν για τα λογικά λάθη
1. Εντοπίζονται ευκολότερα από τα συντακτικά
2. Μπορεί να οδηγήσουν ακόμα και σε απότομη
    διακοπή της εκτέλεσης του προγράμματος.
3. Εντοπίζονται από το διερμηνευτή ή τον
    μεταγλωττιστή.
4. Διαπιστώνονται κατά την εκτέλεση του προγράμματος.
5. Παραβιάζουν το συντακτικό της γλώσσα προγραμματισμού.
6. Έχουν άμεση σχέση με τον αλγόριθμο που επιλέξαμε για
    την επίλυση του προβλήματος.

Απαντήσεις

2, 4, 6

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Τα προβλήματα επιδέχονται τουλάχιστον μια λύση.
2. Τριγωνικός αποκαλείται ο δισδιάστατος πίνακας που
    έχει ίσο αριθμό γραμμών και στηλών.
3. Α_Μ(-8.3) = 8.3
4. Η γλώσσα Pascal είναι μια γλώσσα προγραμματισμού
    ειδικής χρήσης.
5. Ο τμηματικός προγραμματισμός στηρίζεται στη
    φιλοσοφία της ανάλυσης ενός προβλήματος
    σε υποπροβλήματα.


Απαντήσεις

1. Τα επιλύσιμα προβλήματα επιδέχονται τουλάχιστον μια λύση.
2. Τετραγωνικός αποκαλείται ο δισδιάστατος πίνακας που
    έχει ίσο αριθμό γραμμών και στηλών.
3. Α_Μ(-8.3) = -8
4. Η γλώσσα Pascal είναι μια γλώσσα προγραμματισμού
    γενικής χρήσης.
5. Ο τμηματικός προγραμματισμός στηρίζεται στη
    φιλοσοφία της ανάλυσης ενός προγράμματος
    σε υποπρογράμματα.

Τετάρτη, 26 Ιουνίου 2013

Ερωτήσεις σωστού - λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1. Η ανάλυση είναι ένα από τα στάδια αντιμετώπισης προβλημάτων.
2. Η διόρθωση των προγραμμάτων που έχουν γραφεί σε γλώσσα
    μηχανής είναι πολύ εύκολο έργο.
3. Ένας από τους παράγοντες που επηρεάζουν την επιλογή μιας
    γλώσσας προγραμματισμού είναι οι γνώσεις και οι εμπειρίες
    του προγραμματιστή.
4. Ο πίνακας είναι μια στατική δομή δεδομένων που
    αποτελείται από εγγραφές.
5. Για κάθε πρόβλημα υπάρχει ένας μοναδικός αλγόριθμος που
    το επιλύει.
 

Απαντήσεις

1. Σ
2. Λ
3. Σ
4. Λ
5. Λ


Πέμπτη, 13 Ιουνίου 2013

Πίνακας δεδομένων-ζητουμένων και μαθηματική μορφοποίηση

Σ' ένα γυμνάσιο φοιτούν 560 μαθητές. Αν τα αγόρια είναι διπλάσια
από τα κορίτσια, ποιο είναι το πλήθος των αγοριών και ποιο το
πλήθος των κοριτσιών σ' αυτό το σχολείο;
α) Κατασκευάστε πίνακα δεδομένων - ζητουμένων
β) Μορφοποιήστε με μαθηματικό τρόπο το πρόβλημα

Λύση

α) 
     Δεδομένα   
         * Το συνολικό πλήθος των μαθητών είναι 560
         * Το πλήθος των αγοριών είναι διπλάσιο αυτού
            των κοριτσιών
     Ζητούμενα
         * Πόσα είναι τα αγόρια;
         * Πόσα είναι τα κορίτσια;

β) Ας συμβολίσουμε με
        Αγ : το πλήθος των αγοριών
        Κο : το πλήθος των κοριτσιών
   Ισχύουν οι σχέσεις:
        Αγ+Κο = 560
        Αγ = 2*Κο

Τρίτη, 11 Ιουνίου 2013

Αντιστοιχήσεις

Δίνονται οι παρακάτω λέξεις
    1. ημιδομημένα
    2. δομή επιλογής
    3. διαδικασία
    4. γλώσσα προγραμματισμού
    5. ΟΧΙ
και τα ακόλουθα:
    α. υποκατηγορία των επιλύσιμων προβλημάτων
    β. υποκατηγορία προβλημάτων
    γ. Αν..τότε..αλλιώς_αν
    δ. Όσο..επανάλαβε
    ε. τρόπος αναπαράστασης αλγορίθμων
   στ. είδος υποπρογράμματος
    ζ. φυσική γλώσσα
    η. τεχνητή γλώσσα
    θ. συγκριτικός τελεστής
    ι. λογικός τελεστής
Γράψτε τον αριθμό (1-5) και δίπλα το γράμμα (α-ι) έτσι
ώστε να προκύπτει σωστή αντιστοίχηση.

Απαντήσεις

 1. α
 2. γ
 3. στ
 4. η
 5. ι

Σάββατο, 8 Ιουνίου 2013

Ερωτήσεις πολλαπλής επιλογής

Κυκλώστε τη σωστή επιλογή

1. Ο καθορισμός απαιτήσεων
    α. είναι απαραίτητος σε ένα λογικό διάγραμμα
    β. περιλαμβάνει τον προσδιορισμό των
        δεδομένων και των ζητουμένων σε ένα
        πρόβλημα
    γ. μπορεί να γίνει μόνο στα δομημένα
        προβλήματα
    δ. είναι ένας τρόπος αναπαράστασης αλγορίθμων

2. Ο πολλαπλασιασμός αλά ρωσικά
    α. είναι μια μέθοδος πολλαπλασιασμού
        θετικών αριθμών
    β. είναι μια μέθοδος πολλαπλασιασμού
        αρνητικών αριθμών
    γ. είναι μια μέθοδος πολλαπλασιασμού
        θετικών ακεραίων αριθμών
    δ. είναι μια μέθοδος πολλαπλασιασμού
        αρνητικών ακεραίων αριθμών

3. Ο πίνακας
     α. καταλαμβάνει χώρο στη δευτερεύουσα μνήμη
     β. επεκτείνει τις δυνατότητες μιας γλώσσας
         προγραμματισμού
     γ. διατηρεί τα δεδομένα του για πάντα
     δ. είναι μια στατική δομή δεδομένων
   
4.  Ένα πρόγραμμα σε γλώσσα μηχανής
     α. είναι άμεσα εκτελέσιμο
     β. απαιτεί τη χρήση μεταφραστικού προγράμματος
         προκειμένου να εκτελεστεί
     γ. έχει υψηλή μεταφερσιμότητα
     δ. μπορεί εύκολα να διορθωθεί και να συντηρηθεί

5. Μια συνάρτηση
    α. δεν μπορεί να καλεί άλλη συνάρτηση
    β. δεν μπορεί να καλεί διαδικασία
    γ. επιστρέφει τουλάχιστον ένα αποτέλεσμα
    δ. έχει ένα συγκεκριμένο τύπο


Απαντήσεις

1. β
2. γ
3. δ
4. α
5. δ

Διόρθωση λανθασμένων προτάσεων

Διορθώστε τις παρακάτω λανθασμένες προτάσεις και
επαναδιατυπώστε τις με σωστό τρόπο
1. Το ελεύθερο κείμενο είναι ένας από τους
    δυνατούς τρόπους διατύπωσης προγραμμάτων.
2.  Στη δομή επιλογής οι εντολές εκτελούνται
     ακριβώς μια φορά και με τη σειρά που έχουν
     γραφεί.
3.  Η μέθοδος ευθείας συναλλαγής αποκαλείται
     και φυσαλίδα.
4.  Κάθε διαδικασία μπορεί να υλοποιηθεί και
     ως συνάρτηση.
5. Η γλώσσα SQL είναι 3ης γενιάς.



Απαντήσεις

1. Το ελεύθερο κείμενο είναι ένας από τους
    δυνατούς τρόπους διατύπωσης αλγορίθμων.
2. Στη δομή ακολουθίας οι εντολές εκτελούνται
     ακριβώς μια φορά και με τη σειρά που έχουν
     γραφεί.
3.  Η μέθοδος ευθείας ανταλλαγής αποκαλείται
     και φυσαλίδα.
4.  Κάθε συνάρτηση μπορεί να υλοποιηθεί και
     ως διαδικασία.
5. Η γλώσσα SQL είναι 4ης  γενιάς. 

Συμπληρώστε τα κενά

Συμπληρώστε τα κενά στις παρακάτω προτάσεις
1.  Αν ο πίνακας Α[9, 10] περιέχει ακέραιες τιμές
     απαιτούνται _____ bytes για την αποθήκευσή
     του στη μνήμη.
2.  Ένα πρόβλημα που είναι _______ με ένα άλλο
     επιλύσιμο πρόβλημα, είναι και αυτό επιλύσιμο.
3.  Κάθε υποπρόγραμμα πρέπει να μην είναι
     πολύ _______.
4. Οι _________ γλώσσες χαρακτηρίζονται και ως
    γλώσσες χαμηλού επιπέδου.
5. Για να έχει η παράσταση ΟΧΙ Χ ΚΑΙ ΟΧΙ Υ
    την τιμή ΑΛΗΘΗΣ, πρέπει τόσο το Χ όσο
    και το Υ να έχουν τιμή _______.

Απαντήσεις

1. 180
2. συναφές
3. μεγάλο
4. συμβολικές
5. ΨΕΥΔΗΣ


Κυκλώστε τα σωστά

Κυκλώστε τις σωστές προτάσεις
1. Το Ν mod 2 είναι ένας ζυγός αριθμός.
2. Το 2*Ν+7 είναι ένας περιττός αριθμός.
3.  Η λέξη ΣΥΝΑΡΤΗΣΗΣ είναι δεσμευμένη στη
     ΓΛΩΣΣΑ.
4.  Οι πίνακες περιορίζουν τις ιδιότητες του προγράμματος.
5.  Τα αρχεία είναι δομές δεδομένων στη δευτερεύουσα
      μνήμη.
6.  Στα δομημένα προβλήματα η λύση επιλέγεται μέσα
     από ένα στενό σύνολο δυνατών επιλογών.
7.  Η γλώσσα JAVA είναι αντικειμενοστραφής.
8.  Η εντολή ΟΣΟ..ΕΠΑΝΑΛΑΒΕ είναι μια μορφή
     δομής επιλογής.
9.  Η ολίσθηση προς τα αριστερά κατά μια θέση
     προκαλεί το διπλασιασμό ενός αριθμού.
10. Η σειριακή αναζήτηση χρησιμοποιείται
      μόνο όταν ο πίνακας είναι ταξινομημένος.


Απαντήσεις

2, 4, 5,  7,  9

Δευτέρα, 3 Ιουνίου 2013

Ερωτήσεις σωστού λάθους

Ποιες από τις παρακάτω προτάσεις είναι σωστές και ποιες λάθος;
1.  Ο τελεστής ΟΧΙ είναι λογικός και έχει τη μικρότερη ιεραρχία
     από όλους τους άλλους.
2.  Ένας πίνακας λογικού τύπου δεν μπορεί να ταξινομηθεί.
3. Μια από τις τυπικές επεξεργασίες πινάκων είναι και
    η αντιγραφή.
4. Το ελεύθερο κείμενο είναι ένας τρόπος αναπαράστασης
    αλγορίθμων που κινδυνεύει να παραβιάσει το
    κριτήριο της καθοριστικότητας.
5. Τα δεδομένα σ' ένα πρόβλημα γίνονται αντιληπτά από
    έναν εξωτερικό παρατηρητή με μια από τις πέντε
    ανθρώπινες αισθήσεις.


Απαντήσεις

1. Λ
2. Σ
3. Λ
4. Λ
5. Σ