Κυριακή, 13 Οκτωβρίου 2013

Απλοποιήσεις

Ξαναγράψτε το παρακάτω σύνολο εντολών
χρησιμοποιώντας μία μόνο Για..από..μέχρι,
έτσι ώστε να εμφανίζει τα ίδια ακριβώς
αποτελέσματα στη μονάδα εξόδου.

     Για κ από 12 μέχρι 189 με_βήμα 11
          Για μ από 13 μέχρι 1000 με_βήμα 19
                 Αν μ = 19 τότε
                      Εμφάνισε κ+μ
                      Για λ από 120 μέχρι 10 με_βήμα -1
                            Αν λ = 100 τότε
                                 Εμφάνισε (κ-λ)*μ
                            Τέλος_αν
                      Τέλος_επανάληψης
                  Τέλος_αν
          Τέλος_επανάληψης
     Τέλος_επανάληψης

Λύση

     Για κ από 12 μέχρι 189 με_βήμα 11
          Εμφάνισε κ+19
          Εμφάνισε (κ-100)*19
     Τέλος_επανάληψης

1 σχόλιο:

  1. Καλησπέρα, χρειάζεται μια μικρή διόρθωση. Στο πρώτο αν πρέπει να μπει "Αν μ = 13" και στο απλοποιημένο όπου 19 να αντικατασταθεί με την τιμή 13.

    ΑπάντησηΔιαγραφή