Πέμπτη, 10 Οκτωβρίου 2013

Έξοδος αποτελεσμάτων

Τι θα εμφανίσει το παρακάτω σύνολο εντολών;
     Για κ από 12 μέχρι 29 με_βήμα 18
          Για λ από 10 μέχρι 7 με_βήμα -11
              Για μ από 20 μέχρι 80 με_βήμα 100
                    Εμφάνισε κ+λ+μ
              Τέλος_επανάληψης
          Τέλος_επανάληψης
     Τέλος_επανάληψης

Λύση

      * Η Για κ από ....γίνεται μία φορά (κ = 12)
      * Η Για λ από ... γίνεται μία φορά (λ = 10)
      * Η Για μ από ... γίνεται μία φορά (μ = 20)

      Έτσι η Εμφάνισε θα εκτελεστεί μία μόνο φορά και
      θα τυπώσει το αποτέλεσμα της παράστασης
      κ+λ+μ για κ = 12, λ = 10, μ = 20. Αφού
      κ+λ+μ = 12+10+20 = 42, η Εμφάνισε τυπώνει:
            42

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου