Κυριακή, 27 Μαρτίου 2011

Άσκηση : πρόγραμμα + υποπρογράμματα

Ι. Γράψτε συνάρτηση με όνομα Έλεγχος η οποία δέχεται ως
    παραμέτρους δύο πραγματικές τιμές Α, Β και ελέγχει αν
    το Β υπολείπεται του Α τουλάχιστον κατά 13%.
ΙΙ. Γράψτε διαδικασία με όνομα Φίλτρο η οποία δέχεται
     ως παραμέτρους:
       * έναν πραγματικό πίνακα Γ[25],
       * μια πραγματική τιμή Δ,
     και εμφανίζει τους αύξοντες αριθμούς των στοιχείων του
     πίνακα που υπολείπονται του Δ τουλάχιστον κατά 13%.
     Η διαδικασία πρέπει να καλεί με κατάλληλο τρόπο τη
     συνάρτηση Έλεγχος.
ΙΙΙ. Γράψτε πρόγραμμα το οποίο:
      α) Διαβάζει τους μέσους όρους βαθμολογίας των 25
           μαθητών μιας τάξης και τους καταχωρεί σε κατάλληλο
           μονοδιάστατο πίνακα ΠΙΝ,
      β)  Για κάθε τιμή της μεταβλητής ΒΑΘΜΟΣ από το 17.2
            μέχρι και το 20.0, με ενδιάμεσο βήμα μεταβολής το
            0.1, υπολογίζει και εμφανίζει τους αύξοντες αριθμούς
            των στοιχείων του  πίνακα που υπολείπονται του
            ΒΑΘΜΟΣ  τουλάχιστον κατά 13%.
      Το πρόγραμμα πρέπει να καλεί με κατάλληλο τρόπο τη
       διαδικασία Φίλτρο.

Λύση

        ΠΡΟΓΡΑΜΜΑ ΑΣΚ
        ΜΕΤΑΒΛΗΤΕΣ
                ΑΚΕΡΑΙΕΣ: κ
                ΠΡΑΓΜΑΤΙΚΕΣ: ΜΟ[25], ΒΑΘΜΟΣ
        ΑΡΧΗ
                ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 25
                      ΔΙΑΒΑΣΕ ΜΟ[κ]
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                ΓΙΑ ΒΑΘΜΟΣ ΑΠΟ 17.2 ΜΕΧΡΙ 20.0 ΜΕ_ΒΗΜΑ 0.1
                      ΚΑΛΕΣΕ Φίλτρο(ΜΟ, ΒΑΘΜΟΣ)
                ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


        ΣΥΝΑΡΤΗΣΗ Έλεγχος(Α, Β) : ΛΟΓΙΚΗ
        ΜΕΤΑΒΛΗΤΕΣ
               ΠΡΑΓΜΑΤΙΚΕΣ: Α, Β, ΠΟΣ
        ΑΡΧΗ
               ΠΟΣ <-- 100*(Α-Β)/Α
               ΑΝ ΠΟΣ >= 13 ΤΟΤΕ
                     Έλεγχος <-- ΑΛΗΘΗΣ
               ΑΛΛΙΩΣ
                     Έλεγχος <-- ΨΕΥΔΗΣ
               ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


        ΔΙΑΔΙΚΑΣΙΑ Φίλτρο(Γ, Δ)
        ΜΕΤΑΒΛΗΤΕΣ
                 ΠΡΑΓΜΑΤΙΚΕΣ: Γ[25], Δ, ΠΟΣ
                 ΑΚΕΡΑΙΕΣ: κ, Φ
                 ΛΟΓΙΚΕΣ: ΑΠ
        ΑΡΧΗ
                 Φ <-- 0
                 ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 25
                       ΑΠ <-- Έλεγχος(Δ, Γ[κ])
                       ΑΝ ΑΠ = ΑΛΗΘΗΣ ΤΟΤΕ
                             ΓΡΑΨΕ κ
                       ΤΕΛΟΣ_ΑΝ
                 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                 ΑΝ Φ = 0 ΤΟΤΕ
                       ΓΡΑΨΕ 'Δεν υπάρχει κανένας μαθητής που'
                       ΓΡΑΨΕ 'ο ΜΟ του να υπολείπεται του', Δ
                       ΓΡΑΨΕ 'τουλάχιστον κατά 13%'
                 ΤΕΛΟΣ_ΑΝ
        ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ


        

Σάββατο, 26 Μαρτίου 2011

Άσκηση : Εμφωλευμένα Για + βοηθητικός πίνακας

Γράψτε αλγόριθμο που εμφανίζει το αποτέλεσμα
της λογικής παράστασης
  ΟΧΙ Α ΚΑΙ (ΟΧΙ Β Ή  Γ) Ή ΟΧΙ Δ

Λύση

        Αλγόριθμος ΑΣΚ
        Τιμ[1] <-- Αληθής
        Τιμ[2] <-- Ψευδής
        Για κ από 1 μέχρι 2
            Για λ από 1 μέχρι 2
               Για μ από μέχρι 2
                     Για ν από μέχρι 2
                          Εμφάνισε 'Α = ', Τιμ[κ], ' Β = ', Τιμ[λ]
                          Εμφάνισε 'Γ = ', Τιμ[μ], ' Δ = ', Τιμ[ν]
                          Β1 <-- ΟΧΙ (Τιμ[κ])
                          Β2 <-- ΟΧΙ (Τιμ[λ]) Ή Τιμ[μ]
                          Β3 <-- ΟΧΙ (Τιμ[ν])
                          Αποτ <-- Β1 ΚΑΙ Β2 Ή Β3
                          Εμφάνισε 'Αποτέλεσμα =', Αποτ
                     Τέλος_επανάληψης
                Τέλος_επανάληψης
            Τέλος_επανάληψης
        Τέλος_επανάληψης
        Τέλος ΑΣΚ

Παρασκευή, 25 Μαρτίου 2011

Άσκηση : συγγραφή συνάρτησης

Ο καθηγητής πληροφορικής υποβάλλει τους 30 μαθητές της
τάξης του σε ένα τεστ που περιλαμβάνει 18 ερωτήσεις.
Θεωρήστε τον πίνακα Απ[30, 18] που περιέχει τις
απαντήσεις των μαθητών σε κάθε ερώτηση ( Ο - ορθή
απάντηση, Λ - λανθασμένη απάντηση).
Γράψτε συνάρτηση που δέχεται ως παράμετρο τον Απ
και υπολογίζει τον αύξοντα αριθμό (1-18) της ερώτησης
στην οποία έδωσαν λανθασμένη απάντηση οι περισσότεροι
μαθητές (θεωρείστε ότι είναι μοναδική).

Λύση

      ΣΥΝΑΡΤΗΣΗ Δύσκολη(Απ) : ΑΚΕΡΑΙΑ
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Πληθ, κ , λ, Φορές[18], ΜΑΧ, ΑΑΜΑΧ, Φ
            ΧΑΡΑΚΤΗΡΕΣ: Απ[30, 18]
      ΑΡΧΗ
            ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 18
                   Φ <-- 0
                   ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 30
                          ΑΝ Απ[κ, λ] = 'Λ' ΤΟΤΕ
                                 Φ <-- Φ+1
                          ΤΕΛΟΣ_ΑΝ
                   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                   Φορές[λ] <-- Φ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΜΑΧ <-- Φορές[1]
            ΑΑΜΑΧ <-- 1
            ΓΙΑ κ ΑΠΟ ΜΕΧΡΙ 18
                   ΑΝ Φορές[κ] > ΜΑΧ ΤΟΤΕ
                           ΜΑΧ <-- Φορές[κ]
                           ΑΑΜΑΧ <-- κ
                   ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            Δύσκολη <-- ΑΑΜΑΧ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Τετάρτη, 23 Μαρτίου 2011

Πίνακας αλήθειας

Συμπληρώστε τα κενά που λείπουν στον πίνακα αλήθειας
που ακολουθεί

    Χ                Υ               Χ ΚΑΙ Υ       ΟΧΙ (Χ Ή Υ)
Αληθής                        Αληθής
                                                           Αληθής

Λύση

     Χ                Υ               Χ ΚΑΙ Υ       ΟΧΙ (Χ Ή Υ)

Αληθής      Αληθής          Αληθής              Ψευδής
Ψευδής      Ψευδής          Ψευδής              Αληθής

'Ελεγχος αλγοριθμικών κριτηρίων

Ποιό ή  ποιά αλγοριθμικά κριτήρια παραβιάζονται στο
παρακάτω σύνολο εντολών. Αιτιολογήστε την απάντησή σας.
       Αλγόριθμος ΑΣΚ
       Διάβασε Χ
       Υ <-- Τ_Ρ(Α_Τ(Χ))+1
       Όσο Υ > 0 επανάλαβε
             Διάβασε κ
             Αν A_T(κ) div A_T(κ+1)  >  0 τότε
                   Υ <-- Υ-10
             αλλιώς
                   Υ <-- Υ+10
             Τέλος_αν
             μ <-- 1/(κ+7)
       Τέλος_επανάληψης
       Τέλος ΑΣΚ

Λύση

α) Καθοριστικότητα, γιατί αν κ = -7 η εντολή μ <-- 1/(κ+7) δεν
    μπορεί να εκτελεστεί.
β) Έξοδος, γιατί ο αλγόριθμος δεν εμφανίζει κανένα αποτέλεσμα.
γ) Περατότητα, γιατί A_T(κ) div A_T(κ+1)  >  0 = 0 > 0
    = Ψευδής και η εντολή Υ <-- Υ-10 δεν πρόκειται ποτέ να
   εκτελεστεί και το Υ θα αυξάνεται συνεχώς κατά 10. Έτσι το
   Υ θα είναι πάντα θετικό και  η Όσο..επανάλαβε δε θα
   τερματιστεί ποτέ.
 

Μετατροπές

Ξαναγράψτε το παρακάτω σύνολο εντολών με ισοδύναμο
τρόπο αντικαθιστώντας
α) την εξωτερική Για..από..μέχρι με Όσο..επανάλαβε
β) την εσωτερική Για..από..μέχρι με Μέχρις_ότου
γ) την Αν..τότε..αλλιώς με εντολές Αν..τότε

        Διάβασε Ζ, Μ
        Για κ από 21 μέχρι Ζ
             Για λ από 4 μέχρι Μ με_βήμα 2
                  Διάβασε Ν
                  Αν Ν < 10 τότε
                       Εμφάνισε (κ+λ)*Ν
                  αλλιώς
                       Εμφάνισε (κ-λ)*Ν
                  Τέλος_αν
             Τέλος_επανάληψης
        Τέλος_επανάληψης

Λύση


        Διάβασε Ζ, Μ
        κ <-- 21
        Όσο κ <= Ζ επανάλαβε
            Αν Μ >= 4 τότε
                 λ <-- 4
                 Αρχή_επανάληψης
                     Διάβασε Ν
                     Αν Ν < 10 τότε
                          Εμφάνισε (κ+λ)*Ν
                     Τέλος_αν
                     Αν Ν >= 10 τότε
                          Εμφάνισε (κ-λ)*Ν
                     Τέλος_αν
                     λ <-- λ+2
                 Μέχρις_ότου λ > Μ
             Τέλος_αν
             κ <-- κ+1
        Τέλος_επανάληψης


 

Τετάρτη, 16 Μαρτίου 2011

Θέμα 4ο : Επαναληπτικές απολυτήριες εξετάσεις εσπερινού λυκείου 2004

Σ’ ένα διαγωνισμό συμμετέχουν 5000 διαγωνιζόμενοι και
εξετάζονται σε δύο μαθήματα.
Να γράψετε αλγόριθμο που
1. να διαβάζει και να καταχωρίζει σε κατάλληλους πίνακες
    για κάθε διαγωνιζόμενο τον αριθμό μητρώου, το
    ονοματεπώνυμο και τους βαθμούς που πήρε στα δύο
    μαθήματα.
    Οι αριθμοί μητρώου θεωρούνται μοναδικοί. Η
    βαθμολογική κλίμακα είναι από 0 έως και 100.
                                                                          Μονάδες 4
2. να εμφανίζει κατάσταση επιτυχόντων με την εξής μορφή:

Αριθ. Μητρώου  Ονοματεπώνυμο  Μέσος Όρος

Επιτυχών θεωρείται ότι είναι αυτός που έχει μέσο όρο
βαθμολογίας μεγαλύτερο ή ίσο του 60.
                                                                         Μονάδες 4
3. να διαβάζει έναν αριθμό μητρώου και
    α.  σε περίπτωση που ο αριθμός μητρώου είναι
         καταχωρισμένος στον πίνακα, να εμφανίζεται ο
         αριθμός μητρώου, το ονοματεπώνυμο, ο μέσος όρος
         βαθμολογίας και η ένδειξη «ΕΠΙΤΥΧΩΝ» ή «ΑΠΟΤΥΧΩΝ»,
         ανάλογα με τον μέσο όρο.
                                                                         Μονάδες 8
    β. σε περίπτωση που ο αριθμός μητρώου δεν είναι
        καταχωρισμένος στον πίνακα, να εμφανίζεται το
       μήνυμα «Ο αριθμός μητρώου δεν αντιστοιχεί σε
       διαγωνιζόμενο».
                                                                         Μονάδες 4
Σημείωση: Δεν απαιτείται έλεγχος εγκυρότητας καταχώρισης
δεδομένων.

Λύση

     Αλγόριθμος Θ4_ΕπανΕσπ2004

     Για γ από 1 μέχρι 5000
          Διάβασε ΑΜ[γ], ΟΝ[γ]
     Τέλος_επανάληψης
     Για γ από 1 μέχρι 5000
          Για σ από 1 μέχρι 2
               Διάβασε Βαθμ[γ, σ]
          Τέλος_επανάληψης
     Τέλος_επανάληψης
     Για γ από 1 μέχρι 5000
          Αθρ <-- 0
          Για σ από 1 μέχρι 2
               Αθρ <-- Αθρ+Βαθμ[γ, σ]
          Τέλος_επανάληψης
          ΜΟ[γ] <-- Αθρ/2
     Τέλος_επανάληψης
     Εμφάνισε 'Κατάσταση επιτυχόντων ...'
    
Επ <-- 0
     Για
γ από 1 μέχρι 5000
           Αν ΜΟ[γ] >= 60 τότε
                Εμφάνισε ΑΜ[γ], ΟΝ[γ], ΜΟ[γ]
                Επ <-- Επ+1
           Τέλος_αν
     Τέλος_επανάληψης
     Αν Επ = 0 τότε
           Εμφάνισε 'Δεν υπάρχει κανένας επιτυχών'
     Τέλος_αν
     Διάβασε Μητρώο
     done <-- Ψευδής
     pos <-- 0
     γ <-- 1
     Όσο (γ <= 5000) ΚΑΙ (done = Ψευδής) επανάλαβε
           Αν ΑΜ[γ] = Μητρώο τότε
                 done <-- Αληθής
                 pos <-- γ
           αλλιώς
                 γ <-- γ+1
           Τέλος_αν
     Τέλος_επανάληψης
     Αν done = Αληθής τότε
           Εμφάνισε Μητρώο, ΟΝ[pos], ΜΟ[pos]
           Αν ΜΟ[pos] >= 60 τότε
                 Εμφάνισε 'ΕΠΙΤΥΧΩΝ'
           αλλιώς
                 Εμφάνισε 'ΑΠΟΤΥΧΩΝ'
           Τέλος_αν
     αλλιώς
            Εμφάνισε 'Ο αριθμός μητρώου δεν αντιστοιχεί σε'
            Εμφάνισε 'διαγωνιζόμενο'
     Τέλος_αν
     Τέλος Θ4_ΕπανΕσπ2004
 

Θέμα 3ο: Επαναληπτικές απολυτήριες εξετάσεις εσπερινού λυκείου 2004


Μια εταιρεία δημοσκοπήσεων θέτει σ’ ένα δείγμα 2000
πολιτών ένα ερώτημα. Για την επεξεργασία των δεδομένων
να αναπτύξετε αλγόριθμο που:
1. να διαβάζει το φύλο του πολίτη (Α=Άνδρας, Γ=Γυναίκα)
    και να ελέγχει την ορθή εισαγωγή
                                                                          Μονάδες 5
2. να διαβάζει την απάντηση στο ερώτημα, η οποία μπορεί
    να είναι «ΝΑΙ», «ΟΧΙ», «ΔΕΝ ΞΕΡΩ» και να ελέγχει την
    ορθή εισαγωγή
                                                                          Μονάδες 5
3. να υπολογίζει και να εμφανίζει το πλήθος των ατόμων
    που απάντησαν «ΝΑΙ»
                                                                          Μονάδες 5
4. στο σύνολο των ατόμων που απάντησαν «ΝΑΙ» να
   υπολογίζει και να εμφανίζει το ποσοστό των ανδρών και
   το ποσοστό των γυναικών.
                                                                          Μονάδες 5

Λύση


     Αλγόριθμος Θ3_ΕπανΕσπ2004
     ΠληθΝΑΙ <-- 0
     ΑνδΝΑΙ <-- 0
     ΓυνΝΑΙ <-- 0
     Για λ από 1 μέχρι 2000
          Αρχή_επανάληψης
                Διάβασε Φ
          Μέχρις_ότου (Φ = 'Α') Ή (Φ = 'Γ')
          Αρχή_επανάληψης
                Διάβασε Απ
          Μέχρις_ότου (Απ = 'ΝΑΙ') Ή (Απ = 'ΟΧΙ') Ή
                                  (Απ = 'ΔΕΝ ΞΕΡΩ')
          Αν Απ = 'ΝΑΙ' τότε
               ΠληθΝΑΙ <-- ΠληθΝΑΙ+1
               Αν Φ = 'Α' τότε
                     ΑνδΝΑΙ <-- ΑνδΝΑΙ+1
               αλλιώς
                     ΓυνΝΑΙ <-- ΓυνΝΑΙ+1
               Τέλος_αν
          Τέλος_αν
     Τέλος_επανάληψης
     Εμφάνισε  ΠληθΝΑΙ
     Αν ΠληθΝΑΙ > 0 τότε
           ΠΟΣΑνδ <-- 100*ΑνδΝΑΙ/ΠληθΝΑΙ
           ΠΟΣΓυν <-- 100*ΓυνΝΑΙ/ΠληθΝΑΙ
           Εμφάνισε ΠΟΣΑνδ, ΠΟΣΓυν
     αλλιώς
           Εμφάνισε 'Αδύνατος ο υπολογισμός των ποσοστών αφού'
           Εμφάνισε 'κανένας δεν απάντησε ΝΑΙ'
     Τέλος_αν
     Τέλος Θ3_ΕπανΕσπ2004

Τρίτη, 15 Μαρτίου 2011

Θέμα 3ο - Επαναληπτικές Απολυτήριες εξετάσεις εσπερινού λυκείου 2005

Μια εμπορική εταιρεία μέσω αντιπροσώπων διαθέτει στο
αγοραστικό κοινό τρεις τύπους προϊόντων Χ, Ψ και Ζ και
χορηγεί προμήθεια στους αντιπροσώπους της.
Να αναπτύξετε αλγόριθμο, ώστε:
α) να διαβάζει τον τύπο ενός προϊόντος και την τιμή πώλησης
    αυτού,
                                                                         Μονάδες 2
β) να υπολογίζει κλιμακωτά την προμήθεια που θα δοθεί από
    την πώληση σύμφωνα με τον παρακάτω πίνακα:
     Τιμή πώλησης σε ευρώ               Ποσοστά προμήθειας
                                                  Προϊόν Χ       Προϊόν Υ    Προϊόν Ζ
      Από 0 έως και 5000                0%                  2%           4%
Πάνω από 5000 έως και 10000      5%                  6%           6%
       Πάνω από 10000                10%                 7%           8%

Η είσοδος των δεδομένων και ο υπολογισμός της προμήθειας θα
επαναλαμβάνεται μέχρι να δοθεί τύπος προϊόντος Τ,
                                                                       Μονάδες 14
γ) στο τέλος να εμφανίζεται
     i. η προμήθεια που θα δοθεί για κάθε τύπο προϊόντος,
                                                                          Μονάδες 2
    ii. η συνολική προμήθεια που έλαβαν οι αντιπρόσωποι.
                                                                          Μονάδες 2
Λύση

      Αλγόριθμος Θ3_ΕπανΕσπ2005
      ΣυνΧ <-- 0
      ΣυνΥ <-- 0
      ΣυνΖ <-- 0
      Αρχή_επανάληψης
            Διάβασε Τύπος
            Αν Τύπος < > 'Τ' τότε
                  Διάβασε Τιμή                  
                  Αν Τύπος = 'Χ' τότε
                        Αν Τιμή <= 5000 τότε
                              Προμήθεια <-- 0
                        αλλιώς_αν Τιμή <= 10000 τότε
                              Προμήθεια <-- (Τιμή-5000)*0.05
                        αλλιώς
                              Προμήθεια <-- 5000*0.05+(Τιμή-10000)*0.10
                        Τέλος_αν                        
                        ΣυνΧ <-- ΣυνΧ+Προμήθεια
                  αλλιώς_αν Τύπος = 'Υ' τότε
                        Αν Τιμή <= 5000 τότε
                              Προμήθεια <-- Τιμή*0.02
                        αλλιώς_αν Τιμή <= 10000 τότε
                              Προμήθεια <-- 5000*0.02+(Τιμή-5000)*0.06
                        αλλιώς
                              Προμήθεια <-- 5000*0.02+5000*0.06+
                                                       (Τιμή-10000)*0.07
                        Τέλος_αν                 
                        ΣυνΥ <-- ΣυνΥ+Προμήθεια
                  αλλιώς
                         Αν Τιμή <= 5000 τότε
                              Προμήθεια <-- Τιμή*0.04
                        αλλιώς_αν Τιμή <= 10000 τότε
                              Προμήθεια <-- 5000*0.04+(Τιμή-5000)*0.06
                        αλλιώς
                              Προμήθεια <-- 5000*0.04+5000*0.06+
                                                       (Τιμή-10000)*0.08
                        Τέλος_αν
                        ΣυνΖ <-- ΣυνΖ+Προμήθεια
                  Τέλος_αν
                  Εμφάνισε Προμήθεια
            Τέλος_αν
      Μέχρις_ότου Τύπος = 'Τ'
      Σύνολο <-- ΣυνΧ+ΣυνΥ+ΣυνΖ
      Εμφάνισε ΣυνΧ, ΣυνΥ, ΣυνΖ, Σύνολο
      Τέλος Θ3_ΕπανΕσπ2005

Θέμα 4ο: Επαναληπτικές Απολυτήριες εξετάσεις εσπερινού λυκείου 2005

Να αναπτύξετε έναν αλγόριθμο, ώστε
α) να διαβάζει το πλήθος των ασθενών ενός νοσοκομείου,
     το οποίο δεν μπορεί να δεχτεί περισσότερους από 500
     ασθενείς,
                                                                         Μονάδες 2
β) για κάθε ασθενή να διαβάζει τις ημέρες νοσηλείας του,
    τον κωδικό του ασφαλιστικού του ταμείου και τη θέση
    νοσηλείας. Να ελέγχει την ορθότητα εισαγωγής των
    δεδομένων σύμφωνα με τα παρακάτω:
       • οι ημέρες νοσηλείας είναι ακέραιος αριθμός μεγαλύτερος
          ή ίσος του 1,
       • τα ασφαλιστικά ταμεία είναι 10 με κωδικούς από 1 μέχρι
          και 10,
       • οι θέσεις νοσηλείας είναι Α ή Β ή Γ,
                                                                         Μονάδες 6
γ) να υπολογίζει και να εμφανίζει το μέσο όρο ημερών
    νοσηλείας των ασθενών στο νοσοκομείο,
                                                                         Μονάδες 2
δ) να υπολογίζει και να εμφανίζει για κάθε ασθενή το
    κόστος παραμονής που πρέπει να καταβάλει στο
    νοσοκομείο το ασφαλιστικό του ταμείο σύμφωνα
    με τις ημέρες και τη θέση νοσηλείας.
   Το κόστος παραμονής στο νοσοκομείο ανά ημέρα και
   θέση νοσηλείας για κάθε ασθενή φαίνεται στον ακόλουθο
   πίνακα:
      Θέση Νοσηλείας      Κόστος παραμονής ανά ημέρα 
                                         νοσηλείας για κάθε ασθενή
              Α                                         125 €
              Β                                           90 €
              Γ                                           60 €
                                                                         Μονάδες 4
ε) να υπολογίζει και να εμφανίζει με τη χρήση πίνακα το
    συνολικό κόστος που θα καταβάλει το κάθε ασφαλιστικό
    ταμείο στο νοσοκομείο,
                                                                         Μονάδες 4
στ) να υπολογίζει και να εμφανίζει το συνολικό ποσό που
      οφείλουν όλα τα ασφαλιστικά ταμεία στο νοσοκομείο.
                                                                         Μονάδες 2

Λύση

        Αλγόριθμος Θ4_ΕπανΕσπ2005
        Αρχή_επανάληψης
               Διάβασε Ν
        Μέχρις_ότου (Ν > 0) ΚΑΙ (Ν <= 500)
        Για λ από 1 μέχρι Ν
              Αρχή_επανάληψης
                   Διάβασε Ημέρες[λ]
              Μέχρις_ότου Ημέρες[λ] >= 1
              Αρχή_επανάληψης
                   Διάβασε Κωδικός[λ]
              Μέχρις_ότου (Κωδικός[λ] >= 1) ΚΑΙ 
                                     (Κωδικός[λ] <= 10)
              Αρχή_επανάληψης
                   Διάβασε Θέση[λ]
              Μέχρις_ότου (Θέση[λ] = 'Α') Ή (Θέση[λ] = 'Β') Ή 
                                     (Θέση[λ] = 'Γ')
        Τέλος_επανάληψης
         Άθροισμα <-- 0
         Για λ από 1 μέχρι Ν
               Άθροισμα <-- Άθροισμα+Ημέρες[λ]
         Τέλος_επανάληψης
         ΜΟ <-- Άθροισμα/Ν
         Εμφάνισε ΜΟ
         Για λ από μέχρι 10
               Ταμεία [λ] <-- 0
         Τέλος_επανάληψης
         Για λ από μέχρι Ν
               Αν Θέση[λ] = 'Α' τότε
                     Κόστος <-- Ημέρες[λ]*125
               αλλιώς_αν Θέση[λ] = 'Β' τότε
                     Κόστος <-- Ημέρες[λ]*90
               αλλιώς
                     Κόστος <-- Ημέρες[λ]*60
               Τέλος_αν
               Εμφάνισε Κόστος
               ΝοΤαμείου <-- Κωδικός[λ]
               Ταμεία[ΝοΤαμείου] <-- Ταμεία[ΝοΤαμείου]+Κόστος
         Τέλος_επανάληψης
         Για λ από μέχρι 10
               Εμφάνισε Ταμεία [λ] 
         Τέλος_επανάληψης
         Σύνολο <-- 0
         Για λ από μέχρι 10
               Σύνολο <-- Σύνολο+Ταμεία [λ] 
         Τέλος_επανάληψης
         Εμφάνισε Σύνολο
         Τέλος Θ4_ΕπανΕσπ2005

Θέμα 2ο : Επαναληπτικές Απολυτήριες εσπερινού λυκείου 2005

Να αναπτύξετε έναν αλγόριθμο, ώστε
α) να διαβάζει έναν πραγματικό αριθμό μεγαλύτερο του
     μηδενός και μικρότερο του 1000 και να κάνει έλεγχο
     ορθής καταχώρησης του αριθμού,
                                                                    Μονάδες 6
β) να ελέγχει αν είναι ακέραιος και να εμφανίζει τη λέξη
    «ΑΚΕΡΑΙΟΣ» αλλιώς να εμφανίζει τη λέξη
    «ΠΡΑΓΜΑΤΙΚΟΣ»,
                                                                    Μονάδες 6
γ) να ελέγχει, στην περίπτωση που ο αριθμός είναι ακέραιος,
    αν είναι άρτιος ή περιττός και να εμφανίζει τη λέξη
    «ΑΡΤΙΟΣ» ή «ΠΕΡΙΤΤΟΣ» αντίστοιχα.
                                                                    Μονάδες 8

Λύση

   Αλγόριθμος Θ2_ΕπανΕσπ2005
   Αρχή_επανάληψης
        Διάβασε Υ
   Μέχρις_ότου (Υ > 0) ΚΑΙ (Υ < 1000)
   Αν Α_Μ(Υ) = Υ τότε
        Εμφάνισε 'ΑΚΕΡΑΙΟΣ'
        Αν Α_Μ(Υ) mod 2 = 0 τότε
              Εμφάνισε 'ΑΡΤΙΟΣ'
        αλλιώς
              Εμφάνισε 'ΠΕΡΙΤΤΟΣ'
        Τέλος_αν
   αλλιώς
        Εμφάνισε 'ΠΡΑΓΜΑΤΙΚΟΣ'
   Τέλος_αν
   Τέλος Θ2_ΕπανΕσπ2005

Δευτέρα, 14 Μαρτίου 2011

Θέμα 4ο - Επαναληπτικές Απολυτήριες εξετάσεις ενιαίου λυκείου 2005

Μια αεροπορική εταιρία ταξιδεύει σε 15 προορισμούς του
εσωτερικού. Στα πλαίσια της οικονομικής πολιτικής που
πρόκειται να εφαρμόσει, κατέγραψε το ποσοστό πληρότητας
των πτήσεων για κάθε μήνα του προηγούμενου
ημερολογιακού έτους. Η πολιτική έχει ως εξής:
- Δεν θα γίνει καμία περικοπή σε προορισμούς, στους
   οποίους το μέσο ετήσιο ποσοστό πληρότητας των πτήσεων
   είναι μεγαλύτερο του 65.
- Θα γίνουν περικοπές πτήσεων σε προορισμούς, στους
   οποίους το μέσο ετήσιο ποσοστό πληρότητας των πτήσεων
   κυμαίνεται από 40 έως και 65. Οι περικοπές θα γίνουν
   μόνο σε εκείνους τους μήνες που το ποσοστό πληρότητάς
   τους είναι μικρότερο του 40.
- Θα καταργηθούν οι προορισμοί, στους οποίους το μέσο
   ετήσιο ποσοστό πληρότητας των πτήσεων είναι μικρότερο
   του 40.
Να γραφεί αλγόριθμος ο οποίος:
1. Να διαβάζει τα ονόματα των 15 προορισμών και να τα
    αποθηκεύει σε ένα μονοδιάστατο πίνακα.
                                                                   Μονάδες 2
2. Να διαβάζει τα ποσοστά πληρότητας των πτήσεων των
   15 προορισμών για κάθε μήνα και να τα αποθηκεύει σε
   δισδιάστατο πίνακα κάνοντας έλεγχο στην καταχώριση
   των δεδομένων, ώστε να καταχωρούνται μόνο οι τιμές
   που είναι από 0 έως και 100.
                                                                   Μονάδες 4
3. Να βρίσκει και να τυπώνει τα ονόματα των προορισμών
    που δεν θα γίνει καμία περικοπή πτήσεων.
                                                                  Μονάδες 3
4. Να βρίσκει και να τυπώνει τα ονόματα των προορισμών
    που θα καταργηθούν.
                                                                 Μονάδες 3
5. Να βρίσκει και να τυπώνει τα ονόματα των προορισμών,
    στους οποίους θα γίνουν περικοπές πτήσεων, καθώς και
    τους μήνες (αύξοντα αριθμό μήνα) που θα γίνουν οι
    περικοπές.
                                                                 Μονάδες 8

Λύση

       Αλγόριθμος Θ4_ΕπανΕν2005
       Για γ από 1 μέχρι 15
             Διάβασε Ον[γ]
       Τέλος_επανάληψης
        Για γ από μέχρι 15
            Για σ από μέχρι 12
                 Αρχή_επανάληψης
                      Διάβασε ΠΟΣ[γ, σ]
                 Μέχρις_ότου (ΠΟΣ[γ, σ] >= 0) ΚΑΙ 
                                       (ΠΟΣ[γ, σ] <= 100)
            Τέλος_επανάληψης
       Τέλος_επανάληψης
       Για γ από μέχρι 15
            Άθροισμα <-- 0
            Για σ από μέχρι 12
                 Άθροισμα <-- Άθροισμα+ΠΟΣ[γ, σ]
           Τέλος_επανάληψης
           ΜΟ[γ] <-- Άθροισμα/12
       Τέλος_επανάληψης
       Εμφάνισε 'Καμιά περικοπή ....'
       Για γ από μέχρι 15
             Αν ΜΟ[γ] > 65 τότε
                  Εμφάνισε Ον[γ]
             Τέλος_αν
       Τέλος_επανάληψης
       Εμφάνισε 'Κατάργηση προορισμών ....'
       Για γ από μέχρι 15
             Αν ΜΟ[γ] < 40 τότε
                  Εμφάνισε Ον[γ]
             Τέλος_αν
       Τέλος_επανάληψης
       Εμφάνισε 'Περικοπές πτήσεων...'
       Για γ από μέχρι 15
            Αν (ΜΟ[γ] >= 40) ΚΑΙ (ΜΟ[γ] <= 65) τότε
                 Εμφάνισε Ον[γ]
                 Εμφάνισε 'για τους μήνες...'
                 Για σ από μέχρι 12
                      Αν ΠΟΣ[γ, σ] < 40 τότε
                            Εμφάνισε σ
                      Τέλος_αν
                 Τέλος_επανάληψης
       Τέλος_επανάληψης
       Τέλος Θ4_ΕπανΕν2005

Θέμα 3ο - Επαναληπτικές Απολυτήριες εξετάσεις εσπερινού ενιαίου λυκείου 2005

Εκατό (100) υποψήφιοι του ΑΣΕΠ διαγωνίζονται σε τρία
μαθήματα για την κάλυψη θέσεων του Δημοσίου. Να γραφεί
κύριο πρόγραμμα σε ΓΛΩΣΣΑ που να κάνει τα παρακάτω:
α) Διαβάζει τα ονόματα των 100 υποψηφίων του ΑΣΕΠ και
τη βαθμολογία καθενός υποψηφίου σε τρία διαφορετικά
μαθήματα. (Θεωρήστε ότι η βαθμολογία κάθε μαθήματος
είναι από 1 έως 20).
                                                                         Μονάδες 4
β) Βρίσκει και τυπώνει τον ελάχιστο και τον μέγιστο βαθμό
    καθενός υποψηφίου στα τρία μαθήματα που εξετάστηκε.
                                                                         Μονάδες 6
γ) Να γραφεί υποπρόγραμμα, το οποίο να καλείται από το
    κύριο πρόγραμμα, για τον υπολογισμό και την εκτύπωση
    του μέσου όρου κάθε υποψηφίου στα τρία μαθήματα που
   διαγωνίστηκε.
                                                                       Μονάδες 10

Λύση

      ΠΡΟΓΡΑΜΜΑ Θ3_ΕπανΕν2005
      ΜΕΤΑΒΛΗΤΕΣ
             ΑΚΕΡΑΙΕΣ: λ, μ
             ΠΡΑΓΜΑΤΙΚΕΣ: Βαθμ[100, 3], ΜΑΧ, ΜΙΝ
             ΧΑΡΑΚΤΗΡΕΣ: Ον[100]
      ΑΡΧΗ
             ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 100
                  ΔΙΑΒΑΣΕ Ον[λ]
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΓΙΑ λ ΑΠΟ ΜΕΧΡΙ 100
                  ΓΙΑ μ ΑΠΟ ΜΕΧΡΙ 3
                       ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ 
                            ΔΙΑΒΑΣΕ Βαθμ[λ, μ]
                       ΜΕΧΡΙΣ_ΟΤΟΥ (Βαθμ[λ, μ] >= 1) ΚΑΙ
                                                   (Βαθμ[λ, μ] <= 20)
                 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΓΙΑ λ ΑΠΟ ΜΕΧΡΙ 100
                  ΜΑΧ <-- Βαθμ[λ, 1]
                  ΜΙΝ <-- Βαθμ[λ, 1]
                  ΓΙΑ μ ΑΠΟ ΜΕΧΡΙ 3
                       ΑΝ Βαθμ[λ, μ] > ΜΑΧ ΤΟΤΕ
                             ΜΑΧ <-- Βαθμ[λ, μ] 
                       ΤΕΛΟΣ_ΑΝ
                       ΑΝ Βαθμ[λ, μ] < ΜΙΝ ΤΟΤΕ
                             ΜΙΝ <-- Βαθμ[λ, μ] 
                       ΤΕΛΟΣ_ΑΝ                                                   
                 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                 ΓΡΑΨΕ 'Υποψήφιος :', Ον[λ], 'ΜΑΧ =', ΜΑΧ
                 ΓΡΑΨΕ 'ΜΙΝ =', ΜΙΝ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
             ΚΑΛΕΣΕ ΜΕΣΟΙ(Βαθμ)
      ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

      ΔΙΑΔΙΚΑΣΙΑ ΜΕΣΟΙ(Βαθμ)
      ΜΕΤΑΒΛΗΤΕΣ
             ΠΡΑΓΜΑΤΙΚΕΣ: Βαθμ[100, 3], σ, ΜΟ
             ΑΚΕΡΑΙΕΣ: λ, μ
      ΑΡΧΗ
             ΓΙΑ λ ΑΠΟ ΜΕΧΡΙ 100
                  σ <-- 0
                  ΓΙΑ μ ΑΠΟ ΜΕΧΡΙ 3
                        σ <-- σ+Βαθμ[λ, μ]
                  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                  ΜΟ <-- σ/3
                  ΓΡΑΨΕ 'ΜΟ υποψηφίου Νο:', Λ, ' =', ΜΟ
             ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
      ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Θέμα 2ο - Επαναληπτικές Απολυτήριες εξετάσεις εσπερινού ενιαίου λυκείου 2005

Δίνεται το παρακάτω πρόγραμμα το οποίο διαβάζει τις
θερμοκρασίες διαφόρων ημερών του μήνα, έστω 30, και
υπολογίζει τη μέση θερμοκρασία του μήνα.
    ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
    ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30], Μέση, Σύνολο
          ΑΚΕΡΑΙΕΣ: i
    ΑΡΧΗ
          Σύνολο <-- 0
          ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
              ΓΡΑΨΕ “Δώσε τη θερμοκρασία”
              ΔΙΑΒΑΣΕ Θερμοκρασία[i]
              Σύνολο <-- Σύνολο + Θερμοκρασία[i]
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          Μέση <-- Σύνολο/30
          ΓΡΑΨΕ “Μέση Θερμοκρασία:”, Μέση
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
α) Να γραφεί αντίστοιχο πρόγραμμα (που να κάνει τους
     ίδιους υπολογισμούς) χωρίς τη χρήση πίνακα.
                                                             Μονάδες 10
β) Έστω ότι οι τιμές των θερμοκρασιών έχουν δοθεί στην
     κλίμακα Κελσίου. Να τροποποιηθεί το πρόγραμμα που
    δόθηκε έτσι, ώστε κάνοντας χρήση συνάρτησης να
    μετατρέπονται οι θερμοκρασίες από την κλίμακα
    Κελσίου σε κλίμακα Φαρενάιτ.
   Ο τύπος μετατροπής από Κελσίου σε Φαρενάιτ είναι:

           Φαρενάιτ=32+9⋅Κελσίου/5

                                                             Μονάδες 10

Λύση

α)
    ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
    ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία, Μέση, Σύνολο
          ΑΚΕΡΑΙΕΣ: i
    ΑΡΧΗ
          Σύνολο <-- 0
          ΓΙΑ ΑΠΟ ΜΕΧΡΙ 30
              ΓΡΑΨΕ “Δώσε τη θερμοκρασία”
              ΔΙΑΒΑΣΕ Θερμοκρασία
              Σύνολο <-- Σύνολο + Θερμοκρασία
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          Μέση <-- Σύνολο/30
          ΓΡΑΨΕ “Μέση Θερμοκρασία:”, Μέση
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

β)
    ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες_2
    ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30], Μέση, Σύνολο, Φ
          ΑΚΕΡΑΙΕΣ: i
    ΑΡΧΗ
          Σύνολο <-- 0
          ΓΙΑ ΑΠΟ ΜΕΧΡΙ 30
              ΓΡΑΨΕ “Δώσε τη θερμοκρασία”
              ΔΙΑΒΑΣΕ Θερμοκρασία[i]
              Φ <-- Φαρενάιτ(Θερμοκρασία[i])
              Σύνολο <-- Σύνολο + Φ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          Μέση <-- Σύνολο/30
          ΓΡΑΨΕ “Μέση Θερμοκρασία:”, Μέση
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

     ΣΥΝΑΡΤΗΣΗ Φαρενάιτ(Κελσίου) : ΠΡΑΓΜΑΤΙΚΗ
     ΜΕΤΑΒΛΗΤΕΣ
         ΠΡΑΓΜΑΤΙΚΕΣ : Κελσίου
     ΑΡΧΗ
         Φαρενάιτ <-- 32+9*Κελσίου/5
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Θέμα 4ο - Επαναληπτικές Απολυτήριες εξετάσεις ενιαίου λυκείου 2003


Κατά τη διάρκεια πρωταθλήματος μπάσκετ μια ομάδα που
αποτελείται από δώδεκα (12) παίκτες έδωσε είκοσι (20) αγώνες,
στους οποίους συμμετείχαν όλοι οι παίκτες.
Να αναπτύξετε στο τετράδιό σας αλγόριθμο ο οποίος:
α. Να διαβάζει τα ονόματα των παικτών και να τα αποθηκεύει σε
    μονοδιάστατο πίνακα.
                                                                       Μονάδες 2
β. Να διαβάζει τους πόντους που σημείωσε κάθε παίκτης σε
    κάθε αγώνα και να τους αποθηκεύει σε πίνακα δύο διαστάσεων.
                                                                       Μονάδες 3
γ. Να υπολογίζει για κάθε παίκτη το συνολικό αριθμό πόντων
    του σε όλους τους αγώνες και το μέσο όρο πόντων ανά αγώνα.
                                                                       Μονάδες 6
δ. Να εκτυπώνει τα ονόματα των παικτών της ομάδας και το
    μέσο όρο πόντων του κάθε παίκτη ταξινομημένα με βάση
    το μέσο όρο τους κατά φθίνουσα σειρά.
    Παρατήρηση: Σε περίπτωση ισοβαθμίας δεν μας ενδιαφέρει
    η σχετική σειρά των παικτών.
                                                                    Μονάδες 9

Λύση

       Αλγόριθμος Θ4_ΕπανΕν2003
       Για λ από 1 μέχρι 12
            Διάβασε Ον[λ]
       Τέλος_επανάληψης
       Για λ από μέχρι 12
            Για μ από 1 μέχρι 20
                  Διάβασε Πόντοι[λ, μ]
            Τέλος_επανάληψης
       Τέλος_επανάληψης
       Για λ από μέχρι 12
            σ <-- 0
            Για μ από μέχρι 20
                  σ <-- σ+Πόντοι[λ, μ]
            Τέλος_επανάληψης
            Σύνολο[λ] <-- σ
            ΜΟ[λ] <-- σ/20
       Τέλος_επανάληψης
       Για λ από μέχρι 12
            Για μ από 12 μέχρι λ με_βήμα -1
                  Αν ΜΟ[μ-1] < ΜΟ[μ] τότε
                       β1 <-- ΜΟ[μ-1]
                       ΜΟ[μ-1] <-- ΜΟ[μ]
                       ΜΟ[μ] <-- β1
                       β2 <-- Σύνολο[μ-1]
                       Σύνολο[μ-1] <-- Σύνολο[μ]
                       Σύνολο[μ] <-- β2
                       β3 <-- Ον[μ-1]
                       Ον[μ-1] <-- Ον[μ]
                       Ον[μ] <-- β3
                  Τέλος_αν
            Τέλος_επανάληψης
       Τέλος_επανάληψης
       Για λ από 1 μέχρι 12
             Εμφάνισε Ον[λ], ΜΟ[λ]
       Τέλος_επανάληψης
       Αποτελέσματα // Σύνολο //
       Τέλος Θ4_ΕπανΕν2003

Θέμα 3ο : Επαναληπτικές Απολυτήριες εξετάσεις ενιαίου λυκείου 2003

Κάποια δημοτική αρχή ακολουθεί την εξής τιμολογιακή πολιτική
για την κατανάλωση νερού ανά μήνα:
Χρεώνει πάγιο ποσό 2 ευρώ και εφαρμόζει κλιμακωτή χρέωση
σύμφωνα με τον παρακάτω πίνακα:
Κατανάλωση σε κυβικά μέτρα                   Χρέωση ανά κυβικό
       από 0 έως και 5                                              δωρεάν
       από 5 έως και 10                                            0,5 ευρώ
       από 10 έως και 20                                          0,7 ευρώ
       από 20 και άνω                                               1,0 ευρώ
Στο ποσό που προκύπτει από την αξία του νερού και το πάγιο
υπολογίζεται ο Φ.Π.Α. με συντελεστή 18%. Το τελικό ποσό
προκύπτει από την άθροιση της αξίας του νερού, το πάγιο,
το Φ.Π.Α. και το δημοτικό φόρο που είναι 5 ευρώ.
Να γράψετε αλγόριθμο ο οποίος:
α. Να διαβάζει τη μηνιαία κατανάλωση του νερού.
                                                                          Μονάδες 2
β. Να υπολογίζει την αξία του νερού που καταναλώθηκε
    σύμφωνα με την παραπάνω τιμολογιακή πολιτική.
                                                                         Μονάδες 10
γ. Να υπολογίζει το Φ.Π.Α.
                                                                         Μονάδες 4
δ. Να υπολογίζει και να εκτυπώνει το τελικό ποσό.
                                                                         Μονάδες 4


Λύση

      Αλγόριθμος Θ3_ΕπανΕν2003
      Διάβασε Κυβικά
      Αν Κυβικά <= 5 τότε
           Αξία <-- 0
      αλλιώς_αν Κυβικά <= 10 τότε
           Αξία <-- (Κυβικά-5)*0.5
      αλλιώς_αν Κυβικά <= 20 τότε
           Αξία <-- 5*0.5+(Κυβικά-10)*0.7
      αλλιώς
          Αξία <-- 5*0.5+10*0.7+(Κυβικά-20)*1.0
      Τέλος_αν
      ΦΠΑ <-- (Αξία+2)*18/100
      ΠΟΣΟ <-- Αξία+2+ΦΠΑ+5
      Εμφάνισε ΠΟΣΟ
      Τέλος Θ3_ΕπανΕν2003

Θέμα 3ο - Επαναληπτικές Απολυτήριες εξετάσεις ενιαίου λυκείου 2002


 Σε ένα κέντρο νεοσύλλεκτων υπάρχει η πρόθεση να δημιουργηθούν
δύο ειδικές διμοιρίες. Η διμοιρία Α θα αποτελείται από
νεοσύλλεκτους πτυχιούχους τριτοβάθμιας εκπαίδευσης, ηλικίας από
24 έως και 28 χρόνων. Η διμοιρία Β θα αποτελείται από
νεοσύλλεκτους απόφοιτους δευτεροβάθμιας εκπαίδευσης, ηλικίας
από 18 έως και 24 χρόνων. Οι υπόλοιποι νεοσύλλεκτοι δεν
κατατάσσονται σε καμία από αυτές τις διμοιρίες. Να αναπτύξετε
αλγόριθμο ο οποίος:
α. διαβάζει το ονοματεπώνυμο, την ηλικία και έναν αριθμό που
    καθορίζει το επίπεδο σπουδών του νεοσύλλεκτου και
    παίρνει τιμές από 1 έως 3 (1: τριτοβάθμια εκπαίδευση,
    2: δευτεροβάθμια εκπαίδευση, 3: κάθε άλλη περίπτωση)
                                                                          Μονάδες 5
β. εκτυπώνει:
    i) το ονοματεπώνυμο του νεοσύλλεκτου
    ii) το όνομα της διμοιρίας (Α ή Β), εφόσον ο νεοσύλλεκτος
         κατατάσσεται σε μία από αυτές.
                                                                         Μονάδες 15

Λύση

     Αλγόριθμος Θ3_ΕπανΕν2002
     Διάβασε Ον
     Διάβασε Ηλ
     Αρχή_επανάληψης
          Διάβασε Σπ
     Μέχρις_ότου (Σπ >= 1) ΚΑΙ (Σπ <= 3)
     Εμφάνισε Ον
     Αν (Σπ = 1) ΚΑΙ (Ηλ >= 24) ΚΑΙ (Ηλ <= 28) τότε
            Εμφάνισε 'Α'
     Τέλος_αν
     Αν (Σπ = 2) ΚΑΙ (Ηλ >= 18) ΚΑΙ (Ηλ <= 24) τότε
            Εμφάνισε 'Β'
     Τέλος_αν
     Τέλος Θ3_ΕπανΕν2002