Δευτέρα, 14 Μαρτίου 2011

Θέμα 4ο - Επαναληπτικές Απολυτήριες εξετάσεις ενιαίου λυκείου 2001

Κατά τη διάρκεια Διεθνών Αγώνων Στίβου στον ακοντισμό
έλαβαν μέρος δέκα (10) αθλητές. Κάθε αθλητής έκανε έξι (6)
έγκυρες ρίψεις που καταχωρούνται ως επιδόσεις σε μέτρα.
Να αναπτύξετε αλγόριθμο ο οποίος:
α. εισάγει σε πίνακα δύο διαστάσεων τις επιδόσεις όλων
    των αθλητών
                                                                      Μονάδες 3
β. υπολογίζει και καταχωρεί σε μονοδιάστατο πίνακα την
    καλύτερη από τις επιδόσεις κάθε αθλητή
                                                                      Μονάδες 5
γ. ταξινομεί τις καλύτερες επιδόσεις των αθλητών που
    καταχωρήθηκαν στο μονοδιάστατο πίνακα
                                                                      Μονάδες 8
δ. βρίσκει την καλύτερη επίδοση του αθλητή που πήρε
    το χάλκινο μετάλλιο (τρίτη θέση).
                                                                      Μονάδες 4
Παρατήρηση : Υποθέτουμε ότι όλες οι επιδόσεις είναι
μεταξύ τους διαφορετικές.

Λύση

     Αλγόριθμος Θ4_ΕπανΕν2001
     Για λ από 1 μέχρι 10
         Για μ από 1 μέχρι 6
              Διάβασε Μέτρα[λ, μ]
         Τέλος_επανάληψης
     Τέλος_επανάληψης
      Για λ από μέχρι 10
         Μεγ <-- Μέτρα[λ, 1]
         Για μ από μέχρι 6
              Αν Μέτρα[λ, μ] > Μεγ τότε
                   Μεγ <-- Μέτρα[λ, μ]
              Τέλος_αν
         Τέλος_επανάληψης
         ΜΑΧ[λ] <-- Μεγ
     Τέλος_επανάληψης
     Για λ από μέχρι 10
         Για μ από 10 μέχρι λ με_βήμα -1
              Αν ΜΑΧ[μ-1] < ΜΑΧ[μ] τότε
                   β <-- ΜΑΧ[μ-1]
                   ΜΑΧ[μ-1] <-- ΜΑΧ[μ]
                   ΜΑΧ[μ] <-- β
              Τέλος_αν
         Τέλος_επανάληψης
     Τέλος_επανάληψης
     Τρίτος <-- ΜΑΧ[3]
     Αποτελέσματα // Τρίτος, ΜΑΧ //
     Τέλος Θ4_ΕπανΕν2001

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου