Δευτέρα, 14 Μαρτίου 2011

Θέμα 3ο - Επαναληπτικές Απολυτήριες εξετάσεις ενιαίου λυκείου 2002


 Σε ένα κέντρο νεοσύλλεκτων υπάρχει η πρόθεση να δημιουργηθούν
δύο ειδικές διμοιρίες. Η διμοιρία Α θα αποτελείται από
νεοσύλλεκτους πτυχιούχους τριτοβάθμιας εκπαίδευσης, ηλικίας από
24 έως και 28 χρόνων. Η διμοιρία Β θα αποτελείται από
νεοσύλλεκτους απόφοιτους δευτεροβάθμιας εκπαίδευσης, ηλικίας
από 18 έως και 24 χρόνων. Οι υπόλοιποι νεοσύλλεκτοι δεν
κατατάσσονται σε καμία από αυτές τις διμοιρίες. Να αναπτύξετε
αλγόριθμο ο οποίος:
α. διαβάζει το ονοματεπώνυμο, την ηλικία και έναν αριθμό που
    καθορίζει το επίπεδο σπουδών του νεοσύλλεκτου και
    παίρνει τιμές από 1 έως 3 (1: τριτοβάθμια εκπαίδευση,
    2: δευτεροβάθμια εκπαίδευση, 3: κάθε άλλη περίπτωση)
                                                                          Μονάδες 5
β. εκτυπώνει:
    i) το ονοματεπώνυμο του νεοσύλλεκτου
    ii) το όνομα της διμοιρίας (Α ή Β), εφόσον ο νεοσύλλεκτος
         κατατάσσεται σε μία από αυτές.
                                                                         Μονάδες 15

Λύση

     Αλγόριθμος Θ3_ΕπανΕν2002
     Διάβασε Ον
     Διάβασε Ηλ
     Αρχή_επανάληψης
          Διάβασε Σπ
     Μέχρις_ότου (Σπ >= 1) ΚΑΙ (Σπ <= 3)
     Εμφάνισε Ον
     Αν (Σπ = 1) ΚΑΙ (Ηλ >= 24) ΚΑΙ (Ηλ <= 28) τότε
            Εμφάνισε 'Α'
     Τέλος_αν
     Αν (Σπ = 2) ΚΑΙ (Ηλ >= 18) ΚΑΙ (Ηλ <= 24) τότε
            Εμφάνισε 'Β'
     Τέλος_αν
     Τέλος Θ3_ΕπανΕν2002


Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου