Δευτέρα, 14 Μαρτίου 2011

Θέμα 4ο - Επαναληπτικές Απολυτήριες εξετάσεις ενιαίου λυκείου 2003


Κατά τη διάρκεια πρωταθλήματος μπάσκετ μια ομάδα που
αποτελείται από δώδεκα (12) παίκτες έδωσε είκοσι (20) αγώνες,
στους οποίους συμμετείχαν όλοι οι παίκτες.
Να αναπτύξετε στο τετράδιό σας αλγόριθμο ο οποίος:
α. Να διαβάζει τα ονόματα των παικτών και να τα αποθηκεύει σε
    μονοδιάστατο πίνακα.
                                                                       Μονάδες 2
β. Να διαβάζει τους πόντους που σημείωσε κάθε παίκτης σε
    κάθε αγώνα και να τους αποθηκεύει σε πίνακα δύο διαστάσεων.
                                                                       Μονάδες 3
γ. Να υπολογίζει για κάθε παίκτη το συνολικό αριθμό πόντων
    του σε όλους τους αγώνες και το μέσο όρο πόντων ανά αγώνα.
                                                                       Μονάδες 6
δ. Να εκτυπώνει τα ονόματα των παικτών της ομάδας και το
    μέσο όρο πόντων του κάθε παίκτη ταξινομημένα με βάση
    το μέσο όρο τους κατά φθίνουσα σειρά.
    Παρατήρηση: Σε περίπτωση ισοβαθμίας δεν μας ενδιαφέρει
    η σχετική σειρά των παικτών.
                                                                    Μονάδες 9

Λύση

       Αλγόριθμος Θ4_ΕπανΕν2003
       Για λ από 1 μέχρι 12
            Διάβασε Ον[λ]
       Τέλος_επανάληψης
       Για λ από μέχρι 12
            Για μ από 1 μέχρι 20
                  Διάβασε Πόντοι[λ, μ]
            Τέλος_επανάληψης
       Τέλος_επανάληψης
       Για λ από μέχρι 12
            σ <-- 0
            Για μ από μέχρι 20
                  σ <-- σ+Πόντοι[λ, μ]
            Τέλος_επανάληψης
            Σύνολο[λ] <-- σ
            ΜΟ[λ] <-- σ/20
       Τέλος_επανάληψης
       Για λ από μέχρι 12
            Για μ από 12 μέχρι λ με_βήμα -1
                  Αν ΜΟ[μ-1] < ΜΟ[μ] τότε
                       β1 <-- ΜΟ[μ-1]
                       ΜΟ[μ-1] <-- ΜΟ[μ]
                       ΜΟ[μ] <-- β1
                       β2 <-- Σύνολο[μ-1]
                       Σύνολο[μ-1] <-- Σύνολο[μ]
                       Σύνολο[μ] <-- β2
                       β3 <-- Ον[μ-1]
                       Ον[μ-1] <-- Ον[μ]
                       Ον[μ] <-- β3
                  Τέλος_αν
            Τέλος_επανάληψης
       Τέλος_επανάληψης
       Για λ από 1 μέχρι 12
             Εμφάνισε Ον[λ], ΜΟ[λ]
       Τέλος_επανάληψης
       Αποτελέσματα // Σύνολο //
       Τέλος Θ4_ΕπανΕν2003

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου