Παρασκευή, 25 Μαρτίου 2011

Άσκηση : συγγραφή συνάρτησης

Ο καθηγητής πληροφορικής υποβάλλει τους 30 μαθητές της
τάξης του σε ένα τεστ που περιλαμβάνει 18 ερωτήσεις.
Θεωρήστε τον πίνακα Απ[30, 18] που περιέχει τις
απαντήσεις των μαθητών σε κάθε ερώτηση ( Ο - ορθή
απάντηση, Λ - λανθασμένη απάντηση).
Γράψτε συνάρτηση που δέχεται ως παράμετρο τον Απ
και υπολογίζει τον αύξοντα αριθμό (1-18) της ερώτησης
στην οποία έδωσαν λανθασμένη απάντηση οι περισσότεροι
μαθητές (θεωρείστε ότι είναι μοναδική).

Λύση

      ΣΥΝΑΡΤΗΣΗ Δύσκολη(Απ) : ΑΚΕΡΑΙΑ
      ΜΕΤΑΒΛΗΤΕΣ
            ΑΚΕΡΑΙΕΣ: Πληθ, κ , λ, Φορές[18], ΜΑΧ, ΑΑΜΑΧ, Φ
            ΧΑΡΑΚΤΗΡΕΣ: Απ[30, 18]
      ΑΡΧΗ
            ΓΙΑ λ ΑΠΟ 1 ΜΕΧΡΙ 18
                   Φ <-- 0
                   ΓΙΑ κ ΑΠΟ 1 ΜΕΧΡΙ 30
                          ΑΝ Απ[κ, λ] = 'Λ' ΤΟΤΕ
                                 Φ <-- Φ+1
                          ΤΕΛΟΣ_ΑΝ
                   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                   Φορές[λ] <-- Φ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            ΜΑΧ <-- Φορές[1]
            ΑΑΜΑΧ <-- 1
            ΓΙΑ κ ΑΠΟ ΜΕΧΡΙ 18
                   ΑΝ Φορές[κ] > ΜΑΧ ΤΟΤΕ
                           ΜΑΧ <-- Φορές[κ]
                           ΑΑΜΑΧ <-- κ
                   ΤΕΛΟΣ_ΑΝ
            ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
            Δύσκολη <-- ΑΑΜΑΧ
      ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου