Τρίτη, 15 Μαρτίου 2011

Θέμα 4ο: Επαναληπτικές Απολυτήριες εξετάσεις εσπερινού λυκείου 2005

Να αναπτύξετε έναν αλγόριθμο, ώστε
α) να διαβάζει το πλήθος των ασθενών ενός νοσοκομείου,
     το οποίο δεν μπορεί να δεχτεί περισσότερους από 500
     ασθενείς,
                                                                         Μονάδες 2
β) για κάθε ασθενή να διαβάζει τις ημέρες νοσηλείας του,
    τον κωδικό του ασφαλιστικού του ταμείου και τη θέση
    νοσηλείας. Να ελέγχει την ορθότητα εισαγωγής των
    δεδομένων σύμφωνα με τα παρακάτω:
       • οι ημέρες νοσηλείας είναι ακέραιος αριθμός μεγαλύτερος
          ή ίσος του 1,
       • τα ασφαλιστικά ταμεία είναι 10 με κωδικούς από 1 μέχρι
          και 10,
       • οι θέσεις νοσηλείας είναι Α ή Β ή Γ,
                                                                         Μονάδες 6
γ) να υπολογίζει και να εμφανίζει το μέσο όρο ημερών
    νοσηλείας των ασθενών στο νοσοκομείο,
                                                                         Μονάδες 2
δ) να υπολογίζει και να εμφανίζει για κάθε ασθενή το
    κόστος παραμονής που πρέπει να καταβάλει στο
    νοσοκομείο το ασφαλιστικό του ταμείο σύμφωνα
    με τις ημέρες και τη θέση νοσηλείας.
   Το κόστος παραμονής στο νοσοκομείο ανά ημέρα και
   θέση νοσηλείας για κάθε ασθενή φαίνεται στον ακόλουθο
   πίνακα:
      Θέση Νοσηλείας      Κόστος παραμονής ανά ημέρα 
                                         νοσηλείας για κάθε ασθενή
              Α                                         125 €
              Β                                           90 €
              Γ                                           60 €
                                                                         Μονάδες 4
ε) να υπολογίζει και να εμφανίζει με τη χρήση πίνακα το
    συνολικό κόστος που θα καταβάλει το κάθε ασφαλιστικό
    ταμείο στο νοσοκομείο,
                                                                         Μονάδες 4
στ) να υπολογίζει και να εμφανίζει το συνολικό ποσό που
      οφείλουν όλα τα ασφαλιστικά ταμεία στο νοσοκομείο.
                                                                         Μονάδες 2

Λύση

        Αλγόριθμος Θ4_ΕπανΕσπ2005
        Αρχή_επανάληψης
               Διάβασε Ν
        Μέχρις_ότου (Ν > 0) ΚΑΙ (Ν <= 500)
        Για λ από 1 μέχρι Ν
              Αρχή_επανάληψης
                   Διάβασε Ημέρες[λ]
              Μέχρις_ότου Ημέρες[λ] >= 1
              Αρχή_επανάληψης
                   Διάβασε Κωδικός[λ]
              Μέχρις_ότου (Κωδικός[λ] >= 1) ΚΑΙ 
                                     (Κωδικός[λ] <= 10)
              Αρχή_επανάληψης
                   Διάβασε Θέση[λ]
              Μέχρις_ότου (Θέση[λ] = 'Α') Ή (Θέση[λ] = 'Β') Ή 
                                     (Θέση[λ] = 'Γ')
        Τέλος_επανάληψης
         Άθροισμα <-- 0
         Για λ από 1 μέχρι Ν
               Άθροισμα <-- Άθροισμα+Ημέρες[λ]
         Τέλος_επανάληψης
         ΜΟ <-- Άθροισμα/Ν
         Εμφάνισε ΜΟ
         Για λ από μέχρι 10
               Ταμεία [λ] <-- 0
         Τέλος_επανάληψης
         Για λ από μέχρι Ν
               Αν Θέση[λ] = 'Α' τότε
                     Κόστος <-- Ημέρες[λ]*125
               αλλιώς_αν Θέση[λ] = 'Β' τότε
                     Κόστος <-- Ημέρες[λ]*90
               αλλιώς
                     Κόστος <-- Ημέρες[λ]*60
               Τέλος_αν
               Εμφάνισε Κόστος
               ΝοΤαμείου <-- Κωδικός[λ]
               Ταμεία[ΝοΤαμείου] <-- Ταμεία[ΝοΤαμείου]+Κόστος
         Τέλος_επανάληψης
         Για λ από μέχρι 10
               Εμφάνισε Ταμεία [λ] 
         Τέλος_επανάληψης
         Σύνολο <-- 0
         Για λ από μέχρι 10
               Σύνολο <-- Σύνολο+Ταμεία [λ] 
         Τέλος_επανάληψης
         Εμφάνισε Σύνολο
         Τέλος Θ4_ΕπανΕσπ2005

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου