Παρασκευή, 11 Μαρτίου 2011

Θέμα 4ο : Απολυτήριες εξετάσεις εσπερινού ενιαίου λυκείου 2005

Σε ένα πανελλήνιο σχολικό διαγωνισμό μετέχουν 20 σχολεία.
Κάθε σχολείο αξιολογεί 5 άλλα σχολεία και δεν αυτοαξιολο-
γείται. Η βαθμολογία κυμαίνεται από 1 έως και 10.
Να γραφεί τμήμα αλγορίθμου που
α) να διαβάζει τα ονόματα των σχολείων και να τα αποθηκεύει
     σε μονοδιάστατο πίνακα Α 20 θέσεων,
                                                                        Μονάδες 2
β) να εισάγει αρχικά την τιμή 0 σε όλες τις θέσεις ενός δισδιά-
    στατου πίνακα Β 20 γραμμών και 20 στηλών.
                                                                        Μονάδες 2
γ) Να καταχωρίζει στον πίνακα Β τη βαθμολογία που δίνει κάθε
     σχολείο για 5 άλλα σχολεία.
     Σημείωση:
     Στη θέση i,j του πίνακα Β αποθηκεύεται ο βαθμός που το
     σχολείο i δίνει στο σχολείο j, όπως φαίνεται στο παράδειγμα
     που ακολουθεί.
                                                                       Μονάδες 6
δ) να υπολογίζει τη συνολική βαθμολογία του κάθε σχολείου
     και να την καταχωρίζει σε μονοδιάστατο πίνακα 20 θέσεων
     με όνομα SUM,
                                                                       Μονάδες 4
ε) να εμφανίζει τα ονόματα και τη συνολική βαθμολογία όλων
    των σχολείων κατά φθίνουσα σειρά της συνολικής βαθμολογίας.
                                                                       Μονάδες 6
Παράδειγμα
            Σχολ1   Σχολ2 ... Σχολ5 ...  Σχολ18   Σχολ19  Σχολ20   
Σχολ1   
Σχολ2    10                  ...      8     ...      4              8          6
...
Σχολ20                          ...       4     ...    

Στο ανωτέρω παράδειγμα:
Το Σχολείο2 έδωσε την παρακάτω βαθμολογία: στο Σχολείο1 
το βαθμό 10, στο Σχολείο5 το βαθμό 8, στο Σχολείο18 το
βαθμό 4, στο Σχολείο19 το βαθμό 8, και στο Σχολείο20 το
βαθμό 6. Το Σχολείο5 έχει πάρει την παρακάτω βαθμολογία:
από το Σχολείο2 το βαθμό 8 και από το Σχολείο20 το βαθμό 4.

Λύση

     Αλγόριθμος Θ4_Εσπ2005
     Για γ από 1 μέχρι 20
         Διάβασε Α[λ]
     Τέλος_επανάληψης
     Για γ από 1 μέχρι 20
         Για σ από 1 μέχρι 20
             Β[γ, σ] <-- 0
         Τέλος_επανάληψης
     Τέλος_επανάληψης
     Για γ από 1 μέχρι 20
          Πλήθος <-- 0
          Όσο Πλήθος < 5 επανάλαβε          
                Επιτρ <-- Ψευδής
                Αρχή_επανάληψης
                     Διάβασε σ
                     Αν (σ < 1) Ή (σ > 20) τότε
                           Εμφάνισε 'Το ', σ, 'είναι εκτός ορίων'
                     αλλιώς_αν σ = γ τότε
                           Εμφάνισε 'Δεν μπορεί ένα σχολείο να'
                           Εμφάνισε 'βαθμολογήσει τον εαυτό του'
                     αλλιώς_αν Β[γ, σ] < > 0 τότε
                           Εμφάνισε 'Αυτό το σχολείο έχει ήδη'
                           Εμφάνισε 'βαθμολογηθεί'
                     αλλιώς
                           Επιτρ <-- Αληθής
                     Τέλος_αν
                Μέχρις_ότου Επιτρ = Αληθής
                Διάβασε Β[γ, σ]
                Πλήθος <-- Πλήθος+1
          Τέλος_επανάληψης
     Τέλος_επανάληψης
     Για σ από 1 μέχρι 20
         Άθροισμα <-- 0 
         Για γ από 1 μέχρι 20
             Άθροισμα <-- Άθροισμα+Β[γ, σ]
         Τέλος_επανάληψης
         SUM[σ] <-- Άθροισμα
    
Τέλος_επανάληψης
     Για μ από 2 μέχρι 20
         Για λ από 20 μέχρι μ με_βήμα -1
             Αν SUM[λ-1] < SUM[λ] τότε
                  β1 <-- SUM[λ-1]
                  SUM[λ-1] <-- SUM[λ]
                  SUM[λ] <-- β1
                  β2 <-- Α[λ-1]
                  Α[λ-1] <-- Α[λ]
                  Α[λ] <-- β2
             Τέλος_αν
         Τέλος_επανάληψης
     Τέλος_επανάληψης
     Για λ από 1 μέχρι 20
          Εμφάνισε Α[λ], SUM[λ]
     Τέλος_επανάληψης
     Τέλος Θ4_Εσπ2005


Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου