Τετάρτη, 9 Μαρτίου 2011

Θέμα 3ο : Απολυτήριες εξετάσεις εσπερινού ενιαίου λυκείου 2004


Σε έναν αγώνα δισκοβολίας συμμετέχουν 20 αθλητές. Κάθε
αθλητής έκανε μόνο μία έγκυρη ρίψη που καταχωρείται ως
επίδοση του αθλητή και εκφράζεται σε μέτρα.
Να αναπτύξετε αλγόριθμο που
α. να διαβάζει για κάθε αθλητή το όνομα και την επίδοσή του,
                                                                    Μονάδες 5
β. να ταξινομεί τους αθλητές ως προς την επίδοσή τους,
                                                                   Μονάδες 5
γ. να εμφανίζει τα ονόματα και τις επιδόσεις των τριών
   πρώτων αθλητών, αρχίζοντας από εκείνον με την
   καλύτερη επίδοση,
                                                                   Μονάδες 5
δ. να εμφανίζει τα ονόματα και τις επιδόσεις των πέντε
    τελευταίων αθλητών, αρχίζοντας από εκείνον με την
    καλύτερη επίδοση.
                                                                  Μονάδες 5
Σημείωση : Να θεωρήσετε ότι δεν υπάρχουν αθλητές με
την ίδια ακριβώς επίδοση.


Λύση

    Αλγόριθμος Θ3_Εσπ2004
    Για λ από 1 μέχρι 20
         Διάβασε Ον[λ], Επ[λ]
    Τέλος_επανάληψης
    Για κ από 2 μέχρι 20
        Για λ από 20 μέχρι κ με_βήμα -1
              Αν Επ[λ-1] < Επ[λ] τότε
                   β1 <-- Επ[λ-1]
                   Επ[λ-1] <-- Επ[λ]
                   Επ[λ] <-- β1
                   β2 <-- Ον[λ-1]
                   Ον[λ-1] <-- Ον[λ]
                   Ον[λ] <-- β2
              Τέλος_αν
        Τέλος_επανάληψης
    Τέλος_επανάληψης
    Για λ από 1 μέχρι 3
         Εμφάνισε Ον[λ], Επ[λ]
    Τέλος_επανάληψης
    Για λ από 16 μέχρι 20
         Εμφάνισε Ον[λ], Επ[λ]
    Τέλος_επανάληψης
    Τέλος Θ3_Εσπ2004  

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου