Δευτέρα, 14 Μαρτίου 2011

Θέμα 2ο - Επαναληπτικές Απολυτήριες εξετάσεις εσπερινού ενιαίου λυκείου 2005

Δίνεται το παρακάτω πρόγραμμα το οποίο διαβάζει τις
θερμοκρασίες διαφόρων ημερών του μήνα, έστω 30, και
υπολογίζει τη μέση θερμοκρασία του μήνα.
    ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
    ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30], Μέση, Σύνολο
          ΑΚΕΡΑΙΕΣ: i
    ΑΡΧΗ
          Σύνολο <-- 0
          ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
              ΓΡΑΨΕ “Δώσε τη θερμοκρασία”
              ΔΙΑΒΑΣΕ Θερμοκρασία[i]
              Σύνολο <-- Σύνολο + Θερμοκρασία[i]
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          Μέση <-- Σύνολο/30
          ΓΡΑΨΕ “Μέση Θερμοκρασία:”, Μέση
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
α) Να γραφεί αντίστοιχο πρόγραμμα (που να κάνει τους
     ίδιους υπολογισμούς) χωρίς τη χρήση πίνακα.
                                                             Μονάδες 10
β) Έστω ότι οι τιμές των θερμοκρασιών έχουν δοθεί στην
     κλίμακα Κελσίου. Να τροποποιηθεί το πρόγραμμα που
    δόθηκε έτσι, ώστε κάνοντας χρήση συνάρτησης να
    μετατρέπονται οι θερμοκρασίες από την κλίμακα
    Κελσίου σε κλίμακα Φαρενάιτ.
   Ο τύπος μετατροπής από Κελσίου σε Φαρενάιτ είναι:

           Φαρενάιτ=32+9⋅Κελσίου/5

                                                             Μονάδες 10

Λύση

α)
    ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
    ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία, Μέση, Σύνολο
          ΑΚΕΡΑΙΕΣ: i
    ΑΡΧΗ
          Σύνολο <-- 0
          ΓΙΑ ΑΠΟ ΜΕΧΡΙ 30
              ΓΡΑΨΕ “Δώσε τη θερμοκρασία”
              ΔΙΑΒΑΣΕ Θερμοκρασία
              Σύνολο <-- Σύνολο + Θερμοκρασία
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          Μέση <-- Σύνολο/30
          ΓΡΑΨΕ “Μέση Θερμοκρασία:”, Μέση
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

β)
    ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες_2
    ΜΕΤΑΒΛΗΤΕΣ
          ΠΡΑΓΜΑΤΙΚΕΣ: Θερμοκρασία[30], Μέση, Σύνολο, Φ
          ΑΚΕΡΑΙΕΣ: i
    ΑΡΧΗ
          Σύνολο <-- 0
          ΓΙΑ ΑΠΟ ΜΕΧΡΙ 30
              ΓΡΑΨΕ “Δώσε τη θερμοκρασία”
              ΔΙΑΒΑΣΕ Θερμοκρασία[i]
              Φ <-- Φαρενάιτ(Θερμοκρασία[i])
              Σύνολο <-- Σύνολο + Φ
          ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
          Μέση <-- Σύνολο/30
          ΓΡΑΨΕ “Μέση Θερμοκρασία:”, Μέση
     ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

     ΣΥΝΑΡΤΗΣΗ Φαρενάιτ(Κελσίου) : ΠΡΑΓΜΑΤΙΚΗ
     ΜΕΤΑΒΛΗΤΕΣ
         ΠΡΑΓΜΑΤΙΚΕΣ : Κελσίου
     ΑΡΧΗ
         Φαρενάιτ <-- 32+9*Κελσίου/5
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Δεν υπάρχουν σχόλια:

Δημοσίευση σχολίου